Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Steam

Introduction

Steam est une plate-forme de distribution de contenu en ligne (principalement de jeux vidéo), de gestion des droits et de communication développée par Valve depuis 2003, semblable à Desura.
Steam effectue les mises à jour automatiquement et offre des outils communautaires autour des jeux l'utilisant.
La liste des jeux prévus pour être portés sous Linux augmente régulièrement.

Prérequis

Architecture

Le paquet Steam ne fonctionne pour le moment que sur des architectures de type i386 (32bits). Pour les systèmes 64 bits il faut activer le support multiarch avant de pouvoir lancer l'installation :

dpkg --add-architecture i386
apt-get update && apt-get install multiarch-support

Pilotes Libres/Pilotes Propriétaires

Certains jeux vidéos ont besoin des pleines capacités de votre carte graphique. Pour cela, il faut un pilote de bonne qualité.
Bien que dans la plupart des cas, les pilotes libres couvrent largement les besoins, parfois, pour une librairie ou une fonction manquante, il est utile alors d'activer les pilotes propriétaires.

Carte graphique Ati

Les cartes Radeon disposent d'un pilote Libre et d'un propriétaire, à activer selon les besoins, voir : les cartes graphiques ATI.

Carte graphique Intel

Le pilote développé par Intel est entièrement open-source et déjà intégré à Debian.

Carte graphique Nvidia :

Nouveau est le nom du pilote Libre.
Pour le fonctionnement de Steam avec les pilotes propriétaires, il faut ajouter le paquet libgl1-nvidia-glx 32bits ainsi :

apt-get install libgl1-nvidia-glx:i386

Voir: les cartes graphiques Nvidia.

Installation

Jessie

À partir de Jessie, le paquet Steam est disponible dans les dépôts non-free et s'installe simplement avec :

apt-get update && apt-get install steam

Wheezy

Il n'est théoriquement pas possible d'installer Steam sous Wheezy car la version libc6 de Wheezy n'est pas compatible avec la version demandée par Steam. Il existe néanmoins une méthode peu élégante pour by-passer ce problème.

Tout d'abord nous devons installer zenity dont Steam dépend:

apt-get update && apt-get install zenity

Puis l'on récupère l'installateur de l'application Steam directement sur le site officiel : http://store.steampowered.com/about/. Pour l'installer utiliser dpkg :

dkpg -i steam_latest.deb

On récupère une version supérieure de libc6 sur le site d'Ubuntu:

wget http://fr.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6_2.15-0ubuntu10.10_i386.deb
wget http://security.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6-dev_2.15-0ubuntu10.10_i386.deb

Puis l'on crée le répertoire où l'on extrait les fichiers précédemment téléchargés:

mkdir ~/.local/steamlib/
dpkg -x libc6_2.15-0ubuntu10.10_i386.deb ~/.local/steamlib/
dpkg -x libc6-dev_2.15-0ubuntu10.10_i386.deb ~/.local/steamlib/

Il est ensuite nécessaire de “tromper” le système de paquet de Debian pour lui faire oublier que Steam requiert une version supérieure de libc6:

votre_editeur_de_texte_préféré /var/lib/dpkg/status

Recherchez “steam-launcher”:

Extrait de /var/lib/dpkg/status
Package: steam-launcher
Status: install ok unpacked
Priority: optional
Section: games
Installed-Size: 2417
Maintainer: Valve Corporation <linux@steampowered.com&gt;
Architecture: all
Multi-Arch: foreign
Source: steam
Version: 1.0.0.47
Replaces: steam, steam64
Depends: python, curl, libc6 (>= 2.15), python-apt, xterm | gnome-terminal | konsole, xz-utils, zenity
Recommends: jockey-common
Breaks: steam64
Conffiles:
/etc/apt/trusted.gpg.d/steam.gpg newconffile
/etc/apt/sources.list.d/steam.list newconffile
Description: Launcher for the Steam software distribution service
Steam is a software distribution service with an online store, automated
installation, automatic updates, achievements, SteamCloud synchronized
savegame and screenshot functionality, and many social features.
Homepage: http://www.steampowered.com/

Et supprimez la ligne ci-dessous:

Depends: python, curl, libc6 (>= 2.15), python-apt, xterm | gnome-terminal | konsole, xz-utils, zenity

Enfin, pour terminer on crée le script qui nous permettra de lancer Steam:

votre_script
#!/bin/bash
STEAMLIBS=${HOME}/steamlib/lib/i386-linux-gnu/ 
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${STEAMLIBS} steam --verbose

Il ne vous reste plus qu'à rendre executable votre script:

chmod +x votre_script

Puis à l'exécuter:

./votre_script

Steam est désormais utilisable. Il est conseillé de redémarrer votre ordinateur.

Utilisation

Lancez Steam depuis votre menu “jeux” ou dans un terminal en entrant steam.

  • Au premier lancement, steam se met à jour.
  • La première fois que vous vous connecterez, un mail de confirmation vous sera envoyé avec un code. Copiez simplement le code reçu dans la case prévue à cet effet.

Bugs

Crash lors de la navigation des jeux

Ce problème semble être dû au fait que steam est en 32bits et ne trouve pas le fichier libflashplayer.so

Installez le plugin non libre

apt-get install flashplugin-nonfree

Ou/Et téléchargez le adobe flash player depuis le site d'adobe

  1. Extrayez l'archive téléchargé :
    tar vzfx <archive>.tar.gz 
  2. et copiez le fichier libflashplayer.so ici :
    /usr/lib/iceweasel/plugins

Voir aussi

Sources

1) N'hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !
doc/jeux/steam.txt · Dernière modification: 12/03/2016 18:50 par Slyfox

Pied de page des forums

Propulsé par FluxBB