Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Rétroportage

  • Objet : Créer un paquet en local.
  • Niveau requis :
  • Commentaires : Ce tutoriel est tiré du manuel de référence Debian et testé avec le paquet minitube…
  • Suivi :
  • Commentaires sur le forum : Lien vers le forum concernant ce tuto1)

Introduction

Il se peut que vous ayez besoin d'un logiciel ou d'un utilitaire dont le paquet n'est disponible que dans Sid (unstable).
Vous pourriez modifier votre preferences pour pointer vers cette branche.

Ce tuto va dans un autre sens :
Il ne modifie pas les fichiers de configuration et vous restez en stable bien sagement.
On va voir comment, en quelques lignes, créer à partir des sources de sid (unstable) un paquet pour la distribution stable.

Modifier son fichier sources.list

Ajouter cette ligne pour pouvoir télécharger les fichiers sources de sid (unstable):

deb-src http://ftp.fr.debian.org/debian/ unstable main contrib non-free

Installation des paquets nécessaires

Dans un terminal en mode administrateur, entrer les trois commandes suivantes:

apt-get update
apt-get dist-upgrade
apt-get install fakeroot devscripts build-essential

Récupérer les dépendances et les sources

Toujours en mode administrateur entrer la commande suivante:

apt-get build-dep Nom_du_paquet

Puis comme simple utilisateur :

apt-get source Nom_du_paquet
cd Nom_du_paquet*

Modifier la version du paquet qui sera créée

Entrer la commande suivante:

dch -i

Un fichier avec l'éditeur de texte nano2) va s'ouvrir:

Dans la première ligne vous aurez le nom du paquet et sa version.
Par exemple :

minitube (1.6-1.1) unstable; urgency=low

Nous modifions la version ainsi:

minitube (1.6-1.1+bpo1) unstable; urgency=low

Construire les paquets et les installer

Entrer les deux commandes suivantes comme simple utilisateur:

debuild
cd ..

Puis cette commande en mode administrateur :

debi Nom_du_paquet*.changes

Voilà votre paquet est installé

Le système apt m'indiquait que mon paquet était cassé et qu'il manquait des dépendances. La commande apt-get install -f a résolu le problème.

Nota :

Sur le forum df dbkblk précise :

ATTENTION ! Si la dépendance du paquet venant de sid est plus élevée que celle disponible dans stable, il faut aussi rétroporter cette dépendance.

Ce rétroportage des dependances peut être assez contraignant parfois… (casse-bonbon dans l'texte !) ;-)

Liens

1) N'hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !
2) par defaut
doc/mentors/retroportage.txt · Dernière modification: 31/01/2016 14:00 par Frosch

Pied de page des forums

Propulsé par FluxBB