Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:systeme:apt:apt.conf [25/07/2018 15:33]
Beta-Pictoris [Exemples de configurations]
doc:systeme:apt:apt.conf [21/04/2019 15:53] (Version actuelle)
Nsyo [Exemples de configurations]
Ligne 9: Ligne 9:
   * Commentaires sur le forum : [[http://​debian-facile.org/​viewtopic.php?​id=1720 |C'est ici]]((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !))    * Commentaires sur le forum : [[http://​debian-facile.org/​viewtopic.php?​id=1720 |C'est ici]]((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !)) 
  
-**Nota :** Contributeursles FIXME sont là pour vous aider, supprimez-les une fois le problème corrigé ou le champ rempli ! +**ATTENTION !!** 
- +Comme indiqué dans l'​entêtece tutoriel n'est pas vraiment destiné aux débutants qui débutent - désolé pour les débutants qui débutent.
-<note important>​Ce ​tutoriel n'est pas vraiment destiné aux débutants qui débutent - désolé pour les débutants qui débutent.</​note>​+
  
  
Ligne 39: Ligne 38:
 EOF</​code>​ EOF</​code>​
  
-==== Désinstaller les paquets recommandés automatiquement ====+<​note>​ 
 +La syntaxe suivante fonctionne également 
 +<file apt>​APT::​Install-Recommends "​0";​ 
 +APT::​Install-Suggests "​0";</​file>​ 
 +</​note>​
  
-=== Présentation du problème ​=== +==== Désinstaller les paquets recommandés et suggérés automatiquement ====
  
-Par défaut, lors de la désinstallation d'un programme, ses dépendances //​recommandées//​ et //​suggérées//,​ marquées ​[[:doc:​systeme:​apt:​aptitude#Gérer ​les paquets ​automatiquement installés|Auto]], ne seront ​pas désinstallées tant qu'​un ​autre programmeencore en place, les recommandeIl est possible ​de modifier ce comportement.+=== Objectif ===  
 + 
 +La modification ​de la section ​[[doc:​systeme:​apt:​apt.conf#Ne pas traiter ​les paquets ​recommandés comme des dépendances|précédente]] empêchera l'​installation des dépendances //​recommandées//​ et //​suggérées//​mais n'​évitera ​pas l'accumulation de paquets sur votre système. En effet, des dépendances //​obligatoires//​ pour un paquet resteront sur votre systèmemême après désinstallation dudit paquetsi elles sont //​recommandées//​ et //​suggérées//​ pour d'​autres paquets. Cette modification va, donc, entraîner la désinstallation de toutes ​les dépendances //​recommandées//​ et //​suggérées//​ de votre systèmeL'​objectif étant ​de gérer manuellement ces types de paquets pour garder un système toujours propre. Cette modification est complémentaire à la précédente.
  
 === Fichier de configuration ===  === Fichier de configuration === 
Ligne 51: Ligne 56:
 APT::​AutoRemove::​SuggestsImportant "​false";</​file>​ APT::​AutoRemove::​SuggestsImportant "​false";</​file>​
  
-<note important>​Attention ! Cette modification ​va entraîner la désinstallation de tous les paquets //​recommandées//​ et //​suggérées//​automatiquement installés, de votre système. Vous pouvez le vérifier en simulant la mise à jour des paquets ​de votre système de cette façon+=== Vérification === 
-  * Ouvrir un terminal ​root((voir [[:​doc:​systeme:​su|la commande ​su]])) et lancer les commandes suivantes:<​code ​root>apt update && ​apt -s upgrade</code+ 
-</note>+Après avoir appliqué la modification, ​vous pourrez simuler quels paquets ​vont être désinstallés
 +  * Ouvrir un terminal ​et lancer ​la commande ​suivante:<​code ​user>apt -s autoremove</​code>​
  
 ==== Augmenter la taille du cache : ==== ==== Augmenter la taille du cache : ====
Ligne 107: Ligne 113:
 Acquire::​http::​Dl-Limit "​20";​ Acquire::​http::​Dl-Limit "​20";​
 EOF</​code>​ EOF</​code>​
 +
 +===== Mises à jour automatique =====
  
 ==== Réceptionner les mises à jour automatiquement ==== ==== Réceptionner les mises à jour automatiquement ====
Ligne 147: Ligne 155:
  
 Puis installez le paquet suivant : Puis installez le paquet suivant :
 +<code root>​apt-get install unattended-upgrades</​code> ​
  
-<​code ​root>apt-get install ​unattended-upgrades</​code>​+<note tip>Ce paquet unattended-upgrades est installé par défaut si on fait le choix de Gnome à l’installation. \\ Je pense qu’il peut en être de même avec KDE ? \\ (Chalu : https://​debian-facile.org/​viewtopic.php?​pid=281660#​p281660 ) :​-D</​note>​ 
 + 
 +Pour savoir demandez : 
 +<​code ​user>​apt ​policy unattended-upgrades</​code>​ 
 +... et vous recevrez :  
 +<​code>​unattended-upgrades:​ 
 +  Installé :​ 0.93.1+nmu1 
 +  Candidat : 0.93.1+nmu1 
 + Table de version :​ 
 + *** 0.93.1+nmu1 500 
 +        500 http://​ftp.ch.debian.org/​debian stretch/​main amd64 Packages 
 +        100 /​var/​lib/​dpkg/​status 
 +</​code>​ 
 + 
 +Pour en savoir plus sur ce paquet utilisez [[doc:​systeme:​apt|apt avec l'​option show]] ainsi : 
 +<code user>apt show unattended-upgrades</​code>​
  
 Ce paquet installe un fichier de configuration ''/​etc/​apt/​apt.conf.d/​50unattended-upgrade'',​ à l'​intérieur duquel vous trouvez un paragraphe similaire à celui-ci (avec beaucoup de commentaires en plus) Ce paquet installe un fichier de configuration ''/​etc/​apt/​apt.conf.d/​50unattended-upgrade'',​ à l'​intérieur duquel vous trouvez un paragraphe similaire à celui-ci (avec beaucoup de commentaires en plus)
Ligne 168: Ligne 192:
 et d'​ouvrir ensuite le fichier apt-configure-index.txt avec **gedit**. et d'​ouvrir ensuite le fichier apt-configure-index.txt avec **gedit**.
  
 +===== Liens utiles vers le forum =====
 +
 +  * https://​debian-facile.org/​viewtopic.php?​id=10593 \\ //Merci à //​**robert2a**//​ dont les interventions sur le forum sont une vraie mine de soutien et de configuration pour tous ! \\ Que sous ses pas une rivière de pétales de rose s'​étende à jamais !//
doc/systeme/apt/apt.conf.1532525612.txt.gz · Dernière modification: 25/07/2018 15:33 par Beta-Pictoris

Pied de page des forums

Propulsé par FluxBB