Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:systeme:apt:pinning [13/09/2015 18:59]
nIQnutn [Introduction]
doc:systeme:apt:pinning [23/06/2019 14:46] (Version actuelle)
bendia [Introduction] modification de mise en page pour mieux comprendre lespriorités
Ligne 19: Ligne 19:
  
 Les cas d'​utilisation raisonnable sont les suivants : Les cas d'​utilisation raisonnable sont les suivants :
-  - Vous voulez être en //testing// avec les dépôts //sid// sous la main au cas où +  - Vous voulez être en //testing// avec les dépôts //sid// sous la main au cas où ; 
-  - Vous voulez être en //testing// ou //sid// mais récupérer la version //sid// ou //​experimental//​ d'un paquet en particulier +  - Vous voulez être en //testing// ou //sid// mais récupérer la version //sid// ou //​experimental//​ d'un paquet en particulier ​; 
-  - Vous utilisez le dépôt multimedia, mais ne voulez pas donner une forte priorité à tous les paquets qu'il propose+  - Vous utilisez le dépôt multimedia, mais ne voulez pas donner une forte priorité à tous les paquets qu'il propose.
  
 En dehors de ça, si vous voulez mélanger stable et une //​testing/​unstable/​experimental//,​ alors vous devriez prendre rendez-vous d'​urgence chez votre garagiste pour qu'il s'​occupe de votre carie. En dehors de ça, si vous voulez mélanger stable et une //​testing/​unstable/​experimental//,​ alors vous devriez prendre rendez-vous d'​urgence chez votre garagiste pour qu'il s'​occupe de votre carie.
Ligne 29: Ligne 29:
 Les fichiers ''​preferences''​ permettent de fixer la priorité des paquets suivant leurs dépôt. Voici la signification d'une priorité ''​P''​. Les fichiers ''​preferences''​ permettent de fixer la priorité des paquets suivant leurs dépôt. Voici la signification d'une priorité ''​P''​.
  
-  * P 1000 +  * P ≥ 1000 : le paquet sera installé même si APT est forcé d'​installer une version plus ancienne((On appelle cela le //​downgrade//​ par opposition à l'//​upgrade//​.)) ​ que la version actuelle. Cette opération n'est pas sans risque.
-Le paquet sera installé même si APT est forcé d'​installer une version plus ancienne((On appelle cela le //​downgrade//​ par opposition à l'//​upgrade//​.)) ​ que la version actuelle. Cette opération n'est pas sans risque.+
  
-  * 990 < P ≤ 1000 +  * 990 ≤ P < 1000 : le paquet sera installé sauf si une version plus récente est déjà installée.
-Le paquet sera installé sauf si une version plus récente est déjà installée.+
  
-  * 500 < P ≤ 990 +  * 500 ≤ P < 990 : le paquet ne sera installé qu'à défaut de version plus récente installée ou disponible dans la distribution cible.
-Le paquet ne sera installé qu'à défaut de version plus récente installée ou +
-disponible dans la distribution cible.+
  
-  * 100 < P ≤ 500 +  * 100 ≤ P < 500 : le paquet ne sera installé que s'il n'en existe aucune version plus récente, installée ou disponible dans une autre branche.
-Le paquet ne sera installé que s'il n'en existe aucune version plus récente, +
-installée ou disponible dans une autre branche.+
  
-  * 0 < P ≤ 100 +  * 0 < P 100 : le paquet ne sera installé que si aucune autre version du paquet n'est installée.
-Le paquet ne sera installé que si aucune autre version du paquet n'est installée.+
  
-  * P < 0 +  * P < 0 : le paquet ne sera jamais installé.
-Le paquet ne sera jamais installé.+
  
 ==== Configuration initiale ==== ==== Configuration initiale ====
Ligne 61: Ligne 53:
  
 La commande : La commande :
-<code root>apt -t jessie-backports install libreoffice</​code>​ +<code root>apt-get -t stretch-backports install libreoffice</​code>​ 
-donne une priorité élevée à **toute la branche ​jessie-backports** le temps de l’instance d’APT.+donne une priorité élevée à **toute la branche ​stretch-backports** le temps de l’instance d’APT. 
 + 
 +L'​option -t (''​t''​ pour target) indique le dépôt cible où l'on va chercher le paquet à installer en gérant correctement les dépendances par rapport à ce dépôt et aux dépôts stables. \\ 
 +Merci à chalu de cette précision-ci sur le forum à ce post là : 
 +  * https://​debian-facile.org/​viewtopic.php?​pid=207154#​p207154
  
 La commande : La commande :
-<code root>apt install libreoffice/​jessie-backports</​code>​+<code root>apt-get install libreoffice/​stretch-backports</​code>​
 pose des problèmes de dépendances parce que la version prioritaire du paquet libreoffice-common restera celle des sources habituelles et non pas celles des backports. pose des problèmes de dépendances parce que la version prioritaire du paquet libreoffice-common restera celle des sources habituelles et non pas celles des backports.
  
Ligne 71: Ligne 67:
  
 [[https://​debian-facile.org/​viewtopic.php?​id=12207 | différence install -t backports & paquet/​backports]] [[https://​debian-facile.org/​viewtopic.php?​id=12207 | différence install -t backports & paquet/​backports]]
- 
- 
  
 On peut vérifier les priorités en utilisant la ligne de commande, par exemple, si vous êtes en //stable// : On peut vérifier les priorités en utilisant la ligne de commande, par exemple, si vous êtes en //stable// :
 <code user>​apt-cache policy</​code>​ <code user>​apt-cache policy</​code>​
  
 +===== Synaptic =====
 +
 +<note warning>​Le pinning fonctionne si tu utilises soit [[doc:​systeme:​apt:​apt|apt]],​ [[doc:​systeme:​apt:​apt-get|apt-get]] ou [[doc:​systeme:​apt:​aptitude|aptitude]],​ mais si tu utilises [[doc:​systeme:​apt:​synaptic|synaptic]],​ le fichier créé en faisant du pinning va entrer en conflit avec le fichier de configuration de synaptic !</​note>​
 +
 +Configuration de synaptic :
 +  - Tu vas dans : \\ ''​configuration''​ -> ''​préférences''​ onglet ''​Distribution''​
 +  - Tu coches ''​Préférer les version de''​ et tu choisis la version que tu désires.
 +Normalement tu ne devrais plus y être submergé par des demande de mise à jours.
 +
 +Merci à **valmy** et **Severian** qui ont initié cette recommandation sur le forum ! :-)
  
 ===== Précautions ===== ===== Précautions =====
Ligne 89: Ligne 93:
 <code root>​apt-get update</​code>​ <code root>​apt-get update</​code>​
  
-Puis vérifiez que vos modifications ont bien été prises en compte grâce à ''​apt-cache'' ​(voir ci-dessus).+Puis vérifiez que vos modifications ont bien été prises en compte grâce à ''​apt-cache ​policy''​.
  
 <note importante>​Si les résultats affichés ne vous conviennent pas, vous risquez d'​avoir une mauvaise <note importante>​Si les résultats affichés ne vous conviennent pas, vous risquez d'​avoir une mauvaise
Ligne 130: Ligne 134:
  
 <file apt_preferences 90suivi-backports>​Package:​ iceweasel <file apt_preferences 90suivi-backports>​Package:​ iceweasel
-Pin: release a=jessie-backports+Pin: release a=stretch-backports
 Pin-Priority:​ 900</​file>​ Pin-Priority:​ 900</​file>​
 +<​note>​Par défaut le dépôt stable-backports a une priorité de 100. Il est alors inutile de préciser la priorité des autres paquets de stable-backports</​note>​
  
 === Stable avec dépôt multimédia à faible priorité === === Stable avec dépôt multimédia à faible priorité ===
Ligne 148: Ligne 152:
  
 On suppose que vous avez comme sources quelque chose comme ça : On suppose que vous avez comme sources quelque chose comme ça :
-<code apt_sources>​deb http://httpredir.debian.org/​debian testing main contrib non-free +<code apt_sources>​deb http://deb.debian.org/​debian testing main contrib non-free 
-deb http://httpredir.debian.org/​debian sid main contrib non-free</​code>​+deb http://deb.debian.org/​debian sid main contrib non-free</​code>​
 mais que vous voulez rester en //testing// autant que possible. mais que vous voulez rester en //testing// autant que possible.
  
Ligne 159: Ligne 163:
  
  
 +=== Testing avec suivi d'un paquet dans Sid ===
 +Par exemple, je suis en Testing mais veut installer la version du paquet ''​firefox''​ du dépôt de Sid tout en restant à jour.
 +
 +On crée un fichier ''/​etc/​apt/​preferences.d/​40firefox-sid''​ contenant le code suivant :
 +
 +<file apt_preferences 90firefox-sid>​
 +Package: *
 +Pin: release n=sid
 +Pin-priority:​100
 +
 +Package: firefox
 +Pin: release n=sid
 +Pin-Priority:​ 900</​file>​
 +
 +<note warning>​Cette méthode n’est pas conseillé sur Stable. Dans ce cas, il est préférable de construire le paquet depuis les sources du paquet dans Sid en suivant [[/​doc:​mentors:​retroportage| le wiki rétroportage]]</​note>​
 === Sid avec suivi d'un paquet dans Experimental === === Sid avec suivi d'un paquet dans Experimental ===
  
Ligne 168: Ligne 187:
 Pin: release a=experimental Pin: release a=experimental
 Pin-Priority:​ 900</​file>​ Pin-Priority:​ 900</​file>​
 +<​note>​Par défaut le dépôt expérimental a une priorité de 1. Il est alors inutile de préciser la priorité des autres paquets</​note>​
  
 === Sid avec les dépôts multimedia de experimental === === Sid avec les dépôts multimedia de experimental ===
Ligne 195: Ligne 214:
  
 //Merci à //​**caly**//​ sur le chan d'​avoir suscité cet ajout.// :-) //Merci à //​**caly**//​ sur le chan d'​avoir suscité cet ajout.// :-)
- 
 ===== Conseils et remarques ===== ===== Conseils et remarques =====
  
Ligne 202: Ligne 220:
 === Nommer les branches par leur nom **commun** ou leur nom **release** === === Nommer les branches par leur nom **commun** ou leur nom **release** ===
  
-<code apt_sources>​deb http://httpredir.debian.org/​debian/ ​jessie ​main contrib non-free</​code>​+<code apt_sources>​deb http://deb.debian.org/​debian/ ​stretch ​main contrib non-free</​code>​
  
-''​apt-cache policy''​ donne une option (//n=jessie//)+''​apt-cache policy''​ donne une option (//n=stretch//)
  
-<​code>​900 http://httpredir.debian.org/​debian/ ​jessie/main Packages +<​code>​900 http://deb.debian.org/​debian/ ​stretch/main Packages 
-   ​release v=6.0.2.1,​o=Debian,​a=stable,​n=jessie,​l=Debian,​c=main +   ​release v=6.0.2.1,​o=Debian,​a=stable,​n=stretch,​l=Debian,​c=main 
-   ​origin ​httpredir.debian.org</​code>​+   ​origin ​deb.debian.org</​code>​
  
 donc on peut rajouter dans le fichier **preferences** ce style d'​interprétation : donc on peut rajouter dans le fichier **preferences** ce style d'​interprétation :
Ligne 218: Ligne 236:
  
 Package: * Package: *
-Pin: release n=jessie+Pin: release n=stretch
 Pin-priority:​ 900 Pin-priority:​ 900
 </​code>​ </​code>​
Ligne 233: Ligne 251:
 Pin-Priority:​ 100</​code>​ Pin-Priority:​ 100</​code>​
  
-La dernière version de iceweasel avec Jessie ​(testing) ​+La dernière version de iceweasel avec buster ​(testing) ​
 <code apt_sources>​deb http://​cdn.debian.net/​debian unstable main <code apt_sources>​deb http://​cdn.debian.net/​debian unstable main
 deb http://​cdn.debian.net/​debian experimental main</​code>​ deb http://​cdn.debian.net/​debian experimental main</​code>​
doc/systeme/apt/pinning.1442163577.txt.gz · Dernière modification: 13/09/2015 18:59 par nIQnutn

Pied de page des forums

Propulsé par FluxBB