Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:systeme:superutilisateur [17/08/2015 17:26]
milou [root]
doc:systeme:superutilisateur [27/07/2019 11:49] (Version actuelle)
bendia [Application graphique]Ajout d'un avertissement concernant gksu
Ligne 31: Ligne 31:
  
 Lors de votre installation du système Debian, si vous avez renseigné le mot de passe destiné à root, la [[:​doc:​systeme:​su | commande su]] vous permettra d'​opérer le passage à cette session. Lors de votre installation du système Debian, si vous avez renseigné le mot de passe destiné à root, la [[:​doc:​systeme:​su | commande su]] vous permettra d'​opérer le passage à cette session.
 +
 +<note tip>Pour quitter une session //root//, tapez ''​exit''​+<​key>​Entrée</​key>​ ou <​key>​Ctrl</​key>​+<​key>​D</​key>​ :​-D</​note>​
  
 ==== sudo ==== ==== sudo ====
Ligne 40: Ligne 42:
 === sudo !! === === sudo !! ===
  
-Vous utilisez le service **sudo**, vous êtes  logué en tant que simple utilisateur,​ néanmoins vous souhaiter ​installer un logiciel :+Vous utilisez le service **sudo**, vous êtes logué en tant que simple utilisateur,​ néanmoins vous souhaitez ​installer un logiciel :
  
 <code user>​apt-get install terminator</​code>​ <code user>​apt-get install terminator</​code>​
-<file config retour de la commande>​E:​ Impossible d'​ouvrir le fichier verrou /​var/​lib/​dpkg/​lock - open (13: Permission non accordée)+<file config retour de la commande>​E:​ Impossible d'​ouvrir le fichier verrou /​var/​lib/​dpkg/​lock - open (13: Permission non accordée).
 E: Impossible de verrouiller le répertoire d'​administration (/​var/​lib/​dpkg/​). Avez-vous les privilèges du superutilisateur ?​ E: Impossible de verrouiller le répertoire d'​administration (/​var/​lib/​dpkg/​). Avez-vous les privilèges du superutilisateur ?​
 </​file>​ </​file>​
  
-Misère ​vous avez oublié de spécifier le **sudo**, encore obligé de retourner au début de la ligne !+Misère ​! Vous avez oublié de spécifier le **sudo**, encore obligé de retourner au début de la ligne !
  
 Pas de panique, un simple ** < sudo !! > **, exécute la dernière commande avec les droits root. Pas de panique, un simple ** < sudo !! > **, exécute la dernière commande avec les droits root.
 <code user>​apt-get install terminator</​code>​ <code user>​apt-get install terminator</​code>​
-<file config retour de la commande>​E:​ Impossible d'​ouvrir le fichier verrou /​var/​lib/​dpkg/​lock - open (13: Permission non accordée)+<file config retour de la commande>​E:​ Impossible d'​ouvrir le fichier verrou /​var/​lib/​dpkg/​lock - open (13: Permission non accordée).
 E: Impossible de verrouiller le répertoire d'​administration (/​var/​lib/​dpkg/​). Avez-vous les privilèges du superutilisateur ?</​file>​ E: Impossible de verrouiller le répertoire d'​administration (/​var/​lib/​dpkg/​). Avez-vous les privilèges du superutilisateur ?</​file>​
 <code user>​sudo !! <code user>​sudo !!
 </​code>​ </​code>​
 <code user>​sudo apt-get install terminator</​code>​ <code user>​sudo apt-get install terminator</​code>​
-<file config séquence interactive>​Lecture des listes de paquets... Fait +<file config séquence interactive>​Lecture des listes de paquets... Fait. 
-Construction de l'​arbre des dépendances ​      ​ +Construction de l'​arbre des dépendances.      ​ 
-Lecture des informations d'​état... Fait+Lecture des informations d'​état... Fait.
 Les paquets supplémentaires suivants seront installés : ​ Les paquets supplémentaires suivants seront installés : ​
   gnome-mime-data libart-2.0-2 libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common libfam0 libglade2-0 libgnome2-0 libgnome2-common   gnome-mime-data libart-2.0-2 libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common libfam0 libglade2-0 libgnome2-0 libgnome2-common
Ligne 104: Ligne 106:
  
 Certaines applications graphiques nécessitent les droits de superutilisateur pour accomplir leurs tâches correctement (//​[[doc:​environnements:​gnome:​gparted | gparted]]// par exemple). Cependant, il ne faut pas utiliser //su// ou //sudo// pour lancer ces applications sous peine de corrompre votre session graphique :-/ Certaines applications graphiques nécessitent les droits de superutilisateur pour accomplir leurs tâches correctement (//​[[doc:​environnements:​gnome:​gparted | gparted]]// par exemple). Cependant, il ne faut pas utiliser //su// ou //sudo// pour lancer ces applications sous peine de corrompre votre session graphique :-/
 +
 +<note warning>​Le paquet ''​gksu''​ n'​étant pas présent dans //Buster//, ce qui suit concernant GTK n'est plus d'​actualité. Théoriquement,​ les applications en GTK maintenues doivent utiliser d'​autres mécanismes pour permettre d'​obtenir ces droits((voir https://​debian-facile.org/​viewtopic.php?​id=24843))</​note>​
  
 Si vous utilisez des environnements basés sur la bibliothèque graphique **GTK** (//Gnome, XFCE, LXDE//) il faut utiliser la commande ''​gksu''​ ou ''​gksudo''​ ainsi : Si vous utilisez des environnements basés sur la bibliothèque graphique **GTK** (//Gnome, XFCE, LXDE//) il faut utiliser la commande ''​gksu''​ ou ''​gksudo''​ ainsi :
doc/systeme/superutilisateur.1439825170.txt.gz · Dernière modification: 17/08/2015 17:26 par milou

Pied de page des forums

Propulsé par FluxBB