Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 KDE » Profil par défaut de Konsole » 14-02-2017 16:40:22

georges subrenat
Réponses : 0
Bonjour

Je suis en train de tester ansible pour pouvoir faire des déploiements en masse de configuration dans mon lycée. Je travaille avec debian testing et sous kde 5 . J'essaie de faire en sorte que konsole démarre avec un profil particulier, en mode solarisé.

À la base, j'ai mis mes fichiers de configuration dans un répertoire dotfiles. Les fichiers de configurations sont des liens symbolique activé par stow, qui pointent vers les fichiers de ce répertoire. Ce dernier est synchronisé via git avec un compte de framagit.


J'arrive à déployer les fichiers de configurations suivant:
- konsolerc dans le répertoire ~/.console
- un fichier terminale.profile et un   Solarized.colorscheme dans ~/.local/share/konsole

J'arrive à installer tout les paquets et les deux fichiers de configuration, mais le profil de konsole n'est pas pris par défaut. Il faut appuyer dans le menu de konsole permettant de choisir son profil sur le choix "choisir ce profil par défaut".

Il y a-t-il un moyen d'automatiser cela?

Voilà mon main.yml configurant ansible: c'est juste un essai, donc il est très court.


---
- name
: install packages
  become
: true
  apt
: name="{{item}}" state=present
  with_items
:
   - tmux
    - git-all
    - git-annex
    - screen
    - vim
    - stow
    - zsh
    - fonts-powerline

- name
: changer de shell et choisir zsh
  become
: true
  user
: name=georges shell=/bin/zsh

- name
: installer oh-my-zsh
  git
:
   repo=https://github.com/robbyrussell/oh-my-zsh.git
    dest=~/.oh-my-zsh

# On efface le .zshrc afin de ne pas avoir de pb lors du dotfiles
- file
:
   path
: /home/georges/.zshrc
   state
: absent
# On efface le fichier konsolerc dans ~/.config pour ne pas créer de conflit
- file
:
   path
: /home/georges/.config/konsolerc
   state
: absent

# On crée le répertoire dotfiles
- file
:
   path
: /home/georges/dotfiles
   state
: directory

- name
: Cloner le dotfiles
  git
: repo=https://framagit.org/georges/dotfiles-test.git dest=/home/georges/dotfiles

- name
: faire les liens symboliques via stow
  command
: chdir=/home/georges/dotfiles stow {{ item }}
  with_items
:
 - zsh

- name
: faire les liens symboliques via stow pour konsole
  command
: chdir=/home/georges/dotfiles stow -t ~/.local/share/konsole {{ item }}
  with_items
:
 - konsole

# On fait le lien symbolique pour que terminal.profile soit le profil par defaut.
- name
: faire de terminale.profile le profil par défaut
  command
: chdir=/home/georges/dotfiles stow -t ~/.config {{ item }}
  with_items
:
 - konsolerc

 



Je vous remercie d'avance de votre aide et de vos conseils éclairés. Je débute avec ansible, et c'est vraiment un bel outil!

#2 Re : Matériel » [Résolu] Heure de l'horloge hardware non conservée. » 24-02-2016 13:04:25

On a résolu notre problème, grâce aux gens du forum de handylinux entre autre.

Voilà la solution:


sudo timedatectl set-ntp true




Et là, tout fonctionne nickel sur une machine de 14 ans!

La source de l'astuce est ici:
https://wiki.archlinux.org/index.php/systemd-timesyncd

Merci à tous!!

#3 Re : Matériel » [Résolu] Heure de l'horloge hardware non conservée. » 23-02-2016 17:54:53

Bonjour

Merci de vos réponses.

Nous avons déplacé le jumper de la cmos1. Bilan, dans l'autre position, le pc ne boote plus. On l'a donc remis en place. Cependant, rien n'y fait.
Lors d'un arrêt long, c'est à dire plusieurs heures, l'horloge hardware ne se maintient pas: elle redémarre le 01 janvier 2002 à 00h 00 mn 00s. Et à partir de là, impossible d'avoir l'internet.

La carte réseau est intégrée à la carte mère.

Le Pc est un fujitsu siemens, avec une carte mère ms 7275.

Merci de vos aides!

#4 Matériel » [Résolu] Heure de l'horloge hardware non conservée. » 23-02-2016 10:18:52

georges subrenat
Réponses : 14
Bonjour

J'ai un soucis plutôt étrange:
nounours et moi nous avons bricolé un vieux pc. Il avait un soucis d'horloge qui se mettait par défaut à la date du 01/01/2002. On avait pensé à un problème de pile de la carte mère. Nous l'avons donc remplacé et là, patatra! L'horloge se remet de façon visiblement aléatoire à la date du 01/01/2002. Il semble que cela soit le seul réglage par défaut qui déconne. Le problème, c'est que cela affecte l'accès à l'internet.

Si vous avez une idée, merci d'avance.

Le résultat de la sortie de timedatect, après réglage de l'horloge, est :

 $ timedatectl
      Local time: mar. 2016-02-23 10:16:21 CET
  Universal time: mar. 2016-02-23 09:16:21 UTC
        RTC time: mar. 2016-02-23 10:16:44
       Time zone: Europe/Paris (CET, +0100)
     NTP enabled: no
NTP synchronized: no
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  dim. 2015-10-25 02:59:59 CEST
                  dim. 2015-10-25 02:00:00 CET
 Next DST change: DST begins (the clock jumps one hour forward) at
                  dim. 2016-03-27 01:59:59 CET
                  dim. 2016-03-27 03:00:00 CEST




Nous sommes sous handylinux 2.3

#5 Re : Réseau » [Résolu] raccordement filaire impossible » 01-09-2015 12:34:21

@nounours

D'accord, le plantage est lié à la carte vidéo qui n'est pas bien reconnue: on avait le soucis lors de l'installation. Il faudrait que tu utilise le mode graphique sans échec, accessible via la touche F4 au début du démarrage du CD live. Normalement, ça baisse la résolution de la carte et ça ne la fait pas planter. Là, tu pourras tester si tu accède à l'internet. Tu pourrais aussi travailler en mode texte et faire par exemple en console (donc sans utiliser le mode graphique) la commande wget  www.google.fr . Si  le réseau fonctionne, ça te ramène une page index.html

Mode pour ubuntu en live:
http://doc.ubuntu-fr.org/live_cd

#6 Re : Réseau » [Résolu] raccordement filaire impossible » 01-09-2015 11:22:22

Ah, si le live CD n'arrive pas à permettre une connexion à l'internet, ce n'est pas bon signe. Essaie toutefois avec le CD live de ubuntu 14.05 (l'avant dernière version) car il y a désormais deux possibilités: le CD de la 8.04 est peut être trop vieux et ne supporte pas ta carte réseau, ou alors la carte réseau est morte, et il faut en changer: ça coûte 10 euros environ pour une tour, il suffit de la mettre dans l'un des ports de la carte mère et de désactiver l'ancienne dans le BIOS.

#7 Re : Installation de Debian » [Abandonné] skype, mate, xfce ? » 17-07-2015 14:03:15

Non, ce n'est pas linux-firmware-nonfree, qu'il faut installer, car ça c'est sur ubuntu. C'est firmware-nonfree, qui comporte firmware-linux-nonfree...

apt-get install firmware-nonfree
 


bloc à supprimer si la commande n’affiche rien


La preuve !
https://packages.debian.org/fr/source/j … re-nonfree

#8 Re : Matériel » pc portable achat » 22-11-2013 15:38:41

Bon sinon, une balade sur debian.org montre que quelqu'un a installer jessie, la version suivante de débian sur ton pc et et il est indiqué que tout fonctionne...
https://wiki.debian.org/InstallingDebia … 0JV/Jessie

Ca vaut peut être la peine de quitter la branche stable de debian. Au pire, tu reviendra sous suse si tu n'es pas satisfait.

D'après ce que je lis, la carte graphique n'est pas reconnu immédiatement (xorg pour la  fait fonctionner en  utilisant les drivers générique, mais apparemment  il  y a un supplément qui n'est pas reconnu et ne fonctionne qu'avec les drivers propriétaires): c'est sans doute là l'origine des pbs avec debian en stable.

#9 Re : Matériel » pc portable achat » 22-11-2013 15:22:50

Tu ne risque pas de trouver un source.list pour suse: cette distribution fait partie de l'AUTRE CHEMIN du linux, à savoir la branche red hat, comme mandriva, ou centos (qui est la version communautaire de Red Hat). Ce n'est ni mieux ni moins bien que debian, mais ça ne fonctionne pas de la même façon: pas de dpkg, apt-install ou autre aptitude et une arborescence de répertoires différente. Donc il va falloir réapprendre les réflexes.

L'idéal serait sans doute d'arriver à réinstaller sous debian, tout en profitant de ce passage de l'AUTRE COTE pour voir un peu ce qui est reconnu et les drivers installés...

#10 Re : Réseau » wifi sous wheezy et Presario CQ70 » 24-08-2012 13:12:20

J'ai trouvé une solution, pas très élégante mais qui a l'air de fonctionner.

Je fais:

rm /dev/rfkill



Et je rebooute. Après mon bouton de wifi est réactivé.

Si vous avez une autre solution, plus élégante et évitant le reboot je suis preneur.

#11 Re : Réseau » wifi sous wheezy et Presario CQ70 » 23-08-2012 19:44:15

Je te remercie de ta réponse.

Cependant le problème n'a pas l'air d'être de ce coté puisque même sous kde j'arrive à faire fonctionner la wifi, mais cela uniquement à condition d'avoir auparavant activé matériellement le wifi sous gnome!

La carte wifi est reconnue, elle fonctionne même sous kde et avec wicd: c'est le bouton d'activation qui n'est pas visiblement reconnue.

Plus précisement: sous gnome, lorsque je presse le bouton activant la wifi, j'arrive à faire fonctionner la wifi.
J'éteins l'ordinateur tout en ne touchant pas ce bouton: avec wicd, le wifi fonctionne et j'arrive à me connecter à internet. Si j'appuie une fois sur le bouton activant le wifi j'éteins la wifi et là, en réappuyant, impossible de refaire démarrer le wifi et de me reconnecter.
En redémarrant sous gnome, là tout refonctionne!

De toute façon, en faisant:

root@Dyson:/home/georges# dmesg|grep " file not found"



Je n'obtiens rien du tout.

#12 Réseau » wifi sous wheezy et Presario CQ70 » 23-08-2012 10:13:02

georges subrenat
Réponses : 6
Bonjour

Je viens d'installer wheezy sur un presario CQ70 via une netinstall avec comme bureau KDE.
Tout marche bien sauf et c'est étonnant le wifi.

C'est étonnant parce que sous wheezy et gnome 3 (auquel je n'arrive pas à m'habituer) je n'ai aucun soucis de wifi!

Sous kde, j'utilise wicd.

Après différents test, j'ai constaté que c'est un problème assez stupide: la commande rfkill list 0, qui permet de mettre en évidence l'activation du bouton d'allumage du wifi me donne ceci quelque soit l'action effectuée:



root@Dyson:/home/georges# rfkill list 0
0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
 




Or lorsque j'utilise ma version live de debian/wheezy (produite via debian live build) je peux parfaitement commander ce bouton. Et lorsque j'active le wifi via wheezy en live,  et que je démarre après sur la wheezy installée, et bien j'ai le wifi!

La même commande me donne:

root@Dyson:/home/georges# rfkill list 0
0: hp-wifi: Wireless LAN
        Soft blocked:no
        Hard blocked: no
 



Donc, j'en conclu que j'ai un soucis avec ce bouton sous kde. Comment pourrais je activer la reconnaissance de ce commutateur sous wheezy avec kde?

D'avance merci!

#13 Matériel » Douchette USB » 28-02-2012 17:51:39

georges subrenat
Réponses : 1
Bonjour

J'aimerai m'acheter une douchette usb afin de lire les codes barres des bouquins de ma bibliothèque. Le but est de constituer rapidement une base de donnée que je pourrais gérer un peu mieux.

S'il y a parmi vous des gens utilisant ce type de matériel, pouvez vous me conseiller du matériel mais aussi m'indiquer les détails auquel je devrais faire attention pour l'usage au quotidien de ce type d'outils.

Je vous remercie d'avance pour votre aide.

Pied de page des forums

Propulsé par FluxBB