Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Multimédia » Grosses différences Chromium, Chrome, Firefox sur youtube h.264 ou VP9 » 04-06-2019 22:48:14

golgot200 a écrit :

....
EDIT : C'est bien celle-ci ?


mediainfo "Train Driver's View - Washer, track 12 and then Oslo - Ål in 4K UltraHD-GjykaBdn51U.f315.webm.part"
General
Complete name                            : Train Driver's View - Washer, track 12 and then Oslo - Ål in 4K UltraHD-GjykaBdn51U.f315.webm.part
Format                                   : WebM
Format version                           : Version 4
File size                                : 85.4 MiB
Duration                                 : 3 h 24 min
Overall bit rate                         : 58.4 kb/s
Writing application                      : google/video-file
Writing library                          : google/video-file
IsTruncated                              : Yes
FileExtension_Invalid                    : webm

Video
ID                                       : 1
Format                                   : VP9
Codec ID                                 : V_VP9
Duration                                 : 3 h 24 min
Bit rate                                 : 49.2 kb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 59.940 FPS
Color space                              : YUV
Bits/(Pixel*Frame)                       : 0.000
Stream size                              : 71.9 MiB (84%)
Language                                 : English
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
 



oui, la version 1440p pour moi, autrement il y a la précédente dans la chaine qui fait moins (1h30 environ, et 5.8Go la version 1440p)

#2 Multimédia » Grosses différences Chromium, Chrome, Firefox sur youtube h.264 ou VP9 » 04-06-2019 08:45:40

jean-thevenet
Réponses : 5
Chromium est meilleur et de loin pour la lecture des vidéos resservies en H.264, chrome et firefox pixellisent parfois totalement la version 1080p de la vidéo (à ce niveau là c'est une défaillance), alors que chromium la lit aussi bien que la version téléchargée (sous fire-fox) avec VLC

exemple
https://www.youtube.com/watch?v=CTlyTUPB-rA comparez chrome et chromium (et firefox), en 1080p
Chromium est bridé à 1080p mais atteint un niveau de qualité qu'on n'atteint (ou dépasse un peu) seulement en 1440p avec firefox et chrome
autre exemple pour lequel j'ai préparé des saisies d'écran.

chrome-1080p-.jpg
chrome-1080p

chromium-1080p-.jpg
chromium-1080p

Examinez le rendu de l'herbe.

Ce petit détail fait que seul chromium fonctionne pour lire le streaming (chaines de télévisions, les replay), sinon, il faut les télécharger pour les voir dans la netteté correspondante à leur définition.

Chromium échoue totalement pour lire les vidéos d'origine 4K qui sont resservie en On2 VP9, la qualité se dégrade entre chaque images clef pour finir au même niveau de qualité que la version 480p

Chrome et firefox le réussissent, mais chez moi c'est saccadé: la charge de travail atteint 100% des 4 processeurs, ce n'est pas la carte graphique qui est en jeu mais le codec pour le on2 VP9 qui est mal utilisé.

Par contre, une fois téléchargé, cette vidéo passe correctement sur l'ordinateur en lecture fluide, même la version 1440p 60Hz lue avec VLC ou MPV, ce qui prouve le défaillance du décodage on2 vp9 dans les navigateurs. Mais pour la lecture avec VLC et autres, ce n'est possible qu'en méthode d'accélération matérielle SNA, et avec 60% de la puissance processeur: sur le disque dur, les performances n'ont pas baissées (ou peu), par rapport à la faille d'INTEL pour les médias les plus lourds (le 1440p en 60Hz)

Il s'est passé quelque chose aux alentours de mai 2019 lié à chrome et firefox qui font que le codec on2 VP9 consomme plus pour réussir à rendre ces images (et ce que ce soit UXA ou SNA ou rien du tout de configuré) , il y a quelques mois je visionnais longuement en 1440p 60Hz ces vidéos de norvège ou du japon sans problème de puissance: il n'est plus possible de lire correctement le 1080p 60Hz si resservie en On2 VP9: soit c'est dégueu, soit ça demande trop de puissance.

Vérifications faite que c'est lié au On2 VP9: le H.264 60Hz 1080p (débit 6.5Mb/s) passe sans surcharge processeur et reste accessible dans sa version 1080p
Pour cet exemple là, chrome et chromium se valent en qualité mais chrome fonctionne bien qu'en méthode SNA et chromium en méthode UXA, la différence de qualité dans les texture constatées sur le format 1080p 30Hz h.264 ne semble pas se manifester sur cet essai en 60Hz (h.265 5Mb/s upload, mais youtube le rend apparemment en h.264 6.5Mb/s contre 4.3 pour le 30Hz).
Coté textural, le même débit consacré au 30Hz ne donnait pas un meilleur rendu pour un poids de fichier identique: youtube le ressord en 4.3Mb/s au lieu de 6.5 alors que l'lupload fait 5Mb/s pour les deux essais 30 et 60Hz, il y a donc moins de pertes en envoyant du 60Hz. Le phénomène démarquant chromium de chrome n'existait pas à l'époque. Il se produit pour les vidéos envoyées après mi mai 2019 (pour le 1080p), à croire que youtube a changé son réencodage..

J'ai en effet remarqué une trop grosse perte de qualité de la version 1080p qui m'a incité à utiliser le format 1440p, mais cette perte de qualité était du à mon navigateur chrome ou firefox qui lisent trop mal le 1080p: avec chromium ça reste bon.


Autre bizarrerie avec l'accélération matérielle: la méthode SNA est bien plus puissante mais est instable pour les vidéos  (même légères) enregistrées sur disque dur qui font 30Hz (saccades), mais pas celle de 60 (mon écran ne pouvant être utilisé qu'en 60Hz).
Pour être tranquille sur les vidéos de 30Hz je dois rebasculer en méthode UXA. Mais le méthode SNA plus puissante assure sans peine la lecture 60Hz 1440p alors que la méthode UXA, qui ne trébuche pas sur le 30Hz, plafonne à 1440p 30Hz et s'essoufle sur le 60Hz, de la même façon qu'avec les navigateurs web..

Avant les mises à jour de mai 2019, le problème ne s'était jamais posé: c'était toujours impeccablement lu depuis le disque dur.

Donc debian 9.9 se termine avec un "gros bordel" considérant la gestion des codecs et des formats qui obligent à jongler avec plusieurs navigateurs et à télécharger les vidéos pour pouvoir les visionner correctement, a rebooter en chargeant l'accélération graphique en UXA ou en SNA selon les cas: c'est vraiment peu pratique, et cela est en plus de l'impossibilité de choisir autre chose que du 60Hz en VGA pour l'écran (alors qu'avant stretch il y avait les autres fps). J'ai aussi l'impression que les navigateurs utilisent des méthodes d'accélération matérielle qui entrent en conflit avec celle configurée, que youtube a ajouté des subtilités dans les codecs des vidéos resservies, et aucune littérature en parle clairement, à l'heure où l'ordinateur sert de plus en plus à produire de la vidéo et à lire du multimédia, ça n'a jamais été autant le "bordel"..

#3 Re : Présentations » Présentation de "cdarsac" (Toulouse) » 04-06-2019 07:51:45

salut à toi.
Tu te formes pour le travail? dans quel domaine?
Linux s'est montré un peu faible en audio-vidéo, mais a bien rattrapé quelques lacunes de l'essentiel avec audacity et quelques logiciels de montage vidéo, c'est par contre la misère question gestion de l'écran (dans le choix des fréquences, j'étais habitué à avoir des multiples de 24,25 et 30Hz (48,50,60,72,75,85, 96 et 100Hz), maintenant il n'y a plus que du 60Hz. C'est dans ces domaines que j'ai voulu être aidé dernièrement et suis donc allé sur les faux rhum, mais ça saôule, malgré tout.

#4 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 28-05-2019 16:01:53

Je continue quelques essais, j'ai téléchargé la vidéo 1440p et 1080p de https://www.youtube.com/watch?v=_3alv4u3UPU durée 1h14'57" format 60Hz codec On2 VP9 son opus (original 4K en h.265 85Mb/s )

Original 4K h.265 85Mb/s 45Go (d'après le monsieur qui l'a envoyé)
Version 1080p 2.1Go 4.3Mb/s sur youtube, à peine accessible avec quelques sauts et 90% processeur, lu en local est rendu avec 40% puissance processeur. Avec Chomium un problème de décodage interdit d'en profiter, investigation faites, seulement avec le codec On2vp9: la vidéo a un rendu 480p par intermitence. Le seul moyen de regarder correctement la version 1080p est donc de la mettre sur le disque dur et de la lire avec VLC.

Version 1440p 5.8 Go 11.7Mb/s, demande 60% de la puissance processeur, mais est saccadée en fonction de la richesse de l'image!  Mon ordinateur avec VLC peine à la lire correctement sauf les passages dans les tunnels!
C'est un débit variable. Ce débit ne varie pas selon la richesse de l'image ni selon le mouvement, mais selon... sa luminance (le débit reste quasi au maximum lorsque que le train est à l'arrêt, mais est au minimum dans les tunnels).
Ceci est peut être du à la baisse de résolution de la go-pro en basse lumière qui fournie alors une image composées de gros pixels qui représentent donc une redondance élargie à de vastes région de l'image: peut être que le débit est fonction de nombres d'éléments de l'image, même si ils sont immobiles!
Dans les tunnels: 5Mb/s environ (2.2 version 1080p), et dans le paysage, 13 Mb/s (5Mb/s version 1080p),
en 1440p au delà de 10Mb/s environ la puissance de calcul manque (elle ne manquait pas avant la mise à jour de debian 9 début mai 2019)

Les problèmes insolubles de saccades qui restent avec la bon réglage pour la vidéo (la méthode uxa) sont liés au codec On2vp9: les vidéos 60Hz passent bien si elles sont en h.264 mais passent mal en On2 VP9
Quand il s'agit de vidéos youtube au format 1080p, chromium les lit bien mieux (bien plus net) que firefox et chrome, si elles sont en h.264, ce qui est le cas avec des vidéos qui n'étaient pas des 4K mais des 1440p ou 1080p quand on les a envoyé.

De plus le On2 VP9 a un effet détestable d'éléments d'image raffraichies à intervalles réguliers avec une pulsation de 1 à quelques herzt, ce qui est insoutenable avec de la synesthésie (perception visuelle utilisant en partie les zones du cerveau-audio)

#5 Re : Suivi du Wiki et des Projets Git » Wiki: Kdenlive » 22-05-2019 23:23:14

J'aime bien l'analyse, (histogramme et analyse d'image)


Intéressant, tu peux faire un bout de tuto là-dessus ?
Comment tu les interprètes selon tes besoin avec un exemple simple...



Cette visualisation est celle "à la mode" dans Da Vinci résolve et ça surprend de la voir là, et c'est très simple en fait, ça permet de savoir si les noirs sont bien noirs ou gris, si le signal est écrêté (tape en haut), ou bouché (tape en bas), si la plage dynamique de sortie est trop faible, c'est écrêté en haut avant le vrai blanc et les noirs se tassent sur une limite correspondant au gris (pour ajuster le contraste des vidéos profil "flat" il faut expenser cette plage de sortie jusqu'à que ça frôle les limite... etc)

#6 Re : Suivi du Wiki et des Projets Git » Wiki: Kdenlive » 22-05-2019 19:28:24

Ce qui manque (est c'est essentiel), c'est de pouvoir indiquer en chiffre précis le bitrate pour le codec vidéo lors de l'encodage: j'ai longtemps cherché, il y a "qualité" mais l'unité employée est relative: ça me bloque, car je sais précisément quel bitrate employer, mais pas à quoi correspond "qualité", ça ne permet pas de gérer son choix (sinon à tâtons, mais c'est très long).

J'aime bien l'analyse, (histogramme et analyse d'image)

#7 Re : Système » Nouvelle faille? Intel-Microcode - ZombieLoad, RIDL, Fallout & co... » 22-05-2019 08:29:32

oui, c'est par les effets désastreux sur la vidéo sur tous les lecteurs vidéo et navigateur web que je me suis posé la question de la gestion du processeur, mais je ne peux pas dire que c'est juste ça car des logiciels non concernés par la mise à jour globale (Pitivi et Open shot), ont conservé leur performance: ça n'affecte pas des taches de calcul, mais semble affecter des taches qui font coopérer ensemble processeur et carte graphique..

#8 Re : Système » Nouvelle faille? Intel-Microcode - ZombieLoad, RIDL, Fallout & co... » 21-05-2019 09:32:12

mon processeur n'a pas l'hyper-threading mais la dernière mise à jour (incluant évidemment celle de sécurité comportant le nouveau micro-code-intel) a considérablement réduit la performance de lecture des vidéos, même en rétrogradant le noyau et en optimisant le système (et en testant des versions plus anciennes des lecteurs): je n'ai plus le 1440p 60Hz qui demande plus que 100% (donc impossible), contre 60% avant.
Pourtant j'ai le noyau 4.19 qui tourne un peu mieux que les autres plus récents, et avant cette perte de performance j'avais le noyau 4.9.0-6

#9 Re : Le bar » Linux saboté par des concurrents "de l'intérieur"?!! » 20-05-2019 00:56:46

Le processeur ralenti par les mises à jours de sécurité explique aussi une rétrogradation des performances.

#10 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 20-05-2019 00:55:56

Le processeur intel a du être ralenti par la mise à jour du micro-code ce qui explique peut être que l'image n'arrive pas dans les délais à la carte graphique, et peut être aussi certaines routines comptent encore sur la fonctionnalité désactivée du processeur. https://debian-facile.org/viewtopic.php?id=24398

#12 Re : Multimédia » debian stretch 9.9 et chromium, limité au 1080p » 19-05-2019 16:13:57

Chromium ne décode pas du tout de la même façon les vidéos que Chrome et firefox. Avec les miennes ils donne de meilleurs résultats là où chrome efface carrément l'herbe (voir http://thevenet.jean.free.fr/texture-et … video.html )
Par contre, avec des vidéos de https://www.youtube.com/user/HinduCowGirl/videos (celle ci https://www.youtube.com/watch?v=klN-XxzlPkY pour  la version 720p et 1080p (bloqué à la définition demandé), il y a des pertes de nettetés importantes (équivalente lire 480p) à intervalles réguliers, et ça ne le fait pas avec chrome et firefox)
Ça le fait aussi sur https://www.youtube.com/watch?v=vXIw8FfF-Ns&t=197s
ces vidéos de sources différentes ont un commun des textures en mouvement et d'être réencodées à partir d'une version 4K, je crois que elles sont réencodées en On2 VP9 dans les versions 1440 1080 720 au lieu d'être en h.264, et là, c'est chromium qui s'en sort comme un manche.

#14 Re : Le bar » Linux saboté par des concurrents "de l'intérieur"?!! » 19-05-2019 15:20:57

Quel est le Kon qui a ajouté le "culling" sans rien dire?

nano /etc/environment
ajouter.
CLUTTER_PAINT=disable-clipped-redraws:disable-culling

ça empêchait ce qui marchait dans la fenêtre de continuer à fonctionner en plein écran, et c'était ça qui peut être (je ne vais pas faire tous les essais à nouveaux, faisaient les saccades avec l'option SNA + TEARFREE
que j'ai pu réactiver du coup, ça marche encore mieux (moins de consommation électrique)

echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | tee /etc/X11/xorg.conf.d/20-intel.conf
 



Ce n'est pas un signe de bonne santé mentale d'être bien adapté à une société malade


Du coup l'allocation d'adulte handicapé, c'est pour les pas malades: et aux états unis on a enlevé le syndrome neurotypique du DSM.

#15 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 19-05-2019 15:14:42

TRÈS IMPORTANT AUSSI, ça semble résoudre tous les problèmes liés à la synchro-verticale qui empêchait d'utiliser l'option tearfree avec l'accélération SNA
cette ligne à ajouter dans nano /etc/environment
ajouter.
CLUTTER_PAINT=disable-clipped-redraws:disable-culling

C'était ça le truc qui faisait merder tout ce qui marchait bien sauf une fois en plein écran!!!

Le culling: voilà bien encore un truc à la con, difficile à repérer, et chiant à en avoir plein le cul, qui a du être ajouté dans les mises à jour...
ça a sans doute une utilité... mais laquelle?

Reste que sans cela ça tourne tout mieux avec le noyau 4.19 qu'avec les plus récents.

#17 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 17-05-2019 19:04:46

vérifié avec
# uname -a
Linux cilaos-centre-du-monde 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 GNU/Linux

Ça fonctionne tout aussi bien sous  Cinnamon
mais retour de ces erreurs

# dmesg -l err
[    0.019129] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[    0.019313] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[    0.019476] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[    0.020582] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)
[    0.555874] serial 0000:00:16.3: Couldn't register serial port 4080, irq 19, type 0, error -28
[    3.130654] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    3.130664] EDID block is all zeroes
[    3.137734] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    3.137744] EDID block is all zeroes
[    3.141599] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    3.141607] EDID block is all zeroes
[    3.145403] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    3.145411] EDID block is all zeroes

#18 Re : Le bar » Linux saboté par des concurrents "de l'intérieur"?!! » 17-05-2019 18:55:14

C'est la mise à jour de plusieurs éléments qui a tout foiré: ça ne fonctionne plus nom plus avec un noyau récent (j'ai après plusieurs essais repris un vieux noyau) Les versions récente demande trop de ressources pour gérer à la fois le gestionnaire de fenêtre et les vidéos.
il y aussi le démarage par gdm qui part sur une mauvaise base graphique (démarer avec sdm, sans fichier de configuration, fait "ce qu'il faut), c'est peut être tout simplement que ça demande trop de travail à l'ordinateur pour qu'il puisse fonctionner avec la methode "tearfree"
Cinnadon marche mieux.

#19 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 17-05-2019 18:37:21

Croutons a écrit :

pourtant pas le seul a avoir cette carte graphique
https://forums.linuxmint.com/viewtopic.php?t=275668


Il utilise lui aussi  Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)

Ce message d'erreur a disparu en remettant un noyau plus ancien:  4.19.0-0.bpo.4-amd64 #1 SMP Debian 4.19.28-2~bpo9+1 (2019-03-27) x86_64 GNU/Linux
.

[    2.812312] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.812323] EDID block is all zeroes
[    2.815918] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.815928] EDID block is all zeroes
[    2.819467] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.819473] EDID block is all zeroes
[    2.823045] [drm:drm_edid_block_valid [drm]] *ERROR* EDID has major version 0, instead of 1
[    2.823053] EDID block is all zeroes

[    0.019586] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[    0.019771] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
[    0.019936] ACPI Exception: AE_NOT_FOUND, (SSDT: SKL-ULT) while loading table (20160831/tbxfload-228)
[    0.021036] ACPI Error: 1 table load failures, 6 successful (20160831/tbxfload-246)

#20 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 17-05-2019 18:34:14

tout fonctionne avec Cinnamon (et option "tearfree") (sauf le choix de l'écran, toujours bloqué à 60hz)
Mais avec Mate non, pas mieux qu'avant (donc ce n'est pas le démarage par gdm3), pour les lags et le tearing le fautif est donc mate (et à retester si lxde aussi)
et au moins (Cinnamon) ON PEUT RÉGLER LA SOURIS!!!

#21 Re : Multimédia » écran externe considéré comme l'écran d'un portable LCD (sur un fixe) » 17-05-2019 17:54:05

Ne pas se servir de gdm3 mais de sdm pour démarer a résolu le problème du tearing et des saccades, mais pas du choix de l'écran. rétrograder au noyau 4.19 au lieu de 4.909 a résolu les erreurs ACP et DRM qui empêchaient de démarrer le pilote intel i915

#22 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 17-05-2019 17:51:24

en n'utilisant plus gdm3 mais sdm (mais en démarrant par sdm), tous les logiciels marchent, à la fois les navigateurs web et VLC pour la vidéo, et "Eye of Mate" pour la photo: gdm3 (?) ou MATE (?) chargeait (à moins que ça ne soit pas ça et que Mate toure comme une grosse bouze) son propre pilote graphique qui n'était pas le i915 d'Intel!!! (ce qui me fait dire ça c'est que quand le pilote n'y était pas ça fonctionnait pareil)
C'est "résolu", mais en perdant tout de même l'utilisation de Mate, à la place un autre gestionaire de bureau  moins ergonomique pour moi, c'est donc pas tout à fait résolu.

#23 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 17-05-2019 00:49:07

retesté avec toutes les options, ça marche le mieux (à la fois VLC, MV-player et chromium qu'en supprimant ce fichier de configuration
ce n'est peut être tout simplement pas le pilote intel graphic qui est utilisé... donc ça ne configurait pas le pilote fonctionnel.
~$ lspci -v

[code]VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) (prog-if 00 [VGA controller])                                                                                                
        Subsystem: Intel Corporation HD Graphics 530                                                                                                                                                      
        Flags: bus master, fast devsel, latency 0, IRQ 132                                                                                                                                                
        Memory at c0000000 (64-bit, non-prefetchable) [size=16M]                                                                                                                                          
        Memory at b0000000 (64-bit, prefetchable) [size=256M]                                                                                                                                              
        I/O ports at 4000 [size=64]                                                                                                                                                                        
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]                                                                                                                                        
        Capabilities: <access denied>                                                                                                                                                                      
        Kernel driver in use: i915                                                                                                                                                                        
        Kernel modules: i915   [/code]



Corporation HD Graphics 530
Kernel driver in use: i915
Kernel modules: i915

#24 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 16-05-2019 23:07:28

non-résolu: ça ne tient quelques minutes et ça saccade comme (dans tous les logiciels de visualisation vidéo), un logiciel, je ne sais pas lequel occupe la mémoire ou le tampon de mémoire et empêche un défilement fluide des images: ça marche à condition de ne rien démarrer d'autre (peut être thunderbird), seulement regarder de la vidéo.
SI non précisé, la méthode d'accélération matérielle devrait être "glamor"

#25 Re : Matériel » INTEL-graphic tearing et lags chrome-firefox-VLC... [résolu] -- sdm » 16-05-2019 21:47:34

Trouvé la bonne configuration grâce au témoignage https://bugs.chromium.org/p/chromium/is … ?id=344141
sauf que moi c'était Chrome

mkdir /etc/X11/xorg.conf.d/
 



echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n# Option "AccelMethod" "uxa"\n# Option "AccelMethod" "sna"\n Option "TearFree" "true"\n# Option "SwapbuffersWait" "true"\n# Option "VSync" "true"\n# Option "DRI" "2"\nEndSection' | tee /etc/X11/xorg.conf.d/20-intel.conf
 



vérification

#  nano /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
 Identifier "Intel Graphics"
 Driver "Intel"
# Option "AccelMethod" "uxa"
# Option "AccelMethod" "sna"
 Option "TearFree" "true"
# Option "SwapbuffersWait" "true"
# Option "VSync" "true"
# Option "DRI" "2"
EndSection
 



Option "TearFree" "true" et SEULEMENT ÇA.

les 3 navigateurs (dont firefox qui pour la première fois de ma vie fonctionne en streaming) et VLC et Mpv-fonctionnent enfin
Pour regarder les doccumentaire d'Arte ou le journal de Réunion 1ère, reste maintenant à faire reconnaître l'écran (pour le 25 et 50 fps).

Pied de page des forums

Propulsé par FluxBB