Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-11-2014 21:06:40

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

[RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Bonjour à tous,

J'ai réinstallé mon système à l'identique sur un disque SSD mais en partitionnant avec LVM chiffré cette fois.
Et je ne parviens plus à configurer l'interface de grub, notamment à lui faire prendre en compte les modifications de /etc/default/grub (background et résolution surtout).
Le fond d'écran est placé dans la partition non chiffrée /boot.
Voici le fichier en question:

GRUB_DEFAULT=0
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nmi_watchdog=0"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs                                                    
# This works with Linux (no patch required) and with any kernel that obtains                                          
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)                                              
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"                                                            

# Uncomment to disable graphical terminal (grub-pc only)                                                              
#GRUB_TERMINAL=console                                                                                                

# The resolution used on graphical terminal                                                                          
# note that you can use only modes which your graphic card supports via VBE                                          
# you can see them in real GRUB with the command `vbeinfo'                                                            
GRUB_GFXMODE=1366x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux                                        
#GRUB_DISABLE_LINUX_UUID=true                                                                                        

# Uncomment to disable generation of recovery mode menu entries                                                      
#GRUB_DISABLE_RECOVERY="true"                                                                                        

# Uncomment to get a beep at grub start                                                                              
#GRUB_INIT_TUNE="480 440 1"                                                                                          

# Adding wallpaper for grub:                                                                                          
GRUB_BACKGROUND="/boot/grub/grub_bg.tga"



Après un:

update-grub

j'obtiens:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.16-0.bpo.3-amd64
Found initrd image: /boot/initrd.img-3.16-0.bpo.3-amd64
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
done
 


Le fond d'écran n'est pas pris en compte et au redémarrage, la résolution non plus.

Le paquet desktop-base qui installe certains fond de grub est installé, mais sans effet lui aussi.
J'ai vérifié les droits en lecture sur les fichiers concernés.

Auriez-vous une idée?

Dernière modification par sogal (22-11-2014 02:53:30)


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#2 12-11-2014 21:46:41

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Vérifie si :
- la partition de boot non chiffrée est montée sur /boot
- la date du fichier /boot/grub/grub.cfg correspond à la dernière exécution d'update-grub
- son contenu prend en compte les paramètres ajoutés dans /etc/default/grub.

Hors ligne

#3 12-11-2014 22:42:40

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Salut et merci pour ton retour,

raleur a écrit :

Vérifie si :
- la partition de boot non chiffrée est montée sur /boot
- la date du fichier /boot/grub/grub.cfg correspond à la dernière exécution d'update-grub
- son contenu prend en compte les paramètres ajoutés dans /etc/default/grub.


Oui pour les 2 premiers points, pour le dernier, seule une option passée à grub est présente (nmi_watchdog), aucune trace du fond d'écran.

PS: j'ai omis de le préciser mais le paquet grub2-splashimages est bien installé.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 14-11-2014 15:07:31

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Plop sogalpunx,
Tu as essayé de ré-installer le grub sur le secteur de démarrage ?
Tu as essayé de spécifier à la main le chemin vers l'image dans le grub.cfg ?
Tu as essayé de le spécifier sans le préfixe « /boot » qui n'est peut-être pas nécessaire dans le cas d'une partition /boot séparée ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 22-11-2014 01:42:44

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Oï, désolé, je n'avais pas vu passer ta réponse.
Oui j'ai essayé tout cela, en vain.
Certains paramètres de /etc/default/grub sont pris en compte (options noyau).
J'ai créé un /boot/grub/custom.cfg avec des couleurs du menu, c'est pris en compte.
J'ai l'impression que ça vient du module "gfxmode". Je ne m'y connais pas trop en GRUB, mais l'option GFXMODE  du /etc/default/grub n'est pas prise en compte.
Voici mon grub.cfg:


#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

set timeout=3
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=cyan/black
set menu_color_highlight=white/black
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Debian GNU/Linux, avec Linux 3.16-0.bpo.3-amd64' --class debian --class gnu-linux --class gnu --class os {
  load_video
  set gfxpayload=1366x768
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root 5f224364-b398-40d3-9b61-b2961e7ecb52
  echo  'Chargement de Linux 3.16-0.bpo.3-amd64 ...'
  linux /vmlinuz-3.16-0.bpo.3-amd64 root=/dev/mapper/akuma-root ro  quiet nmi_watchdog=0
  echo  'Chargement du disque mémoire initial ...'
  initrd  /initrd.img-3.16-0.bpo.3-amd64
}
menuentry 'Debian GNU/Linux, avec Linux 3.16-0.bpo.3-amd64 (mode de dépannage)' --class debian --class gnu-linux --class gnu --class os {
  load_video
  set gfxpayload=1366x768
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root 5f224364-b398-40d3-9b61-b2961e7ecb52
  echo  'Chargement de Linux 3.16-0.bpo.3-amd64 ...'
  linux /vmlinuz-3.16-0.bpo.3-amd64 root=/dev/mapper/akuma-root ro single
  echo  'Chargement du disque mémoire initial ...'
  initrd  /initrd.img-3.16-0.bpo.3-amd64
}
menuentry 'Debian GNU/Linux, avec Linux 3.2.0-4-amd64' --class debian --class gnu-linux --class gnu --class os {
  load_video
  set gfxpayload=1366x768
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root 5f224364-b398-40d3-9b61-b2961e7ecb52
  echo  'Chargement de Linux 3.2.0-4-amd64 ...'
  linux /vmlinuz-3.2.0-4-amd64 root=/dev/mapper/akuma-root ro  quiet nmi_watchdog=0
  echo  'Chargement du disque mémoire initial ...'
  initrd  /initrd.img-3.2.0-4-amd64
}
menuentry 'Debian GNU/Linux, avec Linux 3.2.0-4-amd64 (mode de dépannage)' --class debian --class gnu-linux --class gnu --class os {
  load_video
  set gfxpayload=1366x768
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root 5f224364-b398-40d3-9b61-b2961e7ecb52
  echo  'Chargement de Linux 3.2.0-4-amd64 ...'
  linux /vmlinuz-3.2.0-4-amd64 root=/dev/mapper/akuma-root ro single
  echo  'Chargement du disque mémoire initial ...'
  initrd  /initrd.img-3.2.0-4-amd64
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
 


Comparé à chez vous, ça cloche?

PS: c'est depuis la réinstallation uniquement, c'est pourtant le même fichier de config qu'avant (et les droits sont corrects).
Merci!


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#6 22-11-2014 02:53:04

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Bon en fait, j'ai purgé tous les paquets grub* puis reinstallé "grub-pc" et ça fonctionne à nouveau.
Et contrairement à ce qui est dit dans le wiki Debian, l'installation du paquet "grub[2]-splashimages" n'est pas nécessaire pour afficher un fond d'écran. Ce paquet contient simplement des fonds d'écrans smile

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#7 22-11-2014 07:38:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Corrige le wiki en ce sens, et fait remonter l'info dans le forum par le lien dans le tuto, en te de celui-ci. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#8 22-11-2014 17:37:32

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU]Config Grub2 en LVM: /etc/default/grub non pris en compte

Je ne parlais pas du wiki DF mais de https://wiki.debian.org/fr/Grub2 qui laisse entendre, du moins c'est comme ça que je l'ai compris, que pour utiliser un fond d'écran de Grub2, le paquet susmentionné est nécessaire, hors ce n'est apparemment pas le cas.
Mais oui, je vais faire un petit paragraphe là-dessus dans http://debian-facile.org/doc:systeme:grub2 wink

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

Pied de page des forums