Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 23-11-2014 16:15:11

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Peux-tu retenter cette modification de grub, mais sur l'entrée "mode normal" ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#27 23-11-2014 16:41:17

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Voici le screenshot en mode classique après la motif dans grub :

141123034148897252.jpg

" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#28 23-11-2014 17:41:58

raleur
Membre
Inscription : 03-10-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Tu veux dire que l'affichage reste figé sur cet écran ?

Pour info il ressort d'une recherche sur le web que ce problème n'est pas un cas isolé. Mais je n'ai pas vu de solution franche. Parfois il est dit que modeset=0 contourne le problème, mais en désactivant l'accéleration graphique, ou que le pilote propriétaire ATI fglrx fonctionne.

Hors ligne

#29 23-11-2014 17:59:15

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Après le texte l'écran noir se lance..
Je me fais pas d'illusion, ça fait quelques années que je me tente à installer Debian sur cette machine sans succès, mais c'est la première fois que j'arrive aussi loin! smile

Le pire c'est que j'aimerais aussi installer debian sur mon iBook G4 mais là ça risque d'être encore plus compliqué. big_smile

Dernière modification par Theverglades (23-11-2014 17:59:48)


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#30 23-11-2014 18:56:50

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Bon, on va devoir y aller à la rache, kwa.  mad

De la même façon que pour le modeset, tu vas spécifier une résolution :

radeon.modeset=0  grub_gfxmode=1024x768x16

des fois que ...


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#31 23-11-2014 19:01:49

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Et ensuite, si tu veux tenter le pilote proprio : https://debian-facile.org/doc:materiel: … ue:ati:ati

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#32 23-11-2014 19:22:58

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

l'imposition de la résolution n'a pas fonctionné..
je vais tenter l'installation du pilote proprio.

En fouinant sur le net je suis tombé sur un gars qui avait le même problème et qui l'a résolu (en 2011), je cite:

J'en ai profité pour essayer de nouveau une install de Debian, j'ai choisi la version testing pour avoir un noyau assez récent car à mon avis le soucis vient de la et à ma grande satisfaction, installation sans problème (bureau KDE) redémarrage at à la place de ce foutu écran noir, le bel écran d'accueil de KDE.



Ce pourrait-il que gnome soit incompatible?


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#33 23-11-2014 20:13:41

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Bon je viens de tenter l'installation du pilote proprio, je ne suis pas sur que cela s'est bien passé, j'ai rencontré plusieurs messages que voici :

141123070817732429.jpg

141123071256821457.jpg

141123071352287356.jpg

" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#34 24-11-2014 09:16:38

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Bonjour,

Quel paquet as-tu installé ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#35 24-11-2014 12:40:01

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Bonjour Paskal!

J'ai tenté ça:

apt-get install fglrx-modules-dkms fglrx-driver linux-headers-$(uname -r) fglrx-control


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#36 24-11-2014 21:36:40

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Bonsoir,

Manifestement, celui-ci ne convient pas, il ne te reste plus que la solution fglrx-legacy-driver.
Pour cela, il te faut suivre à la lettre les indications de ton screen 2 : purger l'installation précédente, activer le dépôt wheezy-backports et seulement ensuite installer ce paquet.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#37 24-11-2014 21:42:42

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

paskal a écrit :

Bonsoir,

Manifestement, celui-ci ne convient pas, il ne te reste plus que la solution fglrx-legacy-driver.
Pour cela, il te faut suivre à la lettre les indications de ton screen 2 : purger l'installation précédente, activer le dépôt wheezy-backports et seulement ensuite installer ce paquet.



Bonsoir Paskal, j'allais justement tenter cette solution mais je me posais la question suivante : faut il que j'enlève le driver libre ou uniquement le proprio?


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#38 25-11-2014 18:22:57

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Le driver libre, tu peux te contenter de le blacklister.

Le proprio, il faut le purger et supprimer sa config dans xorg.conf et éventuellement xorg.conf.d

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#39 25-11-2014 21:46:41

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Bonsoir Paskal,
Merci de suivre encore le fil, ça fait plaisir!

Peux-tu me confirmer les commandes suivantes s'il te plait, je suis toujours débutant big_smile

apt-get remove purge fglrx-modules-dkms fglrx-driver linux-headers-$(uname -r) fglrx-control


ou

aptitude purge '~ifglrx rm -f /etc/X11/xorg.conf



puis:

aptitude -t wheezy-backports install fglrx-legacy-driver



et après :

aticonfig --initial



Je te promets, j'essaie de suivre mais certains trucs m'échappent encore! On trouve des tas de commandes sur le net ce qui ne fait que m'embrouiller encore plus..
Merci pour ta patience!


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#40 25-11-2014 22:30:08

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Mais de rien  smile


Pour la première :

apt-get purge fglrx-modules-dkms fglrx-driver fglrx-control

Tu peux conserver les headers.


La deuxième me semble correcte.


Avant d'installer fglrx-legacy-driver, tu places dans ton sources.list :

## wheezy-backports
deb http://ftp.fr.debian.org/debian wheezy-backports main contrib non-free


Puis tu fais :

apt-get update

pour mettre à jour la base de données de apt, et :

apt-get install -t wheezy-backports fglrx-legacy-driver


et ensuite :

aticonfig --initial




Bon courage.  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#41 25-11-2014 23:11:43

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Alors tout s'est déroulé sans problème, mais toujours cet écran noir...
Je suppose que tu ne vas pas tarder à être à court d'idée..

" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#42 25-11-2014 23:15:10

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Tu supposes bien.  lol
En même temps, personne n'a dit que ce serait impossible.  wink

As-tu refait les essais au niveau du menu Grub ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#43 25-11-2014 23:24:17

raleur
Membre
Inscription : 03-10-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Tu as bien blacklisté le module radeon du noyau et vérifié qu'il ne se chargeait pas ?

Au point où on en est, tu pourrais essayer avec le noyau de wheezy-backports...

Hors ligne

#44 25-11-2014 23:33:57

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

Oui j'ai refais les essais avec Grub

raleur a écrit :

Tu as bien blacklisté le module radeon du noyau et vérifié qu'il ne se chargeait pas ?

Au point où on en est, tu pourrais essayer avec le noyau de wheezy-backports...



Non je ne sais pas comment on fait, c'est vrai que je me suis lancé tête baissé quand j'ai vu les commandes de Paskal roll


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#45 25-11-2014 23:36:28

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

C'est parfois automatique, que donne :

cat /etc/modprobe.d/fglrx-driver.conf


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#46 25-11-2014 23:51:11

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Il faudra aussi vérifier ce qu'a produit aticonfig.

cat /etc/X11/xorg.conf


ou

cat /etc/X11/xorg.conf.d/20-fglrx.conf


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#47 26-11-2014 00:05:02

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

paskal a écrit :

C'est parfois automatique, que donne :

cat /etc/modprobe.d/fglrx-driver.conf



Je ne trouve pas ce fichier..
1416953097.jpg


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#48 26-11-2014 00:15:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

Peux-tu redémarrer l'ordi ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#49 26-11-2014 01:03:07

Theverglades
Membre
Distrib. : Wheezy 7.7.0
Noyau : Linux 3.2.0-4-powerpc
(G)UI : Xfwm4
Inscription : 22-11-2014

Re : [Non résolu][Mac] problème de lancement de Debian

J'ai redémarré, je n'ai toujours pas ce fichier mais toujours l'écran noir.

Les autres commandes n'ont guère plus de succès:

1416962334.jpg

Dernière modification par Theverglades (26-11-2014 02:39:31)


" l'histoire est écrite par les vainqueurs! " - Robert Brasillach
Ma config : Debian sur iBook G4!

Hors ligne

#50 26-11-2014 10:04:42

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Non résolu][Mac] problème de lancement de Debian

On va fouiller un peu (si c'est plus pratique que les photos, tu peux rediriger les retours de commande vers un fichier et les poster via une clé usb).

cat /etc/modprobe.d/fglrx-blacklists-radeon.conf
cat /etc/modprobe.d/radeon-kms.conf
cat /etc/X11/xorg.conf
cat /var/log/Xorg.0.log | grep EE && cat /var/log/Xorg.0.log | grep WW
cat /var/log/Xorg.0.log | grep /drivers/


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums