Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-12-2014 21:24:38

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Resolu] A start job is running for LSB: Raise network interfaces

Bonjour.

Je passe le tuyau. Ça vient juste de m'arriver suite à une mise à jour de Jessie. Au redémarrage j'avais le message :
A start job is running for LSB: Raise network interfaces
Et ça durait plusieurs minutes avant que je n'ai une interface graphique.

J'ai réglé ça en modifiant ce fichier :


# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth0
#iface eth0 inet dhcp
 



Je ne sais pas à quoi ça correspond exactement cette affaire et si quelqu'un sait me dire ça m'intéresse.

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 06-12-2014 22:45:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Probablement l'usage de network-manager couplé avec une configuration écrite dans le fichier /etc/interfaces ?
En commentant les lignes consernant eth0 n-m ne se brouille plus les pattes. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 07-12-2014 12:28:33

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] A start job is running for LSB: Raise network interfaces

C'est ce que j'ai pensé aussi mais c'était juste une intuition. A mon avis ça devrait être réglé un de ces jours...

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 11-12-2014 12:18:49

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Coucou laguespa !

J'ai tout comme vous ce message au démarrage (environ 10 sec --- c'est long) et j'ai suivi vos conseils.
Les 2 lignes sont commentés, mais au prochain redémarrage - j'ai plus de connexion internet ?

Hors ligne

#5 11-12-2014 12:57:55

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] A start job is running for LSB: Raise network interfaces

De mon côté j'ai modifié ce fichier de cette manière :


$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true
 



J'ai passé la valeur managed à true.

Note que j'utilise NetworkManager pour gérer les connexions et qu'il faudra adapter à ton gestionnaire de connexion.

A+

Dernière modification par laguespa (11-12-2014 12:58:58)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 11-12-2014 14:29:38

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Merci d'avoir répondu.

Ceci explique cela, que faire si on ne l'utilise pas ? NetworkManager sert pour une utilisation plus "recherchée" des connexion (type wifi)

Hors ligne

#7 11-12-2014 16:52:23

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] A start job is running for LSB: Raise network interfaces

De toute façon je viens de vérifier et le fait d'avoir modifié NetworkManager.conf ne change rien. J'en déduis que la solution est ailleurs.

Je vois dans ta signature que tu utilises Xfce 4.1. N'as tu aucun gestionnaire de connexion réseau comme Wicd ou autre ?
Pour moi à part les modifications que j'ai faites dans le  fichier /etc/network/interfaces qui consiste à dire que c'est le gestionnaire de connexion réseau (dans mon cas Network Manager) qui doit s'occuper de ça je ne vois pas.

Je donnerais cette explication, mais on me corrigera si je me trompe, qu'en modifiant /etc/network/interfaces la connexion des interfaces réseau n'est pas faite au lancement des services au démarrage de la machine et que c'est le gestionnaire de connexion (NetworkManager, Wicd....) qui s'en occupe ensuite ce qui expliquerait que le message "A start job is running for LSB: Raise network interfaces" n'apparaît pas.
Donc, pour toi, si tu n'as pas de gestionnaire de connexion qui prend la main ce serait normal que ta connexion wifi ne se lance pas et que le seul moyen soit de le faite à la main en ligne de commande. Tu pourrais aussi t'en sortir en créant un bouton qui s'en charge.

A+

Dernière modification par laguespa (11-12-2014 17:01:25)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#8 12-12-2014 15:08:31

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Bonjour laguespa.

Non je n'utilise pas de gestionnaire réseau autre que celui par défaut (ifup/ifdown)

laguespa a écrit :

Je donnerais cette explication, mais on me corrigera si je me trompe, qu'en modifiant /etc/network/interfaces la connexion des interfaces réseau n'est pas faite au lancement des services au démarrage de la machine et que c'est le gestionnaire de connexion (NetworkManager, Wicd....) qui s'en occupe ensuite ce qui expliquerait que le message "A start job is running for LSB: Raise network interfaces" n'apparaît pas.



J'en ai déduis exactement la même chose.

Toutefois, j'ai semble t-il résolu le problème en passant par systemd-networkd.
Je retrouve enfin une vitesse de croisière !

Que j'aime debian et xfce.

Hors ligne

#9 12-12-2014 15:17:12

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Ok, j'avais lu cette possibilité sur un forum qui évoquait le problème mais c'était en allemand sad
Est-ce que tu peux donner le manip' histoire de... smile

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#10 12-12-2014 15:32:13

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

laguespa a écrit :

Ok, j'avais lu cette possibilité sur un forum qui évoquait le problème mais c'était en allemand sad
Est-ce que tu peux donner le manip' histoire de... smile

A+



Pas de soucis.
Voici ce que j'ai fait :
Tout d'abord, ouvrir /etc/network/interfaces
Commenté les lignes ci dessous :

allow-hotplug eth0


iface eth0 inet dhcp



Attention : au redémarrage et en absence de gestionnaire de connexion, vous n'aurez plus de connexion.

Désactiver tout type de gestionnaire de connexion (type wcid, network-manager) le cas présent.
On crée un fichier dans /etc/systemd/network du nom de eth0.network.

Dedans on écrit :

[Match]
Name=eth0

[Network]
DHCP=v4



Note : eth0 (à modifier en fonction de votre branchement / détection -- si plusieurs ports -> cf ifconfig)
Console (on active le service par systemctl pour qu'il se lance au démarrage)

 systemctl enable systemd-networkd



On redémarre on vérifie que tout est ok

ping  -c 3 www.debian-facile.org
ifconfig
systemctl status systemd-networkd



Résultat -> Concluant.
A voir sur plusieurs redémarrage / à adapter à sa situation. (Pour moi, cas simple -> un cable ethernet seulement)
Plus d'infos ici : https://wiki.archlinux.org/index.php/systemd-networkd

Dernière modification par candy_debian (12-12-2014 15:35:28)

Hors ligne

#11 25-10-2015 20:23:25

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

je fais un petit up du sujet wink
j'ai rencontré ce problème après l'installation de unbound et la configuration du dns sur 127.0.0.1


précisions :
pas d'utilisation de gestionnaire de connexion (network-manager, wcid...)
configuration pour avoir une IP fixe et une MTU optimal
utilisation de unbound (dns-nameservers 127.0.0.1)


mes modifs :

nano /etc/network/interfaces


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
# auto lo
iface lo inet loopback

# The primary network interface
#auto eth0
#allow-hotplug eth0
#iface eth0 inet static
#address xxx.xxx.xxx.xxx
#netmask 255.255.255.0
#gateway xxx.xxx.xxx.xxx
# dns-* options are implemented by the resolvconf package, if installed
#dns-nameservers 127.0.0.1
#mtu 1464


tout commenté à partir de # The primary network interface


création de 50-eth0.network

nano /etc/systemd/network/50-eth0.network


[Match]
Name=eth0

[Network]
DHCP=no
DNS=127.0.0.1
Address=xxx.xxx.xxx.xxx/24
Gateway=xxx.xxx.xxx.xxx
 



création de 50-eth0.link

nano /etc/systemd/network/50-eth0.link


[Match]
MACAddress=xx:xx:xx:xx:xx:xx
OriginalName=eth0

[Link]
MTUBytes=1464
MACAddressPolicy=persistent
WakeOnLan=off



activation et reboot

systemctl enable systemd-networkd
reboot



les vérifs :

 ping  -c 3 www.debian-facile.org
 ifconfig
 systemctl status systemd-networkd
 netstat -ulnp | grep ":53 "


(le derniers étant pour vérifier unbound)

non seulement le problème A start job is running for LSB: Raise network interfaces à disparu, mais j'ai l'impression que le pc démarre plus vite


complément d'infos (liens)
systemd-networkd.service
systemd.network — Network configuration
systemd.link — Network device configuration

Dernière modification par Severian (09-11-2015 00:38:56)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#12 14-03-2016 22:53:37

vost
Membre
Inscription : 14-03-2016

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Bonjour,

Je viens de migré mon debian 7 vers 8.
Tous c'est bien passé jusqu'à ce que je redémarre!

J'ai eu le message d'erreur : "A start job is running for LSB: Raise network interfaces" mais avec (timer : no limit)

3KCf59SOb5gDP-aqXSiFSmQ2m6rdUOO3NTDyPums5E0?size=1280x960&size_mode=3

Un peu de bidouille plus tard

GpDe7ptAOpKfKPWIXWlDIiJLL3cQcs0eax3xP4oEEQ4?size=1280x960&size_mode=3

Et ca c'était plus dérangeant... Bref, j'ai réussi en démarrant sur un ISO à modifier la tempo, et enfin démarrer la machine!

Maintenant j'ai toujours ce message d'erreur... (et le démarrage est très long).

Comment procéder pour configurer le réseau correctement ? (précision : c'est une VM)
J'ai openVPN en Bridge

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto br0
iface br0 inet static
        address 192.168.****
        netmask 255.255.255.0
        gateway 192.168.****
        bridge_ports eth0
        post-up /etc/openvpn/scripts/ovup && /etc/init.d/openvpn start
        pre-down /etc/init.d/openvpn stop
        post-down /etc/openvpn/scripts/ovdown

Bridge_fd 9
Bridge_hello 2
Bridge_maxage 12
Bridge_stp off

auto eth1
 



Au démarrage j'ai maintenant :

eStOs_QWvgVaBsOtRDseRnMIvkcq_nsME7DJ7tZjJrs?size=1280x960&size_mode=3

Si vous avez des conseils, ou piste, merci beaucoup !

A bientôt smile
vost

Hors ligne

#13 26-03-2016 19:57:48

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Merci Severian !

Je n'ai plus l'erreur et oui, l'impression que ça démarre plus vite.

Par contre, je n'ai plus mon vnc.
Je vais chercher, je reviendrai ici si besoin.


vost, ouvre un topic si ça n'est pas fait car on ne bernacle pas le post d'autrui : https://debian-facile.org/atelier:bernacle

Gling ! un point choco.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#14 26-03-2016 20:04:47

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Resolu] A start job is running for LSB: Raise network interfaces

au passage, en partant de ce post j'ai fini là
-> https://debian-facile.org/doc:reseau:systemd:network

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#15 26-03-2016 20:07:23

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Merci ! smile

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#16 27-03-2016 01:49:02

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Resolu] A start job is running for LSB: Raise network interfaces

parole de hobbitt ! network-manager c'est du mordor !
c'est pas kiss comme galadriel!

Hors ligne

#17 29-03-2016 19:26:35

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Resolu] A start job is running for LSB: Raise network interfaces

Plus de VNC, même en lançant le service, j'ouvre un topic.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

Pied de page des forums