Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-12-2014 19:12:32

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Problème suite a l'installation des driver nvidia

Alors voila ayant une carte graphique nvidia (GTX 650) j'ai installer les driver en suivant le tutoriel de la doc mais quand je redémarre mon PC Gnome ne ce lance pas et je suis bloqué en mode console ;_;
Merci d'avance de votre aide.

Hors ligne

#2 07-12-2014 19:26:51

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : Problème suite a l'installation des driver nvidia

Salut,

As tu lu cette magnifique page du wiki :

https://debian-facile.org/doc:materiel: … ia:accueil ?

Elle m'a dépanné plus d'une fois...

roll

Leonlemouton
°(")°

Hors ligne

#3 07-12-2014 19:30:43

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

oui c'est le tuto dont je parle dans mon premier message

Hors ligne

#4 07-12-2014 19:42:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia



Bonsoir

le drivers non free de debian est trés bien et facile a mettre en place. (340.x.x ) prend en charge ta carte.
tu rajoute "contrib non-free" a ton /etc/apt/sources.list
et tu rajoute ces 2 lignes a la fin

deb http://ftp.fr.debian.org/debian/jessie-backports main contrib non_free
deb-src http://ftp.fr.debian.org/debian/jessie-backports main contrib non-free

tu remplace jessie par wheezy (par contre j ai un doute sur le driver 340 blackports pour wheezy)

 apt-get update
 apt-get upgrade
 apt-get install xserver-xorg-video-nvidia
il va gerer les dependances
creer le dossier xorg.conf.d
 mkdir /etc/X11/xorg.conf.d
creer le fichier 20-nvidia.conf
 echo -e 'Section "Device"\n\tIdentifier "device0"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

ou avec l éditeur  nano

Section "Device"
Identifier    "Device0"
Driver        "nvidia"
EndSection

tu reboot et c est finit

 reboot

 



si tu peut demarrer en console purge le driver propriétaire et installe comme ci dessus.
ps: reconnait jusqu a la carte nvidia 780 titan (pas encore la serie 9xx mais ça viendra smile    )

si tu veut cuda aussi


apt-get  install nvidia-cuda-toolkit
 


il va gerer les dependances

@++

ps: j ai oublie quelque chose pour le sources.list  ,  rajouté lignes blackports

Dernière modification par robert2a (07-12-2014 20:20:56)

Hors ligne

#5 07-12-2014 19:45:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème suite a l'installation des driver nvidia


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 07-12-2014 19:55:49

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

Sa ne marche toujours pas je demarre en console et gnome ne demarre pas (j'ai rien quand je fais ctrl+alt+f7 juste un curseur qui clignote)

Hors ligne

#7 07-12-2014 20:03:14

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

tu a purge ton install du driver proprietaire  nvidia ?

apt-get remove "nom du packet" --purge

il doit te remettre le driver nouveau ensuite tu installe le backports

tu a quelle version de debian ?

ps: avec l installateur graphique ou le mode console c est un jeu d enfant l installation des drivers video , j ai connut l epoque des gpu woodoo sous linux , misere ......  smile

le tuto n'est pas trop a jour , pour le pilote "nouveau"  le dossier xorg.conf.d n existe pas ainsi que le fichier 20-nvidia.conf
pourquoi faire compliqué quand c est si simple.

Dernière modification par robert2a (29-04-2015 13:26:12)

Hors ligne

#8 07-12-2014 20:07:49

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

Oui sa ne marche vraiment pas c'est la tristitude ;_;

Hors ligne

#9 07-12-2014 20:08:15

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : Problème suite a l'installation des driver nvidia

Oki,
Sur le tty1 (ctrl+alt+f1), tu te connectes en root.
Puis:

nano /etc/apt/sources.list


Tu vérifies que ton fichier ressemble à ça (pour wheezy) sinon tu le modifies (ctrl+x pour quitter nano):

# wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
# wheezy updates 
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
# wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free


Ensuite

apt-get update


apt-get upgrade


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-glx linux-headers-$(uname -r)


Puis

nano /etc/X11/xorg.conf


Section "Device"
Identifier    "Video Card"
Driver        "nvidia"
Option          "NoLogo"                    "1"
Option          "RenderAccel"               "1"
EndSection



et tu redémarres:

reboot




Si tu as les backports dans ton sources.list:

# wheezy-backports
deb http://ftp.fr.debian.org/debian wheezy-backports main contrib non-free


alors il faut remplacer nvidia-glx par nvidia-driver lors de l'installation:

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)



En espérant que ça te dépanne...:)


Leonlemouton
°(")°

Hors ligne

#10 07-12-2014 20:25:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

par contre un peu d infos sur ce que tu a installe comme debian et quel drivers nvidia tu a voulu installer.

tu a 2 methodes au dessus mais il va falloir que tu effaces les betises precedentes.

et a mon avis  il faut que tu soit sur ton bureau avec le driver generique avant de tester une des methodes. ( d ou la necessité de purger)

Hors ligne

#11 07-12-2014 21:13:44

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

J'ai debian 7.7 et j'ai essayer d'installer le pilote nvidia pour carte recente en repectant cette page de la doc : https://debian-facile.org/doc:materiel: … ia:accueil

Hors ligne

#12 07-12-2014 21:28:54

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

je pense que c est ce paragraphe que tu a utilisé

=> Le pilote propriétaire (cartes relativement récentes) avec DKMS

tu peus tout faire en mode graphique par le gestionnaire de paquets synaptic et une console root , et redemarrer a la fin des modifications.

debian 7.7 ne me parle pas (je suis en 8 avec jessie ) donc je pense que c est wheezy

si tu peut regarder les logs de xorg  dans /var/log/Xorg.0.log

nano /var/log/Xorg.0.log

voir l erreur du serveur Xorg

ps: si tu suis ma methode => apt-get install xserver-xorg-video-nvidia et que tu a bien suivi mon tuto et si quelqu un peut confirmer que ce driver est present dans wheezy en console ça doit fonctionner .
il est possible que le driver que tu a installe ne connaisse pas ta carte video , surement precisé dans le log de xorg.

sur jessie la derniere version est la 340.46-6 du driver nvidia non-free inclu dans debian
bien tout verifier , une erreur dans le fichier 20-nvidia.conf peu bloquer le démarrage du serveur xorg
dans la console bien lire tous les messages et les noter si erreur
tu arrive sur la ligne de commande actuellement ?  (ecran noir)

Dernière modification par robert2a (07-12-2014 21:44:47)

Hors ligne

#13 07-12-2014 21:54:40

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : Problème suite a l'installation des driver nvidia

tu peux tenter ça :

apt-get install nvidia-xconfig


puis

nvidia-xconfig



ça va te générer automatiquement un /etc/X11/xorg.conf et remplacer ton fichier et ça peut entraîner d'autres problèmes...

par précaution tu peux le sauvegarder avant:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.sos



NB: à tes risques et périls; je fais toujours ça après ma réinstallation sans souci...
puis reboot.


Leonlemouton
°(")°

Hors ligne

#14 07-12-2014 22:18:10

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

Et tant donne que c'est une installation recente est-ce que sa vaut le coup de tout reinstaller ?

Hors ligne

#15 07-12-2014 22:20:21

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : Problème suite a l'installation des driver nvidia

non; essaie nvidia-xconfig (mon humble avis)

Leonlemouton
°(")°

Hors ligne

#16 07-12-2014 22:30:42

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

Ok j'essayerais demain apres le college. Bonne nuit !

Hors ligne

#17 07-12-2014 22:47:20

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

LudoBike a écrit :

Et tant donne que c'est une installation recente est-ce que sa vaut le coup de tout reinstaller ?



moi je dirais non , faut essayer de comprendre , depuis que j ai une machine en serveur sans "bureau en mode graphique" je stress moins  quand je perd xorg  smile
mais si tu decide de tout refaire , installe "jessie" , et fait comme je t ai expliqué plus haut , jessie est plus a jour et les drivers nvidia inclu dans le non-free bien meilleur.
il y a eu encore des mises a jour des drivers nvidia hier ou aujourd hui (j avais 175 mises a jour .......... )

je pense que le tuto nvidia doit etre revu avec jessie , tu a 2 messages en mode graphique , un pour créer le fichier 20-nvidia.conf (une console root et tu le crée )  et un pour t avertir que le nouveau noyau n est pas pris en charge , mais qu un reboot  devrait suffire pour resoudre ce probleme .

ceci est plus trop d actualité  =>

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-glx linux-headers-$(uname -r)



si tu install le driver => 

apt-get install xserver-xorg-video-nvidia

  , dkms sera invoqué et les dépendances aussi

"xserver-xorg-video-nvidia" est le nom du packet que tu veut installer (dans le gestionnaire de mise a jour graphique tu peut voir les drivers dispo , recherche => "nvidia"
avec les versions en face , pour celui ci tu verra 340 ( pour jessie il ne reste avec les blackports que les drivers "nouveau" , "302" et le "340" , les autres ont disparut de memoire.) .

Dernière modification par robert2a (07-12-2014 23:01:05)

Hors ligne

#18 08-12-2014 13:10:36

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Problème suite a l'installation des driver nvidia

Et si tout ça ne marche pas, il y a toujours ce bon vieux script smxi:

http://smxi.org/

Il permet d'installer le pilote Nvidia suivant plusieurs méthodes: à la Debian, à la manière Nvidia (.run) et il permet aussi d'installer un beta-driver pour les cartes les plus récentes
ou pour avoir les dernières fonctionnalités.

Actuellement sur Jessie/Sid, il installe par défaut le 343.36. (nvidia-current) ou le 340.58 pour les cartes plus anciennes.

Dernière modification par yoshi (08-12-2014 13:29:07)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#19 08-12-2014 14:24:42

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Problème suite a l'installation des driver nvidia

J'étais jsqu'à présent avec le pilote 340.58, ayant une GeForce GTS 250 de début 2009 qui ne supportait pas le 343.36.
Il y a deux jours, j'ai changé pour une GeForce GTX 760.
Mes systèmes ont redémarré en graphique sur le 340.58 avec la GTX 760 sans rien faire.
Là, je viens d'installer le 343.36 sans aucun problème sur ma Sid avec le script smxi, et sur ma Jessie en installant directement le .run en mode texte.
"finger in the nose".

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#20 08-12-2014 19:20:24

LudoBike
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16-2-amd64
(G)UI : Xfce 4.10
Inscription : 31-10-2014

Re : Problème suite a l'installation des driver nvidia

C'est bon j'ai réinstallé nouveau puis j'ai installé les pilotes nvidia comme robert2a l'a dit plut tôt. Maintenant je peux déinstaller nouveau ?

Hors ligne

#21 09-12-2014 04:01:13

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

Bonjour
non tu désinstalle rien smile   le pilote nouveau est présent mais non intallé , pas un soucis il fait parti du systeme.
pour les backports le 343.36 n'existe pas encore (c est un pilote propriétaire nvidia)
utilise si possible celui de debian non-free il sera plus stable si ta carte le supporte.
je n'ai qu un probleme avec les dernieres cartes 970 et 980 (non reconnu ) sinon tout fonctionne.
a noter les cartes 8xxx et 9xxx et series 200 ne seront plus supportées par le 343.
@++

ps: je comprends pas qu on utilise debian et que l on fasse de la pub pour des drivers propriétaires sur debian-facile
go utiliser windows  alors smile

Dernière modification par robert2a (29-04-2015 13:28:35)

Hors ligne

#22 09-12-2014 07:31:43

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème suite a l'installation des driver nvidia

@rober2a : Bah ! Ce serait un peu radical pour du libre d'imposer les pilotes libres et uniquement eux.
Autant rester sur un OS proprio alors, si c'est pour faire comme eux. big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#23 09-12-2014 11:53:49

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Problème suite a l'installation des driver nvidia

ps: je comprends pas qu on utilise debian et que l on fasse de la pub pour des drivers propriétaires sur debian-facile
go utiliser windows  alors


Ahh, je suppose que c'est pour moi, ça ....

Je n'utilise plus Windows depuis une dizaine d'années sur mes ordis.
Pour ce qui est des pilotes proprios Nvidia, deux choix: utiliser nouveau, qui a énormément progressé depuis le kernel 3.13, soit utiliser les pilotes Nvidia.
Utiliser ceux qui sont dans les dépôts Debian, pourquoi pas, mais ils sont trop souvent légèrement dépassés. Pas de première jeunesse.
Plus stables que ceux qui viennent directement de chez Nvidia, pourquoi ils le seraient, Debian va les chercher là aussi ...
Après, c'est un choix, quand on met un peu de thunes pour avoir une bonne carte graphique, autant que son fonctionnement soit optimisé avec le pilote
le plus approprié pour la faire tourner.
De toute façon, ils fonctionnent tous sous Debian. Après, en poussant le raisonnement un peu plus loin, un libriste pur et dur qui ne veut pas entendre parler
de pilotes non libres utilisera un système comme OpenBSD, NetBSD dont les kernels ne supportent aucun blob proprio. CQFD.

Dernière modification par yoshi (09-12-2014 12:10:40)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#24 09-12-2014 13:37:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Problème suite a l'installation des driver nvidia

il y a des gens qui bossent pour intégrer des drivers non-libre a debian , et les constructeurs ne leur facilite pas la tache (nvidia c est sur ) .
pour le retard c est vrai , les drivers sont  anciens , sur jessie il y a eu un grand bond en avant puisqu il prend en compte jusqu a la serie 780 titan (avec cuda 6 )
et pour la fiabilité , un driver fait pour debian sera plus stable que le driver du constructeur qui ne va pas l optimiser pour une distrib particuliere.
l installation est tellement simple avec les blackports pourquoi s en priver.
enfin j'espere que LudoBike aura résolu son soucis .

Hors ligne

#25 09-12-2014 13:59:33

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Problème suite a l'installation des driver nvidia

Ok, je comprends ton point de vue. Pas de soucis.

Pour ce qui est des pilotes Nvidia présents dans les dépôts Debian:
Optimisés pour Debian ? Leur code source est fermé, Debian ne peut pas les optimiser.
Nvidia les rends compatibles avec une version de Xorg et éventuellement avec une version (ou plusieurs) du noyau Linux.
Pour eux, c'est générique: une version Linux, une FreeBSD et je crois aussi une version Solaris pour ce qui est des UNIX.

Donc après, c'est chacun selon ses choix et sa méthode. Installer selon la méthode Debian, oui, c'est plus "propre"
déontologiquement parlant.
L'important, c'est qu'il y a plusieurs solutions possibles, si l'une ne marche pas, on peut en utiliser une autre, ça arrive. wink

Dernière modification par yoshi (09-12-2014 14:01:55)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

Pied de page des forums