Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2014 19:37:14

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

[Résolu] Avertissement Adobe flash

Bonjour,

Je viens de faire les mises à jour sous Jessie et je me retrouve face à ce message:

1418405587.png

Qu'est ce que je peux faire ?

Dernière modification par nIQnutn (12-12-2014 22:38:53)

Hors ligne

#2 12-12-2014 20:32:53

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

A tout hasard c'est pas une popup ou autre cochonnerie ?
Mise à jour de faite, je suis aussi sous jessie, et je n'ai pas ce message

Hors ligne

#3 12-12-2014 20:50:53

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

@nIQnutn: oui, le plugin Adobe Flash est obsolète, et les versions récentes ne sont plus supportées par Adobe.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 12-12-2014 21:53:30

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Avertissement Adobe flash

Adobe est en retard, ça fait des années que je ne le supporte plus leur plug-in Flash tongue

Jouer sous Debian ? Facile !

Hors ligne

#5 12-12-2014 21:55:07

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Du coup, est ce qu'il faut changer de plugin ? si oui lequel ?

Qu'en est il des mises à jour de sécurité ?

j'ai regardé de ce coté mais j'ai rien vu d'intéressant
https://wiki.debian.org/FlashPlayer

Hors ligne

#6 12-12-2014 22:00:37

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

Non, il n'y a pas de plugin officiel compatible iceweasel/firefox.
Les plugins libres sont de manière générale assez en retard et donc ne permettent pas vraiment d'utiliser flash.

Il n'y a plus de solution 100% compatible flash avec iceweasel/firefox.

Tu peux tenter chromium avec pepperflash (le bytecode qu'utilisent les plugins Chrome/Chromium) ou directement chrome… Ou encore mieux, dire adieu à Flash smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 12-12-2014 22:18:26

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Je pense que le plus simple et de désactiver et de me mettre en parallèle un chromium avec pepperflash pour dépanner.

J'espère que Flash disparaitra bientôt.


Merci pour les infos wink

Hors ligne

#8 12-12-2014 22:54:10

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu] Avertissement Adobe flash

Tiens, j'ai eu le même message sous Wheezy ce matin.
Une mise à jour de iceweasel,
Flash désactivé dans Firefox.
Juste fait un :


update-flashplugin-nonfree --install
 



Tout est rentré dans l'ordre. Plugin réactivé smile
Oui ..... bon .............. je sais ......................... tongue

Dernière modification par golgot200 (12-12-2014 22:59:52)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#9 12-12-2014 22:59:42

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

À ne pas faire bien sûr, ceci constituant une faille de sécurité majeure smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 12-12-2014 23:00:52

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu] Avertissement Adobe flash

J'ai édité mon message en même temps captnfab   lol

le oui bon je sais

Dernière modification par golgot200 (12-12-2014 23:01:28)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#11 12-12-2014 23:57:02

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Sur Iceweasel, j'ai une version 11.2. et sur chromium 16.0 , j'en déduis que c'est bon.

Hors ligne

#12 13-12-2014 01:02:19

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

@nIQnutn: oui, le plugin Adobe Flash est obsolète, et les versions récentes ne sont plus supportées par Adobe.


C'est bien beau mais ceux qui utilise Iceweasel et qui sont sous debian (ou autre distribution) et qui veulent utiliser flash parce malheureusement on en mange à toutes les sauces, c'est mange ta main et tais toi ? Ou alors installe une version plus récente mais non suivi par Adobe pour les mises à jours de sécurité.
Belle mentalité.

Donc soit solution alternative avec mille an de retard genre Gnash et Lightspark, soit Chromium et pepperflash.
Iceweasel 31.3 est compatible HTLM5 ?

Edition : je viens d'avoir ce message.
Edition 2 : Ok le problème n'est pas tant le HTLM5 comme toujours mais sa démocratisation usuelle.

Dernière modification par candy_debian (13-12-2014 01:28:44)

Hors ligne

#13 13-12-2014 09:57:34

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Avertissement Adobe flash

Pareil : sur le générateur de numéro de carte bancaire virtuelle !  mad

Comment j'vais faire mes achats de Nolwen ?  Sur fenêtre ?  sad

edit : bon, ça fonctionne avec SRWare iron ; je suppose qu'il utilise pepperflashplugin-nonfree.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#14 13-12-2014 10:49:47

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : [Résolu] Avertissement Adobe flash

J'ai cru comprendre que la version 16 de flash corrigeais une importante faille de sécurité. Du coup pas mal de sites/navigateurs se mettent à bloquer toutes les anciennes versions de flash. Ça risque du coup de poser un sérieux problème pour notre vieillissante version 11 neutral

Adhérent April N° 9016

Hors ligne

#15 13-12-2014 12:55:42

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

Cela fait presque 3 ans que nous savons qu'Adobe ne fait plus de version Linux : http://www.freenews.fr/freenews-edition … inux-11620
3 ans également que nous avertissons que la solution flashplugin n'est pas une solution à long terme, à cause de cela.

C'est un peu tard maintenant pour réagir smile Et c'est plutôt auprès d'Adobe qu'il fallait le faire…

Comment faire maintenant qu'il n'y a plus le flash d'adobe pour les navigateurs autres que Google Chrome ? Par ordre de préférence :
1) Se passer de Flash
2) Passer à Chromium + pepperflash
3) Tenter sa chance avec Iceweasel + Gnash
4) Passer à Chrome

Tout cela est documenté dans notre page wiki sur flash smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 13-12-2014 12:57:30

chuugar
Membre
Lieu : Nancy, France
Distrib. : Jessie
Noyau : 4.7.2 (compilé)
(G)UI : Openbox
Inscription : 17-08-2012

Re : [Résolu] Avertissement Adobe flash

Je vais surement me faire taper sur les doigts, mais il existe bien un moyen d'avoir la dernière version de Flash sous Iceweasel (pratique pour les sites de replay...).
Quelques malfrats ont wrappé Pepperflash pour le faire fonctionner correctement sur Mozilla.
Il suffit, d'avoir Pepperflash (ou Chrome) installé, de compiler le Fresh Player Plugin, de le placer le .so dans ~/.mozilla/plugins/ .

Source: http://www.webupd8.org/2014/05/fresh-pl … flash.html

Vous cherchez une alternative à Google?
Essayez StartPage !

Hors ligne

#17 13-12-2014 13:27:46

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

Cela fait presque 3 ans que nous savons qu'Adobe ne fait plus de version Linux : http://www.freenews.fr/freenews-edition … inux-11620
3 ans également que nous avertissons que la solution flashplugin n'est pas une solution à long terme, à cause de cela.

C'est un peu tard maintenant pour réagir smile Et c'est plutôt auprès d'Adobe qu'il fallait le faire…


La fin de flash et de son utilisation est une chose (qui ravira bien du monde - qui ne voyait en flash que la castration de l'interface web), la fin de son support en est une autre.

captnfab a écrit :


1) Se passer de Flash
2) Passer à Chromium + pepperflash
3) Tenter sa chance avec Iceweasel + Gnash
4) Passer à Chrome


Pour le point 1, c'est un non sens à l'heure actuelle...
Pour le reste on sent bien toute la claustration de la situation.

Edition : chuugar, vous avez testé cette méthode ?

Dernière modification par candy_debian (13-12-2014 13:28:39)

Hors ligne

#18 13-12-2014 13:38:07

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

Cela fait presque 3 ans que nous savons qu'Adobe ne fait plus de version Linux : http://www.freenews.fr/freenews-edition … inux-11620
3 ans également que nous avertissons que la solution flashplugin n'est pas une solution à long terme, à cause de cela.

C'est un peu tard maintenant pour réagir smile Et c'est plutôt auprès d'Adobe qu'il fallait le faire…

Comment faire maintenant qu'il n'y a plus le flash d'adobe pour les navigateurs autres que Google Chrome ? Par ordre de préférence :
1) Se passer de Flash
2) Passer à Chromium + pepperflash
3) Tenter sa chance avec Iceweasel + Gnash
4) Passer à Chrome

Tout cela est documenté dans notre page wiki sur flash smile



Tout est dit.

Je pense qu'Adobe ne dispose pas assez de personnes, ni de moyens pour assurer flash pour linux lol

Hors ligne

#19 13-12-2014 13:51:26

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :


1) Se passer de Flash
2) Passer à Chromium + pepperflash
3) Tenter sa chance avec Iceweasel + Gnash
4) Passer à Chrome


candy_debian a écrit :

Pour le point 1, c'est un non sens à l'heure actuelle...


Le point 1, je le pratique depuis bien plus de 3 ans, et je n'ai pas plus de problème de sens que ça si ça peut te rassurer smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#20 13-12-2014 13:53:27

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

chuugar a écrit :

Je vais surement me faire taper sur les doigts, mais il existe bien un moyen d'avoir la dernière version de Flash sous Iceweasel (pratique pour les sites de replay...).
Quelques malfrats ont wrappé Pepperflash pour le faire fonctionner correctement sur Mozilla.
Il suffit, d'avoir Pepperflash (ou Chrome) installé, de compiler le Fresh Player Plugin, de le placer le .so dans ~/.mozilla/plugins/ .

Source: http://www.webupd8.org/2014/05/fresh-pl … flash.html


Ok, je ne connaissais pas cette solution. Je la classerais entre là 1) et la 2) alors smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#21 13-12-2014 14:21:33

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

Le point 1, je le pratique depuis bien plus de 3 ans, et je n'ai pas plus de problème de sens que ça si ça peut te rassurer smile


Pourrais-t-on avoir moult explication ?
Auriez vous simplement renoncé au flash ? Croyez bien que si cela était aussi facile, je pencherais vers cette solution.

A moins d'éviter sciemment les sites utilisant flash....
Encore une fois, je reste attentif à un éclaircissement !

captnfab a écrit :

À ne pas faire bien sûr, ceci constituant une faille de sécurité majeure


Je n'ai pas compris par ailleurs cette remarque ! De quelle faille est il question ? Celle d'utiliser flash ? big_smile

Dernière modification par candy_debian (13-12-2014 14:23:20)

Hors ligne

#22 13-12-2014 14:21:46

chuugar
Membre
Lieu : Nancy, France
Distrib. : Jessie
Noyau : 4.7.2 (compilé)
(G)UI : Openbox
Inscription : 17-08-2012

Re : [Résolu] Avertissement Adobe flash

candy_debian a écrit :

Edition : chuugar, vous avez testé cette méthode ?



Honnêtement, je ne l'ai pas fait sous Debian (car je n'ai pas besoin de Flash sur cette machine), mais par contre ça fonctionne impec' sous OpenSUSE. smile


Vous cherchez une alternative à Google?
Essayez StartPage !

Hors ligne

#23 13-12-2014 14:23:47

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

Merci d'avoir pris le soin de répondre chuugar

Hors ligne

#24 13-12-2014 14:26:04

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Je pense qu'on ne va pas sur le même genre de site également.

J'étais obligé d'utiliser flash sur un site qui utilisait flash pour de la vidéo mais les prix ont tellement augmenté que j'ai renoncé. Au final, je n'en aurai besoin que ponctuellement.

Hors ligne

#25 13-12-2014 14:31:33

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

candy_debian a écrit :

captnfab a écrit :

Le point 1, je le pratique depuis bien plus de 3 ans, et je n'ai pas plus de problème de sens que ça si ça peut te rassurer smile


Pourrais-t-on avoir moult explication ?
Auriez vous simplement renoncé au flash ? Croyez bien que si cela était aussi facile, je pencherais vers cette solution.


Oui.
Pour les sites comme YouTube, Vimeo et DailyMotion, il est possible d'accéder aux vidéos via divers outils, comme get_flash_video, youtubedl ou cclive, et maintenant, via le lecteur HTML5 directement (quitte à utiliser une extension IceWeasel).
Pour les sites de Replay, il est souvent possible de contourner les protections en examinant les codes sources des fichiers contenant les paramètres donnés au lecteur Flash.
Pour les jeux flash, je m'en passe.
Pour les autres sites nécessitant Flash, je m'en passe aussi. En fait, je ne saurais même pas te dire lesquels nécessitent Flash pour fonctionner… je n'en ai pas rencontré récemment.

candy_debian a écrit :

captnfab a écrit :

À ne pas faire bien sûr, ceci constituant une faille de sécurité majeure


Je n'ai pas compris par ailleurs cette remarque ! De quelle faille est il question ? Celle d'utiliser flash ? big_smile


La version 11.2 n'est plus supportée par Adobe et contient des failles de sécurités connues. L'utiliser alors qu'elle n'est plus supportée est donc un risque plus que certain.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums