Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 13-12-2014 14:40:37

candy_debian
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.1
Inscription : 05-12-2014

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :


Pour les sites comme YouTube, Vimeo et DailyMotion, il est possible d'accéder aux vidéos via divers outils, comme get_flash_video, youtubedl ou cclive, et maintenant, via le lecteur HTML5 directement (quitte à utiliser une extension IceWeasel).
Pour les sites de Replay, il est souvent possible de contourner les protections en examinant les codes sources des fichiers contenant les paramètres donnés au lecteur Flash.
Pour les jeux flash, je m'en passe.
Pour les autres sites nécessitant Flash, je m'en passe aussi. En fait, je ne saurais même pas te dire lesquels nécessitent Flash pour fonctionner… je n'en ai pas rencontré récemment.


Comme je le pensais, rien en natif pour un utilisateur lambda. Cela reste tout à votre honneur, vous essayez de vous débarrassez de l'emprise instaurée par flash avec des méthodes dites de contournement.

Vous n'en restez pas moins tributaire de flash, malgré vos solutions énoncées. Vivement la démocratisation majoritaire de l'HTLM5 afin d'en finir avec cette abomination qui fut appelé FLASH !

captnfab a écrit :


La version 11.2 n'est plus supportée par Adobe et contient des failles de sécurités connues. L'utiliser alors qu'elle n'est plus supportée est donc un risque plus que certain.


Pourtant Adobe s'est engagé à corriger ces problèmes de sécurités pendant 5 ans... A moins que ces failles soient issues du coeur central de la version 11.2 et ne puissent être corrigé que par une mise à jour de plus haut niveau.

Du coup la solution X (je l'appelerais ainsi) de chuugar prendrait tout son sens.

Merci pour ces informations

Dernière modification par candy_debian (13-12-2014 14:44:10)

Hors ligne

#27 13-12-2014 14:47:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

En fait, je ne saurais même pas te dire lesquels nécessitent Flash pour fonctionner.

Comme je le disais : un générateur de numéro virtuel de carte bancaire, pour les achats en ligne.
J'évite de donner le numéro réel sur le net.  roll


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#28 13-12-2014 14:47:19

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Avertissement Adobe flash

Le HTML5 est en général supporté de manière native. Pour les sites mal conçus en revanche, il faut effectivement utiliser des méthodes de contournement qui ne sont pas toujours clé-en-main.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#29 13-12-2014 14:47:58

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Avertissement Adobe flash

captnfab a écrit :

Le HTML5 est en général supporté de manière native. Pour les sites mal conçus en revanche, il faut effectivement utiliser des méthodes de contournement qui ne sont pas toujours clé-en-main.

Un p'tit tuto alors ?  big_smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#30 13-12-2014 15:14:56

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Solution, un peu lourde mais wine devrait fonctionné sans trop de pb ou plus simplement avec playonlinux.

Hors ligne

#31 13-12-2014 15:24:32

chuugar
Membre
Lieu : Nancy, France
Distrib. : Jessie
Noyau : 4.7.2 (compilé)
(G)UI : Openbox
Inscription : 17-08-2012

Re : [Résolu] Avertissement Adobe flash

nIQnutn a écrit :

Solution, un peu lourde mais wine devrait fonctionné sans trop de pb ou plus simplement avec playonlinux.



nlQnutn a écrit :

lourde



*Sale wink

lol


Vous cherchez une alternative à Google?
Essayez StartPage !

Hors ligne

#32 13-12-2014 19:42:17

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Avertissement Adobe flash

candy_debian a écrit :

captnfab a écrit :

1) Se passer de Flash

Pour le point 1, c'est un non sens à l'heure actuelle...


Mince, je suis une aberration depuis des années et je ne le savais même pas big_smile


Jouer sous Debian ? Facile !

Hors ligne

#33 13-12-2014 21:48:39

bartaba
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [Résolu] Avertissement Adobe flash

salut à tous

apparemment le fait de faire apt-get upgrade ne suffit pas pour mettre flash à jour, car le paquet flashplugin-nonfree se contente seulement de telecharger et d'installer flash player, mais par la suite c'est à nous de le mettre à jour en tapant la commande qui a été donnée dans ce topic :

update-flashplugin-nonfree --install



vous pouvez vérifier la version de flash en tapant about:plugins dans la barre d'adresse de Iceweasel, la derniere est la 11.2.202.425

Voilà, mais bon adobe ne va pas maintenir les mises à jour de flash pour linux éternellement, c'est pourquoi il faut des maintenant se pencher sur des alternatives : pas gnash ou autre parce que ça a l'air d'être mort ces projets là.
Je pense plutôt à des scripts greasemonkey ou ce genre de truc, j'avais vu ça une fois je vais essayer de le retrouver et de tester

Hors ligne

#34 13-12-2014 23:05:52

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

bartaba a écrit :

salut à tous

apparemment le fait de faire apt-get upgrade ne suffit pas pour mettre flash à jour, car le paquet flashplugin-nonfree se contente seulement de telecharger et d'installer flash player, mais par la suite c'est à nous de le mettre à jour en tapant la commande qui a été donnée dans ce topic :

update-flashplugin-nonfree --install



vous pouvez vérifier la version de flash en tapant about:plugins dans la barre d'adresse de Iceweasel, la derniere est la 11.2.202.425

Voilà, mais bon adobe ne va pas maintenir les mises à jour de flash pour linux éternellement, c'est pourquoi il faut des maintenant se pencher sur des alternatives : pas gnash ou autre parce que ça a l'air d'être mort ces projets là.
Je pense plutôt à des scripts greasemonkey ou ce genre de truc, j'avais vu ça une fois je vais essayer de le retrouver et de tester



Pas très pratique tout ça.
Je viens de mettre à jour mais je désactive pour le moment et voir ça me manque réellement.

Hors ligne

#35 14-12-2014 19:35:17

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : [Résolu] Avertissement Adobe flash

J'ai supprimé flash de mon ordi il y a quelques semaines et franchement j'en suis pas mort.

Passer par des scripts ou des solutions capilotracté ? Franchement, le HTML5 est au point maintenant, aux webmasteurs de s'y mettre et continuer d'utiliser flash ne va pas les motiver...

Adhérent April N° 9016

Hors ligne

#36 15-12-2014 01:14:03

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Résolu] Avertissement Adobe flash

Heu y a aussi shumway développé par mozilla non? tongue

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#37 15-12-2014 10:50:25

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Je viens de rédiger un petit chapitre sur l'utilisation de freshplayerplugin pour iceweasel si certain veulent tester:
http://debian-facile.org/doc:media:flas … ayerplugin
J'ai fais les tests sous testing, et il m'indique maintenant le plug in en version: 15,0,0,189, ce qui est bien mieux que la version proposé par adobe: 11.2.202.425
A terme il faudra sûrement reprendre la page en entier pour la rendre plus lisible.
Je vais retester dans une vm pour voir.
Merci


Edit: après un

apt-get install --reinstall pepperflashplugin-nonfree


J'ai bien la version: 16,0,0,235

Hors ligne

#38 15-12-2014 15:35:40

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : [Résolu] Avertissement Adobe flash

J'ai appliqué la solution chromium. Cela fonctionne très bien. J'ai remplacé stable-backports par jessie-backports.

Dernière modification par aramis_qc (15-12-2014 15:38:40)

Hors ligne

#39 01-01-2015 21:19:55

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : [Résolu] Avertissement Adobe flash

J'ai lu récemment un article sur le magazine "Linux Pratique " concernant pipelight voici un lien : http://la-vache-libre.org/pipelight-ins … -gnulinux/
Ca me semble pas mal à voir, sinon moi j'utilise qupzilla et je n'ai aucun souci.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#40 02-01-2015 04:06:53

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Avertissement Adobe flash

Je ne le connaissais pas celui-là, qupzilla. Comme il est disponible pour Jessie et Sid, je peux tester la bête pour voir question de voir ce qu'elle a dans le ventre smile.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#41 15-01-2015 15:01:25

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

Re : [Résolu] Avertissement Adobe flash

Bonjour je suis nouveau sur Debian, j'utilise Iceweasel, récemment j'ai voulu lire une vidéo et voici ce qui est apparu :

Capture_du_2015_01_15_13_54_11.jpg

J'ai donc regarder sur Internet et essayé d'installer le paquet flsashplugin et voici sa réponse :

Capture_du_2015_01_15_13_59_16.jpg

Je suis un peu perdu.. Que faire ??

Merci

Dernière modification par tot94 (15-01-2015 15:01:39)

Hors ligne

#42 15-01-2015 15:03:02

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

Re : [Résolu] Avertissement Adobe flash

root@debian:/home/gueg# apt-get install flashplugin-nonfree
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet flashplugin-nonfree n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « flashplugin-nonfree » n'a pas de version susceptible d'être installée
 



Tenez c'est plus lisible.

Hors ligne

#43 15-01-2015 15:06:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

D"abord

  Voir le tuto : Trop cool d'indiquer son installation dans son profil !


ensuite le wiki est assez clair
https://debian-facile.org/doc:media:fla … -et-autres

si jamais ça ne marche pas, indique les éventuels messages d'erreurs. On t'aidera par la suite

Hors ligne

#44 15-01-2015 15:10:12

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

flashplugin-nonfree est bien présent pour wheezy, jessie et sid.
https://packages.debian.org/wheezy/flashplugin-nonfree

je pense qu'il s'agit d'un pb de sources.list
donne nous le résultat de

cat /etc/apt/sources.list

Hors ligne

#45 15-01-2015 15:10:24

bartaba
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [Résolu] Avertissement Adobe flash

il doit manquer les sources contrib et non-free dans ton fichier sources.list, il faut que tu les ajoutes.
je supposes que tu as wheezy ? http://debian-facile.org/doc:systeme:apt:sources.list

Hors ligne

#46 15-01-2015 15:32:35

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

Re : [Résolu] Avertissement Adobe flash

J'ai fait un more pcq on voyait pas tout avec cat

root@debian:/home/gueg# more /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official Multi-architecture amd64/i386 N
ETINST #1 20141018-13:43]/ wheezy main

#deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official Multi-architecture amd64/i386 NE
TINST #1 20141018-13:43]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main

 

Hors ligne

#47 15-01-2015 15:51:57

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

Il te manque différent composant dans ton fichier sources.list

Je te conseille de lire la page pour comprendre le fonctionnement.
L'essentiel est ici
http://debian-facile.org/doc:systeme:ap … ble-wheezy

une fois le fichier modifié, tu lances

apt-get update
apt-get install flashplugin-nonfree

Hors ligne

#48 15-01-2015 16:11:40

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

Re : [Résolu] Avertissement Adobe flash

Je viens de le faire mais du coup j'ai l'impression c'est un peu le bordel..
Est-ce que je peux y faire un tri ?

root@debian:/home/gueg# more /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official Multi-architecture amd64/i386 N
ETINST #1 20141018-13:43]/ wheezy main

#deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official Multi-architecture amd64/i386 NE
TINST #1 20141018-13:43]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main

# wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib
# wheezy updates  
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib
# wheezy security
deb http://security.debian.org/ wheezy/updates main contrib

# wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
# wheezy updates  
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
# wheezy-backports
deb http://ftp.fr.debian.org/debian wheezy-backports main contrib non-free
# wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free

[3]+  Stoppé                 more /etc/apt/sources.list
 

Hors ligne

#49 15-01-2015 16:44:36

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Avertissement Adobe flash

oui, il semble qu'il y ait des doublons.

Je te conseille de commenté, toutes les lignes sauf les dernières contenant "main contrib non-free"
repost le résultat si tu veux être sûr du résultat.

Hors ligne

#50 15-01-2015 19:29:05

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

Re : [Résolu] Avertissement Adobe flash

Par exemple est ce que dans ce cas :

deb http://security.debian.org/ wheezy/updates main contrib
deb http://security.debian.org/ wheezy/updates main contrib non-free

La 2e est identique à la 1ere avec l'apport de "non-free" donc on peut supprimer la 1ère ligne ?

Hors ligne

Pied de page des forums