Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 21-12-2014 18:10:25

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

deuchdeb a écrit :

Tout à fait d'accord, mais sur Wheezy, seule la solution Chromium le permet.


Ca doit être possible, mais il faut se pencher sur la compilation des deux lib qui manquent mais je n'ai plus de wheezy sous la main pour tester ça.
On peut voir du côté du Pinning aussi, mais en tout cas ce sera plus complexe que sous Jessie, Ça c'est sur.

Hors ligne

#27 28-12-2014 22:02:53

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Flash: dépasser la version 11.2

Merci surtout au projet "pepperflashplugin", ça nous enlève une belle épine du pied.


Pas vraiment. Ça permet à Youtube, Dailymotion et Cie de continuer à utiliser cette daube dont le principal intérêt n'est pas de diffuser des vidéos mais de soutirer des informations à l'utilisateur et de contourner les réglages et la politique de sécurité du navigateur.


« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#28 01-02-2015 06:36:33

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Bonjour,

Sur Jessie :


apt-get install build-essential git cmake pkg-config libglib2.0-dev libasound2-dev libx11-dev libgl1-mesa-dev liburiparser-dev libcairo2-dev libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libfreetype6-dev libgtk2.0-dev libxinerama-dev libconfig-dev libevent-dev libegl1-mesa-dev libgles2-mesa-dev ragel
 



manquait chez moi

libpulse-dev libssl-dev



patrick@debian:~/freshplayerplugin/build$ cmake ..
-- checking for modules 'alsa;glib-2.0;gio-2.0;x11;xrandr;gl;glesv2;libconfig;libevent;libevent_pthreads;cairo;pango;pangocairo;pangoft2;freetype2;gtk+-2.0;openssl'
--   found alsa, version 1.0.28
--   found glib-2.0, version 2.42.1
--   found gio-2.0, version 2.42.1
--   found x11, version 1.6.2
--   found xrandr, version 1.4.2
--   found gl, version 10.3.2
--   found glesv2, version 10.3.2
--   found libconfig, version 1.4.9
--   found libevent, version 2.0.21-stable
--   found libevent_pthreads, version 2.0.21-stable
--   found cairo, version 1.14.0
--   found pango, version 1.36.8
--   found pangocairo, version 1.36.8
--   found pangoft2, version 1.36.8
--   found freetype2, version 17.1.11
--   found gtk+-2.0, version 2.24.25
--   found openssl, version 1.0.1k
-- Configuring done
-- Generating done
-- Build files have been written to: /home/patrick/freshplayerplugin/build
patrick@debian:~/freshplayerplugin/build$ make
Scanning dependencies of target parson-obj
[  1%] Building C object 3rdparty/CMakeFiles/parson-obj.dir/parson/parson.c.o
[  1%] Built target parson-obj
Scanning dependencies of target freshwrapper-obj
[  2%] Building C object src/CMakeFiles/freshwrapper-obj.dir/async_network.c.o
[  4%] Building C object src/CMakeFiles/freshwrapper-obj.dir/audio_thread.c.o
[  5%] Building C object src/CMakeFiles/freshwrapper-obj.dir/audio_thread_alsa.c.o
[  7%] Building C object src/CMakeFiles/freshwrapper-obj.dir/config.c.o
[  8%] Building C object src/CMakeFiles/freshwrapper-obj.dir/compat.c.o
[  9%] Building C object src/CMakeFiles/freshwrapper-obj.dir/header_parser.c.o
[ 11%] Building C object src/CMakeFiles/freshwrapper-obj.dir/keycodeconvert.c.o
[ 12%] Building C object src/CMakeFiles/freshwrapper-obj.dir/np_entry.c.o
[ 14%] Building C object src/CMakeFiles/freshwrapper-obj.dir/np_functions.c.o
[ 15%] Building C object src/CMakeFiles/freshwrapper-obj.dir/main_thread.c.o
[ 16%] Building C object src/CMakeFiles/freshwrapper-obj.dir/reverse_constant.c.o
[ 18%] Building C object src/CMakeFiles/freshwrapper-obj.dir/tables.c.o
[ 19%] Building C object src/CMakeFiles/freshwrapper-obj.dir/trace.c.o
[ 21%] Building C object src/CMakeFiles/freshwrapper-obj.dir/n2p_proxy_class.c.o
[ 22%] Building C object src/CMakeFiles/freshwrapper-obj.dir/p2n_proxy_class.c.o
[ 23%] Building C object src/CMakeFiles/freshwrapper-obj.dir/pp_interface.c.o
[ 25%] Building C object src/CMakeFiles/freshwrapper-obj.dir/pp_resource.c.o
[ 26%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_core.c.o
[ 28%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_audio_config.c.o
[ 29%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_audio_input.c.o
[ 30%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_audio.c.o
[ 32%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_browser_font.c.o
[ 33%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_buffer.c.o
[ 35%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_char_set.c.o
[ 36%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_crypto.c.o
[ 38%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_cursor_control.c.o
[ 39%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_file_chooser.c.o
[ 40%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_file_io.c.o
[ 42%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_file_ref.c.o
[ 43%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_clipboard.c.o
[ 45%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_drm.c.o
[ 46%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_file.c.o
[ 47%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_font_file.c.o
[ 49%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_fullscreen.c.o
[ 50%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash.c.o
[ 52%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_menu.c.o
[ 53%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_flash_message_loop.c.o
[ 54%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_font.c.o
[ 56%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_graphics2d.c.o
[ 57%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_graphics3d.c.o
[ 59%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_image_data.c.o
[ 60%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_input_event.c.o
[ 61%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_instance.c.o
[ 63%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_memory.c.o
[ 64%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_message_loop.c.o
[ 66%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_nacl.c.o
[ 67%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_net_address.c.o
[ 69%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_network_monitor.c.o
[ 70%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_opengles2.c.o
[ 71%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_printing.c.o
[ 73%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_tcp_socket.c.o
[ 74%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_text_input_controller.c.o
[ 76%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_text_input.c.o
[ 77%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_udp_socket.c.o
[ 78%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_uma.c.o
[ 80%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_url_loader.c.o
[ 81%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_url_request_info.c.o
[ 83%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_url_response_info.c.o
[ 84%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_url_util.c.o
[ 85%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_var.c.o
[ 87%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_video_capture.c.o
[ 88%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_video_decoder.c.o
[ 90%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_view.c.o
[ 91%] Building C object src/CMakeFiles/freshwrapper-obj.dir/ppb_x509_certificate.c.o
[ 92%] Building C object src/CMakeFiles/freshwrapper-obj.dir/screensaver_control.c.o
[ 94%] Building C object src/CMakeFiles/freshwrapper-obj.dir/audio_thread_pulseaudio.c.o
[ 94%] Built target freshwrapper-obj
Scanning dependencies of target generate_fsm
[ 95%] Generating uri_parser_fsm.c
[ 95%] Built target generate_fsm
Scanning dependencies of target uri-parser-obj
[ 97%] Building C object src/uri_parser/CMakeFiles/uri-parser-obj.dir/uri_parser.c.o
[ 97%] Built target uri-parser-obj
Scanning dependencies of target freshwrapper-pepperflash
[ 98%] Building C object src/CMakeFiles/freshwrapper-pepperflash.dir/config_pepperflash.c.o
Linking C shared library ../libfreshwrapper-pepperflash.so
[ 98%] Built target freshwrapper-pepperflash
Scanning dependencies of target dep_check
[100%] Building C object src/CMakeFiles/dep_check.dir/dep_check.c.o
Linking C executable dep_check
[100%] Built target dep_check
patrick@debian:~/freshplayerplugin/build$
 




Compilation OK

Copie du plugin dans /usr/lib/mozilla/plugins/


Fonctionne pas chez moi avec Iceweasel hmm

failed to load libfreshwrapper-pepperflash.so

Capture-_AC-DC_-_Rock_or_Bust_-_YouTube_-_Iceweasel.png

Bizarre.


EDIT : Pas mal, j'ai quitté et  je me suis reconnecté  à ma session, lancé Iceweasel et maintenant ça fonctionne.

Dernière modification par golgot200 (01-02-2015 07:13:48)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#29 09-02-2015 14:02:37

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Bonjour,

Jessie.
Sur iceweasel, les vidéos sur dailymotion sont chez moi décallées ( haut - gauche). Sur Youtube, c'est bon.
Je vous met un lien pour vérifier si chez vous c'est la même chose:

http://www.dailymotion.com/video/x2gqhw … 2015_music

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#30 28-03-2015 11:05:29

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

Pour info, j'ai ajouté la libssl-dev dans les dépendances à installer.
Elle semble nécessaire maintenant

Hors ligne

#31 31-03-2015 22:29:31

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Retour à flashplugin-nonfree normal chez moi car ce pepper depuis quelques temps plante toutes le 30 secondes chez moi. Le son continu sur une vidéo figé pleine écran. Je veux bien virer flash totalement, mais si c'est pour faire un reboot toute les deux minutes, non merci smile

À signaler aussi qu'avec le flashplugin-nonfree, tout fonctionne parfaitement ... malheureusement wink

Dernière modification par golgot200 (31-03-2015 22:34:48)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#32 31-03-2015 23:07:31

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Flash: dépasser la version 11.2

il y a aussi pipelight-multi que j'ai découvert en essayant de faire fonctionner flash sur un processeur non compatible SSE2. Il fonctionne bien mais pas partout, j'ai donc opté pour gnash html5 et smplayer smile vive le pc temporaire ou mieux, les sites qui proposent du contenus de divertissement sur un format privateur sad

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#33 01-04-2015 11:50:14

chuugar
Membre
Lieu : Nancy, France
Distrib. : Jessie
Noyau : 4.7.2 (compilé)
(G)UI : Openbox
Inscription : 17-08-2012

Re : Flash: dépasser la version 11.2

J'ai découvert pipelight-multi également cette semaine. Il permet d'accéder au contenu flash soumis aux DRM (les sites de replay par exemple).
Cependant, ce n'est pas dans les dépôts officiels, mais dans ceux d'un tiers.
En gros: ça utilise Wine pour émuler Flash et Silverlight dans Iceweasel. A noter que cela fonctionne sous Wheezy / Jessie et Sid.
Il est impératif de ne pas avoir une quelconque autre version de Flash installée sur le PC.

Marche à suivre:
1 - Ajouter les dépots:
Wheezy :

wget http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/Release.key


Jessie / Sid :

wget http://repos.fds-team.de/Release.key


 apt-key add Release.key



2 - Installation:

apt-get update && apt-get install pipelight-multi



3 - Fermez votre navigateur et poursuivez:

pipelight-plugin --update


pipelight-plugin --enable flash


pipelight-plugin --enable silverlight



Sources:
http://pipelight.net/cms/install/instal … ebian.html
http://forum.ubuntu-fr.org/viewtopic.ph … #p17478471


Vous cherchez une alternative à Google?
Essayez StartPage !

Hors ligne

#34 01-04-2015 13:14:54

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

Youtube passe au html5 + VP9,
https://www.youtube.com/html5
Firefox commence à prendre en charge les MSE pour Media Source Extension (MSE)  et les Encrypted Media Extensions (EME) une sorte de DRM pour lecteur html5.
Voir ici :
http://linuxfr.org/news/firefox-37-vient-de-sortir
Avec les version backports, on pourrait pouvoir en profiter une fois Jessie devenue Stable.
A terme cela permettrait d'avoir une moins grande dépendances au flash en surfant sur le Web (On peut toujours rêver smile )

Hors ligne

#35 01-04-2015 13:34:31

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Mais il y a une chose qui je pige pas :

Iceweasel 31.5.3 prend :
HTMLVideoElement
H.264
WebM VP8

alors que Firefox 37 (ZIP Linux), lui ne prend pas le H.264
J'ai loupé un truc ?

Dernière modification par golgot200 (01-04-2015 13:35:18)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#36 01-04-2015 15:17:28

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

golgot200 a écrit :


alors que Firefox 37 (ZIP Linux), lui ne prend pas le H.264
J'ai loupé un truc ?


Pourquoi il ne le prendrai pas? Tu as vu ça où?

Hors ligne

#37 01-04-2015 17:40:44

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : Flash: dépasser la version 11.2

Iceweasel 31.5.3 sur Jessie ne supporte pas le H.264, ou alors j'ai un soucis.

Adhérent April N° 9016

Hors ligne

#38 01-04-2015 17:43:42

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

kao a écrit :


Pourquoi il ne le prendrai pas? Tu as vu ça où?




Voilà pour moi :

Iceweasel 31.5.3 :

31.png

et Firefox 37 (pas de H.264)

37.png


Mavrick a écrit :


Iceweasel 31.5.3 sur Jessie ne supporte pas le H.264, ou alors j'ai un soucis.



C'est bien pour ça que je suis perdu big_smile


EDIT:

Firefox 37

Sur :
http://html6test.com/

H.264 support  .............. NO

Et YES pour la 31 du dépôt tongue


Mouais, c'est pas clair tout ça :

http://www.jeuxvideo.com/forums/42-38-3 … outube.htm

Dernière modification par golgot200 (01-04-2015 18:41:47)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#39 01-04-2015 19:54:53

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Et la version Iceweasel 37 experimental de la mozilla.debian.net prend le H.264

Dernière modification par golgot200 (01-04-2015 19:55:26)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#40 01-04-2015 21:31:55

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

Donc pour avoir


Media Source Extensions OK
MSE & WebM VP9          OK
 



Il faut faire
about:config

Rechercher "media.gstreamer.enabled" et mettre sur true

Maintenant j'en ai 5 sur 6 avec Iceweasel 37 du dépôt mozilla.debian.net

HTMLVideoElement
H.264
WebM VP8
Media Source Extensions
MSE & WebM VP9

Iceweasel_370.png

EDIT: La version Firefox 37 (archive) n'as pas l'option "media.gstreamer.enabled" à moins peut-être de la créer

Dernière modification par golgot200 (01-04-2015 21:41:54)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#41 02-04-2015 17:25:03

Mavrick
Membre
Lieu : Loin de ma Bretagne natale...
Distrib. : Debian 8 (Jessie)
Noyau : Linux 3.16 amd64
(G)UI : Xfce 4.10
Inscription : 18-11-2013

Re : Flash: dépasser la version 11.2

J'ai installé la version 37 via mozilla.debian.net, "media.gstreamer.enabled" est sur True et pourtant aucun changement... hmm

Edit: Solution trouvé ici, je test...
Edit 2 : Okay tout est activé et tout fonctionne !

Dernière modification par Mavrick (02-04-2015 17:39:51)


Adhérent April N° 9016

Hors ligne

#42 02-04-2015 20:00:59

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Flash: dépasser la version 11.2

@Mavrick

Impeccable pour toi. J'avais essayé ton lien mais pour moi c'est ... nada  lol

Dernière modification par golgot200 (02-04-2015 20:01:25)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#43 02-04-2015 21:10:10

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Flash: dépasser la version 11.2

@ golgot200 @ Mavrick @ à tous,

Le lien de Mavrick fonctionne sur mon butineur : iceweasel 37 ( sous le capot , où il est question de Linux et de MSE )

Pour bientôt : " Flash est mort, vive HTML5 " smile

édition : pour tester, mais ça reste du youtube qui rime avec je sais plus quoi : "Le Bagad de Lann-Bihoue (Live)" de Soldat Louis

Dernière modification par nono47 (02-04-2015 21:57:54)

Hors ligne

#44 17-05-2015 12:53:55

Odysseus
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : xfce
Inscription : 27-04-2013
Site Web

Re : Flash: dépasser la version 11.2

J'ai le message d'erreur suivant :-(

~/freshplayerplugin/build$ cmake ..
-- checking for modules 'alsa;glib-2.0;gio-2.0;x11;xrandr;xrender;xcursor;gl;libconfig;libevent;libevent_pthreads;cairo;pango;pangocairo;pangoft2;freetype2;openssl;libv4l2'
--   package 'libv4l2' not found
CMake Error at /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:341 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:395 (_pkg_check_modules_internal)
  CMakeLists.txt:29 (pkg_check_modules)


-- checking for optional dependencies
--   no libpulse found (optional)
--   no jack found (optional)
-- Configuring incomplete, errors occurred!
See also "/home/odysseus/freshplayerplugin/build/CMakeFiles/CMakeOutput.log".

Hors ligne

#45 18-05-2015 10:47:29

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

Essaye de rajouter "libv4l-dev et libv4l-0" c'est peut-être une nouvelle lib nécessaire pour la compilation

Hors ligne

#46 18-05-2015 16:40:37

Odysseus
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : xfce
Inscription : 27-04-2013
Site Web

Re : Flash: dépasser la version 11.2

kao a écrit :

Essaye de rajouter "libv4l-dev et libv4l-0" c'est peut-être une nouvelle lib nécessaire pour la compilation



Ok ça fonctionne !

Merci

Hors ligne

#47 19-05-2015 05:24:35

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Flash: dépasser la version 11.2

Toute l'install c'est bien déroulé recompiler une 2e fois et rien nada .. snif pas ici 2 Shockwave flashplayer  11.2.202.457 et 13.1.2.3

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#48 19-05-2015 07:47:41

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Flash: dépasser la version 11.2

1432014438.jpg

tongue

Hors ligne

#49 19-05-2015 11:21:27

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Flash: dépasser la version 11.2

@Ir0nsh007er il faut désinstaller tout les autres flash et ne garder que le pepperflash avant de se lancer dans la compilation. Trop de flash tue le flash.

Hors ligne

#50 19-05-2015 15:09:14

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Flash: dépasser la version 11.2

Donc je dois tout désinstaller et recommencer?

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

Pied de page des forums