Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-12-2014 20:15:20

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

[Résolu] Guild Wars 2 avec playonlinux / Probleme DirectX9

Bonjour. Le titre n'est pas très explicite alors je vais vous argumenter cela.

J'ai fait l'installation de Guild Wars 2 par playonlinux.

Aucun soucis durant l'installation. Pour le lancement avec Optirun (oui, j'ai la technologie optimus, et je passe donc par bumblebee) il me manquait des librairie que j'ai rajouté.

Finalement, le lancement se fait. J'ai le lancher, la connexion à mon compte. Mais quand le jeu se lance, j'ai un message d'erreure de Guild War 2 : Initialisation de la sortie 3D impossible. Veuillez verifier que DirectX 9 est bien installé ainsi qu'un pilote vidéo a jour.

Par contre, le jeu se lance normalement quand je suis seulement sur le chipset graphique. Mais biensur elle est pas assez puissante pour faire tourner le jeu.

Donc DirectX fonctionne avec le chipset graphique, mais pas avec la carte Nvidia.

Je vais continuer mes recherches, mais je suis ouvert à toute proposition.

note : asus n550jk / chipset HD4000 / Nvidia GTX850M / Debian 64bit

Dernière modification par sadik (28-12-2014 10:36:02)

Hors ligne

#2 27-12-2014 20:23:35

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Guild Wars 2 avec playonlinux / Probleme DirectX9

Je lance Guild Wars 2 avec l’option suivante :

wine Gw2.exe -dx9single



J’en ai oublié la raison depuis bien longtemps, mais je suis sûr qu’elle était excellente big_smile
Utilises-tu aussi cette option au lancement ? Sinon un essai avec celle-ci change-t-il quelque chose à ton erreur ?


Jouer sous Debian ? Facile !

Hors ligne

#3 28-12-2014 10:04:37

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] Guild Wars 2 avec playonlinux / Probleme DirectX9

Merci de ta réponse.

Oui je lance gw2 avec cette option. Même un peu plus que cela vu que je rajoute optirun, l'email et même le mot de passe pour l'auto login.
C'est très pratique. Mais ca ne résouds pas mon problème. A mon avis, ça doit être une histoire de lien avec les lib. Vu que le jeu fonctionne quand je le lance uniquement avec ma HD4000.
Je continu les recherches big_smile

Hors ligne

#4 28-12-2014 10:35:39

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] Guild Wars 2 avec playonlinux / Probleme DirectX9

Souci résolu !

Je viens d'essayer de lancer uniquement playonlinux en optirun (d'habitude, je lancais directement le jeu)

Et là : bibliothèque gl32bit non detecté (alors que sans optirun pas de soucis)

Du coup :

aptitude install libgl1-nvidia-glx:i386



Et Gw2 tourne sur l'ordi.

Merci beaucoup aux intervenants qui m'ont aiguillé vers la resolution du problème !

Hors ligne

Pied de page des forums