Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-01-2015 17:01:40

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Resolu] Impossible d'installer un nouveau noyau.

Salut.

J'ai fait plusieurs tentatives d'installation du noyau linux-image-3.16.0-0.bpo.4-amd64 et je n'arrive pas à l'installer.
Je me demande si ce n'est pas du à la désinstallation des noyaux antérieurs pour lesquels j'ai simplement utilisé un aptitude remove le_noyau

Toujours est-il que aptitude search linux-image me donne ça :


# aptitude search linux-image
v   linux-image                                                                                -                                                                                                    
p   linux-image-2.6-amd64                                                                      - Linux for 64-bit PCs (dummy package)                                                                
c   linux-image-3.12-0.bpo.1-amd64                                                             - Linux 3.12 for 64-bit PCs                                                                          
c   linux-image-3.13-0.bpo.1-amd64                                                             - Linux 3.13 for 64-bit PCs                                                                          
c   linux-image-3.14-0.bpo.1-amd64                                                             - Linux 3.14 for 64-bit PCs                                                                          
c   linux-image-3.16-0.bpo.3-amd64                                                             - Linux 3.16 for 64-bit PCs                                                                          
c   linux-image-3.16.0-0.bpo.4-amd64                                                           - Linux 3.16 for 64-bit PCs                                                                          
p   linux-image-3.16.0-0.bpo.4-amd64-dbg                                                       - Debugging symbols for Linux 3.16.0-0.bpo.4-amd64                                                    
i A linux-image-3.2.0-4-amd64                                                                  - Linux 3.2 for 64-bit PCs                                                                            
p   linux-image-3.2.0-4-amd64-dbg                                                              - Debugging symbols for Linux 3.2.0-4-amd64                                                          
p   linux-image-3.2.0-4-rt-amd64                                                               - Linux 3.2 for 64-bit PCs, PREEMPT_RT                                                                
p   linux-image-3.2.0-4-rt-amd64-dbg                                                           - Debugging symbols for Linux 3.2.0-4-rt-amd64                                                        
i   linux-image-amd64                                                                          - Linux for 64-bit PCs (meta-package)                                                                
p   linux-image-amd64-dbg                                                                      - Debugging symbols for Linux amd64 configuration (meta-package)                                      
p   linux-image-rt-amd64
 



J'ai beau essayer d'installer le noyau 3.16 pas moyen...

Merci de vos conseils.

A+

Dernière modification par laguespa (20-01-2015 12:59:28)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 19-01-2015 17:20:08

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Resolu] Impossible d'installer un nouveau noyau.

Salut,
Quelles sont les entrées de ton /etc/apt/sources.list ?
Comment essayes-tu de l'installer (i.e avec quelle commande)?
Si tu as ajouté les sources.list des backports, il te faudrait peut-être définir des priorités de pinning qui vont avec ou user d'une commande du type:

apt-get install -t wheezy-backports linux-image-3.16.0-0.bpo.4-amd64


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 19-01-2015 18:33:47

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Impossible d'installer un nouveau noyau.

Bon, erreur de débutant mais comme je jongle entre stable et sid en ce moment j'avais oublié l'option -t pour les backports. hmm

Cependant ça ne règle pas le problème :


# apt-get install -t wheezy-backports linux-image-3.16.0-0.bpo.4-amd64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  irqbalance libnuma1
Paquets suggérés :
  linux-doc-3.16 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  irqbalance libnuma1 linux-image-3.16.0-0.bpo.4-amd64
0 mis à jour, 3 nouvellement installés, 0 à enlever et 191 non mis à jour.
Il est nécessaire de prendre 34,5 ko/33,7 Mo dans les archives.
Après cette opération, 163 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://ftp.fr.debian.org/debian/ wheezy-backports/main irqbalance amd64 1.0.6-2~bpo70+1 [34,5 kB]
34,5 ko réceptionnés en 0s (230 ko/s)
Préconfiguration des paquets...
Sélection du paquet linux-image-3.16.0-0.bpo.4-amd64 précédemment désélectionné.
(Lecture de la base de données... 138730 fichiers et répertoires déjà installés.)
Dépaquetage de linux-image-3.16.0-0.bpo.4-amd64 (à partir de .../linux-image-3.16.0-0.bpo.4-amd64_3.16.7-ckt2-1~bpo70+1_amd64.deb) ...
Sélection du paquet libnuma1 précédemment désélectionné.
Dépaquetage de libnuma1 (à partir de .../libnuma1_2.0.8~rc4-1_amd64.deb) ...
Sélection du paquet irqbalance précédemment désélectionné.
Dépaquetage de irqbalance (à partir de .../irqbalance_1.0.6-2~bpo70+1_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de linux-image-3.16.0-0.bpo.4-amd64 (3.16.7-ckt2-1~bpo70+1) ...
/etc/kernel/postinst.d/dkms:
Error! Bad return status for module build on kernel: 3.16.0-0.bpo.4-amd64 (x86_64)
Consult /var/lib/dkms/fglrx/12-6+point/build/make.log for more information.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.16.0-0.bpo.4-amd64
/etc/kernel/postinst.d/zz-update-grub:
Generating grub.cfg ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-3.16.0-0.bpo.4-amd64
Found initrd image: /boot/initrd.img-3.16.0-0.bpo.4-amd64
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found Debian GNU/Linux (8.0) on /dev/sda7
done
Paramétrage de libnuma1 (2.0.8~rc4-1) ...
Paramétrage de irqbalance (1.0.6-2~bpo70+1) ...
Installation de la nouvelle version du fichier de configuration /etc/init.d/irqbalance ...
[ ok ] Starting SMP IRQ Balancer: irqbalance.
 



Cette Error! Bad return status for module build on kernel: 3.16.0-0.bpo.4-amd64 ne me dit rien qui vaille...

Précision : le driver proprio pour la carte [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series] est installé et ça a l'air d'être un problème connu que ce driver met le bordel.

Dernière modification par laguespa (19-01-2015 18:42:18)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 19-01-2015 19:00:51

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Resolu] Impossible d'installer un nouveau noyau.

Pourquoi 191 paquets non mis à jour ?
Tu fais cohabiter Wheezy et Sid ? Il y a surement un problème d'incohérence la dessous.

Lors de ma dernière install de Wheezy, j'ai eu aussi un soucis pour installer le kernel 3.16 des backports. Pour que ça marche, j'ai dû faire un dist-upgrade complet sur les backports.
Pour ma part, Wheezy, c'est terminé. Je ne l'installerai plus, Jessie est déjà assez mûre pour la remplacer.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#5 19-01-2015 19:09:43

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Impossible d'installer un nouveau noyau.

Wheezy et Sid sont sur deux partitions différentes donc aucun problème de ce côté là.
Pourquoi 191 paquets non mis à jour ?... Pas d'idée là-dessus mais rien d'inquiétant d'autant que le dernier update/upgrade date d'il y a 2 minutes et ne m'a donné que 3 paquets à mettre à jour.
D'accord avec toi pour Jessie. Je l'ai sur une autre machine et ça tourne bien. Je crois que je vais migrer dans pas longtemps.

A+

Dernière modification par laguespa (19-01-2015 19:11:00)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 19-01-2015 19:17:31

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Impossible d'installer un nouveau noyau.

Il n'empêche que je ferais bien le test de déinstaller le driver propriétaire et de réactiver le libre mais je sais pas comment faire...
Je viens d'essayer mais je n'avais plus d'affichage graphique alors -> mode dépannage -> réinstallation de fglrx-driver fglrx-control roll

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#7 19-01-2015 19:17:38

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Resolu] Impossible d'installer un nouveau noyau.

Ca n'engage que moi : Je dirais même que Jessie tourne beaucoup mieux que Wheezy.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#8 19-01-2015 19:19:10

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Resolu] Impossible d'installer un nouveau noyau.

Là dessus, je ne peux pas t'aider, je n'ai toujours utilisé que du Nvidia.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#9 19-01-2015 23:07:34

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Resolu] Impossible d'installer un nouveau noyau.

yoshi a écrit :

Pourquoi 191 paquets non mis à jour ?


C’est normal, ce nombre est dû à l’utilisation de "-t wheezy-backports" et correspond au nombre de paquets qui peuvent être mis à jour vers une version présente dans la branche wheezy-backports.

Au sujet du pilote non-libre fglrx, je n’ai qu’un seul conseil à donner : en rester le plus loin possible !
AMD et nVIDIA sont similaires pour leur talent de développer des pilotes extrêmement difficiles à intégrer à quelque distribution que ce soit. Les pilotes libres n’offrent peut-être pas autant de performances, mais au moins ils s’intègrent parfaitement à Debian.


Jouer sous Debian ? Facile !

Hors ligne

#10 20-01-2015 10:34:22

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Impossible d'installer un nouveau noyau.

C'est pas trop pour une question de performance que j'ai installé le pilote propriétaire, c'est que le pilote libre me faisait chauffer la carte graphique à 58°C. En plus, selon le noyau sur lequel je démarrais, la mauvaise gestion du matériel par le pilote libre me plantait la machine. Tous les noyaux à partir de 3.1x m'ont posé ce problème quelque soit la distribution que j'ai pu utiliser.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#11 20-01-2015 12:59:07

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Impossible d'installer un nouveau noyau.

Bonjour.

J'ai fini par trouver ce qui n'allait pas. Je suis en multiboot avec Sid et c'est donc le grub de Sid qui charge le noyaux au démarrage. Par conséquent l'installation des nouveaux noyaux doit se faire dans Sid.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

Pied de page des forums