Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-01-2015 16:29:18

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

[Résolu] Mon ordi plante dès qu'il passe en veille

Bonjour,

Tout est dans le titre, en fait, et je ne saurais pas en dire beaucoup plus.
Le fait est que dès que je laisse mon ordinateur allumé un certain temps, je le retrouve écran éteint, souvent il est encore chaud alors qu'il aurait dû se mettre en veille depuis ce temps, et il est impossible de le réanimer. Si un CD est dans le lecteur, il se remet à tourner au moment où j'enfonce une touche, et puis s'arrête peu après ; mais l'ordi, lui, ne se réveille pas.
Le fait qu'il reste chaud (et pas toujours de la même façon, du reste), me fait dire qu'il plante au moment où il se met en veille, et reste à tourner en boucle sur ce qu'il était en train de faire à ce moment-là. Même si je le mets en veille manuellement, la sortie de veille est impossible.

Par quel bout prendre les choses ?

Dernière modification par Muselaar (01-02-2015 18:38:28)


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#2 20-01-2015 17:23:59

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Le noyau que tu utilises est toujours celui indiqué dans ta description? (Noyau : Linux 3.2.0-4-amd64)
Car il me semble avoir lu sur linuxfr.org que le problème de plantage lors d'une mise en veille est connu sur la dernière mise à jour de debian wheezy.

YA3HGA-H

Hors ligne

#3 20-01-2015 17:36:33

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Salut,
Peut-être que la mise en veille fait planter ton affichage mais que la machine reste allumée. Si tu fais Ctrl+Alt+F1 est-ce que tu passes en console normalement?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 20-01-2015 20:07:59

Deep
Membre
Distrib. : Linux Host-002 3.16.0-4-amd64 #1 SMP Debian 3.16.7
Inscription : 21-12-2014

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

bonjour à tous,

Meme problème que Muselaar avec cette config :

Linux Host-002 3.2.0-4-amd64 #1 SMP Debian 3.2.65-1 x86_64 GNU/Linux


l'ordi se met en veille tout seul, le PC reste allumé mais l'écran non et impossible de sortir de la veille a part la méthode bourrin....

je suis donc vos avis avec attention wink

EDIT: si ça peut t'aider j'avais suivi ça mais sans succès :
https://www.debian-fr.org/empecher-la-m … 34265.html

Dernière modification par Deep (20-01-2015 20:24:08)

Hors ligne

#5 21-01-2015 00:04:04

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Merci pour vos réponses.
Je suis bien toujours sur le même noyau, mais je suis maintenant en Wheezy 7.8, j'ai mis à jour mon profil
Le problème est récent chez moi, ça ne fait pas plus de 2-3 semaines, je dirais.
Même quand je mets en veille manuellement, impossible d'en ressortir.
Si je fais Ctrl+Alt+F1, ça produit le même résultat apparent qu'une mise en veille avec plantage, l'écran devient tout noir, et plus rien n'est possible, et si je le fais après la mise en veille, eh bien ça ne fait rien du tout.

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#6 21-01-2015 11:46:46

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Salut,
Effectivement la dernière mise à jour cause quelques problèmes de mise en veille sur certains portables:
http://linuxfr.org/news/debian-7-8-huit … -de-wheezy
Tu peux éventuellement essayer avec un des noyaux corrigés mentionnés dans la dépêche ci-dessus et disponibles ici:
https://people.debian.org/~benh/packages/

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#7 21-01-2015 13:58:15

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Salut,
et merci pour cette réponse qui donne l'origine du bug.
Mais je ne suis que très novice, et je ne vois pas clairement ce que je dois faire : quel paquet télécharger, et ensuite, je fais quoi avec ?

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#8 21-01-2015 15:31:38

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Ok pardon.
Je pense qu'en téléchargeant le premier paquet .deb en date du 11 janvier puis en l'installant avec la commande:

dpkg -i linux-image-3.2.0-4-amd64_3.2.65-1+deb7u1~test_amd64.deb


ça devrait être bon. Il faudra juste que ton le menu du GRUB tu fasses attention à bien sélectionner ce noyau là (ça devrait être le cas par défaut vu que c'est le plus récent).


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#9 22-01-2015 00:10:25

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

sogalpunx a écrit :

Il faudra juste que ton le menu du GRUB tu fasses attention à bien sélectionner ce noyau là (ça devrait être le cas par défaut vu que c'est le plus récent).


Le problème éventuel, c'est que j'utilise rEfit pour le démarrage, à cause du dualboot, et je ne sais pas du tout comment ça marche. Je n'étais pas arrivé à le mettre en place, c'est un ami de passage qui me l'a fait, assorti d'explications qui me sont passées loin au dessus de ma petite tête.


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#10 22-01-2015 22:44:48

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Bonsoir,

Une expérience intéressante de cet après-midi : j'ai verrouillé mon écran, et puis j'ai laissé mon ordinateur.
Quand je suis revenu, il s'était mis en veille, la preuve étant qu'il était froid (ou s'il n'était pas en veille, c'est bien imité).
Et il n'y a eu aucun problème pour revenir dessus, l'écran s'est ranimé dès que j'ai touché le clavier, j'ai tapé mon mot de passe, et tute bene.
Peut-être un palliatif pour la situation actuelle ? Je tenterai la même chose pour demain, on verra.
Parce que j'ai un peu peur de faire le bazar avec rEfit en changeant le noyau sans savoir ce que je dois changer ou non pour rEfit…

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#11 01-02-2015 18:38:05

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Mon ordi plante dès qu'il passe en veille

Je ne sais pas si mon précédent post était pertinent, en fait, mais de toute façon, le problème semble résolu, je viens de faire le test d'une mise en veille, mon ordi n'a pas planté.
Je marque donc [Résolu], sous réserve que la situation soit stable.
Je suis incapable de dire s'il y a eu ou non la mise à jour qui corrigeait le problème. Je peux seulement dire que j'ai lancé des mises à jour du système récemment, mais je n'ai pas pensé auparavant à faire le test de la mise en veille…

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

Pied de page des forums