Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-01-2015 15:38:52

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Resolu] Touchpad qui ne fonctionne pas.

Bonjour.

Je viens de passer ma machine sous Jessie et je me rends compte que le touchpad ne fonctionne plus alors qu'il marchait sous Wheezy.
C'est un Toshiba L670, la gestion de l'ACPI est sur off mais j'imagine que ça n'a rien à voir.
Tout me semble installé d'ailleurs je peux configurer le pavé tactile dans l'interface graphique mais il ne s'active pas.
J'ai un interrupteur matériel sur l'ordi pour activer/désactiver et puis apparemment une combinaison avec FN + F9. J'ai bien essayé mais ça ne donne rien.


# aptitude search xserver-xorg-input-synaptics
i A xserver-xorg-input-synaptics                                                               - pilote de pavé tactile Synaptics pour le serveur X.Org                                              
p   xserver-xorg-input-synaptics-dbg                                                           - pilote de pavé tactile Synaptics pour le serveur X.Org                                              
p   xserver-xorg-input-synaptics-dev
 




# egrep -i 'synap|alps|etps' /proc/bus/input/devices
N: Name="SynPS/2 Synaptics TouchPad"
 



Je vois pas ce qui cloche. J'ai fait l'installation de Jessie avec le pavé matériellement désactivé mais je ne crois pas que ça puisse poser de problème.

J'ai vérifié aussi dans le bios je n'ai rien à paramétrer à ce niveau.

Une idée ?

A+

Dernière modification par laguespa (01-02-2015 17:49:40)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 26-01-2015 17:12:36

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Touchpad qui ne fonctionne pas.

Ça s'est mis à remarcher et je ne sais pas pourquoi....

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#3 26-01-2015 17:50:31

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Touchpad qui ne fonctionne pas.

Bah non, en fait ça marche de temps en temps et pas à tous les démarrages.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 28-01-2015 15:29:10

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Resolu] Touchpad qui ne fonctionne pas.

salut laguespa,
tu peux donner le retour de

synclient -l


regarde si le touchpadoff est sur 0


TouchpadOff             = 0
 


Si ça n'est pas le cas, tu entres dans un terminal

synclient TouchpadOff= 0



@+


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#5 28-01-2015 15:43:07

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Touchpad qui ne fonctionne pas.

Salut.

Ce qui me paraît bizarre c'est que le touchpad fonctionne (un peu quand il veut mais là tout de suite il fonctionne) et pourtant :


$ synclient -l | grep Touchpad
    TouchpadOff             = 0
 



Je vais le passer à 1 et on verra.

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 28-01-2015 21:06:13

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Resolu] Touchpad qui ne fonctionne pas.

salut,
non non, lit bien la commande. Touchpadoff veut dire "désactiver le touchpad". Donc 0 veut dire que le touchpadoff est inactif donc que le touchpad fonctionne. S'il est sur 1, le touchpad est désactivé.

@+

<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#7 28-01-2015 21:14:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Resolu] Touchpad qui ne fonctionne pas.

Tu peux modifier le fonctionnement du touchpad en modifiant le fichier suivant:

/usr/share/X11/xorg.conf.d/50-synaptics.conf

Moi je voulait avoir le défilement des pages en faisant glisser le doigt sur le cöté alors j'ai ajouter ces lignes
   
    Option "TapButton1" "1"
    Option "VertEdgeScroll" "1"
Entre Section "InputClass" and EndSection.

Hors ligne

#8 28-01-2015 21:24:35

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Touchpad qui ne fonctionne pas.

Lætitia a écrit :

salut,
non non, lit bien la commande. Touchpadoff veut dire "désactiver le touchpad". Donc 0 veut dire que le touchpadoff est inactif donc que le touchpad fonctionne. S'il est sur 1, le touchpad est désactivé.

@+



T'as raison, je suis vraiment étourdi smile


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#9 28-01-2015 22:52:45

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Resolu] Touchpad qui ne fonctionne pas.

Hi hi hi wink
comme le dit deuchdeb, si entrer touchpadoff=0 à la volée ne résout pas ton problème (quand il se pose), dans le fichier "/usr/share/X11/xorg.conf.d/50-synaptics.conf" tu peux ajouter une ligne :

Option "TouchpadOff" "0"



@+


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#10 28-01-2015 23:40:55

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Resolu] Touchpad qui ne fonctionne pas.

On n'est pas censés modifier les fichiers dans /usr/share/X11/xorg.conf.d/, mais les copier dans /etc/X11/xorg.conf.d/ et les modifier là-bas :-°
Sinon, ces fichiers sont écrasés à la prochaine mise à jour.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 01-02-2015 17:49:21

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Touchpad qui ne fonctionne pas.

Salut.

La modification de Laeticia suffit apparemment. Après plusieurs redémarrages successifs pour en avoir le coeur net tout semble fonctionner.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#12 02-02-2015 00:44:06

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Resolu] Touchpad qui ne fonctionne pas.

salut,
cool smile N'oublie pas la combine du capt'n, elle pourra t'être utile si ton fichier se fait écraser. wink

laguespa a écrit :

Laeticia


AhAhahAHAaaaaaaaa… À moi la garde, qu'on amène le Maroilles et les tagadas qu'on l'enduise comme il se doit! lol


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#13 12-02-2015 13:25:55

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Re : [Resolu] Touchpad qui ne fonctionne pas.

Je me greffe sur ce fil : merci à deuchdeb pour son tuyau, j'ai désormais un touchpad 100% fonctionnel sur mon eeepc 701 (par défaut, j'avais pas le clic en tapotant ni la barre de défilement).
Précision : y'a 3 sections  "InputClass" and "EndSection" dans mon fichier : il faut mettre ça dans la 2e (clickpad), et pas dans la 1e…
J'ai appliqué la manip de captnfab qui est plus explicite que ce qui est écrit dans le fichier lui-même en commentaire.
Et ça roule nickel !

Hors ligne

#14 12-02-2015 13:59:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Resolu] Touchpad qui ne fonctionne pas.

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums