Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-01-2015 17:25:31

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

[resolu]installation samba

Bonjour
j'ai un soucis pour installer samba sur une machine.j ai utilisé le wiki DF et premiere remarque il manque un "S" a "users" sur la ligne "valid users = sharing" sur le tuto pdf. (5 eme ligne dans global)
vérifié a l aide de :

 testparm smb.conf


a mon premier test j ai perdu le dossier user de mon logging (plus le proprietaire)
et maintenant j ai des erreurs dont j aimerai vous faire part.
voici mon smb.conf

[


voir plus bas , smb.conf correct
 


apres ceci j ai perdu mon logging , retour a l invite . Apres recherche j ai perdu les droits sur mon dossier /home/monuser , j ai reussi a remettre de l ordre en root

si je tape smbpasswd -L  il me demande newpassword  (pour visualiser les utilisateurs samba)

je suis un peu perdu , si j ai bien compris il faut un groupe (samba) , ici sharing , un utilisateur  (encore sharing) et créer un mot de passe pour l utilisateur "sharing"
ou est mon erreur ?  de plus j aimerai faire un partage ailleur que dans le /home/user  ainsi que public  (sur un disque dédié)

Dernière modification par robert2a (31-01-2015 19:24:12)

En ligne

#2 27-01-2015 14:11:17

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

Bonjour

j'ai desinstallé samba sans trouver de solution , j ai bien crée le groupe partage , nomé "partage" , cree un utilisateur "partage" propriétaire du groupe , ajouté mon user au groupe.
a part l icone partage windows je n ai rien a partagé (j ai teste un partage dans home et sur un autre disque ).

pour mon probleme avec le tuto je pense que "chown -R sharing:sharing  /home/monuser   (user du logging debian)" m a enlever mes droits du dossier pour les donner a sharing.
voir le tuto cette ligne porte a confusion , hypathie = user
et dans prérequis  chown  -R sharing:sharing  /home/hypathie/    ou j ai remplace hypathie par mon user (ici c est "sharing" propriete de sharing (user)

si quelqu un peut verifier et corriger si besoin , bon j avoue que si j avais pris un temps de reflexion ça  ne devait pas arriver......

je voulais un petit coin pour archiver quelques fichiers de mes machines , a l occasion je testerai NFS.

ps: une autre remarque , partir sur un fichier conf vide et suivre le tuto n a pas fonctionne , j ai du reprendre des lignes du conf original comme type serveur => server standalone sinon samba se mettai en serveur de domaine.
je suis sur jessie , peut etre une cause aussi par rapport a wheezy

@++

En ligne

#3 27-01-2015 21:44:32

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : [resolu]installation samba

salut à toi

Pour installer un samba fonctionnel :

installe samba samba-client samba-common

aptitude install samba samba-client samba-common



mon smb.conf décommenté, change le groupe de travail de ta machine



[global]

   workgroup = MONGROUPE
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   server role = standalone server
   security = user
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user


#=======================partages =======================

#Imprimantes
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

# partage de dossiers locaux

[partage]
  comment = partage
  path = /media/partage
  read only = no
  browseable = yes
  valid users = USERNAME
  writable = yes

 



Ajoute un utilisateur dédié à ton partage réseau

useradd -r -s /bin/false USERNAME



ajoute un mot de passe samba :

smbpasswd -a USERNAME



ajoute l'utilisateur réseau au groupe du propriétaire de ton répertoire partagé :

useradd USERNAME MONGROUPEPROPRIODUREP



redémarre samba :

/etc/init.d/samba restart



et voilou normalement tu peux accéder à ton répertoire partagé depuis d'autres machines linux ou windows smile

Dernière modification par totophe56 (27-01-2015 21:45:20)

Hors ligne

#4 28-01-2015 02:06:02

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

Bonsoir
merci pour ta réponse , j ai fait apres quelques recherches tout comme toi a part  path = /media/partage j ai mit  /home/partage.
donc soit j ai un residu de config qui me perturbe mon install (fort possible apres tous les test )  soit j ai fait une erreur dans la procedure .
pour les imprimantes j ai un serveur cups qui fonctionne tres bien , donc samba pour les imprimantes ça ne m interresse pas.
c est une imprimante reseau sous un reseau local 1 et cups la partage sous un reseau local 2 (que des machines linux) , entre les 2 une passerelle linux.
samba serait sur le reseau 2 (linux uniquement).
ce matin j ai tous nettoyé la machine , il me faudra refaire un essaie avec ta methode.

le dernier essaie , j ai justement utlise  : groupe partage , utilisateur partage propriétaire du groupe partage et mon useurname que j ai ajoute au groupe partage .
ta maniere de faire n a pas les memes scripts que ce que j ai fait  , peut etre que c est la mon erreur.
exemple: moi j ai fait useradd partage  (ce qui ma cree le groupe partage , l utilisateur partage  et demandee le mot de passe pour l utilisateur partage)
quand je teste je viendrai donner le resultat.

En ligne

#5 29-01-2015 16:27:01

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

Bonjour

j'ai un partage actif sur le serveur ...  enfin ....  cool  , par contre petite question le meme utilisateur sur une machine cliente n a pas acces pourquoi ?
je precise de ce client j ai acces au partage par le proprietaire du groupe pas par l utilisateur rataché au groupe .
il y a quelque chose a faire cote client , le user du logging est le meme sur le serveur et le client.
par rapport a ton script j ai rajoute l ip du serveur sinon c est un copier coller , j ai tout effacer le reste.

ps: j utilise l explorateur de fichier de gnome , il me demande le mdp  (avec un utilisateur et un groupe de travail)

pour l instant j ai un partage sur le serveur , en esperant trouver pourquoi d un client cela ne fonctionne que avec l user proprietaire du groupe (ce qui est deja tres bien tongue  )
un autre bug impossible de mettre autre chose que workgroup comme groupe de travail il ne le prend pas en compte ( mdr samba est bien un fake de win )
j ai pas teste les droits ecriture et autre , je m en occuperai si probleme.
merci pour le coup de main

Dernière modification par robert2a (29-01-2015 16:29:04)

En ligne

#6 29-01-2015 17:47:20

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

re

pour mes soucis , ce que tu m a donne pour ajouter l utilisateur au groupe du propriétaire du repertoire partage ne fonctionne pas.

useradd username groupepropriodurep

ça me renvoi sur l aide , il doit manquer quelque chose.

mon groupe est "bidule" avec le user proprio de bidule "bidule"  , je veus rajouter "machin" qui a un compte sur le serveur et les clients

useradd  machin bidule  (ça me renvoi sur l aide de useradd ) et comme je veus pas faire de betise ........

si je fait adduser  machin bidule  il me dit que machin est deja dans le groupe de bidule.
et si je cree un mdp pour  machin

smbpasswd -a  machin  ça ne fonctionne pas (logging du partage refusé pour machin)

ps: re
la doc dit , chaque utilisateur a besoin d un compte sur le serveur , il faut creer des comptes unix puis enregistrer chaque utilisateur dans la base de samba
compte unix cree par adduser
l ajout d un utilisateur existant par smbpasswd -a  machin (qui demande le mdp interractivement)
machin a un compte unix (logging sur le bureau ) , la bd de samba est bien renseigné avec  smbpasswd -a machin
ou est le probleme ?

Dernière modification par robert2a (29-01-2015 18:36:47)

En ligne

#7 29-01-2015 20:27:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

j ai remit en non résolu , j abandonne pour aujourd hui , mon reseau est sur un domaine interne mais je vois pas le rapport , l user du groupe de partage peut se connecter.
et impossible de rajouter mon user du logging sur le partage (enfin il existe mais le logging echoue)
je pense aussi au mot de passe mal geré pour l user mais ça depasse mes competences.
en plus je sais pas vous mais j ai des log de presque 3go comme "messages" sur jessie ça recommence a bugger avec les dernieres mise a jour.

@++

En ligne

#8 29-01-2015 20:39:47

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : [resolu]installation samba

Salut,
Il y a des infos sur la commande useradd ici :
http://debian-facile.org/doc:systeme:useradd

Voici la commande permettant de créer un nouvel utilisateur (jchalle) dont le groupe par défaut sera celui du super-utilisateur (root) :

useradd -g root jchalle



Sinon je crois que tu peux utiliser cette commande :

adduser utilisateur groupe


http://doc.ubuntu-fr.org/adduser
wink


En espérant que ça t'aidera... smile

@+


Leonlemouton
°(")°

Hors ligne

#9 30-01-2015 02:14:40

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

j ai utilisée  useradd --help   et adduser --help , pour essayé de trouver le probleme

useradd -g j ai pas teste , mais  adduser utilisateur groupe  fonctionne puis smbpasswd pour ajouter l utilisateur a samba , tout ce passe bien mais lors d une connection au partage , la connection est refusée .

alors que l utilisateur propriétaire du partage  est bien géré.j ai acces au partage.

=> Ajoute un utilisateur dédié à ton partage réseau  (post de totophe56 ci dessus)


useradd -r -s /bin/false USERNAME
 


je testerai useradd -g nomdupartage nomuser

merci de l info

En ligne

#10 31-01-2015 00:21:03

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : [resolu]installation samba

robert2a a écrit :

connection au partage , la connection est refusée .



dis nous ce que retourne la commande

ls -la /rep/partagesamba



stp

Tu as bien mis la ligne valid user dans le smb.conf ?

Hors ligne

#11 31-01-2015 10:31:07

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

oui j ai bien mit validuser=nomdupropriétairedugroupedepartage



ls -la /media/partage/partagesamba

drwxrwxrwx 1 root root   4096 janv. 29 18:05 .
drwxrwxrwx 1 root root  16384 janv. 29 18:05 ..
drwxrwxrwx 1 root root   8192 déc.  17 16:24 A_TRIER
 



je fais une petite remarque (peut etre aucun rapport) cette nuit j ai eu des emails d alarme de cette machine ( exim4 fonctionne bien cool ).
php5 , cron et exim4
mes log depasse le giga (syslog , messages et user.log) , depuis ce matin syslog est reste a 25ko .
j ai supprime apache , php5 , mysql , samba (la machine me permet de tester les applications et d apprendre donc pas de soucis rien de precieux n a été perdu ).
j ai purge avec desinstallation complette .

la machine est en ip fixe , sur le reseau il ya un dns et dhcp (autre machine)
a prio samba a besoin de resoudre le nom de la machine d apres les logs (je pense au conf de samba qui a besoin d une information suplementaire)
et ce soucis d utilisateur non reconnu . J ai avance un peu au depart le partage ne fonctionnait pas du tout , maintenant j ai acces avec le proprio du groupe de partage .....
et je precise que je teste le partage par le bureau de gnome (explorateur fichier) du serveur et des clients.
je prend un temps de reflexion et je recommence l installation roll

Dernière modification par robert2a (31-01-2015 10:49:51)

En ligne

#12 31-01-2015 10:59:54

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

Ma config (avec des valeurs réelles)



voir plus bas smb.conf correct

 



nom du groupe de partage : sharingbob
utilisateur propriétaire du partage : bob
utilisateur machine : robert

le disque dur (du partage) est monte sur /media/partage
le dossier de partage sur ce disque est /robert/

Dernière modification par robert2a (31-01-2015 19:25:08)

En ligne

#13 31-01-2015 11:03:33

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : [resolu]installation samba

Salut,

Il faut modifier les droits d'accès au dossier /media/partage/partagesamba

Tu peux essayer un truc comme ça :

chown -R USERNAME:MONGROUPEPROPRIODUREP /media/partage/partagesamba


chmod -R 770 /media/partage/partagesamba



@+

Dernière modification par leonlemouton (31-01-2015 11:03:52)


Leonlemouton
°(")°

Hors ligne

#14 31-01-2015 11:11:41

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

je l ai fait il ne le prend pas en compte. le proprio est toujours root (hier samba etait encore installe )

pas d erreur (je l ai mit en verbose) il y a 1go de données ça prend du temps a la fin proprio root  lol


root@debian1:/media/partage# mkdir robert
root@debian1:/media/partage# ls
partage  robert
root@debian1:/media/partage# chown -R robert:robert /media/partage/robert/
root@debian1:/media/partage# chmod -R 770 /media/partage/robert/
root@debian1:/media/partage#
 



le resultat


root@debian1:/media/partage# ls -la /media/partage/robert
total 16
drwxrwxrwx 1 root root     0 janv. 31 10:12 .
drwxrwxrwx 1 root root 16384 janv. 31 10:12 ..
 


j ai mit 2 dossiers et quelques fichiers , nouvel essaie


root@debian1:/media/partage# chown -R robert:robert /media/partage/robert/
root@debian1:/media/partage# chmod -R 770 /media/partage/robert/
root@debian1:/media/partage#
root@debian1:/media/partage# ls -la /media/partage/robert
total 17
drwxrwxrwx 1 root root   248 janv. 31 10:22 .
drwxrwxrwx 1 root root 16384 janv. 31 10:24 ..
drwxrwxrwx 1 root root   520 janv. 31 10:24 Debian1
drwxrwxrwx 1 root root     0 janv. 31 10:22 Debian10
root@debian1:/media/partage#
 



je n ai pas de soucis pour ecrire lire etc , sur ce disque avec mon user .
hier le groupe de partage etait crée , idem meme resultat
le proprietaire du groupe avait au moin le droit de lecture c est sur , je pense pas que le soucis soit la .(le user du logging par l explorateur de fichier de gnome a tous les droits sur ce dossier (et le disque) c est sur aussi)

Dernière modification par robert2a (31-01-2015 11:39:34)

En ligne

#15 31-01-2015 11:36:54

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : [resolu]installation samba

ce tuto devrait pouvoir t'apporter des réponses :

http://clementgrimal.fr/blog/2013/01/30 … e-dur-usb/

notamment sur la configuration du montage (Les permissions point 4)...

bon courage smile

Leonlemouton
°(")°

Hors ligne

#16 31-01-2015 11:46:58

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

oula je ne touche pas au montage ......... c est un disque interne (config en dur au pire je peus utiliser l uid au lieu du nom )


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3cf723da-7588-4084-a53a-c3182636c315 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=440838e3-464d-4481-9fe9-70b40978e23c none            swap    sw              0       0

/dev/sdb1       /media/partage          ntfs   user,auto     0       0
/dev/sdc1       /media/Sauvegarde       ntfs   user,auto     0       0

/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto      0       0
/dev/sr1        /media/cdrom1   udf,iso9660 user,noauto      0       0
 



je vai etudier le point 4 , mais le montage est fait "user" et "auto" et je n ai pas de probleme pour ecrire et lire et executer , quelque chose que je comprend pas ........ hmm

Dernière modification par robert2a (31-01-2015 11:53:11)

En ligne

#17 31-01-2015 12:01:54

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [resolu]installation samba

Salut,


à propos de montage, pour mon nas, j'ai ça :

//192.168.1.2/dossier-nas /mnt/montage-nas cifs credentials=/home/monuser/.smbcredentials,iocharset=utf8,gid=1001,uid=1001,_netdev  0 0


avec dans ~/.smbcredentials

username=monuser
password=monmotdepasse


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 31-01-2015 12:20:44

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

re

modif faite , par contre je ne veut pas partager le disque mais un dossier (le tuto parle de partage la clé )


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3cf723da-7588-4084-a53a-c3182636c315 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=440838e3-464d-4481-9fe9-70b40978e23c none            swap    sw              0       0

# /dev/sdb1       /media/partage          ntfs   user,auto     0       0
UUID=4634236D34235EE5       /media/partage          ntfs   user,auto     0       0
# /dev/sdc1       /media/Sauvegarde       ntfs   user,auto     0       0
UUID=59942C8F3A011534       /media/Sauvegarde       ntfs   user,auto     0       0


/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto      0       0
/dev/sr1        /media/cdrom1   udf,iso9660 user,noauto      0       0
 


j ai rebooté c est correct mais a mon avis ne fait pas avancé mon affaire (disons que l UUID est plus sur , pas de risque de confusion de l os sur les disques )
je precise c est un serveur , 3 controleur de disque dont un raid 10 materiel.
je continue a lire le tuto tongue
pour le montage paskal c est pour les clients ?  ou le serveur aussi ?

Dernière modification par robert2a (31-01-2015 12:21:13)

En ligne

#19 31-01-2015 12:35:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [resolu]installation samba

robert2a a écrit :

pour le montage paskal c est pour les clients ?  ou le serveur aussi ?

Pour les clients, sur lesquels je n'ai que samba-common d'installé.
Sur le serveur (partage de dossiers), je n'ai accès à la config qu'à travers l'interface web.  sad


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 31-01-2015 12:37:17

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

ce qui me concerne sur ton tuto



Création du groupe :
  sudo groupadd storage
Récupération de l’id de ce groupe. La commande :
  cat /etc/group |grep storage




Ajout de l’utilisateur pi (ou toto si vous vous appelez toto) :
  sudo usermod -a -G storage pi

Partage avec Samba

  [mon_disque]
      path = /storage/mon_disque
      browseable = yes
      read only = no
      guest ok = yes
      force group = storage

 



avec mes infos :

nom du groupe de partage : sharingbob
utilisateur propriétaire du partage : bob
utilisateur machine : robert
nom du dossier partage /media/partage/robert

le disque dur (du partage) est monte sur :    /media/partage
le dossier de partage sur ce disque est:    /robert/


ce qui donne :
  sudo groupadd sharingbob
  cat /etc/group |grep sharingbob
resultat
root@debian1:/home/robert# groupadd sharingbob
root@debian1:/home/robert# cat /etc/group |grep sharingbob
sharingbob:x:1001:

  sudo usermod -a -G sharingbob robert   // ici un petit soucis il faut un utilisateur existant (bob n existe pas)
verification

 -a, --append                  ajouter l'utilisateur aux GROUPES
                                supplémentaires mentionnés par l'option -G
                                sans supprimer l 'utilisateur des autres
 -G, --groups GROUPES          définir une nouvelle liste de groupes
                                supplémentaires
ça a  l air correct :P  // ne pas detruire mon compte utilisateur

root@debian1:/home/robert# usermod -a -G sharingbob robert


Partage avec Samba
  [robert]           //mit le nom du dossier partagé
            comment = robert  
      path = /media/partage/robert         //chemin du dossier partagé
      browseable = yes
      read only = no
            writable = yes
      #guest ok = yes // inutile pour moi
            valid users = sharingbob                //le plus important les users de mon groupe de partage
      force group = sharingbob               // a tester
 

Dernière modification par robert2a (31-01-2015 13:15:09)

En ligne

#21 31-01-2015 13:20:43

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

vous pensez que je peut réinstaller samba ?
apres avoir effectuer les manips ci dessus création du groupe , ajout d un utilisateur au groupe et ajouter la bonne config a smb.conf
il est obligatoire de vider le conf de samba , ou juste modifier ou ajouter les valeurs qui manque ?

ps: ok paskal , mais pour le montage du partage sur les clients on verra quand il fonctionne  lol

PS2:

meme soucis , le user + mdp n a pas d acces au partage , pas de message d erreur je revient au logging de connection a chaque essaie

Dernière modification par robert2a (31-01-2015 13:54:01)

En ligne

#22 31-01-2015 13:53:43

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : [resolu]installation samba

Salut à voius

je rejoins Paskal sur le soucis de chmod ou chown, le soucis vient du fstab smile (qui assigne root en propriétaire et groupe de propriétaire au montage et qui ne te permet pas le chmod ou chown)

si par exemple le format de ta partition est en ntfs, remplace ntfs par le système de fichier de ta partition dans ton fstab :

UUID=uuid-de-la-partition-windows /media/windows ntfs-3g gid=groupe-utilisateur-debian,uid=utilisateur-debian,gmask=0022    0       0



ensuite tu ajoute ton utilisateur reseausamba au groupe-utilisateur-debian

c'est simplement ça qui t'empêche d'avoir accès à ton partage à partir du réseau ;-)

Hors ligne

#23 31-01-2015 14:14:06

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

je comprends pas , pourquoi un utilisateur du groupe de partage aurait les droits et pas l utilisateur linux.
quand j ai crée le groupe bob utilisateur bob (compte systeme ) il avait des droits root alors ?
et si je ne veus pas donner le disque en partage je peus pas utiliser samba ?
que les choses soit claire je ne connais pas windows , je partage que sur des machines linux et que le disque appartienne a root cela me semble raisonnable. (windows fait la meme chose , le disque est la propiété du systeme)
et pourquoi un utilisateur linux peut modifier le contenu du disque , meme totalement l effacer , fichier et dossier (il n y a que le formatage qui demande un acces root)
mais tu a raison sur le fait que mon dossier personnel par exemple appartient a robert  smile 
je vai chercher sur ce que tu m a ecrit , pour le moment je comprend rien ..........  tongue
je vois les icones du partage , debian1 et windows , je peus explorer => dossier imprimantes et dossier robert => ensuite il me faut me connecter=> et blocage

ps: j ai teste avec root , il n a pas acces au partage non plus (on sais jamais)

les seul logs que j ai de samba

log log.nmbd

[2015/01/31 12:41:56.423541,  0] ../source3/nmbd/nmbd.c:57(terminate)
  Got SIGTERM: going down...
[2015/01/31 12:44:29,  0] ../source3/nmbd/nmbd.c:907(main)
  nmbd version 4.1.13-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2015/01/31 12:44:29.184361,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'nmbd' finished starting up and ready to serve connections*****

  Samba name server DEBIAN1 is now a local master browser for workgroup WORKGROUP on subnet 192.168.10.10

log log.smbd

[2015/01/31 12:35:27,  0] ../source3/smbd/server.c:1189(main)
  smbd version 4.1.13-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2015/01/31 12:35:28.351023,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsFailed to delete pidfile /var/run/samba/smbd.pid. Error was Aucun fichier ou dossier de ce type
[2015/01/31 12:36:22,  0] ../source3/smbd/server.c:1189(main)
  smbd version 4.1.13-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2015/01/31 12:36:22.068809,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsFailed to delete pidfile /var/run/samba/smbd.pid. Error was Aucun fichier ou dossier de ce type
[2015/01/31 12:44:29,  0] ../source3/smbd/server.c:1189(main)
  smbd version 4.1.13-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2015/01/31 12:44:30.294857,  0] ../lib/util/become_daemon.c:136(daemon_ready)

le reste est vide , log.192.168.10.10 ou log.debian1

Dernière modification par robert2a (31-01-2015 14:29:47)

En ligne

#24 31-01-2015 14:37:50

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]installation samba

j'ai essaye de comprendre , dans mon fstab je dois mettre :

UUID=4634236D34235EE5       /media/partage          ntfs-3g   gid=sharingbob,uid=robert,gmask=1001     0       0

j ai le ntfs 3g installé , a priori jessie la par defaut.

j ai une sauvegarde du disque , j espere rien perdre .......

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3cf723da-7588-4084-a53a-c3182636c315 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=440838e3-464d-4481-9fe9-70b40978e23c none            swap    sw              0       0

# /dev/sdb1       /media/partage          ntfs   user,auto     0       0
# UUID=4634236D34235EE5       /media/partage          ntfs   user,auto     0       0
UUID=4634236D34235EE5       /media/partage          ntfs-3g   gid=sharingbob,uid=robert,gmask=1001     0       0


# /dev/sdc1       /media/Sauvegarde       ntfs   user,auto     0       0
UUID=59942C8F3A011534       /media/Sauvegarde       ntfs   user,auto     0       0


/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto      0       0
/dev/sr1        /media/cdrom1   udf,iso9660 user,noauto      0       0

bon je reboot , prier pour moi  roll

Dernière modification par robert2a (31-01-2015 14:46:24)

En ligne

#25 31-01-2015 14:52:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [resolu]installation samba

Amène....

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums