Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-02-2015 18:28:22

ToNiO44
Membre
Inscription : 17-01-2013

linux-tools

Bonjour à tous,

j'aimerais utiliser la commande "perf" pour enregistrer les performances d'un programme

j'ai actuellement un serveur dédié sous Debian Wheezy 64 Bits avec un kernel 3.10.23-xxxx-grs-ipv6-64

j'ai installer le paquet linux-tools sans problème

et dès que j'essaye d'utiliser la commande perf voici ce que j'obtiens:

perf record mon programme
/usr/bin/perf: line 24: exec: perf_3.10: not found
E: linux-tools-3.10 is not installed.



apt-get install linux-tools
Unpacking linux-tools (from .../linux-tools_3.2+46_all.deb) ...
Setting up linux-tools (3.2+46) ...



apt-cache search linux-tools
linux-tools - Performance analysis tools for Linux (meta-package)
linux-tools-2.6 - Performance analysis tools for Linux (dummy package)
linux-tools-3.2 - Performance analysis tools for Linux 3.2



perf record mon programme
/usr/bin/perf: line 24: exec: perf_3.10: not found
E: linux-tools-3.10 is not installed.



apt-get install linux-tools-3.10
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-tools-3.10
E: Couldn't find any package by regex 'linux-tools-3.10'



apparemment le fait d'avoir la version 3.2 ne permet pas à linux-tools de fonctionner
je pensais qu'une version supérieur passerait sans problème mais non

est ce que par hasard quelqu'un à déjà rencontrer ce problème?

le souci c'est que je ne sais pas si sa vient de mon kernel qui me semble pourtant à jour
ou si c'est une erreur de configuration ou un bug connu sous debian

merci d'avance pour votre aide

ToNiO

Dernière modification par ToNiO44 (06-02-2015 18:29:46)

Hors ligne

#2 06-02-2015 21:13:24

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : linux-tools

Ton noyau n’est pas une version proposée dans les dépôts officiels Debian.
Si tu tiens à continuer à l’utiliser, il va falloir que tu te procures le paquet linux-tools via la même source.

Jouer sous Debian ? Facile !

Hors ligne

#3 06-02-2015 23:00:21

ToNiO44
Membre
Inscription : 17-01-2013

Re : linux-tools

Bonjour vv222,

merci déjà pour votre aide

qu'est ce que vous endenter par la même source?

car mon serveur dédié est chez OVH et je suis apparemment sur le dernier noyau (en netboot)

par contre je pensais que mon kernel venait des dépôts officiel de Debian

merci d'avance pour votre aide

ToNiO

Hors ligne

#4 07-02-2015 00:56:00

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : linux-tools

Le noyau "standard" de Wheezy est le 3.2, et le dernier disponible dans les backports est le 3.16.
SI ce sont les gars d’OVH qui t’ont collé celui-ci, désolé pour eux mais ça ne respire ni le professionnalisme, ni même la compétence.

Pour pouvoir installer une version fonctionnelle de linux-tools depuis les dépôts officiels Debian, il faudra d’abord que tu passes sur un des deux noyaux officiellement supportés par Debian (3.2 ou 3.16).

Jouer sous Debian ? Facile !

Hors ligne

#5 07-02-2015 01:15:59

ToNiO44
Membre
Inscription : 17-01-2013

Re : linux-tools

Merci beaucoup vv222 c'est beaucoup plus claire smile

après pour OVH je ne sais je ne préfère pas m'avancer

j'ai peut être aussi fait des erreurs de manipulation

car je voit qu'ils ont les versions 3.16 mais bizarrement pas la version 3.2

ftp://ftp.ovh.net/made-in-ovh/bzImage/

au pire des cas je met à jour mon kernel manuelement en désactivant le netboot et en bootant sur le disque dur

est ce que par hasard vous connaissez un tutorial ou une procédure pour effectuer une mise à jour du noyau depuis la source officiel debian?

merci encore pour votre aide

Hors ligne

#6 07-02-2015 15:12:47

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : linux-tools

Avant tout, quelle version veut-tu utiliser, la 3.2 ou la 3.16?

Si tu ne sais pas laquelle est la plus adaptée, je te conseille de rester sur la 3.2 qui a bénéficié d’une période de tests beaucoup plus longue depuis son inclusion dans Wheezy.
Dans ce cas celui-ci s’installe tout simplement via la commande suivante en root :

apt-get install linux-image-amd64


Jouer sous Debian ? Facile !

Hors ligne

#7 07-02-2015 15:18:32

ToNiO44
Membre
Inscription : 17-01-2013

Re : linux-tools

Merci beaucoup vv222

si possible sur la 3.2 oui

je vais essayer la commande que vous m'avez indiquer

merci encore

Hors ligne

Pied de page des forums