Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 11-02-2015 14:44:04

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Non, non, c'est très clair.  big_smile

Mais j'avais compris de travers : je croyais que "apt-get install paquet/sid" n'installait que "paquet".  sad
Comme tu le décris, c'est finalement très souple.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#27 14-02-2015 20:25:11

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Bonsoir,


J'ai essayé ce fichier preferences :

Package: *
Pin: release n=wheezy
Pin-Priority: 900

Package: *
Pin: release n=wheezy-updates
Pin-Priority: 900

Package: *
Pin: release n=wheezy-backports
Pin-Priority: 500

Package: *
Pin: release n=jessie
Pin-Priority: 150,

Package: *
Pin: release n=sid
Pin-Priority: 100
 


Dans l'ensemble, ça me parait jouable mais :

apt-cache policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.fr.debian.org/debian/ sid/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ sid/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ sid/main Translation-en
 500 http://ftp.fr.debian.org/debian/ sid/contrib Translation-en
 100 http://ftp.fr.debian.org/debian/ sid/non-free i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ sid/contrib i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ sid/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ sid/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ sid/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 150 http://security.debian.org/ jessie/updates/non-free i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 150 http://security.debian.org/ jessie/updates/contrib i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 150 http://security.debian.org/ jessie/updates/main i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 150 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 150 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 150 http://security.debian.org/ jessie/updates/main amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/contrib Translation-en
 150 http://ftp.fr.debian.org/debian/ jessie/non-free i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=non-free
     origin ftp.fr.debian.org
 150 http://ftp.fr.debian.org/debian/ jessie/contrib i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=contrib
     origin ftp.fr.debian.org
 150 http://ftp.fr.debian.org/debian/ jessie/main i386 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
 150 http://ftp.fr.debian.org/debian/ jessie/non-free amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=non-free
     origin ftp.fr.debian.org
 150 http://ftp.fr.debian.org/debian/ jessie/contrib amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=contrib
     origin ftp.fr.debian.org
 150 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
     release o=Debian,a=testing,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/main Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/non-free i386 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib i386 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/main i386 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/non-free amd64 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib amd64 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-backports/main amd64 Packages
     release v=,o=Debian Backports,a=wheezy-backports,n=wheezy-backports,l=Debian Backports,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy-updates/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy-updates/main Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy-updates/contrib Translation-en
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=non-free
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=contrib
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=non-free
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=contrib
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=wheezy-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ wheezy/updates/non-free Translation-en
 500 http://security.debian.org/ wheezy/updates/main Translation-en
 500 http://security.debian.org/ wheezy/updates/contrib Translation-en
 900 http://security.debian.org/ wheezy/updates/non-free i386 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=non-free
     origin security.debian.org
 900 http://security.debian.org/ wheezy/updates/contrib i386 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=contrib
     origin security.debian.org
 900 http://security.debian.org/ wheezy/updates/main i386 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=main
     origin security.debian.org
 900 http://security.debian.org/ wheezy/updates/non-free amd64 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=non-free
     origin security.debian.org
 900 http://security.debian.org/ wheezy/updates/contrib amd64 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=contrib
     origin security.debian.org
 900 http://security.debian.org/ wheezy/updates/main amd64 Packages
     release v=7.0,o=Debian,a=stable,n=wheezy,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ wheezy/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ wheezy/main Translation-en
 500 http://ftp.fr.debian.org/debian/ wheezy/contrib Translation-en
 900 http://ftp.fr.debian.org/debian/ wheezy/contrib i386 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=contrib
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy/non-free i386 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=non-free
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=main
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy/contrib amd64 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=contrib
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy/non-free amd64 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=non-free
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
     release v=7.8,o=Debian,a=stable,n=wheezy,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets épinglés :
 


Les translations de sid et Jessie se retrouvent à la priorité 500 comme celles de Wheezy.
Je ne pense pas que ce soir souhaitable ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#28 14-02-2015 20:49:17

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Ce n'est pas encore ça :

apt-get install python-pyzolib/sid -s


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 0.3.3-1 » (Debian:unstable [all]) pour « python-pyzolib »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 python-pyzolib : Dépend: python:any (< 2.8)
                  Dépend: python:any (>= 2.7.5-5~)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Les paquets installés de stable, dans une version insuffisante, sont donc prioritaires.

Et si j'essaye :

apt-get install -t sid python-pyzolib -s


ma distro passe fortement en testing/unstable  big_smile :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cups-daemon cups-server-common hp-ppd hplip-data init-system-helpers libbz2-1.0:i386 libdb5.3:i386 libgcrypt20 libgssglue1
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 liblua5.1-filesystem0 libmarkdown2 libmpc2 libmpdec2 libmpdec2:i386 libopenjpeg5
  libperl5.20 libpython3-stdlib libpython3-stdlib:i386 libpython3.4-minimal libpython3.4-minimal:i386 libpython3.4-stdlib
  libpython3.4-stdlib:i386 libqpdf13 libreadline6:i386 librtmp0:i386 libsecret-1-0 libsecret-common libssl-dev libssl-doc libsystemd0
  libwebp5 lua-filesystem printer-driver-foo2zjs-common python3.4:i386 python3.4-minimal:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  binutils bzip2 cpp-4.7 cups-bsd cups-client cups-common cups-daemon cups-ppdc cups-server-common dpkg fontconfig fontconfig-config
  foomatic-filters g++-4.7 gcc-4.7 gcc-4.7-base gcc-4.7-base:i386 gcc-4.9-base gcc-4.9-base:i386 geany-plugin-latex
  geany-plugin-spellcheck geany-plugins-common gimp-data gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-glib-2.0 glib-networking
  glib-networking-common glib-networking-services hplip-data init-system-helpers lib32gcc1 lib32stdc++6 libalgorithm-diff-xs-perl
  libatk1.0-0 libatk1.0-data libatk1.0-dev libbz2-1.0 libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386 libc6-i686:i386
  libcairo-gobject2 libcairo-perl libcairo-script-interpreter2 libcairo2 libcairo2-dev libcups2 libcups2:i386 libcupscgi1 libcupsimage2
  libcupsmime1 libcupsppdc1 libcurl3 libcurl3:i386 libdb5.3 libdbd-mysql-perl libdbi-perl libelfg0 libexif12 libexif12:i386 libffi6
  libffi6:i386 libfile-fcntllock-perl libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libgcc-4.7-dev libgcc1 libgcc1:i386
  libgcrypt20 libgfortran3 libgirepository-1.0-1 libglib-perl libglib2.0-0 libglib2.0-bin libglib2.0-dev libgmp-dev libgmp10
  libgmp10:i386 libgmpxx4ldbl libgnutls-deb0-28 libgnutls-deb0-28:i386 libgomp1 libgpg-error0 libgpg-error0:i386 libgssapi-krb5-2
  libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgutenprint2 libhogweed2 libhogweed2:i386 libhtml-parser-perl
  libicu52 libio-socket-ip-perl libitm1 libjavascriptcoregtk-1.0-0 libk5crypto3 libk5crypto3:i386 libkeyutils1 libkeyutils1:i386
  libkrb5-3 libkrb5-3:i386 libkrb5support0 libkrb5support0:i386 liblocale-gettext-perl libmpc3 libmpdec2 libmpfr4 libnet-dbus-perl
  libnet-ssleay-perl libnettle4 libnettle4:i386 libobjc4 liborc-0.4-0 libp11-kit0 libp11-kit0:i386 libpcre3 libpcre3:i386 libpcre3-dev
  libpcrecpp0 libperl4-corelibs-perl libpipeline1 libpixman-1-0 libpixman-1-dev libproxy1 libpython-dev libpython-stdlib libpython2.7
  libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libpython3.4-minimal libpython3.4-stdlib libqpdf13
  libquadmath0 libreadline6 libreoffice-l10n-fr librtmp1 librtmp1:i386 libsecret-1-0 libsecret-common libselinux1 libselinux1:i386
  libsocket-perl libsoup2.4-1 libstdc++6 libstdc++6:i386 libstdc++6-4.7-dev libsystemd0 libtasn1-6 libtasn1-6:i386
  libtext-charwidth-perl libtext-iconv-perl libtirpc1 libuuid-perl libwebkitgtk-1.0-common libwebp5 libxml-parser-perl locales man-db
  mime-support nfs-common nfs-kernel-server perl perl-base perl-modules printer-driver-c2esp printer-driver-foo2zjs-common
  printer-driver-m2300w python python-aptdaemon python-aptdaemon.gtk3widgets python-dev python-gi python-minimal python2.7 python2.7-dev
  python2.7-minimal tasksel
Paquets suggérés :
  binutils-doc bzip2-doc gcc-4.7-locales xpp cups-pdf g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg gcc-4.7-multilib
  libmudflap0-4.7-dev libgcc1-dbg libgomp1-dbg libitm1-dbg libquadmath0-dbg libmudflap0-dbg libcloog-ppl0 libppl-c4 libppl9 libpwl5
  glibc-doc glibc-doc:i386 locales:i386 libfont-freetype-perl libcairo2-doc libclone-perl libmldbm-perl libnet-daemon-perl
  libsql-statement-perl rng-tools libglib2.0-doc libgmp10-doc libmpfr-dev gnutls-bin gnutls-bin:i386 krb5-doc krb5-user krb5-doc:i386
  krb5-user:i386 gstreamer-codec-install gnome-codec-install gstreamer1.0-tools gutenprint-locales libdata-dump-perl hyphen-fr
  libreoffice-grammarcheck-fr libstdc++6-4.7-doc groff open-iscsi watchdog perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
  libb-lint-perl libcpanplus-dist-build-perl libcpanplus-perl libfile-checktree-perl liblog-message-simple-perl liblog-message-perl
  libobject-accessor-perl python-doc python-gi-cairo python2.7-doc binfmt-support
Paquets recommandés :
  cups-browsed xdg-user-dirs gstreamer1.0-plugins-base qpdf rename libarchive-extract-perl libmodule-pluggable-perl libpod-latex-perl
  libterm-ui-perl libtext-soundex-perl libcgi-pm-perl libmodule-build-perl libpackage-constants-perl tk
Les paquets suivants seront ENLEVÉS :
  aptdaemon cups foomatic-db-engine geany-plugin-markdown ghostscript-cups gimp hpijs hplip libcupsdriver1 libgtk2-perl libhpmud0
  libpango-perl libperl5.14 libsane-hpaio libsnmp15 libwebkitgtk-1.0-0 luakit midori printer-driver-foo2zjs printer-driver-gutenprint
  printer-driver-hpcups printer-driver-hpijs printer-driver-postscript-hp printer-driver-splix surf task-print-server
Les NOUVEAUX paquets suivants seront installés :
  cups-daemon cups-server-common gcc-4.9-base gcc-4.9-base:i386 init-system-helpers libdb5.3 libelfg0 libffi6 libffi6:i386
  libgcc-4.7-dev libgcrypt20 libgmp10:i386 libgnutls-deb0-28 libgnutls-deb0-28:i386 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0
  libhogweed2 libhogweed2:i386 libicu52 libmpc3 libmpdec2 libnettle4:i386 libpcre3:i386 libperl4-corelibs-perl libproxy1 libpython-dev
  libpython-stdlib libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libpython3.4-minimal libpython3.4-stdlib
  libqpdf13 librtmp1 librtmp1:i386 libsecret-1-0 libsecret-common libsystemd0 libtasn1-6 libtasn1-6:i386 libwebp5
  printer-driver-foo2zjs-common python-pyzolib
Les paquets suivants seront mis à jour :
  binutils bzip2 cpp-4.7 cups-bsd cups-client cups-common cups-ppdc dpkg fontconfig fontconfig-config foomatic-filters g++-4.7 gcc-4.7
  gcc-4.7-base gcc-4.7-base:i386 geany-plugin-latex geany-plugin-spellcheck geany-plugins-common gimp-data gir1.2-atk-1.0
  gir1.2-freedesktop gir1.2-glib-2.0 glib-networking glib-networking-common glib-networking-services hplip-data lib32gcc1 lib32stdc++6
  libalgorithm-diff-xs-perl libatk1.0-0 libatk1.0-data libatk1.0-dev libbz2-1.0 libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386
  libc6-i686:i386 libcairo-gobject2 libcairo-perl libcairo-script-interpreter2 libcairo2 libcairo2-dev libcups2 libcups2:i386
  libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3:i386 libdbd-mysql-perl libdbi-perl libexif12 libexif12:i386
  libfile-fcntllock-perl libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libgcc1 libgcc1:i386 libgfortran3 libgirepository-1.0-1
  libglib-perl libglib2.0-0 libglib2.0-bin libglib2.0-dev libgmp-dev libgmp10 libgmpxx4ldbl libgomp1 libgpg-error0 libgpg-error0:i386
  libgssapi-krb5-2 libgssapi-krb5-2:i386 libgutenprint2 libhtml-parser-perl libio-socket-ip-perl libitm1 libjavascriptcoregtk-1.0-0
  libk5crypto3 libk5crypto3:i386 libkeyutils1 libkeyutils1:i386 libkrb5-3 libkrb5-3:i386 libkrb5support0 libkrb5support0:i386
  liblocale-gettext-perl libmpfr4 libnet-dbus-perl libnet-ssleay-perl libnettle4 libobjc4 liborc-0.4-0 libp11-kit0 libp11-kit0:i386
  libpcre3 libpcre3-dev libpcrecpp0 libpipeline1 libpixman-1-0 libpixman-1-dev libpython2.7 libquadmath0 libreadline6
  libreoffice-l10n-fr libselinux1 libselinux1:i386 libsocket-perl libsoup2.4-1 libstdc++6 libstdc++6:i386 libstdc++6-4.7-dev
  libtext-charwidth-perl libtext-iconv-perl libtirpc1 libuuid-perl libwebkitgtk-1.0-common libxml-parser-perl locales man-db
  mime-support nfs-common nfs-kernel-server perl perl-base perl-modules printer-driver-c2esp printer-driver-m2300w python
  python-aptdaemon python-aptdaemon.gtk3widgets python-dev python-gi python-minimal python2.7 python2.7-dev python2.7-minimal tasksel
141 mis à jour, 44 nouvellement installés, 26 à enlever et 1435 non mis à jour.
Remv aptdaemon [0.45-2]
Remv task-print-server [3.14.1]
Remv printer-driver-splix [2.0.0+svn306-2]
Remv printer-driver-postscript-hp [3.12.6-3.1+deb7u1]
Remv hplip [3.12.6-3.1+deb7u1]
Remv printer-driver-hpcups [3.12.6-3.1+deb7u1]
Inst nfs-kernel-server [1:1.2.6-4] (1:1.2.8-9 Debian:testing [amd64]) []
Inst nfs-common [1:1.2.6-4] (1:1.2.8-9 Debian:testing [amd64]) []
Inst libtirpc1 [0.2.2-5] (0.2.5-1 Debian:testing [amd64]) []
Inst libc6-i386 [2.13-38+deb7u7] (2.19-15 Debian:unstable [amd64]) []
Inst libc-dev-bin [2.13-38+deb7u7] (2.19-15 Debian:unstable [amd64]) [libc6-dev:amd64 ]
Inst libc6-dev [2.13-38+deb7u7] (2.19-15 Debian:unstable [amd64]) []
Inst locales [2.13-38+deb7u7] (2.19-15 Debian:unstable [all]) []
Inst libc6 [2.13-38+deb7u7] (2.19-15 Debian:unstable [amd64]) [libc6:amd64 on libc6:i386] [libc6:i386 on libc6:amd64] [libc6:i386 ]
Inst libc6:i386 [2.13-38+deb7u7] (2.19-15 Debian:unstable [i386]) [libc6-i686:i386 on libc6:i386] [libc6-i686:i386 ]
Conf libc6 (2.19-15 Debian:unstable [amd64]) [libc6-i686:i386 ]
Conf libc6:i386 (2.19-15 Debian:unstable [i386]) [libc6-i686:i386 ]
Inst libc6-i686:i386 [2.13-38+deb7u7] (2.19-15 Debian:unstable [i386]) []
Inst gcc-4.7-base [4.7.2-5] (4.7.4-3 Debian:unstable [amd64]) [gcc-4.7-base:amd64 on gcc-4.7-base:i386] [gcc-4.7-base:i386 on gcc-4.7-base:amd64] [libstdc++6:amd64 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 gcc-4.7-base:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst gcc-4.7-base:i386 [4.7.2-5] (4.7.4-3 Debian:unstable [i386]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf gcc-4.7-base (4.7.4-3 Debian:unstable [amd64]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf gcc-4.7-base:i386 (4.7.4-3 Debian:unstable [i386]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst gcc-4.9-base:i386 (4.9.2-10 Debian:unstable [i386]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst gcc-4.9-base (4.9.2-10 Debian:unstable [amd64]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf gcc-4.9-base (4.9.2-10 Debian:unstable [amd64]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf gcc-4.9-base:i386 (4.9.2-10 Debian:unstable [i386]) [libstdc++6:amd64 libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libstdc++6 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [libstdc++6:amd64 on libstdc++6:i386] [libstdc++6:i386 on libstdc++6:amd64] [libstdc++6:i386 g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libstdc++6:i386 [4.7.2-5] (4.9.2-10 Debian:unstable [i386]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf libstdc++6 (4.9.2-10 Debian:unstable [amd64]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf libstdc++6:i386 (4.9.2-10 Debian:unstable [i386]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libgcc1 [1:4.7.2-5] (1:4.9.2-10 Debian:unstable [amd64]) [libgcc1:amd64 on libgcc1:i386] [libgcc1:i386 on libgcc1:amd64] [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgcc1:i386 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libgcc1:i386 [1:4.7.2-5] (1:4.9.2-10 Debian:unstable [i386]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf libgcc1 (1:4.9.2-10 Debian:unstable [amd64]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Conf libgcc1:i386 (1:4.9.2-10 Debian:unstable [i386]) [g++-4.7:amd64 libgomp1:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libgomp1 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libitm1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libitm1 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libquadmath0:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libquadmath0 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libgcc-4.7-dev (4.7.4-3 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libmpfr4 [3.1.0-5] (3.1.2-3 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libmpc3 (1.0.2-2 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 cpp-4.7:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst cpp-4.7 [4.7.2-5] (4.7.4-3 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst binutils [2.22-8+deb7u2] (2.25-4 Debian:unstable [amd64]) [g++-4.7:amd64 gcc-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst gcc-4.7 [4.7.2-5] (4.7.4-3 Debian:unstable [amd64]) [g++-4.7:amd64 lib32gcc1:amd64 libgfortran3:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst g++-4.7 [4.7.2-5] (4.7.4-3 Debian:unstable [amd64]) [lib32gcc1:amd64 libgfortran3:amd64 libobjc4:amd64 lib32stdc++6:amd64 libstdc++6-4.7-dev:amd64 ]
Inst libstdc++6-4.7-dev [4.7.2-5] (4.7.4-3 Debian:unstable [amd64]) [lib32gcc1:amd64 libgfortran3:amd64 libobjc4:amd64 lib32stdc++6:amd64 ]
Inst libobjc4 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [lib32gcc1:amd64 libgfortran3:amd64 lib32stdc++6:amd64 ]
Inst libgfortran3 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [lib32gcc1:amd64 lib32stdc++6:amd64 ]
Inst lib32stdc++6 [4.7.2-5] (4.9.2-10 Debian:unstable [amd64]) [lib32gcc1:amd64 ]
Inst lib32gcc1 [1:4.7.2-5] (1:4.9.2-10 Debian:unstable [amd64]) []
Inst libgmp-dev [2:5.0.5+dfsg-2] (2:6.0.0+dfsg-6 Debian:testing [amd64]) []
Inst libgmpxx4ldbl [2:5.0.5+dfsg-2] (2:6.0.0+dfsg-6 Debian:testing [amd64]) []
Inst libgmp10 [2:5.0.5+dfsg-2] (2:6.0.0+dfsg-6 Debian:testing [amd64]) []
Inst libkeyutils1 [1.5.5-3+deb7u1] (1.5.9-5+b1 Debian:testing [amd64]) [libkeyutils1:amd64 on libkeyutils1:i386] [libkeyutils1:i386 on libkeyutils1:amd64] [libkeyutils1:i386 ]
Inst libkeyutils1:i386 [1.5.5-3+deb7u1] (1.5.9-5+b1 Debian:testing [i386]) []
Conf libkeyutils1 (1.5.9-5+b1 Debian:testing [amd64]) []
Conf libkeyutils1:i386 (1.5.9-5+b1 Debian:testing [i386]) []
Inst libk5crypto3 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [amd64]) [libk5crypto3:amd64 on libk5crypto3:i386] [libk5crypto3:i386 on libk5crypto3:amd64] [libk5crypto3:i386 ]
Inst libk5crypto3:i386 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [i386]) []
Inst libgssapi-krb5-2:i386 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [i386]) [libgssapi-krb5-2:amd64 on libgssapi-krb5-2:i386] [libgssapi-krb5-2:i386 on libgssapi-krb5-2:amd64] [libgssapi-krb5-2:amd64 ]
Inst libgssapi-krb5-2 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [amd64]) []
Inst libkrb5support0:i386 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [i386]) [libkrb5support0:amd64 on libkrb5support0:i386] [libkrb5support0:i386 on libkrb5support0:amd64] [libkrb5-3:i386 libkrb5support0:amd64 ]
Inst libkrb5support0 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [amd64]) [libkrb5-3:amd64 libkrb5-3:i386 ]
Conf libkrb5support0 (1.12.1+dfsg-17 Debian:testing [amd64]) [libkrb5-3:amd64 libkrb5-3:i386 ]
Conf libkrb5support0:i386 (1.12.1+dfsg-17 Debian:testing [i386]) [libkrb5-3:amd64 libkrb5-3:i386 ]
Conf libk5crypto3 (1.12.1+dfsg-17 Debian:testing [amd64]) [libkrb5-3:amd64 libkrb5-3:i386 ]
Conf libk5crypto3:i386 (1.12.1+dfsg-17 Debian:testing [i386]) [libkrb5-3:amd64 libkrb5-3:i386 ]
Inst libkrb5-3:i386 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [i386]) [libkrb5-3:amd64 on libkrb5-3:i386] [libkrb5-3:i386 on libkrb5-3:amd64] [libkrb5-3:amd64 ]
Inst libkrb5-3 [1.10.1+dfsg-5+deb7u2] (1.12.1+dfsg-17 Debian:testing [amd64])
Conf libkrb5-3 (1.12.1+dfsg-17 Debian:testing [amd64])
Conf libkrb5-3:i386 (1.12.1+dfsg-17 Debian:testing [i386])
Conf libgssapi-krb5-2 (1.12.1+dfsg-17 Debian:testing [amd64])
Conf libgssapi-krb5-2:i386 (1.12.1+dfsg-17 Debian:testing [i386])
Inst libgmp10:i386 (2:6.0.0+dfsg-6 Debian:testing [i386])
Inst libnettle4 [2.4-3] (2.7.1-5 Debian:testing [amd64])
Inst libnettle4:i386 (2.7.1-5 Debian:testing [i386])
Inst libhogweed2:i386 (2.7.1-5 Debian:testing [i386])
Inst libffi6 (3.1-2+b2 Debian:testing [amd64])
Inst libp11-kit0:i386 [0.12-3] (0.20.7-1 Debian:testing [i386]) [libp11-kit0:amd64 on libp11-kit0:i386] [libp11-kit0:i386 on libp11-kit0:amd64] [libp11-kit0:amd64 ]
Inst libp11-kit0 [0.12-3] (0.20.7-1 Debian:testing [amd64]) []
Inst libffi6:i386 (3.1-2+b2 Debian:testing [i386])
Conf libffi6:i386 (3.1-2+b2 Debian:testing [i386])
Conf libffi6 (3.1-2+b2 Debian:testing [amd64])
Conf libp11-kit0:i386 (0.20.7-1 Debian:testing [i386])
Conf libp11-kit0 (0.20.7-1 Debian:testing [amd64])
Inst libtasn1-6:i386 (4.2-2 Debian:testing [i386])
Inst libgnutls-deb0-28:i386 (3.3.8-5 Debian:testing [i386])
Inst libcupsppdc1 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Inst libcupsmime1 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Inst libcupsimage2 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Inst printer-driver-c2esp [24-2] (27-2 Debian:testing [amd64]) []
Remv libcupsdriver1 [1.5.3-5+deb7u4] []
Inst libcupscgi1 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Remv printer-driver-gutenprint [5.2.9-1] []
Remv cups [1.5.3-5+deb7u4] []
Inst cups-bsd [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Inst cups-client [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) []
Inst libcups2 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64]) [libcups2:amd64 on libcups2:i386] [libcups2:i386 on libcups2:amd64] [libcups2:i386 ]
Inst libcups2:i386 [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [i386]) []
Inst libgnutls-deb0-28 (3.3.8-5 Debian:testing [amd64]) []
Conf libgmp10 (2:6.0.0+dfsg-6 Debian:testing [amd64]) []
Conf libgmp10:i386 (2:6.0.0+dfsg-6 Debian:testing [i386]) []
Inst libhogweed2 (2.7.1-5 Debian:testing [amd64]) []
Conf libnettle4 (2.7.1-5 Debian:testing [amd64]) []
Conf libnettle4:i386 (2.7.1-5 Debian:testing [i386]) []
Conf libhogweed2 (2.7.1-5 Debian:testing [amd64]) []
Conf libhogweed2:i386 (2.7.1-5 Debian:testing [i386]) []
Inst libtasn1-6 (4.2-2 Debian:testing [amd64]) []
Conf libtasn1-6 (4.2-2 Debian:testing [amd64]) []
Conf libtasn1-6:i386 (4.2-2 Debian:testing [i386]) []
Conf libgnutls-deb0-28 (3.3.8-5 Debian:testing [amd64]) []
Conf libgnutls-deb0-28:i386 (3.3.8-5 Debian:testing [i386]) []
Conf libcups2 (1.7.5-10 Debian:testing [amd64]) []
Conf libcups2:i386 (1.7.5-10 Debian:testing [i386]) []
Inst cups-common [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [all])
Inst cups-ppdc [1.5.3-5+deb7u4] (1.7.5-10 Debian:testing [amd64])
Conf libcupsppdc1 (1.7.5-10 Debian:testing [amd64])
Conf cups-common (1.7.5-10 Debian:testing [all])
Conf cups-ppdc (1.7.5-10 Debian:testing [amd64])
Remv foomatic-db-engine [4.0.8-3]
Remv geany-plugin-markdown [1.24+dfsg-2~bpo70+1]
Remv ghostscript-cups [9.05~dfsg-6.3+deb7u1]
Remv gimp [2.8.2-2+deb7u1]
Remv hpijs [3.12.6-3.1+deb7u1]
Remv libgtk2-perl [2:1.244-1]
Remv printer-driver-hpijs [3.12.6-3.1+deb7u1]
Remv libsane-hpaio [3.12.6-3.1+deb7u1]
Remv libhpmud0 [3.12.6-3.1+deb7u1]
Remv libpango-perl [1.222-1+b1]
Remv libsnmp15 [5.4.3~dfsg-2.8+deb7u1]
Remv libperl5.14 [5.14.2-21+deb7u2]
Remv surf [0.4.1-8]
Remv midori [0.4.3+dfsg-0.1]
Remv luakit [2012.03.25-1]
Remv libwebkitgtk-1.0-0 [1.8.1-3.4]
Remv printer-driver-foo2zjs [20120510dfsg0-1]
Inst libpcre3-dev [1:8.30-5] (2:8.35-3.3 Debian:testing [amd64]) []
Inst libpcrecpp0 [1:8.30-5] (2:8.35-3.3 Debian:testing [amd64]) []
Inst libpcre3 [1:8.30-5] (2:8.35-3.3 Debian:testing [amd64])
Inst libpcre3:i386 (2:8.35-3.3 Debian:testing [i386])
Conf libpcre3 (2:8.35-3.3 Debian:testing [amd64])
Conf libpcre3:i386 (2:8.35-3.3 Debian:testing [i386])
Inst libselinux1 [2.1.9-5] (2.3-2 Debian:testing [amd64]) [libselinux1:amd64 on libselinux1:i386] [libselinux1:i386 on libselinux1:amd64] [libselinux1:i386 ]
Inst libselinux1:i386 [2.1.9-5] (2.3-2 Debian:testing [i386])
Conf libselinux1 (2.3-2 Debian:testing [amd64])
Conf libselinux1:i386 (2.3-2 Debian:testing [i386])
Inst libfontconfig1-dev [2.9.0-7.1] (2.11.0-6.3 Debian:testing [amd64]) []
Inst libfontconfig1 [2.9.0-7.1] (2.11.0-6.3 Debian:testing [amd64]) [libfontconfig1:amd64 on libfontconfig1:i386] [libfontconfig1:i386 on libfontconfig1:amd64] [libfontconfig1:i386 ]
Inst libfontconfig1:i386 [2.9.0-7.1] (2.11.0-6.3 Debian:testing [i386]) []
Inst fontconfig-config [2.9.0-7.1] (2.11.0-6.3 Debian:testing [all])
Conf fontconfig-config (2.11.0-6.3 Debian:testing [all])
Conf libfontconfig1 (2.11.0-6.3 Debian:testing [amd64])
Conf libfontconfig1:i386 (2.11.0-6.3 Debian:testing [i386])
Inst fontconfig [2.9.0-7.1] (2.11.0-6.3 Debian:testing [amd64])
Inst libpipeline1 [1.2.1-1] (1.4.0-1 Debian:testing [amd64])
Inst man-db [2.6.2-1] (2.7.0.2-5 Debian:testing [amd64])
Inst dpkg [1.16.15] (1.17.23 Debian:testing [amd64])
Conf dpkg (1.17.23 Debian:testing [amd64])
Inst perl [5.14.2-21+deb7u2] (5.20.1-5 Debian:testing [amd64]) []
Inst libio-socket-ip-perl [0.16-2] (0.32-1 Debian:testing [all]) []
Inst libsocket-perl [2.002-1] (2.016-1 Debian:testing [amd64]) []
Inst libxml-parser-perl [2.41-1+b1] (2.41-3 Debian:testing [amd64]) []
Inst libuuid-perl [0.02-5] (0.05-1+b1 Debian:testing [amd64]) []
Inst libtext-iconv-perl [1.7-5] (1.7-5+b2 Debian:testing [amd64]) []
Inst libtext-charwidth-perl [0.04-7+b1] (0.04-7+b3 Debian:testing [amd64]) []
Inst libnet-ssleay-perl [1.48-1+b1] (1.65-1+b1 Debian:testing [amd64]) []
Inst libnet-dbus-perl [1.0.0-1+b1] (1.0.0-2+b2 Debian:testing [amd64]) []
Inst perl-base [5.14.2-21+deb7u2] (5.20.1-5 Debian:testing [amd64]) [liblocale-gettext-perl:amd64 on perlapi-5.14.2:amd64] [libcairo-perl:amd64 libhtml-parser-perl:amd64 libdbi-perl:amd64 liblocale-gettext-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Conf perl-base (5.20.1-5 Debian:testing [amd64]) [libcairo-perl:amd64 libhtml-parser-perl:amd64 libdbi-perl:amd64 liblocale-gettext-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst liblocale-gettext-perl [1.05-7+b1] (1.05-8+b1 Debian:testing [amd64]) [libcairo-perl:amd64 libhtml-parser-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libhtml-parser-perl [3.69-2] (3.71-1+b3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libproxy1 (0.4.11-4+b2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst glib-networking-common [2.32.3-1] (2.42.0-2 Debian:testing [all]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 glib-networking-services:amd64 glib-networking:amd64 ]
Inst glib-networking-services [2.32.3-1] (2.42.0-2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 glib-networking:amd64 ]
Inst glib-networking [2.32.3-1] (2.42.0-2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libgirepository-1.0-1 [1.32.1-1] (1.42.0-2.2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst gir1.2-freedesktop [1.32.1-1] (1.42.0-2.2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst gir1.2-glib-2.0 [1.32.1-1] (1.42.0-2.2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python-aptdaemon.gtk3widgets [0.45-2] (1.1.1-4 Debian:testing [all]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python-aptdaemon [0.45-2] (1.1.1-4 Debian:testing [all]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python-gi [3.2.2-2] (3.14.0-1 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python2.7-minimal [2.7.3-6+deb7u2] (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libpython2.7-minimal (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libdb5.3 (5.3.28-9 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libpython2.7-stdlib (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libpython2.7 [2.7.3-6+deb7u2] (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 python2.7-dev:amd64 ]
Inst libpython2.7-dev (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 python2.7-dev:amd64 ]
Inst python2.7-dev [2.7.3-6+deb7u2] (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python2.7:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python2.7 [2.7.3-6+deb7u2] (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libpython-stdlib (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python-minimal [2.7.3-4+deb7u1] (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libpython-dev (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python-dev [2.7.3-4+deb7u1] (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Conf libpython2.7-minimal (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Conf python2.7-minimal (2.7.9-1 Debian:unstable [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Conf python-minimal (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 python:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst python [2.7.3-4+deb7u1] (2.7.8-3 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libelfg0 (0.8.13-5 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libglib2.0-bin [2.33.12+really2.32.4-5] (2.42.1-1 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib2.0-dev:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libglib2.0-dev [2.33.12+really2.32.4-5] (2.42.1-1 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libglib2.0-0 [2.33.12+really2.32.4-5] (2.42.1-1 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libglib-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libglib-perl [3:1.260-1] (3:1.305-2 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 libfile-fcntllock-perl:amd64 ]
Inst libfile-fcntllock-perl [0.14-2] (0.22-1+b1 Debian:testing [amd64]) [libcairo-perl:amd64 libdbi-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 ]
Inst libdbi-perl [1.622-1+deb7u1] (1.631-3+b1 Debian:testing [amd64]) [libcairo-perl:amd64 libalgorithm-diff-xs-perl:amd64 libdbd-mysql-perl:amd64 ]
Inst libdbd-mysql-perl [4.021-1+b1] (4.028-2+b1 Debian:testing [amd64]) [libcairo-perl:amd64 libalgorithm-diff-xs-perl:amd64 ]
Inst libcairo-perl [1.090-2] (1.104-2 Debian:testing [amd64]) [libalgorithm-diff-xs-perl:amd64 ]
Inst libalgorithm-diff-xs-perl [0.04-2+b1] (0.04-3+b1 Debian:testing [amd64]) []
Inst perl-modules [5.14.2-21+deb7u2] (5.20.1-5 Debian:testing [all]) [lsof:amd64 ]
Inst bzip2 [1.0.6-4] (1.0.6-7+b2 Debian:testing [amd64]) [lsof:amd64 ]
Inst libbz2-1.0 [1.0.6-4] (1.0.6-7+b2 Debian:testing [amd64]) [lsof:amd64 ]
Conf libbz2-1.0 (1.0.6-7+b2 Debian:testing [amd64]) [lsof:amd64 ]
Inst libpixman-1-dev [0.26.0-4+deb7u1] (0.32.6-3 Debian:testing [amd64]) [lsof:amd64 ]
Inst libpixman-1-0 [0.26.0-4+deb7u1] (0.32.6-3 Debian:testing [amd64]) [lsof:amd64 ]
Inst libcairo2-dev [1.12.2-3] (1.14.0-2.1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libcairo2 [1.12.2-3] (1.14.0-2.1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libcairo-script-interpreter2 [1.12.2-3] (1.14.0-2.1 Debian:testing [amd64]) [lsof:amd64 ]
Inst mime-support [3.52-1+deb7u1] (3.58 Debian:testing [all]) [lsof:amd64 ]
Inst libreadline6 [6.2+dfsg-0.1] (6.3-8+b3 Debian:testing [amd64]) [lsof:amd64 ]
Conf libreadline6 (6.3-8+b3 Debian:testing [amd64]) [lsof:amd64 ]
Inst libcairo-gobject2 [1.12.2-3] (1.14.0-2.1 Debian:testing [amd64]) [lsof:amd64 ]
Inst tasksel [3.14.1] (3.29 Debian:testing [all]) [lsof:amd64 ]
Inst libgpg-error0 [1.10-3.1] (1.17-3 Debian:testing [amd64]) [libgpg-error0:amd64 on libgpg-error0:i386] [libgpg-error0:i386 on libgpg-error0:amd64] [lsof:amd64 libgpg-error0:i386 ]
Inst libgpg-error0:i386 [1.10-3.1] (1.17-3 Debian:testing [i386]) [lsof:amd64 ]
Conf libgpg-error0 (1.17-3 Debian:testing [amd64]) [lsof:amd64 ]
Conf libgpg-error0:i386 (1.17-3 Debian:testing [i386]) [lsof:amd64 ]
Inst libgcrypt20 (1.6.2-4+b1 Debian:testing [amd64]) [lsof:amd64 ]
Conf libgcrypt20 (1.6.2-4+b1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libsystemd0 (215-12 Debian:unstable [amd64]) [lsof:amd64 ]
Inst init-system-helpers (1.22 Debian:testing [all]) [lsof:amd64 ]
Inst cups-daemon (1.7.5-10 Debian:testing [amd64]) [lsof:amd64 ]
Inst foomatic-filters [4.0.17-1] (4.0.17-6 Debian:unstable [amd64]) [lsof:amd64 ]
Inst libatk1.0-dev [2.4.0-2] (2.14.0-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst gir1.2-atk-1.0 [2.4.0-2] (2.14.0-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libatk1.0-0 [2.4.0-2] (2.14.0-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libatk1.0-data [2.4.0-2] (2.14.0-1 Debian:testing [all]) [lsof:amd64 ]
Inst librtmp1:i386 (2.4+20131018.git79459a2-5 Debian:testing [i386]) [lsof:amd64 ]
Inst libcurl3 [7.26.0-1+wheezy12] (7.38.0-4 Debian:testing [amd64]) [libcurl3:amd64 on libcurl3:i386] [libcurl3:i386 on libcurl3:amd64] [lsof:amd64 libcurl3:i386 ]
Inst libcurl3:i386 [7.26.0-1+wheezy12] (7.38.0-4 Debian:testing [i386]) [lsof:amd64 ]
Inst librtmp1 (2.4+20131018.git79459a2-5 Debian:testing [amd64]) [lsof:amd64 ]
Conf librtmp1 (2.4+20131018.git79459a2-5 Debian:testing [amd64]) [lsof:amd64 ]
Conf librtmp1:i386 (2.4+20131018.git79459a2-5 Debian:testing [i386]) [lsof:amd64 ]
Conf libcurl3 (7.38.0-4 Debian:testing [amd64]) [lsof:amd64 ]
Conf libcurl3:i386 (7.38.0-4 Debian:testing [i386]) [lsof:amd64 ]
Inst libexif12 [0.6.20-3] (0.6.21-2 Debian:testing [amd64]) [libexif12:amd64 on libexif12:i386] [libexif12:i386 on libexif12:amd64] [lsof:amd64 libexif12:i386 ]
Inst libexif12:i386 [0.6.20-3] (0.6.21-2 Debian:testing [i386]) [lsof:amd64 ]
Conf libexif12 (0.6.21-2 Debian:testing [amd64]) [lsof:amd64 ]
Conf libexif12:i386 (0.6.21-2 Debian:testing [i386]) [lsof:amd64 ]
Inst libgstreamer1.0-0 (1.4.4-2 Debian:testing [amd64]) [lsof:amd64 ]
Inst liborc-0.4-0 [1:0.4.16-2] (1:0.4.22-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libgstreamer-plugins-base1.0-0 (1.4.4-2 Debian:testing [amd64]) [lsof:amd64 ]
Inst libgutenprint2 [5.2.9-1] (5.2.10-3 Debian:testing [amd64]) [lsof:amd64 ]
Inst libicu52 (52.1-7 Debian:testing [amd64]) [lsof:amd64 ]
Inst libjavascriptcoregtk-1.0-0 [1.8.1-3.4] (2.4.8-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libmpdec2 (2.4.1-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libpython3.4-minimal (3.4.2-4 Debian:unstable [amd64]) [lsof:amd64 ]
Inst libpython3.4-stdlib (3.4.2-4 Debian:unstable [amd64]) [lsof:amd64 ]
Inst libqpdf13 (5.1.2-2 Debian:testing [amd64]) [lsof:amd64 ]
Inst libsecret-common (0.18-1 Debian:testing [all]) [lsof:amd64 ]
Inst libsecret-1-0 (0.18-1+b1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libsoup2.4-1 [2.38.1-3] (2.48.0-1 Debian:testing [amd64]) [lsof:amd64 ]
Inst libwebp5 (0.4.1-1.2+b2 Debian:testing [amd64]) [lsof:amd64 ]
Inst cups-server-common (1.7.5-10 Debian:testing [all]) [lsof:amd64 ]
Inst geany-plugin-latex [1.24+dfsg-2~bpo70+1] (1.24+dfsg-5 Debian:testing [amd64]) [lsof:amd64 ]
Inst geany-plugins-common [1.24+dfsg-2~bpo70+1] (1.24+dfsg-5 Debian:testing [all]) [lsof:amd64 geany-plugin-spellcheck:amd64 ]
Inst geany-plugin-spellcheck [1.24+dfsg-2~bpo70+1] (1.24+dfsg-5 Debian:testing [amd64]) [lsof:amd64 ]
Inst gimp-data [2.8.2-2+deb7u1] (2.8.14-1 Debian:testing [all]) [lsof:amd64 ]
Inst hplip-data [3.12.6-3.1+deb7u1] (3.14.6-1 Debian:testing [all]) [lsof:amd64 ]
Inst libperl4-corelibs-perl (0.003-1 Debian:7.8/stable, Debian:testing, Debian:unstable [all])
Inst libpython3-stdlib (3.4.2-2 Debian:testing [amd64])
Inst libreoffice-l10n-fr [1:4.3.3-2~bpo70+2] (1:4.3.3-2 Debian:testing [all])
Inst libwebkitgtk-1.0-common [1.8.1-3.4] (2.4.8-1 Debian:testing [all])
Inst printer-driver-foo2zjs-common (20140925dfsg0-3 Debian:testing [all])
Inst printer-driver-m2300w [0.51-7] (0.51-12 Debian:testing [amd64])
Inst python-pyzolib (0.3.3-1 Debian:unstable [all])
Conf libtirpc1 (0.2.5-1 Debian:testing [amd64])
Conf nfs-common (1:1.2.8-9 Debian:testing [amd64])
Conf nfs-kernel-server (1:1.2.8-9 Debian:testing [amd64])
Conf libc6-i386 (2.19-15 Debian:unstable [amd64])
Conf libc-dev-bin (2.19-15 Debian:unstable [amd64])
Conf libc6-dev (2.19-15 Debian:unstable [amd64])
Conf locales (2.19-15 Debian:unstable [all])
Conf libc6-i686:i386 (2.19-15 Debian:unstable [i386])
Conf libgomp1 (4.9.2-10 Debian:unstable [amd64])
Conf libitm1 (4.9.2-10 Debian:unstable [amd64])
Conf libquadmath0 (4.9.2-10 Debian:unstable [amd64])
Conf libgcc-4.7-dev (4.7.4-3 Debian:unstable [amd64])
Conf libmpfr4 (3.1.2-3 Debian:unstable [amd64])
Conf libmpc3 (1.0.2-2 Debian:unstable [amd64])
Conf cpp-4.7 (4.7.4-3 Debian:unstable [amd64])
Conf binutils (2.25-4 Debian:unstable [amd64])
Conf gcc-4.7 (4.7.4-3 Debian:unstable [amd64])
Conf libstdc++6-4.7-dev (4.7.4-3 Debian:unstable [amd64])
Conf g++-4.7 (4.7.4-3 Debian:unstable [amd64])
Conf libobjc4 (4.9.2-10 Debian:unstable [amd64])
Conf libgfortran3 (4.9.2-10 Debian:unstable [amd64])
Conf lib32gcc1 (1:4.9.2-10 Debian:unstable [amd64])
Conf lib32stdc++6 (4.9.2-10 Debian:unstable [amd64])
Conf libgmpxx4ldbl (2:6.0.0+dfsg-6 Debian:testing [amd64])
Conf libgmp-dev (2:6.0.0+dfsg-6 Debian:testing [amd64])
Conf libcupsmime1 (1.7.5-10 Debian:testing [amd64])
Conf libcupsimage2 (1.7.5-10 Debian:testing [amd64])
Conf printer-driver-c2esp (27-2 Debian:testing [amd64])
Conf libcupscgi1 (1.7.5-10 Debian:testing [amd64])
Conf cups-client (1.7.5-10 Debian:testing [amd64])
Conf cups-bsd (1.7.5-10 Debian:testing [amd64])
Conf libpcrecpp0 (2:8.35-3.3 Debian:testing [amd64])
Conf libpcre3-dev (2:8.35-3.3 Debian:testing [amd64])
Conf libfontconfig1-dev (2.11.0-6.3 Debian:testing [amd64])
Conf fontconfig (2.11.0-6.3 Debian:testing [amd64])
Conf libpipeline1 (1.4.0-1 Debian:testing [amd64])
Conf man-db (2.7.0.2-5 Debian:testing [amd64])
Conf libdb5.3 (5.3.28-9 Debian:unstable [amd64])
Conf perl (5.20.1-5 Debian:testing [amd64])
Conf perl-modules (5.20.1-5 Debian:testing [all])
Conf libsocket-perl (2.016-1 Debian:testing [amd64])
Conf libio-socket-ip-perl (0.32-1 Debian:testing [all])
Conf libxml-parser-perl (2.41-3 Debian:testing [amd64])
Conf libuuid-perl (0.05-1+b1 Debian:testing [amd64])
Conf libtext-iconv-perl (1.7-5+b2 Debian:testing [amd64])
Conf libtext-charwidth-perl (0.04-7+b3 Debian:testing [amd64])
Conf libnet-ssleay-perl (1.65-1+b1 Debian:testing [amd64])
Conf libnet-dbus-perl (1.0.0-2+b2 Debian:testing [amd64])
Conf liblocale-gettext-perl (1.05-8+b1 Debian:testing [amd64])
Conf libhtml-parser-perl (3.71-1+b3 Debian:testing [amd64])
Conf libproxy1 (0.4.11-4+b2 Debian:testing [amd64])
Conf glib-networking-common (2.42.0-2 Debian:testing [all])
Conf libglib2.0-0 (2.42.1-1 Debian:testing [amd64])
Conf glib-networking-services (2.42.0-2 Debian:testing [amd64])
Conf glib-networking (2.42.0-2 Debian:testing [amd64])
Conf libgirepository-1.0-1 (1.42.0-2.2 Debian:testing [amd64])
Conf gir1.2-glib-2.0 (1.42.0-2.2 Debian:testing [amd64])
Conf libpixman-1-0 (0.32.6-3 Debian:testing [amd64])
Conf libcairo2 (1.14.0-2.1 Debian:testing [amd64])
Conf libcairo-gobject2 (1.14.0-2.1 Debian:testing [amd64])
Conf gir1.2-freedesktop (1.42.0-2.2 Debian:testing [amd64])
Conf mime-support (3.58 Debian:testing [all])
Conf libpython2.7-stdlib (2.7.9-1 Debian:unstable [amd64])
Conf python2.7 (2.7.9-1 Debian:unstable [amd64])
Conf libpython-stdlib (2.7.8-3 Debian:testing [amd64])
Conf python (2.7.8-3 Debian:testing [amd64])
Conf python-gi (3.14.0-1 Debian:testing [amd64])
Conf python-aptdaemon (1.1.1-4 Debian:testing [all])
Conf python-aptdaemon.gtk3widgets (1.1.1-4 Debian:testing [all])
Conf libpython2.7 (2.7.9-1 Debian:unstable [amd64])
Conf libpython2.7-dev (2.7.9-1 Debian:unstable [amd64])
Conf python2.7-dev (2.7.9-1 Debian:unstable [amd64])
Conf libpython-dev (2.7.8-3 Debian:testing [amd64])
Conf python-dev (2.7.8-3 Debian:testing [amd64])
Conf libelfg0 (0.8.13-5 Debian:testing [amd64])
Conf libglib2.0-bin (2.42.1-1 Debian:testing [amd64])
Conf libglib2.0-dev (2.42.1-1 Debian:testing [amd64])
Conf libglib-perl (3:1.305-2 Debian:testing [amd64])
Conf libfile-fcntllock-perl (0.22-1+b1 Debian:testing [amd64])
Conf libdbi-perl (1.631-3+b1 Debian:testing [amd64])
Conf libdbd-mysql-perl (4.028-2+b1 Debian:testing [amd64])
Conf libcairo-perl (1.104-2 Debian:testing [amd64])
Conf libalgorithm-diff-xs-perl (0.04-3+b1 Debian:testing [amd64])
Conf bzip2 (1.0.6-7+b2 Debian:testing [amd64])
Conf libpixman-1-dev (0.32.6-3 Debian:testing [amd64])
Conf libcairo-script-interpreter2 (1.14.0-2.1 Debian:testing [amd64])
Conf libcairo2-dev (1.14.0-2.1 Debian:testing [amd64])
Conf tasksel (3.29 Debian:testing [all])
Conf libsystemd0 (215-12 Debian:unstable [amd64])
Conf init-system-helpers (1.22 Debian:testing [all])
Conf cups-daemon (1.7.5-10 Debian:testing [amd64])
Conf foomatic-filters (4.0.17-6 Debian:unstable [amd64])
Conf libatk1.0-data (2.14.0-1 Debian:testing [all])
Conf libatk1.0-0 (2.14.0-1 Debian:testing [amd64])
Conf gir1.2-atk-1.0 (2.14.0-1 Debian:testing [amd64])
Conf libatk1.0-dev (2.14.0-1 Debian:testing [amd64])
Conf libgstreamer1.0-0 (1.4.4-2 Debian:testing [amd64])
Conf liborc-0.4-0 (1:0.4.22-1 Debian:testing [amd64])
Conf libgstreamer-plugins-base1.0-0 (1.4.4-2 Debian:testing [amd64])
Conf libgutenprint2 (5.2.10-3 Debian:testing [amd64])
Conf libicu52 (52.1-7 Debian:testing [amd64])
Conf libjavascriptcoregtk-1.0-0 (2.4.8-1 Debian:testing [amd64])
Conf libmpdec2 (2.4.1-1 Debian:testing [amd64])
Conf libpython3.4-minimal (3.4.2-4 Debian:unstable [amd64])
Conf libpython3.4-stdlib (3.4.2-4 Debian:unstable [amd64])
Conf libqpdf13 (5.1.2-2 Debian:testing [amd64])
Conf libsecret-common (0.18-1 Debian:testing [all])
Conf libsecret-1-0 (0.18-1+b1 Debian:testing [amd64])
Conf libsoup2.4-1 (2.48.0-1 Debian:testing [amd64])
Conf libwebp5 (0.4.1-1.2+b2 Debian:testing [amd64])
Conf cups-server-common (1.7.5-10 Debian:testing [all])
Conf geany-plugins-common (1.24+dfsg-5 Debian:testing [all])
Conf geany-plugin-latex (1.24+dfsg-5 Debian:testing [amd64])
Conf geany-plugin-spellcheck (1.24+dfsg-5 Debian:testing [amd64])
Conf gimp-data (2.8.14-1 Debian:testing [all])
Conf hplip-data (3.14.6-1 Debian:testing [all])
Conf libperl4-corelibs-perl (0.003-1 Debian:7.8/stable, Debian:testing, Debian:unstable [all])
Conf libpython3-stdlib (3.4.2-2 Debian:testing [amd64])
Conf libreoffice-l10n-fr (1:4.3.3-2 Debian:testing [all])
Conf libwebkitgtk-1.0-common (2.4.8-1 Debian:testing [all])
Conf printer-driver-foo2zjs-common (20140925dfsg0-3 Debian:testing [all])
Conf printer-driver-m2300w (0.51-12 Debian:testing [amd64])
Conf python-pyzolib (0.3.3-1 Debian:unstable [all])


Mais c'est peut-être le cas de certains paquets ...


Ce qui est curieux : https://packages.debian.org/sid/python-pyzolib
Il n'est pas indiqué de version minimum de Python.  hmm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#29 16-02-2015 15:17:42

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : conseils pour le fichier preferences

paskal a écrit :

Les translations de sid et Jessie se retrouvent à la priorité 500 comme celles de Wheezy.
Je ne pense pas que ce soir souhaitable ?


C’est normal, les "Translations" sont toujours à une priorité de 500, quel que soit le contenu de ton fichier preferences. Ça n’interférera pas avec les priorités que tu as déclaré.


-----


paskal a écrit :

Ce qui est curieux : https://packages.debian.org/sid/python-pyzolib
Il n'est pas indiqué de version minimum de Python.  hmm


Je penche pour une précision manquante sur le site plutôt que pour une erreur d’APT.
Dans ce genre de situation tu as deux choix :
_rester avec apt-get, et déclarer le paquets à tirer de Sid un par un, par exemple dans ta situation :

apt-get install python-pyzolib/sid python/sid -s


_passer à aptitude, en espérant que celui-ci ait une solution plus convenable à te proposer :

aptitude install python-pyzolib/sid -s


Jouer sous Debian ? Facile !

Hors ligne

#30 16-02-2015 17:25:18

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

J'ai regardé le fichier control de python-pyzolib

Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)


Je ne comprends pas le <<2.8 mais la version python de Wheezy est la 2.7.3-4, ce qui explique sans doute l'enchaînement de paquets de Jessie avec mon test "-t sid".


Je regarderai avec aptitude, bien que je n'aie jamais eu satisfaction avec.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#31 16-02-2015 21:32:21

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : conseils pour le fichier preferences

paskal a écrit :

J'ai regardé le fichier control de python-pyzolib

Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)


Je ne comprends pas le <<2.8


C’est une restriction de version essentielle : quand une version de Python passera de la numérotation 2.7.x à 2.8.x, ça signifiera qu’un changement suffisamment important a eu lieu pour casser la compatibilité avec la branche 2.7. Le module python-pyzolib devra probablement être ré-écrit à ce moment pour être compatible avec la nouvelle branche 2.8.
Mais tout ça est théorique, je ne serais pas surpris que la branche 2.7 soit la dernière branche de python 2, les changements majeurs étant plutôt effectués dans la branche 3.x.

mais la version python de Wheezy est la 2.7.3-4, ce qui explique sans doute l'enchaînement de paquets de Jessie avec mon test "-t sid".


En effet, il est possible qu’une mise-à-jour de python amène dans ses bagages une bonne quantité de dépendances.

Je regarderai avec aptitude, bien que je n'aie jamais eu satisfaction avec.


Aptitude est généralement efficace lorsqu’on en limite l’usage à ces situations conflictuelles.
Par contre c’est une vraie plaie à utiliser pour de la maintenance quotidienne.


Jouer sous Debian ? Facile !

Hors ligne

#32 16-02-2015 21:54:52

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Merci pour ces précisions, vv222  smile


En ce qui concerne aptitude, ça part rapidement en sucette avec nfs :

aptitude install python-pyzolib/sid -s
Les NOUVEAUX paquets suivants vont être installés :
  python:i386{ab} python-pyzolib
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 34 non mis à jour.
Il est nécessaire de télécharger 196 ko d'archives. Après dépaquetage, 933 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 python : Est en conflit avec: python:i386 mais 2.7.8-3 doit être installé.
 python:i386 : Dépend: python2.7:i386 (>= 2.7.8-5~) mais il ne sera pas installé.
               Dépend: libpython-stdlib:i386 (= 2.7.8-3) mais il ne sera pas installé.
               Pré-Dépend: python-minimal:i386 (= 2.7.8-3) mais il ne sera pas installé.
               Est en conflit avec: python mais 2.7.3-4+deb7u1 est installé.
ouverts : 16 ; fermés : 48 ; reportés : 2 ; en conflit : 2
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     python:i386 [Non installé]                              
2)     python-pyzolib [Non installé]                            


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                              
1)      nfs-common                                                                  
2)      nfs-kernel-server                                                          
3)      python-dev                                                                  
4)      python2.7-dev                                                              

      Installer les paquets suivants :                                              
5)      libdb5.3 [5.3.28-7~deb8u1 (testing)]                                        
6)      libffi6 [3.1-2+b2 (testing, unstable)]                                      
7)      libpython-stdlib [2.7.8-3 (testing, unstable)]                              
8)      libpython2.7-minimal [2.7.8-11 (testing)]                                  
9)      libpython2.7-stdlib [2.7.8-11 (testing)]                                    

      Conserver les paquets suivants dans leur version actuelle :                  
10)     python:i386 [Non installé]                                                  

      Mettre à jour les paquets suivants :                                          
11)     libc-dev-bin [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]            
12)     libc6 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                  
13)     libc6:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
14)     libc6-dev [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
15)     libc6-i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
16)     libc6-i686:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]        
17)     libpython2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
18)     libtirpc1 [0.2.2-5 (now, stable) -> 0.2.5-1 (testing, unstable)]            
19)     locales [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                
20)     python [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]        
21)     python-minimal [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]
22)     python2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]              
23)     python2.7-minimal [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]      


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                              
1)      nfs-common                                                                  
2)      nfs-kernel-server                                                          
3)      python-dev                                                                  

      Installer les paquets suivants :                                              
4)      libdb5.3 [5.3.28-7~deb8u1 (testing)]                                        
5)      libffi6 [3.1-2+b2 (testing, unstable)]                                      
6)      libpython-stdlib [2.7.8-3 (testing, unstable)]                              
7)      libpython2.7-dev [2.7.8-11 (testing)]                                      
8)      libpython2.7-minimal [2.7.8-11 (testing)]                                  
9)      libpython2.7-stdlib [2.7.8-11 (testing)]                                    

      Conserver les paquets suivants dans leur version actuelle :                  
10)     python:i386 [Non installé]                                                  

      Mettre à jour les paquets suivants :                                          
11)     libc-dev-bin [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]            
12)     libc6 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                  
13)     libc6:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
14)     libc6-dev [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
15)     libc6-i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
16)     libc6-i686:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]        
17)     libpython2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
18)     libtirpc1 [0.2.2-5 (now, stable) -> 0.2.5-1 (testing, unstable)]            
19)     locales [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                
20)     python [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]        
21)     python-minimal [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]
22)     python2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]              
23)     python2.7-dev [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
24)     python2.7-minimal [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]      


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                              
1)      libtirpc1                                                                  
2)      nfs-common                                                                  
3)      nfs-kernel-server                                                          
4)      rpcbind                                                                    

      Installer les paquets suivants :                                              
5)      libdb5.3 [5.3.28-7~deb8u1 (testing)]                                        
6)      libffi6 [3.1-2+b2 (testing, unstable)]                                      
7)      libpython-dev [2.7.8-3 (testing, unstable)]                                
8)      libpython-stdlib [2.7.8-3 (testing, unstable)]                              
9)      libpython2.7-dev [2.7.8-11 (testing)]                                      
10)     libpython2.7-minimal [2.7.8-11 (testing)]                                  
11)     libpython2.7-stdlib [2.7.8-11 (testing)]                                    

      Conserver les paquets suivants dans leur version actuelle :                  
12)     python:i386 [Non installé]                                                  

      Mettre à jour les paquets suivants :                                          
13)     libc-dev-bin [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]            
14)     libc6 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                  
15)     libc6:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
16)     libc6-dev [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
17)     libc6-i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
18)     libc6-i686:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]        
19)     libpython2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
20)     locales [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                
21)     python [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]        
22)     python-dev [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]    
23)     python-minimal [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]
24)     python2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]              
25)     python2.7-dev [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
26)     python2.7-minimal [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]      


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                              
1)      nfs-common                                                                  
2)      nfs-kernel-server                                                          

      Installer les paquets suivants :                                              
3)      libdb5.3 [5.3.28-7~deb8u1 (testing)]                                        
4)      libffi6 [3.1-2+b2 (testing, unstable)]                                      
5)      libpython-dev [2.7.8-3 (testing, unstable)]                                
6)      libpython-stdlib [2.7.8-3 (testing, unstable)]                              
7)      libpython2.7-dev [2.7.8-11 (testing)]                                      
8)      libpython2.7-minimal [2.7.8-11 (testing)]                                  
9)      libpython2.7-stdlib [2.7.8-11 (testing)]                                    

      Conserver les paquets suivants dans leur version actuelle :                  
10)     python:i386 [Non installé]                                                  

      Mettre à jour les paquets suivants :                                          
11)     libc-dev-bin [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]            
12)     libc6 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                  
13)     libc6:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
14)     libc6-dev [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
15)     libc6-i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]              
16)     libc6-i686:i386 [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]        
17)     libpython2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
18)     libtirpc1 [0.2.2-5 (now, stable) -> 0.2.5-1 (testing, unstable)]            
19)     locales [2.13-38+deb7u7 (now, stable) -> 2.19-13 (testing)]                
20)     python [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]        
21)     python-dev [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]    
22)     python-minimal [2.7.3-4+deb7u1 (now, stable) -> 2.7.8-3 (testing, unstable)]
23)     python2.7 [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]              
24)     python2.7-dev [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]          
25)     python2.7-minimal [2.7.3-6+deb7u2 (now, stable) -> 2.7.8-11 (testing)]      


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#33 17-02-2015 00:12:43

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : conseils pour le fichier preferences

Après vérification, la version Sid de python2.7 dépend de la version Jessie/Sid de la libc6 (>= 2.15).
Mettre à jour la libc6 vers une version supérieure est l’opération la plus casse-gueule qu’on puisse trouver si on veut rester en stable…

Dans ce genre de cas, j’aurais tendance à me tourner vers de la compilation (soit de python2.7, soit de ton module python spécifique).

Après une vérification de plus, la version Sid de python2.7 ne compilera pas avec la version Wheezy de dpkg-dev.
Le module python-pyzolib par contre ne me paraît pas nécessiter quoi que ce soit d’absent des dépôts de Wheezy, c’est donc par là que je me tournerais (compilation de python-pyzolib sur la version Wheezy de python2.7).

Jouer sous Debian ? Facile !

Hors ligne

#34 17-02-2015 10:24:59

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

vv222 a écrit :

Le module python-pyzolib par contre ne me paraît pas nécessiter quoi que ce soit d’absent des dépôts de Wheezy, c’est donc par là que je me tournerais (compilation de python-pyzolib sur la version Wheezy de python2.7).

Effectivement, cela semble être la voie la plus raisonnable.  hmm

Dommage, mais je trouverai bien un autre paquet à installer pour tester mon pinning.  smile

En tout cas, merci pour toutes ces informations riches d'enseignements.  cool


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#35 17-02-2015 16:36:41

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : conseils pour le fichier preferences

paskal a écrit :

Dommage, mais je trouverai bien un autre paquet à installer pour tester mon pinning.  smile


Ah, le pinning, cette idée excellente sur le papier mais qui ne fonctionne jamais dans la pratique…

Bon, j’exagère un peu, je l’utilise régulièrement pour forcer des versions particulières ou au contraire interdire des versions boguées. Mais pour un cas d’usage tel que celui-ci, installer un paquet d’une branche plus récente sur une Debian stable, ça ne fonctionne pour ainsi dire presque jamais (toujours pour des raisons de dépendances en cascade).

En tout cas, merci pour toutes ces informations riches d'enseignements.  cool


De rien, les connaissances qu’on ne partage pas sont juste gaspillées.


Jouer sous Debian ? Facile !

Hors ligne

#36 18-02-2015 23:08:52

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

vv222 a écrit :

Ah, le pinning, cette idée excellente sur le papier mais qui ne fonctionne jamais dans la pratique…

big_smile

Suite à ton post https://debian-facile.org/viewtopic.php … 49#p108349 , je me suis dit que j'allais peut-être profiter d'une version récente de youtube-dl.
Hélas, la cascade de dépendances est encore pire.  hmm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#37 19-02-2015 02:46:41

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : conseils pour le fichier preferences

Au sujet de youtube-dl, tu as essayé avec l’option d’apt-get "--without-recommends" ?
Il y a des chances que ça allège pas mal ses dépendances.

Jouer sous Debian ? Facile !

Hors ligne

#38 19-02-2015 12:50:37

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Wahou ! Comment n'y ai-je pas pensé ? Merci.  smile

apt-get install -t sid --no-install-recommends youtube-dl
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Paquets recommandés :
  libav-tools ffmpeg rtmpdump
Les NOUVEAUX paquets suivants seront installés :
  youtube-dl


Ça ne résout pas le problème de téléchargement de la vidéo en question mais c'est un autre problème.  big_smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#39 19-02-2015 14:05:02

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : conseils pour le fichier preferences

j essaie de suivre votre discution  roll  , pour comprendre comment gerer les priorités pour sid et experimental , j avoue etre un peu perdu. hmm

Hors ligne

#40 19-02-2015 14:12:20

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Ben chaque cas est particulier : quel est ton objectif ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#41 19-02-2015 16:04:40

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : conseils pour le fichier preferences

tester le pire smile
je suis sur sid pour poster , j ai trouvé un deb pour driver graphique nvidia en 343.xx  en experimental mais a priori a installer en manuel.

sur jessie il y a trop de dependances incorrectes , j avais espoir de tester sur sid.
l installateur graphique me donne "erreur" mais pas le detail.
il me reste en console avec apt.

mon sources.list


deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free


 



preference n est pas renseigné .

en recherche graphique des packets je ne voit pas ce fameux driver (experiemental) et pas mal de dependences comme nvidia-opencl-icd-343.36-1_amd64.deb

https://packages.debian.org/experimenta … ncl-common

j ai l impression que tout est a installer en manuel , mais les dependances bloques.

Dernière modification par robert2a (19-02-2015 16:13:10)

Hors ligne

#42 19-02-2015 16:27:33

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : conseils pour le fichier preferences

as-tu experimental et testing dans tes sources ?
je crois qu'ils sont plus que nécessaire en sid...

En plus, en freeze c'est encore moins confortable de ce que je me suis laissé dire par la piraterie... wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#43 19-02-2015 19:49:32

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : conseils pour le fichier preferences

voila c est fait tellement experimental j ai du installer packe par packe , une galere avec un gpu intel (la carte pas reconnu par nouveau) puis une 9800 nvidia jai du forcer l install pas reconnu par le driver nvidia puis mise en place de GTX750 et redemarrage .
pour la stabilite pour l instant c est nickel , mieux que jessie cool
le cpu est a 100% d utilisation je vai martiriser le gpu aussi et en plus j installe des packets ........


    25.033] (==) ModulePath set to "/usr/lib/xorg/modules"
[    25.033] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[    25.043] (II) Loader magic: 0x7ffa3adf6d80
[    25.043] (II) Module ABI versions:
[    25.043]  X.Org ANSI C Emulation: 0.4
[    25.043]  X.Org Video Driver: 18.0
[    25.043]  X.Org XInput driver : 21.0
[    25.043]  X.Org Server Extension : 8.0
[    25.043] (II) xfree86: Adding drm device (/dev/dri/card0)
[    25.045] (--) PCI:*(0:4:0:0) 10de:1381:1462:8a9c rev 162, Mem @ 0xfd000000/16777216, 0xe0000000/268435456, 0xde000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/524288
[    25.047] (II) LoadModule: "glx"
[    25.056] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    28.145] (II) Module glx: vendor="NVIDIA Corporation"
[    28.146]  compiled for 4.0.2, module version = 1.0.0
[    28.146]  Module class: X.Org Server Extension
[    28.150] (II) NVIDIA GLX Module  343.36  Mon Dec  1 15:50:02 PST 2014
[    28.162] (II) LoadModule: "nvidia"
[    28.167] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    28.464] (II) Module nvidia: vendor="NVIDIA Corporation"
[    28.464]  compiled for 4.0.2, module version = 1.0.0
[    28.464]  Module class: X.Org Video Driver
[    28.470] (II) NVIDIA dlloader X Driver  343.36  Mon Dec  1 15:28:39 PST 2014
[    28.470] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    28.471] (++) using VT number 7
 



c est un petit dual core (en 775) de 2006 environ avec 1GO de ddr2 (une seule barrette) chipset G41

Dernière modification par robert2a (19-02-2015 19:55:40)

Hors ligne

#44 19-02-2015 19:53:46

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Je me demande si il ne faudrait pas scinder la discussion pour que tu reçoives une aide spécifique à ce problème particulier ?  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#45 19-02-2015 19:56:52

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : conseils pour le fichier preferences

non désole du derangement c est termine j ai ma reponse et le driver est en 343  wink

je vai continer a vous lire
et pour te repondre non pas de testing dans les sources

Dernière modification par robert2a (19-02-2015 19:57:58)

Hors ligne

#46 19-02-2015 19:57:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

ok smile

Pas de dérangement, je pensais que le pb était loin de sa solution !  lol

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#47 19-02-2015 20:09:28

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : conseils pour le fichier preferences

mais tu voie que il y a un soucis dans le gestionnaire de paquet il me dit que je peus desinstaller le nouveau driver nvidia
je pense que c est dans preference ou je vai lui dire ce que je veus ..........
d ou l interet de votre discusion wink

Hors ligne

#48 19-02-2015 20:23:42

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Je pense que tu devrais spécifier le paquet en question, dans l'esprit de https://debian-facile.org/doc:systeme:a … perimental

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#49 20-02-2015 12:34:40

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

Pour en revenir à mon fichier prefences(au #27), il y a quelque chose que je trouve curieux :

# apt-cache policy vlc
vlc:
  Installé : 2.0.3-5+deb7u1
  Candidat : 2.0.3-5+deb7u2+b1
 Table de version :
     2.2.0~rc2-2 0
        150 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        100 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
     2.1.5-1~bpo70+1 0
        500 http://ftp.fr.debian.org/debian/ wheezy-backports/main amd64 Packages
     2.0.3-5+deb7u2+b1 0
        900 http://security.debian.org/ wheezy/updates/main amd64 Packages
 *** 2.0.3-5+deb7u1 0
        900 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status

# apt-get install vlc -s
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  vlc-nox vlc-plugin-notify vlc-plugin-pulse
Paquets suggérés :
  videolan-doc
Les paquets suivants seront mis à jour :
  vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse
4 mis à jour, 0 nouvellement installés, 0 à enlever et 40 non mis à jour.
Inst vlc-plugin-pulse [2.0.3-5+deb7u1] (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64]) []
Inst vlc-plugin-notify [2.0.3-5+deb7u1] (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64]) []
Inst vlc [2.0.3-5+deb7u1] (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64]) []
Inst vlc-nox [2.0.3-5+deb7u1] (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64])
Conf vlc-nox (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64])
Conf vlc-plugin-pulse (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64])
Conf vlc-plugin-notify (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64])
Conf vlc (2.0.3-5+deb7u2+b1 Debian-Security:7.0/stable [amd64])


À mon sens, vlc ne devrait pas avoir à être mis à jour.
edit : vu, c'est une mise à jour de sécurité qui est candidate.  smile


Pour libreoffice, c'est correct bien que moins significatif :

# apt-cache policy libreoffice
libreoffice:
  Installé : 1:4.3.3-2~bpo70+2
  Candidat : 1:4.3.3-2~bpo70+2
 Table de version :
     1:4.3.3-2 0
        150 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        100 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
 *** 1:4.3.3-2~bpo70+2 0
        500 http://ftp.fr.debian.org/debian/ wheezy-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.4+dfsg2-0+deb7u3 0
        900 http://security.debian.org/ wheezy/updates/main amd64 Packages
     1:3.5.4+dfsg2-0+deb7u2 0
        900 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages

# apt-get install libreoffice -s
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
libreoffice est déjà la plus récente version disponible.




Par ailleurs, pour

apt-get upgrade

c'est impeccable : toutes les mises à jour proviennent de stable.  cool


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#50 20-02-2015 13:10:07

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : conseils pour le fichier preferences

C'est parfait après l'upgrade :

# apt-cache policy vlc
vlc:
  Installé : 2.0.3-5+deb7u2+b1
  Candidat : 2.0.3-5+deb7u2+b1
 Table de version :
     2.2.0~rc2-2 0
        150 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        100 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
     2.1.5-1~bpo70+1 0
        500 http://ftp.fr.debian.org/debian/ wheezy-backports/main amd64 Packages
 *** 2.0.3-5+deb7u2+b1 0
        900 http://security.debian.org/ wheezy/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.3-5+deb7u1 0
        900 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages


# apt-get install vlc -s
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
vlc est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.




Je ne poste pas le retour de :

apt-get install -t sid --no-install-recommends vlc -s

ça dépasse la mémoire de mon terminal !  lol


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums