Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-01-2009 12:43:02

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

reconnaissance de la touche Fn

bonjour à tous!
Je viens de faire une installation à partir du réseau, avec xfce. Je rencontre un souci pour la configuration de mes raccourcis : la touche Fn (vous savez, celle qui sert aux touches bleues sur les portables) n'est pas reconnue, j'ai une entrée vide dans la configuration des raccourcis...
il me manque sans doute un paquet, mais lequel?

merci d'avance!

YA3HGA-H

Hors ligne

#2 24-01-2009 13:25:13

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Salut Thuban

Tapes en root
xmodmap
Peux-tu indiquer ce qu'il te réponds ?

A bientôt

Dernière modification par damien (24-01-2009 13:27:16)


logo_3dminfographie_signature.png

Hors ligne

#3 24-01-2009 13:28:46

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : reconnaissance de la touche Fn

merci pour la réponse!
alors, voici le retour de la commande :
Lothlorien:/home/xavier# xmodmap
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Meta_L (0x9c)
mod2        Num_Lock (0x4d)
mod3     
mod4        Super_L (0x7f),  Hyper_L (0x80)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x71),  ISO_Level3_Shift (0x7c)

YA3HGA-H

Hors ligne

#4 24-01-2009 13:36:22

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Bizare j'espèrais voir apparaitre "Fn" ou un truc dans le genre...
Est-ce que tu as regardé dans Système / Préférences / Clavier ?
Il y a des options dans agencement...

logo_3dminfographie_signature.png

Hors ligne

#5 24-01-2009 14:12:45

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : reconnaissance de la touche Fn

ben justement, il n'a pas l'air de la reconaitre ma touche Fn, et comme j'ai fait une installation minimale, je me suis dit qu'il devait manquer un paquet...
je suis sous xfce, je ne peux pas avoir ce gestionnaire de configuration que tu me proposes... Existe-t-il un fichier de configuration à modifier sinon?

YA3HGA-H

Hors ligne

#6 24-01-2009 17:09:16

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Il doit surement y avoir un outil pour paramétrer le clavier en mode graphique sous Xfce.
Je ne sais pas où il se trouve par contre car je suis sous gnome.

Si tu veux configurer ton clavier regarde ce manuel http://www.debian.org/doc/manuals/debia … re.fr.html

logo_3dminfographie_signature.png

Hors ligne

#7 30-01-2009 03:42:02

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : reconnaissance de la touche Fn

damien a écrit :

Bizare j'espèrais voir apparaitre "Fn" ou un truc dans le genre...
Est-ce que tu as regardé dans Système / Préférences / Clavier ?
Il y a des options dans agencement...


Salut!

Moi aussi j'ai un portatif et ma touche Fn est inutlisable.  À la commande "xmodmap", aucune référence n'apparaît à quelque touche Fn.  Je suis en Gnome, alors j'ai ceci dans Système /Préférences / Clavier / Agencements : PC générique 105 touches (intl).

Voilà, je suis allé avec ma maque d'odinateur et le modèle (ce qui donne: "Compaq portable internet" et ça semble fonctionner.
Cependant, xmodmap ne donne toujours pas de référence à Fn.

Merci les amis.

Dernière modification par Patriboom (30-01-2009 03:43:08)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 24-11-2009 06:57:51

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

Quelqu'un a t'il trouvé la solution ?

Hors ligne

#9 24-11-2009 19:16:02

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

Hors ligne

#10 24-11-2009 22:21:11

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Salut bjm

Toujours pas de solution neutral
Tu fait bien de ressortir cette discussion non résolue.
J'y ai réfléchi et me demandais si que peut-être en rajoutant une option dans le xorg.
Voici donc mon xorg

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "latin9"
EndSection


Xkb est peut-être une solution

Du coup me viens à demander la section Inputdevice du xorg.conf de Thuban
Sinon en activant avec cette combianaison de touche "Fn"+"VerrNum" ou "Fn + end"
Voici aussi quelques liens
http://www.debian.org/doc/manuals/debia … pings_in_x
http://www.debian.org/doc/manuals/debia … ionmethods

@+


logo_3dminfographie_signature.png

Hors ligne

#11 24-11-2009 23:36:33

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

J'ai rajouté cette section
Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "latin9"
EndSection

Mais çà ne marche pas sad

Hors ligne

#12 24-11-2009 23:56:19

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

ce qui est gênant pour moi c'est de pas pouvoir faire un
ctrl+alt+F2 et ctrl+alt+F7

Hors ligne

#13 25-11-2009 00:03:45

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Peux-tu envoyer tout ton xorg.conf stp
Il va peut-être falloir que tu le reconfigure.

logo_3dminfographie_signature.png

Hors ligne

#14 25-11-2009 00:12:03

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

Voilà

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
EndSection

Section "Device"
    Identifier    "Configured Video Device"
    Option        "UseFBDev"        "true"
EndSection

Section "Monitor"
    Identifier    "LCD"
    Option        "DPMS"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Intel Corporation 945GM Chipset Family Graphics Controller Chipset Integrated Graphics Device"
    Monitor        "LCD"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x860"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "DRI"
    Mode 0666
EndSection

Hors ligne

#15 05-12-2009 18:06:48

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

Je viens d'installer squeeze les touches FN sont reconnu , cependant il faut faire attention
à l'ordre dans lequel on presse les touches notamment pour basculer vers la console .
Il se peu que sous lenny elle marche mais ayant désinstaller lenny ?


A+

Hors ligne

#16 06-12-2009 12:40:39

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : reconnaissance de la touche Fn

Ouep bjm cool

Squeeze résout pas mal de problème.
Méfie toi de squeeze il y a pas mal de bugs...

@+

logo_3dminfographie_signature.png

Hors ligne

#17 06-12-2009 13:19:43

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : reconnaissance de la touche Fn

Bonjour damien
Quel genre de bug ?

Hors ligne

Pied de page des forums