Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-02-2015 11:19:28

chtr
Membre
Distrib. : Jessie
Noyau : 3.2.0-4amd64
(G)UI : Gnome
Inscription : 30-06-2012
Site Web

[RESOLU] plus de apt-get update possible

Bonjour à vous,

Je ne sais pas ce que j'ai fait mais voila le résultat de cette commande:

root@debian:/home/chris# apt-get update
E: Ligne 26 mal formée dans la liste des sources /etc/apt/sources.list (analyse de l'URI)
E: La liste des sources ne peut être lue.
 



#

deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official amd64 NETINST Binary-1 20141018-13:04]/ wheezy main

deb cdrom:[Debian GNU/Linux 7.7.0 _Wheezy_ - Official amd64 NETINST Binary-1 20141018-13:04]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main contrib
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib

deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib
deb http://liveusb.info/multisystem/depot all main
deb-src http://liveusb.info/multisystem/depot all main
deb http://ftp.de.debian.org/debian wheezy main
deb-src http://ftp.de.debian.org/debian wheezy main
deb http://http.debian.net/debian wheezy main
deb-src http://http.debian.net/debian wheezy main
deb http://http.debian.net/debian wheezy-updates main
deb-src http://http.debian.net/debian wheezy-updates main
deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0
deb-src http://mozilla.debian.net/ squeeze-backports iceweasel-4.0
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib
deb deb.bitmask.net/debian utopic main
deb-src deb.bitmask.net/debian utopic main



Je ne vois ce qui serait à modifier sad

Je suis preneur d'un coup de main pour réparer hmm
Merci à vous.
chris

Dernière modification par chtr (11-02-2015 15:03:07)


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#2 10-02-2015 11:29:21

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [RESOLU] plus de apt-get update possible

Pour les lignes 26 et 27 il semble que ce soit pour une wheezy:
deb http://deb.bitmask.net/debian wheezy main
et pour une jessie:
deb http://deb.bitmask.net/debian jessie main
Regarde ici:
https://bitmask.net/en/install/linux

Tu peux commenter les dernières lignes et relancer l'update, cela devrait aussi fonctionner.

Utopic c'est pour une ubuntu.

Hors ligne

#3 10-02-2015 11:30:31

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [RESOLU] plus de apt-get update possible

je ne sais pas ce que c'est comme dépot

deb deb.bitmask.net/debian utopic main
deb-src deb.bitmask.net/debian utopic main



en plus la page http://deb.bitmask.net/repository/

How to use

In your /etc/apt/sources.list:

deb http://deb.leap.se/debian testing main
deb-src http://deb.leap.se/debian testing main




bref je te conseille de commenter les 2 dernières lignes

#deb deb.bitmask.net/debian utopic main
#deb-src deb.bitmask.net/debian utopic main

Hors ligne

#4 11-02-2015 10:36:18

sv0t
Membre
Distrib. : Debian
Noyau : Linux deb 3.16.0-4-amd64
(G)UI : oui
Inscription : 16-01-2015

Re : [RESOLU] plus de apt-get update possible

chtr a écrit :

Je ne sais pas ce que j'ai fait


Bonjour,

Multiplier les dépôts rend forcement plus délicat le maintient d'une distribution, si tu as besoins de logiciel spécifique, tu peux les compiler sur ton système de cette façon tu éviteras pas mal de galère inutiles.

smiley_emoticons_my2cents.gif

Hors ligne

#5 11-02-2015 11:48:07

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] plus de apt-get update possible

@sv0t Compiler des programmes rend les choses encore plus compliquées. Ces programmes ne sont pas pris en compte
par le gestionnaire de paquets (en terme de dépendances) (sauf si tu utilises checkinstall) et il faut se tenir au courant des mises à jour
et des bugs, ce qui peut occuper pas mal de temps.

De plus, il vaut mieux éviter les sources externes à debian pour maintenir au maximum la stabilité et la cohérence du système.
Après chacun fait comme il veut. Mais je pense que ce sont de bonnes pratiques. Surtout quand on utilise debian de manière
professionnelle.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#6 11-02-2015 15:02:11

chtr
Membre
Distrib. : Jessie
Noyau : 3.2.0-4amd64
(G)UI : Gnome
Inscription : 30-06-2012
Site Web

Re : [RESOLU] plus de apt-get update possible

Salut à vous,

Merci pour tous vos conseil.
Le problème est résolu, pour ça j'ai supprimé le dépôt bitmask.
J'y reviendrai plus tard. L'idée était d’installer le nouveau VPN pour riseup.net

Encore merci.
chris

Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#7 11-02-2015 17:50:56

sv0t
Membre
Distrib. : Debian
Noyau : Linux deb 3.16.0-4-amd64
(G)UI : oui
Inscription : 16-01-2015

Re : [RESOLU] plus de apt-get update possible

enicar a écrit :

@sv0t Compiler des programmes rend les choses encore plus compliquées. Ces programmes ne sont pas pris en compte
par le gestionnaire de paquets (en terme de dépendances) (sauf si tu utilises checkinstall) et il faut se tenir au courant des mises à jour
et des bugs, ce qui peut occuper pas mal de temps.

Les listes de diffusion sont là pour ça. Je préfère largement la compil aux dépôts exotique, mais les goûts et les couleurs...

@+

Hors ligne

#8 11-02-2015 17:55:48

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] plus de apt-get update possible

@sv0t je suis contre les dépôts exotiques aussi big_smile

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

Pied de page des forums