Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-02-2015 21:15:08

tot94
Membre
Distrib. : Gnome 3.4.2
Noyau : Linux 3.2.0-4-686-pae
Inscription : 15-01-2015

PERL, problème exécution module

Bonjour,

Je veux créer un programme perl.
Tout d'abord j'installe le paquet :


gueg@debian:~/prg$ sudo apt-get install libwww-mechanize-perl
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  libwww-mechanize-perl
0 mis à jour, 1 nouvellement installés, 0 à enlever et 79 non mis à jour.
Il est nécessaire de prendre 0 o/111 ko dans les archives.
Après cette opération, 244 ko d'espace disque supplémentaires seront utilisés.
Sélection du paquet libwww-mechanize-perl précédemment désélectionné.
(Lecture de la base de données... 159944 fichiers et répertoires déjà installés.)
Dépaquetage de libwww-mechanize-perl (à partir de .../libwww-mechanize-perl_1.71-1_all.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libwww-mechanize-perl (1.71-1) ...
 



Ensuite lorsque je veux vérifier qu'ils se sont bien installé, j'ai une erreur:


gueg@debian:~/prg$ perl -e 'use WWW::mechanize'
Can't locate WWW/mechanize.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
 



Je ne vois pas du tout à quoi correspond l'erreur..
Problème de syntaxe peut-être ?

Hors ligne

Pied de page des forums