Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-03-2015 07:15:13

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Résolu] Ajuster les .htaccess

Bonjour,

je lis ceci

Il y a deux raisons principales d'éviter l'utilisation des fichiers .htaccess.

La première est liée aux performances. Lorsque la directive AllowOverride est définie de façon à autoriser l'utilisation des fichiers .htaccess, httpd va rechercher leur présence dans chaque répertoire. Ainsi, permettre l'utilisation des fichiers .htaccess est déjà en soi une cause de dégradation des performances, que vous utilisiez effectivement ces fichiers ou non ! De plus, le fichier .htaccess est chargé en mémoire chaque fois qu'un document fait l'objet d'une requête.

Notez aussi que httpd doit rechercher les fichiers .htaccess dans tous les répertoires de niveau supérieur, afin de rassembler toutes les directives qui s'appliquent au répertoire courant (Voir la section comment sont appliquées les directives). Ainsi, si un fichier fait l'objet d'une requête à partir d'un répertoire /www/htdocs/exemple, httpd doit rechercher les fichiers suivants


dans  http://httpd.apache.org/docs/2.2/fr/howto/htaccess.html

Je suis bien d'accord avec le principe, mais je dois tester mes choses en local avant de les exposer sur internet.  Je veux donc avec un mirroir en local afin de m'assurer que tout fonctionne bien.

Je veux surtout gérer les erreurs (404 en premier lieu) avec du PHP / MySQL de façon à récupérer les erreurs provoquées par les usagers pour améliorer le système et faire en sorte que les usagers y trouvent leur compte.  Ainsi, une page appelée - mais inexistante  -peut-elle devenir le sujet d'une recherche dans la base de données.

Voilà, bref, je veux tester mon .htaccess en local.

J'ai ceci dans mon .htaccess local, à la racine de mon site web.

<Files .htaccess>
order allow,deny
deny from all
</Files>

DirectoryIndex index.php
IndexIgnore *

ErrorDocument 300 http://plongee.rcmission.net/erreur/plusieurs.html
ErrorDocument 400 http://plongee.rcmission.net/erreur/bad_request.html
ErrorDocument 401 http://plongee.rcmission.net/erreur/identification_nec.html
ErrorDocument 402 http://plongee.rcmission.net/erreur/identification_nec.html
ErrorDocument 403 http://plongee.rcmission.net/erreur/forbidden.html
ErrorDocument 404 /introuvable.php
ErrorDocument 300 http://plongee.rcmission.net/erreur/plusieurs.html
ErrorDocument 500 http://plongee.rcmission.net/erreur/internal_server_error.html
ErrorDocument 504 http://plongee.rcmission.net/erreur/delai_depasse.html

RewriteEngine on
RewriteRule ^(.+).rss$ $1.xml [L]

 



Ma page inttrouvable.php fonctionne bien, l'erreur ne vient pas d'elle.
Sur internet, ce code a l'effet souhaité.

Je veux maintenant que les erreurs 404 sur mon serveur local soient là aussi traitées par introuvable.php
Or j'obtiens un message d'erreur 

Not Found

The requested URL /MesSites/rcmission/plongee/torpille was not found on this server.
Apache/2.2.22 (Debian) Server at 127.0.0.1 Port 80



J'ai pourtant fait - en suivant les indications de http://www.itx-technologies.com/blog/28 … -et-ubuntu

a2enmod rewrite

en root et redémarré mon serveur
et puis, oui

ls -l /usr/lib/apache2/modules/

affiche bien un module rewrite chargé et démarré.


Pourquoi Debian ne veut-il pas encore lire mon fichier .htaccess?
Que faire?

Merci à l'avance.

Dernière modification par Patriboom (08-08-2016 13:30:47)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 20-07-2016 14:00:00

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Ajuster les .htaccess

Bonjour à tous,

De retour au même problème.
Depuis un an, j'avais mis de côté car je ne m'en servais pas vraiment.
Désormais il me faut définir un sous-répertoire protégé par mot de passe, il faut donc que mon .htaccess soit bien lu et exécuté, ce qui inclut le module rewrite.

Oui, 

ls -l /usr/lib/apache2/modules/

  m'affiche bien un mod_rewrite.so chargé.

Merci à l'avance de votre attention et votre aide.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#3 20-07-2016 14:15:34

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Ajuster les .htaccess

J'ai lu ceci: 

After that, you should enable mod_rewrite with this command:

sudo a2enmod rewrite
The last one, restart your apache service:

sudo service apache2 restart



dans http://askubuntu.com/questions/422027/m … ot-working

Et ça fonctionne  (piste pour qui chercherait la même solution).
Ne reste qu'à s'assurer le démarrage du module rewrite à chaque démarrage de l'ordinateur
et c'est là que nous trouvons:

https://technique.arscenic.org/lamp-lin … es-modules

et créons un lien symbolique vers mod_rewrite pour que l'action soit permanente (si ce n'est déjà fait):

/etc/apache2/mods-enabled# ln -s rewrite.load ../mods-available/rewrite.load


Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 20-07-2016 21:18:08

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Ajuster les .htaccess

Il faut aussi savoir que les serveurs LInux utilisent des mots de passe encodés. les windowsiens - eux - ont des mots de passe en clair.

Pour encoder votre mot de passe, vous pouvez utiliser ce code

<?php
if (isset($_POST['login']) AND isset($_POST['pass'])) {
  $login = $_POST['login'];
  $pass_crypte = crypt($_POST['pass']); // On crypte le mot de passe
  echo 'Ligne à copier dans le .htpasswd :<br />' . $login . ':' . $pass_crypte;
} else { // On n'a pas encore rempli le formulaire
?>
</p>
<p>Entrez votre login et votre mot de passe pour le crypter.</p>
<form method="post">
<p>
Login : <input type="text" name="login"><br />
Mot de passe : <input type="text" name="pass"><br /><br />
<input type="submit" value="Crypter !">
</p>
</form>

<?php }
 


Fourni par:   http://forum.alsacreations.com/topic-20 … t-pas.html et qui fonctionne très bien.


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums