Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 22-03-2015 18:03:21

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : mount nfs : access denied by server

Bonjour paskal,
et merci pour la piste smile

:~# service autofs stop
[ ok ] Stopping automount....



à partir de là:
https://bugs.launchpad.net/ubuntu/+sour … ug/1094271
j'essaye d'imiter Jose Luis Tirado (txelu70) smile

~# mkdir /etc/auto.master.d


~# cd /etc/auto.master.d


/etc/auto.master.d# touch nfs.autofs


/etc/auto.master.d# ls


nfs.autofs


/etc/auto.master.d# nano nfs.autofs



je copie le contenu de auto.nfs :

/etc/auto.master.d# cat nfs.autofs


/media /etc/auto.nfs --timeout=30



relance :

/etc/auto.master.d# automount -f -v


Starting automounter version 5.0.7, master map /etc/auto.master
using kernel protocol version 5.02
lookup(file): failed to read included master map auto.master
mounted indirect on /media with timeout 30, freq 8 seconds
mounted indirect on /media/ds411 with timeout 30, freq 8 seconds
1 submounts remaining in /media
1 submounts remaining in /media
1 submounts remaining in /media
1 submounts remaining in /media
1 submounts remaining in /media
^C1 submounts remaining in /media
umounted indirect mount /media/ds411
shut down path /media/ds411
umounted indirect mount /media
shut down path /media
autofs stopped



bon... enfin, non, pas bon smile
une idée de ce qui lui ferait vraiment plaisir ?
(oui, ça fait redite smile)

Dernière modification par debianux (22-03-2015 18:05:36)

Hors ligne

#27 22-03-2015 20:30:45

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : mount nfs : access denied by server

ici:
http://ubuntuforums.org/archive/index.p … 22728.html

quirino77
July 15th, 2012, 04:13 PM
I got the solution.

Firt mistake, my auto.master has:
+auto.master
then i comment this line and the "lookup(file): failed to read included master map auto.master" was gone. Looks like with this line, it search for the file on a NIS.

Second mistake, my goflex.cifs has execute attribute. The autofs do not work this way. I had to chmod -x the file.

Now everything is ok.



donc, j'essaye en commentant l'avant-dernière ligne :

# cat /etc/auto.master


#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
#/misc  /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
# options are explicitly given.
#
#/net -hosts
#
# Include /etc/auto.master.d/*.autofs
#
+dir:/etc/auto.master.d
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
#+auto.master
/media/ds411 /etc/auto.nfs --timeout=30



relance :

# automount -f -v


Starting automounter version 5.0.7, master map /etc/auto.master
using kernel protocol version 5.02
mounted indirect on /media with timeout 30, freq 8 seconds
mounted indirect on /media/ds411 with timeout 30, freq 8 seconds
1 submounts remaining in /media
1 submounts remaining in /media
^C1 submounts remaining in /media
umount_autofs_indirect: ask umount returned busy /media
shut down path /media
umounted indirect mount /media/ds411
shut down path /media/ds411
autofs stopped



je ne comprends pas grand chose...

Hors ligne

#28 22-03-2015 20:39:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : mount nfs : access denied by server

c'est vrai que c'est plutôt abscons, je ne vois pas trop, là  sad

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums