Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-03-2015 13:29:18

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

[RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Excusez moi pour ce titre un peu sibyllin, mais je voulais être assez précis et je ne savais pas trop comment formuler le problème.

J'ai installé wheezy sur mon portable Lenovo Thinkpad T60 avec un iso d'install non-free XFCE.
Tout l'installation c'est faites sans problème, réseau et internet reconnu.

Lorsque que je démarre le PC, après le grub, je tombe sur un écran noir avec un curseur qui clignote, mais ce n'est pas une console, je ne peux rien écrire.

Si je prend la main (alt + f2), que je lance startx, pas de problème, je retombe sur XFCE et tout à l'air de fonctionner correctement.

J'ai modifier le fichier /etc/inittab en remplacer la ligne id:2:initdefault: par id:5:initdefault: pour spécifier un démarrage avec l'interface graphique, mais pas de changement, je retombe sur cet écran noir.

Si quelqu'un peu me donner un coup de main wink

Dernière modification par dropforged (15-03-2015 22:51:18)

Hors ligne

#2 13-03-2015 20:02:56

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Salut,

As tu installé un gestionnaire de connexion comme lightdm, xdm ou gdm ?

apt-get install lightdm



@+


Leonlemouton
°(")°

Hors ligne

#3 13-03-2015 20:38:13

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Oui, lightdm est bien installé, je le vois d'ailleur se lancer juste avant d'arriver à l'écran noir. J'arrive même à le lancer depuis la console.
C'est ce qui est ralant mad, c'est que tout fonctionne quand je lance startx depuis la console.

D'ailleurs, j'ai fais une petite erreur dans mon premier post, lorsque je modifie le fichier /etc/inittab en remplacer la ligne id:2:initdefault: par id:5:initdefault: , je retombe sur l'écran noir, mais là, impossible de prendre la main, seul le reboot en faisant CTRL + ALT + SUPP est possible.


Par contre, j'ai essayer de choisir depuis GRUB, le mode de dépannage, et là, je tombe lors du listing du démarrage sur :


[12.705156] IBM Trackpoint firmware : 0x0e, buttons : 3/3

Give root password for maintenance (or type Control-D to continue):

[   12.921809] input : TPPS/2 IBM Trackpoint as device/plateform/i8042/serio1/serio2/input/input9




Est-ce que le problème pourrais provenir du trackpoint (présent sur mon Lenovo) ?

Dernière modification par dropforged (13-03-2015 20:50:38)

Hors ligne

#4 14-03-2015 00:25:29

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Salut,
Je ne connais pas cette machine, mais en installant à partir d'une ISO non-free (<= rien que ce terme aurait du t'effrayer wink ) il est possible que tu aies installé des pilotes privateurs qui rentre en conflit. Essaye, dans le grub d'éditer la ligne de démarrage (touche "e") puis d'ajouter à la fin de la ligne commençant par "linux" le terme "nomodeset".

Pour ce qui est du trackpoint, je doute fort que ce soit la source du problème. Je t'écris depuis un Thinkpad installé plusieurs fois avec une wheezy sans problème aucun. Mais c'était à partir d'une version free cela dit...

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#5 14-03-2015 10:36:56

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Merci de ta réponse sogalpunx, j'ai essayé, mais ça ne change rien.

mais en installant à partir d'une ISO non-free (<= rien que ce terme aurait du t'effrayer wink )



En fait, j'ai choisis un iso non-free pour l'install, pour avoir les pilotes du wifi qui ne sont pas libre

Hors ligne

#6 14-03-2015 12:05:40

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Ok, j'en déduis que tu n'as pas de connexion câblée ? Si le réseau est bien pratique, il n'est pas impérativement nécessaire.
Sur ton T60, au niveau vidéo c'est de l'Intel, donc le pilote libre xserver-xorg-video-intel suffit et doit être installé de toute façon.
Que te renvoies la commande

dpkg -l | grep non-free

?


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#7 14-03-2015 15:09:28

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

dropforged a écrit :

après le grub, je tombe sur un écran noir avec un curseur qui clignote, mais ce n'est pas une console, je ne peux rien écrire.


Si, c'est un console. Tu confonds le contenant (la console) et le contenu (le programme qui affiche dedans, typiquement le login ou un shell). Ce n'est pas parce que tu tapes quelque chose que ça s'affiche mais parce qu'un programme ad hoc l'envoie sur la console. Or l'objet du gestionnaire de connexion n'est pas d'afficher ce que tu tapes.

dropforged a écrit :

J'ai modifier le fichier /etc/inittab en remplacer la ligne id:2:initdefault: par id:5:initdefault: pour spécifier un démarrage avec l'interface graphique


C'est inutile. Dans Debian, les niveaux d'exécution (runlevel) 2 à 5 sont tous équivalents par défaut et lancent le gestionnaire de connexion graphique s'il y en a un.

dropforged a écrit :

j'ai essayer de choisir depuis GRUB, le mode de dépannage, et là, je tombe lors du listing du démarrage sur :


Ce ne sont que des messages d'information du noyau qui ne sont pas affichés lors d'un démarrage normal à cause de l'option "quiet" passée par GRUB au noyau, qui a pour effet de n'afficher que les messages d'erreur.

dropforged a écrit :

lightdm est bien installé, je le vois d'ailleur se lancer juste avant d'arriver à l'écran noir. J'arrive même à le lancer depuis la console.


Et il fonctionne ou bien cela conduit à l'écran noir ?

dropforged a écrit :

je retombe sur l'écran noir, mais là, impossible de prendre la main,


Et avec Ctrl+Alt+F2 ?

Hors ligne

#8 14-03-2015 22:32:04

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Pour répondre à sogalpunx :

Que te renvoies la commande
dpkg -l | grep non-free



ça me renvoie une liste de driver, mais je ne sais pas comment copier cette liste pour te la montrer.

En gros il y a plusieurs

ATI/AMD Radeon display driver                      1:12-6+point-3



puis un

nvidia-xconfig



Je vais essayer de me débrouiller à faire une capture d'écran...

Pour répondre à raleur :


J'ai modifier le fichier /etc/inittab en remplacer la ligne id:2:initdefault: par id:5:initdefault: pour spécifier un démarrage avec l'interface graphique
C'est inutile. Dans Debian, les niveaux d'exécution (runlevel) 2 à 5 sont tous équivalents par défaut et lancent le gestionnaire de connexion graphique s'il y en a un.



Merci, c'est bon à savoir wink

lightdm est bien installé, je le vois d'ailleur se lancer juste avant d'arriver à l'écran noir. J'arrive même à le lancer depuis la console.

Et il fonctionne ou bien cela conduit à l'écran noir ?



Oui, quand je le lance j'ai l'écran ou un peu choisir sa cession : xserveur ou xfcf, non de l'utilisateur...

je retombe sur l'écran noir, mais là, impossible de prendre la main,

Et avec Ctrl+Alt+F2 ?



Quand dans le fichier etc/inittab j'ai id:2:initdefault:, j'arrive à prendre la main ainsi, par contre quand j'ai id:5:initdefault:, là, c'est impossible de prendre la main, la seule combinaison de touche qui est reconnu est ctrl+alt+supp pour rebooter.


Merci de votre aide à tout les 2 smile

Dernière modification par dropforged (14-03-2015 22:36:12)

Hors ligne

#9 14-03-2015 22:52:32

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Est-ce que le paquet xfce4-session est correctement installé? Normalement oui.
Est-ce que la commande

lsmod

montre que certains modules des pilotes graphiques non-libres sont chargés et pourraient poser problème?
Si tu as un affichage du gestionnaire de connexion, le problème ne vient finalement peut-être pas des composants vidéo, mais d'ailleurs, de la connexion à ta session.
À la limite essayes avec un autre gestionnaire de connexion, tel que slim:

apt-get install slim


lors de la configuration du paquet tu vas pouvoir choisir ton gestionnaire par défaut, sélectionne slim puis

service lightdm stop
service slim start

puis réessaye de te connecter. Si besoin, tu peux, dans slim, sélectionner la session avec F1.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#10 15-03-2015 09:59:57

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Si le problème peux provenir des pilotes non-free, je peux très bien refaire une install depuis le CD libre, ça ne me pose pas de problème, sauf pour le wifi.
J'avais essayé une install non free, mais il me fallait les pilote wifi.

J'ai téléchargé "firmware-iwlwifi_0.36+wheezy.1_all.deb", si le le rajoute dans le répertoire firmware de mon iso libre (sur cle usb) est-ce que je peux faire une instll libre sauf pour le wifi ?

Hors ligne

#11 15-03-2015 10:14:39

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

la procédure normale est de mettre le firmware wifi sur un stick que l'on connecte à la demande lors de l'installation smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#12 15-03-2015 11:59:50

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

smolski a écrit :

la procédure normale est de mettre le firmware wifi sur un stick que l'on connecte à la demande lors de l'installation smile


Pour plus d'infos, voir ici: https://www.debian.org/releases/stable/ … 04.html.fr
Et quand bien même ça ne marcherait pas, cela n'est pas bloquant, tu peux très bien finir ton installation sans réseau, puis installer le paquet des pilotes wifi, redémarrer pour les activer et modifier ton sources.list pour ajouter les lignes des dépôts (voir le wiki pour cela). C'est certes un peu plus lourd mais saches que c'est une solution.

Sinon as-tu essayé avec slim avant de tout réinstaller?


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#13 15-03-2015 13:00:24

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

J'ai essayé d'installé slim, il y a du mieux, maintenant, quand je démarre, je tombe directement sur la console (login, password)...

Quand je fait startx, je retombe sur le bureau xfce

Par contre, quand je clique sur le bouton déconnexion, je ne tombe pas sur le gestionnaire de session, je retombe sur la console.

Je vais essayer une install depuis l'iso free et les pilotes wifi sur une cle usb.

Je veux être libre smile

Dernière modification par dropforged (15-03-2015 13:24:11)

Hors ligne

#14 15-03-2015 20:24:18

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

dropforged a écrit :

J'ai essayé d'installé slim, il y a du mieux, maintenant, quand je démarre, je tombe directement sur la console (login, password)...


Je n'appelles pas ça du mieux. Visiblement slim ne se lance pas, tu aurais obtenu le même résultat juste en désinstallant ou désactivant lightdm.

dropforged a écrit :

r contre, quand je clique sur le bouton déconnexion, je ne tombe pas sur le gestionnaire de session, je retombe sur la console.


Rien d'étonnant puisque tu as lancé la session Xfce depuis la console, sans passer par un gestionnaire de connexion.

Ce qui m'étonne, c'est que lightdm fonctionne bien si tu le lances à la main mais pas lorsqu'il est lancé au démarrage. Tu le lances en root ou en simple utilisateur ?

Hors ligne

#15 15-03-2015 22:50:57

dropforged
Membre
Distrib. : Debian
Noyau : Wheezy 7.8 /Jessie 8.0
(G)UI : XFCE
Inscription : 08-03-2015

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

J'ai installé la version libre de wheezy XFCE avec le pilote firmware-iwlwifi_0.36+wheezy.1_all.deb et là aucun problème big_smile

Je ne sais pas pourquoi ça ne fonctionnais pas, mais bon, l'essentiel est que maintenant ça tourne comme une horloge...

Merci beaucoup pour votre aide en tout cas wink

Hors ligne

#16 15-03-2015 23:55:06

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Ecran noir démarrage, malgrés id:5:initdefault:

Et bien voilà! Parfait, content que ça fonctionne! Et ça fonctionnera surement d'autant mieux que tu n'as pas toute une palanquée de machins privateurs dans ton système! cool

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

Pied de page des forums