Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-03-2015 15:12:49

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Warning nvidia-installer

Salut les loulous, ça fait un bail smile

J'explique mon cas : installation récente d'une debian 7.8 depuis une netinstall + fluxbox .
Nouvelle CG cataloguée "trop récente" (GTX750) installée sur mon pc non prise en charge par "nouveau" , donc obligé de passer par le .run (ou bien c'est framebuffer obligatoire mais là c'est très moyen sur du long terme), l'opération s'est bien déroulée, reboot normal et utilisation correct de debian par la suite .
Précision je suis en stable, donc pas de fichiers de preférences pour jouer avec testing ou sid , du très basique en somme .

Seulement voilà après 2 ou 3 jours il y a un souci avec apt qui me lance des avertissements à chaque apt-get update/install :

Le programme « nvidia-installer » est installé sur ce système.
Cela est probablement dû à une ancienne installation du pilote graphique non libre de NVIDIA, effectuée  directement avec le fichier *.run de NVIDIA. Cette installation est incompatible avec les paquets Debian. Afin d'installer correctement les paquets Debian, il est nécessaire de défaire les changements effectués par le programme « nvidia-installer ». 
Faut-il exécuter « nvidia-installer --uninstall » ?


Inutile de préciser que c'est pénible car les mises-à-jour s'arrêtent apres le message d'avertissements, et les installations n'aboutissent pas non-plus car si je réponds "Non" tout s'arrête(l'opération en cours est annulée) et si je réponds "Oui" (oui oui j'ai essayé pour voir ^^) idem mais là ça bug le prompt figé obligé de kill apt .

Et c'est une boucle sans fin puisqu'ensuite si je désire réutiliser apt j'ai un message du type :

E: dpkg a été interrompu. Il est nécessaire d'utiliser « dpkg --configure -a » pour corriger le problème.


Et le « dpkg --configure -a » me lance à nouveau la boîte de dialogue du message précédent à propos de "nvidia-installer" .

Ma question est est-ce normal d'avoir ce type de chose lorsqu'on passe par un .run ? Si oui est-il possible de contourner le problème ? Et si non que puis-je faire pour corriger ma possible erreur ?
Ou alors ma CG est-elle trop récente pour être utilisée correctement sous Debian ?

Merci wink

Hors ligne

#2 26-03-2015 17:11:59

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Warning nvidia-installer

Bonjour

oui il faut te passer des mises a jour si tu a un .run de nvidia et oui si ton chipset de ta GTX750 est un maxwell  (pas toutes les gtx750 sont equipé du maxwell )  il te faut le pilote propriétaire nvidia.
idem pour GTX 960 , 970 et 980

personnellement j attend avant de faire les mises a jour (et je desinstalle le .run ) puis le réinstall ensuite .
avec jessie c est galere , il y a beaucoup de mise a jour encore.
normalement si la mise a jour ne touche pas le noyau ça passe , mais je garanti pas roll

@++

Dernière modification par robert2a (26-03-2015 17:17:25)

En ligne

#3 26-03-2015 17:26:19

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Warning nvidia-installer

Perso, j'ai le pilote Nvidia proprio 346.47 d'installé sur mes deux Jessie, et ça ne me pose aucun problème pour faire mes mises à jour .....
Je précise que je n'ai jamais installé un pilote Nvidia depuis les dépôts Debian. Je n'installe pas non plus directement le.run de chez Nvidia.

Toujours avec le script smxi, et ça marche.


http://smxi.org/site/install.htm


cd /usr/local/bin && wget -Nc smxi.org/smxi.zip && unzip smxi.zip && smxi




Récemment, j'ai téléchargé linux-source 3.19 sur experimental, je l'ai compilé, headers compris bien entendu, et hop, on repasse par smxi et pilote Nvidia 346.47, et rox !

Dernière modification par yoshi (26-03-2015 17:49:06)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#4 26-03-2015 17:45:47

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Warning nvidia-installer

tu est celui qui confirme la regle , j ai donné mon avis , avec le nombre de gpu maxwell que j ai installé sur debian jessie cette année  tongue  je suis sur de moi  cool

certaines mises a jours cassent l installation du .run .

je parle d une installation de jessie avec contrib non-free et du .run du constructeur , installé dans les regles (j ai effacé mon post puisque D_F ne conseille pas l installation de drivers proprio )

dans le cas de jessie avec les derniers gpu il n y a pas d autres solutions que le .run pour avoir autre chose qu un ecran noir et toutes les fonctions de la carte fonctionnelles . (dans mon cas le gpu est a 100% d utilisation sans aucun bug en permanence  ).
le noyau est mit a jour par debian , une installation exterieure (non-debian) sera perdu a chaque mise a jour du noyau .
dans ce cas je vois pas comment cela peut bien se passer , le .run recompile le noyau et la mise a jour debian va supprimer cette modification
suis je dans le vrai ? roll
(par mon experience pratique j en suis convaincu mais bon  .......   )  cool

wink

Dernière modification par robert2a (26-03-2015 17:50:33)

En ligne

#5 26-03-2015 18:05:55

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Warning nvidia-installer

robert2a, je comprends bien ton message, et je te crois sur parole !
Si tu dis que le .run NVIDIA mets le bronx dans les maj avec un gpu Maxwell, je te crois.

Le script smxi ne fait pas que d'installer le .run Nvidia à l'arrache. Il va chercher beaucoup de softs dans les dépôts Debian avant, dont module-assistant.
Pour les gpu Maxwell, je crois que ce script a été le premier à proposer un béta-driver permettant de les faire fonctionner.

Après, il est vrai que ce script n'est pas bien vu du tout ici (contrairement au forum "cousin" debian-fr.org oû il est assez souvent conseillé).
Moi, je me contre-fiche de savoir si c'est "déontologiquement" propre, ou pas d'installer un pilote Nvidia avec ce script. L'essentiel, c'est que ça fonctionne BIEN.
Et pour moi, ce script est simplement parfait, et il a fait ses preuves, depuis le temps qu'il existe.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#6 26-03-2015 19:43:17

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : Warning nvidia-installer

Arf j'aime pas ça hmm
Passer par smxi j'en n'ai pas lu que du bien ,mais faut voir apres tout qui ne tente rien n'a rien.
Quant à desinstaller le .run chaque fois que j'ai besoin d'utiliser apt ça va pas le faire non plus (car pour le moment même apt-get install pose problème , pas uniquement apt-get update) .
Je vais réfléchir à ce que je vais faire alors , merci les gars pour votre coup de main wink

Hors ligne

#7 26-03-2015 20:17:30

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Warning nvidia-installer

Bonsoir,

Attention tout de même avec le script sgfxi, sous Wheezy tout fonctionnait à merveille. Sous Jessie, je ne dirais pas la même chose : quelques warnings, voir même ERROR & FAILED tout de même wink

Dernière modification par golgot200 (26-03-2015 20:27:13)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#8 26-03-2015 20:45:27

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Warning nvidia-installer

Bonsoir,
Je n'ai jamais eu de soucis avec smxi/sgfxi sous Jessie. Même avec mon kernel 3.19 perso que j'ai compilé dernièrement.
A l'origine, ce script a été développé pour Debian Sid (sidux exactement à l'époque).

Dernière modification par yoshi (26-03-2015 20:47:26)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#9 26-03-2015 20:53:23

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Warning nvidia-installer

@yoshi

C'est tout à fait possible. wink
chez moi, 9 fois, ça à marché mais la 10 fois tout à cassé. Si mes souvenirs son bon c'est suite à la mise à jour d'un paquet pour X

Pour l'instant, je reste sous nvidia-driver des dépôts (jessie) qui va bien contrairement à celui de Wheezy qui était une vrai catastrophe pour moi .
Une fois stabilisée, je repasse au script wink

Dernière modification par golgot200 (26-03-2015 20:57:27)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums