Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-04-2015 16:32:14

Kaazz
Membre
Inscription : 07-04-2015

Soucis Dovecot

Bonjour à tous !
Cela fait maintenant quelques jours que je suis sur mon projet de BTS. Je souhaite faire un serveur de messagerie sous Postfix/dovecot avec un AD à côté. La partie postfix marche niquel , je peux m'envoyer des e-mails entre utilisateurs de l'AD mais je ne parviens pas à réussir l'authentification IMAP avec dovecot. Je ne sais pas comment tout autoriser ou laisser les  utilisateurs de l'AD s'authentifier. L'authentification marche seulement avec un utilisateur ( alors que j'ai enlevé le paramète static_uid --'). Du coup , je ne peux pas configurer mon client Thunderbird comme il se doit.

debian dovecot: imap: Error: Internal auth failure pour tout !

Voici mes confs :
dovecot -n

mail_location = maildir:/home/virtual/%n/Maildir
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
passdb {
  args = /etc/dovecot/dovecot-ldap.conf
  driver = ldap
}
protocols = imap
service auth {
  unix_listener /var/spool/postfix/private/auth {
    mode = 0666
  }
}
ssl_cert = </etc/dovecot/dovecot.pem
ssl_key = </etc/dovecot/private/dovecot.pem
userdb {
  driver = passwd
}
userdb {
  args = /etc/dovecot/dovecot-ldap.conf
  driver = ldap
}
 



dovecot-ldap.conf


hosts = ANNULAB.GSB.coop
base = dc=GSB,dc=coop
ldap_version = 3
auth_bind = yes
auth_bind_userdn = GSB\%u
pass_filter = (&(objectclass=person)(mail=%u))
user_filter = (&(objectClass=person)(mail=%u))
 



auth-ldap.conf.ext

passdb {
  driver = ldap
  args = /etc/dovecot/dovecot-ldap.conf
}
userdb {
  driver = ldap
  args = /etc/dovecot/dovecot-ldap.conf
}
#userdb {
 # driver = static
  #args = uid=5000 gid=5000 home=/home/virtual/%u/Maildir
#}
 



Si quelqu'un sait comment tout autoriser ou mieux , que les utilisateurs puissent s'identifier "a login <userad> <password_user>" ça serait génial !

Dernière modification par Kaazz (07-04-2015 16:35:23)

Hors ligne

#2 08-04-2015 10:56:23

Kusajika
Membre
Inscription : 08-04-2015

Re : Soucis Dovecot

Bonjour , il y a une chose que je ne comprend pas , je n'ai pas vu ta configuration d'imap lors de ton dovecot -n

tu n'as pas un truc style :


service imap-login {
  inet_listener imap {
    port = 143
  }
  inet_listener imaps {
    port = 993
    ssl = yes
  }
 



?

Hors ligne

#3 11-04-2015 13:28:48

Kaazz
Membre
Inscription : 07-04-2015

Re : Soucis Dovecot

Salut , merci pour ta réponse.
Maintenant que tu le dis , je n'ai pas cela lors de mon dovecot -n
Cependant , je ne voulais justement pas activer le ssl mais je vais essayer de déclarer le port à l'écoute tout de même ( il y était déjà mais qui ne tente rien...)

Edit : ce que tu m'as dit de rajouter est pourtant bien dans mon fichier dovecot.conf mais il n'apparait pas dans le dovecot -n
Voici le dovecot.conf :

protocols = imap

service imap {
inet_listener = 143
}

auth_mechanisms = plain login

disable_plaintext_auth = no
ssl = no

mail_location = maildir:/home/virtual/%n/Maildir

first_valid_uid = 20001
last_valid_uid = 20001

first_valid_gid = 20001
last_valid_gid = 20001

valid_chroot_dirs = /var/vmail

passdb {
      driver = ldap
      args = /etc/dovecot/dovecot-ldap.conf
}

userdb {
      driver = ldap
      args = /etc/dovecot/dovecot-ldap.conf
}

log_path = /var/log/dovecot.log
auth_debug = yes



Et je ne peux m'authentifier qu'avec le user "virtual" ayant un uid et gid de 5000 comme dans mes fichiers de conf , or je n'arrive pas à donner ce gid à mes utilisateurs AD. ( je ne veux pas créer les users sur le serveur de messagerie car ca n'a aucun intérêt)

cat /var/log/dovecot.log

auth: Debug: client in: AUTH  1 PLAIN service=imap  secured session=g6/zQnETwgAAAAAAAAAAAAAAAAAAAAAB  lip=::1 rip=::1 lport=143 rport=49602 resp=<hidden>
Apr 11 13:34:19 auth: Info: ldap(virtual,::1,<g6/zQnETwgAAAAAAAAAAAAAAAAAAAAAB>): invalid credentials
Apr 11 13:34:21 auth: Debug: client out: FAIL 1 user=virtual
Apr 11 13:37:11 imap-login: Info: Disconnected: Inactivity (auth failed, 1 attempts in 172 secs): user=<virtual>, method=PLAIN, rip=::1, lip=::1, secured, session=<g6/zQnETwgAAAAAAAAAAAAAAAAAAAAAB>
Apr 11 13:41:30 master: Warning: Killed with signal 15 (by pid=4119 uid=0 code=kill)

Dernière modification par Kaazz (11-04-2015 14:11:10)

Hors ligne

#4 20-04-2015 14:19:01

Kusajika
Membre
Inscription : 08-04-2015

Re : Soucis Dovecot

Bonjour, désolé pour le temps de réponse , tu utilises quelle version de dovecot ? car j'ai la 2.1.7 et tout mes fichier de conf se trouvent dans le dossier conf.d/ et sont séparés.

Hors ligne

#5 20-04-2015 14:48:40

Kaazz
Membre
Inscription : 07-04-2015

Re : Soucis Dovecot

Bonjour , ne t'en fais pas j'ai réussi à me débrouiller tout est niquel pour moi smile

Hors ligne

#6 20-04-2015 15:00:16

Kusajika
Membre
Inscription : 08-04-2015

Re : Soucis Dovecot

Super smile , Bonne continuation.

Hors ligne

#7 20-04-2015 18:29:24

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Soucis Dovecot

Kaazz a écrit :

Bonjour , ne t'en fais pas j'ai réussi à me débrouiller tout est niquel pour moi smile


Chouette un problème résolu big_smile

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Ca pourrait même être pas mal d'expliquer comment afin que cela puisse servire à d'autres ayant le même problème wink


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

Pied de page des forums