Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-02-2009 16:25:04

kmash
Membre
Inscription : 11-02-2009

Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour,
j'ai un souci avec synaptic, qui lorsque je le lance me demande mon mot de passe, puis plus rien. Idem pour les mises à jour automatiques. Lorsque je tape la commande
sudo apt-get update, je tape mon mot de passe root, puis :
[sudo] password for ######:
###### is not in the sudoers file.  This incident will be reported.
Je vois absolument pas d ou ca peut venir... un peu d'aide?

Je débute, soyez indulgents ;-)

Hors ligne

#2 13-02-2009 16:37:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour kmash,

Tu mets le mot de passe root, pas celui de l'user. OK ? wink

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 13-02-2009 16:38:37

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

sudo est désactivé dans Debian, il faut utiliser su. Donc pour lancer un apt-get update par exemple :

su


puis tu rentres le mot de passe root (rien ne s'affiche, c'est normal). Ensuite tu peux lancer ta commande :

apt-get update


Pour revenir en mode simple utilisateur, rien de plus simple :

exit


Pour savoir dans quel mode tu te trouves, regarde ton invite de commande. Mode utilisateur :

utilisateur@nom-machine:~$


Mode superutilisateur :

nom-machine:/répertoire/où/tu/es#


Pour tes problèmes en graphique avec Synaptic je ne vois pas ce que ça peut-être, désolé.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#4 13-02-2009 22:46:53

kmash
Membre
Inscription : 11-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Merci mais je connais déjà tout ca.
c'est vraiment ennuyeux, je ne peux plus lancer synaptic, ni aucune application me demandant des droits d'accès... donc plus de mises à jour, et installations de paquets seulement avec la console, et c est vraiment pas mon truc... une idée?

Hors ligne

#5 13-02-2009 22:55:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonsoir,

Au fait, tu es sur Etch ou Lenny là ? tongue

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 13-02-2009 23:21:21

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

kmash a écrit :

Merci mais je connais déjà tout ca.
c'est vraiment ennuyeux, je ne peux plus lancer synaptic, ni aucune application me demandant des droits d'accès...


Bonjour,

Je crois que tu n'as pas lu ce qui t'a été répondu, si ?

Parce que j'ai bien lu que tu as dit:

Lorsque je tape la commande
sudo apt-get update, je tape mon mot de passe root, puis :
[sudo] password for ######:
###### is not in the sudoers file.  This incident will be reported.
Je vois absolument pas d ou ca peut venir... un peu d'aide?


Alors mani n'est pas idiot non plus.  wink

Tu nous as aussi dit:

Je débute, soyez indulgents ;-)


Ok. Je vais essayer. ;-)

Chez moi, je peux utiliser su ou sudo à volonté, mais d'abord pour pouvoir faire ça, j'ai installé sudo pour pouvoir l'utiliser, et ensuite, j'ai configuré le fichier /etc/sudoers, en l'éditant en mode administrateur avec la commande visudo qu'il faut lancer en mode root (=administrateur). J'ai donc utilisé su pour pouvoir passer en mode root.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#7 13-02-2009 23:36:59

kmash
Membre
Inscription : 11-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

je suis desolé mais je ne pense pas que mon problème vienne de là, ca doit plutot etre l'interface graphique qui à un problème... enfin bref je vous remercie d'avoir répondu si vite. Je souhaitais de toute facon installer ubuntu et non debian (question de gout), mais comme ce n'est pas moi qui ait procédé à l'installation, je vais devoir m'arracher pour l'installer en bootant via pxe, vu que mon antiquité est incapable de booter sur quoi que ce soit d'autre ;-)

Dernière modification par kmash (13-02-2009 23:38:07)

Hors ligne

#8 14-02-2009 01:55:25

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

kmash a écrit :

je suis desolé mais je ne pense pas que mon problème vienne de là, ca doit plutot etre l'interface graphique qui à un problème


C'est marrant, toi qui ne sais pas grand-chose tu ne penses pas, alors que nous qui en savons un petit peu plus savons que ça vient de là !

sad

/Edit: un peu de Google avec visudo:
http://cern91.tuxfamily.org/linux/index … ?page=sudo

Tu peux chercher d'autres exemples, pour enrichir tes bases.
(all your base are belong to us)


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#9 14-02-2009 05:16:56

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

kmash a écrit :

Je souhaitais de toute facon installer ubuntu et non debian (question de gout)


Sous debian il éxiste un terminal root que sous ubuntu il n'éxiste qu'un terminal utilisateur.
L'avantage de debian est que l'on tape une seule fois le mot de passe superutilisateur et vous voilà en terminal root.
Plus besoin de taper ce sudo à la con comme sous ubuntu.
Moi, je préfère debian, désolé !


logo_3dminfographie_signature.png

Hors ligne

#10 14-02-2009 06:43:16

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

ca sentait le troll ce post ....
prochain troll on ferme la discussion

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#11 14-02-2009 22:33:42

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

alt+f2
puis
gksu (ou kdesu) synaptic

ca raconte qoui ?

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#12 15-02-2009 18:45:40

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

freddec a écrit :

alt+f2
puis
gksu (ou kdesu) synaptic

ca raconte qoui ?


Bonsoir,

Après avoir fait une mise à jour de Etch vers Lenny cet aprè-midi, mon soucis est identique.

debian:~# synaptic
(synaptic:4593): Gtk-WARNING **: cannot open display:
debian:~#

En mode graphique, plus de possibilité de se logger en root!
Que s'est-il passé?

Parenthèse :

Félicitation pour les participants à ce forum, j'ai beaucoup appris grâce à vos interventions.

Merci.


C'est par ici qu'on va par là!

Hors ligne

#13 15-02-2009 19:02:52

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Salut vanpatr

Ouvres une console root et écris la commande suivante
cat /etc/apt/sources.list
Peux-tu nous retourner le résultat de cette commande.
Merci

ps : Si tu ne peux plus avoir de console root, essaie une console utilisateur et tapes su. Ensuite, tu rentres ton mot de passe et te voilà en root.

logo_3dminfographie_signature.png

Hors ligne

#14 15-02-2009 19:10:46

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour vanptr et bienvenue sur DF,

Tu peux ouvrir un nouveau topic pour ton problème, que cela s'ordonne tranquille entre toutes les demandes...

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#15 16-02-2009 00:19:52

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Re-bonsoir,

Je crois avoir compris d'où viens le problème.

Discordance entre le clavier en console Ctrl+Alt+F1 et celui de la console bash ( mode graphique ).

La solution serait donc de redéfinir le mot de passe root de manière a ce qu'il ne contienne pas de carractères discordant entre les deux claviers.

Est-il possible de redéfinir le mot de passe de root? - Je cherche ...et j'ai trouvé bien sûr, trop simple ...
Ctrl+Alt+F1,

debian:/#
Mot de passe : <ancien mot de passe>
debian:/# passwd


Introduire alors deux fois le nouveau mot de passe sans les carractères qui sont la cause du problème.
Maintenant que l'accès en console bash est possible et que le reste (repris dans le sujet) fonctionne du point de vue accès administrateur (root);
Il reste a rechercher pourquoi cette différence au clavier?

Damien

Comment procéder pour transmettre ce résultat sans devoir retaper toute le fichier sources.list, compte tenu que je n'ai pas accès à la console bash sous root?

Même si tu as une solution que j'ignore et bien venue, compte tenu de la solution ci-dessus, c'est plus facile.

Donc voiçi la réponse :

debian:/# cat /etc/apt/sources.list
#
#deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ - Official i386 NETINST Binary-1 20081220-23:12]/ etch contrib main
#deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ - Official i386 NETINST Binary-1 20081220-23:12]/ etch contrib main
##lenny
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free
##security
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
##multimedia marillat
#deb http://www.debian-multimedia.org lenny main contrib non-free
#deb-src http://www.debian-multimedia.org lenny main contrib non-free
##dépôts sid
#priorités spécifiées dans /etc/apt/preferences      
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free
##Backports
deb http://www.backports.org/debian/ etch-backports main contrib non-free
debian:/#


Et pour compléter :

debian:/# cat /etc/apt/preferences

Package: mutt
Pin: release o=Debian, a=etch-backports
Pin-priority: 999

Package: *
Pin: release o=Debian, a=testing
Pin-priority: 990

Package: *
Pin: release o=Debian, a=unstable
Pin-priority: 90
debian:/#


J'espère avoir aidé.
Merci pour vos réponses.

NB : Openoffice ne s'ouvre pas chez moi, si je trouve la solution, j'ouvre un autre "sujet" et j'indiquerai le lien "ici" dès qu'il sera connu.

Cette discution et problème n'en est plus, donc [RESOLU].

Dernière modification par vanpatr (18-02-2009 03:49:45)


C'est par ici qu'on va par là!

Hors ligne

#16 16-02-2009 00:52:29

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Euh. Je dirais ...
Tu peux peut-être essayer de faire une copie du sources.list dans le /home/ton_usr/
Essaie donc en ligne de commande

cp /etc/apt/sources.list /home/ton_usr/sources_copie.list


Ensuite tu ouvres le dossier /home/ton_usr/ avec nautilus et tu doit retrouver le fichier sources_copie.list

Bon courage !

Dernière modification par damien (16-02-2009 00:57:06)


logo_3dminfographie_signature.png

Hors ligne

#17 16-02-2009 01:37:27

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Damien,
Génial ta réponse.
Et j'apprends, je perfectionne, mes connaisssances des "commandes de base Linux".
Encore merci pour ton aide.
@+

C'est par ici qu'on va par là!

Hors ligne

#18 16-02-2009 10:38:03

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Perso, je n'utilise pas le fichier preferences.

##dépôts sid
#priorités spécifiées dans /etc/apt/preferences      
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free


Ces lignes ne me plaisent pas. (Juste parcequ'il y a sid)
Je ne suis pas un développeur donc sid j'oublie (Je parle pour moi)
Je suis sûr que d'intégrer du sid dans sa distrib ça fout le bordel...
Enfin tu es libre de faire ce que tu veux.

a+

ps : Ouvres une discussion la prochaine fois. Car ce n'est pas toi le rédacteur du premier message de la discussion.
Si ton problème est résolu tu ne peux donc pas modifier le premier message et indiquer [résolu]


logo_3dminfographie_signature.png

Hors ligne

#19 17-02-2009 03:00:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

damien a écrit :

Salut vanpatr

Ouvres une console root et écris la commande suivante
cat /etc/apt/sources.list
Peux-tu nous retourner le résultat de cette commande.
Merci

ps : Si tu ne peux plus avoir de console root, essaie une console utilisateur et tapes su. Ensuite, tu rentres ton mot de passe et te voilà en root.


Salut

Il n'est pas nécessaire d'être en root pour voir le contenu du fichier sources.list (ou de n'importe quel autre fichier). Un simple

$ cat /etc/apt/sources.list


suffit.

Dernière modification par martinux_qc (17-02-2009 03:06:01)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#20 17-02-2009 03:12:48

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

vanpatr a écrit :

Damien,
Génial ta réponse.
Et j'apprends, je perfectionne, mes connaisssances des "commandes de base Linux".
Encore merci pour ton aide.
@+


Il existe quelques sites pour connaître les commandes de base de GNU/Linux. En voici un parmi d'autre : commandes fondamentales


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#21 17-02-2009 03:26:00

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

vanpatr a écrit :

Donc voiçi la réponse :

debian:/# cat /etc/apt/sources.list
#
#deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ - Official i386 NETINST Binary-1 20081220-23:12]/ etch contrib main
#deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ - Official i386 NETINST Binary-1 20081220-23:12]/ etch contrib main
##lenny
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free
##security
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
##multimedia marillat
#deb http://www.debian-multimedia.org lenny main contrib non-free
#deb-src http://www.debian-multimedia.org lenny main contrib non-free
##dépôts sid
#priorités spécifiées dans /etc/apt/preferences      
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free
##Backports
deb http://www.backports.org/debian/ etch-backports main contrib non-free
debian:/#


Et pour compléter :

debian:/# cat /etc/apt/preferences

Package: mutt
Pin: release o=Debian, a=etch-backports
Pin-priority: 999

Package: *
Pin: release o=Debian, a=testing
Pin-priority: 990

Package: *
Pin: release o=Debian, a=unstable
Pin-priority: 90
debian:/#


J'espère avoir aidé.
Merci pour vos réponses.

NB : Openoffice ne s'ouvre pas chez moi, si je trouve la solution, j'ouvre un autre "sujet" et j'indiquerai le lien "ici" dès qu'il sera connu.


Salut

Tes fichiers sources.list et preferences sont pour le moins bizarre. Tu utilises principalement les dépôts lenny, mais tu n'y fait pas mention dans ton fichier preferences où tu mets la priorité sur le dépôt etch-backports. Pourquoi cela. Maintenant que lenny est la nouvelle stable, il serait important de revoir tout cela. Si tu désires utiliser la nouvelle stable (lenny), il va falloir revoir tout cela.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#22 17-02-2009 04:57:06

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour martin_mtl,
Merci pour ta réponse et ton intervention (ton aide).
Que me propose tu de modifier?
J'ai donné les info's sur mon laptop  au post #15 ici suite à un écran noir.
Je me suis inspiré notamment de cette cette discussion.

Dernière modification par vanpatr (17-02-2009 05:02:14)


C'est par ici qu'on va par là!

Hors ligne

#23 17-02-2009 07:56:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour vanpatr,

Pour les commandes linux, nous avons ça aussi sur le wiki DF (voir le bandeau d'accueil...) wink
http://debian-facile.org/wiki/doku.php? … l:commande

Tu as 2 versions debian : Etch et Lenny ?

Pour Etch, maintenant, le stable c'est Lenny, vois dans le wiki la mise à jour proposée, tu auras le profit de l'actualisation. Et le sources.liste adequat...

Pour les sources.list exotiques, tu as, dans la même section que ton post la centralisation des sources.list en tête, tu peux t'en inspirer...

Je te signale que tu as greffé ton post sur un post en cours... Faut pas... Tu ouvres une discussion nouvelle et tu lui mets un titre. Ainsi, en cas de résolution de TON problème, un [résolu] rajouté dans le titre éclaire chacun sur ton topic...

Pour celui-ci, je pense que l'on reste ici... roll

Valà, valà... cool

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#24 17-02-2009 10:16:38

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

@vanpatr : Tu as une raison particulière de vouloir la version de mutt venant de etch-backports ? Dans les dépôts Lenny c'est la 1.5.18-6. Si cette version te convient, je te conseille de changer tes fichiers comme ceci.

/etc/apt/sources.list

## Lenny
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

## Lenny-security
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

## Multimedia Marillat
deb http://www.debian-multimedia.org lenny main contrib non-free
deb-src http://www.debian-multimedia.org lenny main contrib non-free

## Sid ## Priorités spécifiées dans /etc/apt/preferences      
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free


/etc/apt/preferences

Package: *
Pin: release o=Debian, a=stable
Pin-priority: 990

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable
Pin-priority: 960

Package: *
Pin: release o=Debian, a=unstable
Pin-priority: 90


J'ai décommenté les dépôts multimedia dans le sources.list et les ai rajoutés dans le fichiers preferences, pour faire quelquechose d'assez complet, mais là c'est toi qui voit ! Et si tu n'as pas besoin des dépôts de Sid, je te conseille de les retirer aussi.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#25 17-02-2009 15:04:42

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Pb synaptic, ne démarre pas, apt-get update ne fonctionne pas

Bonjour,

vanpatr, j'ajouterai mon conseil, pour la sécurité du système : ne  jamais se loguer en root en mode graphique. Saymal, saytrètrèsmal.

Et puis aussi le:
debian:~# synaptic
(synaptic:4593): Gtk-WARNING **: cannot open display:
debian:~#

ça ce n'est pas à faire non plus. on ne lance pas des applications graphiques depuis la console ! Il y a des modes fenêtrés pour les fenêtres, ce n'est pas pour rien.

Installez et configurez sudo, et lancez 'gksu synaptic', ou 'kdesu synaptic' si vous avez la flemme de cliquer dans les menus...

quand au message : "cannot open display:" as-tu tenter de lancer une application graphique depuis une console tty ?

damien : je ne suis pas développeur/développeuse non plus, et j'ai installé sid. Pourquoi : parce que c'est la version la plus à jour, parce que je ne m'embarrasse pas avec apt préférences et pinning, et parce que depuis des années plusieurs personnes m'ont dit que chez elles c'est très stable. Donc, ne surtout rien dire contre SID ! Ça ferait des trolls...  wink

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

Pied de page des forums