Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-02-2009 21:30:50

koshie
Membre
Inscription : 19-06-2008

[RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

En faite la méthode avec un installeur spéciale eeePC fonctionne, je m'étais juste tromper en copiant l'img.

Bonsoir,

J'ai installé une Lenny en netinstall sur mon eeePC 900 HD (avec un disque dur de 160GO et pas le mini disque dur en SSD), je m'aide via ceci : http://wiki.debian.org/DebianEeePCFrenc … dInstaller

J'ai donc pris une clé totalement vide où j'ai mis boot.img.gz, atl2-modules-2.6-486, linux-image-2.6-486 et l'iso de netinstall bien entendu.

Je fais donc un :

zcat boot.img.gz > /dev/sdX


Puis un :

Cindy:/home/koshie/eeePC# cp atl2-modules-2.6-486_2.6.26-6_i386.deb debian-Lenny-DI-rc2-i386-netinst.iso linux-image-2.6-486_2.6.26+17_i386.deb /mnt/


Tout est okay, je boot sur la clé, j'installe le système de base... Je redémarre et arrive sur un jolie terminal smile !

Je me logue, tape su,  monte la clé et tente d'installer le paquet linux-image comme ceci :

dpkg -i /mnt/linux-image-*.deb


Et là... pan. Ça marche pas. Pour résumer la console me dit que :

dpkg : des problèmes de dépendances empêchent la configuration de linux-image-2.6-486 : linux-image-2.6-436 dépend de linux-image-2.6.26-1-486 ; cependant : Le paquet linux-image-2.6.26-1-486 n'est pas installé.
dpkg : erreur de traitement de linux-image-2.6.26-1-486 (--install) : problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6-486


Quelqu'un sait-il d'où cela pourrait-il venir ?

Je vous remercie d'avance, Koshie.

Dernière modification par koshie (01-03-2009 22:15:33)

Hors ligne

#2 14-02-2009 02:03:07

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Grâce à un ami j'ai réussi à installer le nouveau noyau, il provient d'ici : http://packages.debian.org/etch/linux-i … half.1-686

Cependant ça ne marche toujours pas pour atl qui vient d'ici : http://packages.debian.org/etch/atl2-mo … -etchnhalf

Hors ligne

#3 14-02-2009 03:01:36

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut koshie,

À part des méthodes inconnues de moi, que pourrais-tu utiliser avec ce mini-portable ? Tu as quoi comme système dessus rien ?

Et puis quand tu dis:

Je me logue, tape su et monte la clé comme ceci :

    dpkg -i /mnt/linux-image-*.deb


tu te trompes d'erreur j'imagine ? tu as bien voulu dire que tu essaie d'installer linux-image avec la commande dpkg -i ?

/Edit : tutoriel trop vieux: 2008-05-28 (date en bas de page), essaie *nos* tutoriels:
http://debian-facile.org/wiki/doku.php? … ion:debian

(en fait c'est surtout que je ne vois pas ce que tu fais avec etchandhalf, alors que Lenny passe stable... )

pas si simple de trouver où sont les images...
veux-tu regarder là ?
http://www.debian.org/devel/debian-installer/


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#4 14-02-2009 09:49:10

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut (toujours toi qui me répond big_smile) !

Qu'entend-tu par méthode que je pourrais utiliser avec ce mini-portable? Comme système de base il y avait Windows XP.

Alors j'ai du faire une erreur oui, je voulais dire je monte la clé puis je tape dpkg... Désolé big_smile.

J'ai cherché une méthode pour installer Debian sur un eeePC mais il n'y en a pas (sur le site Debian-Facile) !

L'Etchanhalf m'a aussi choqué, j'ai tenté de voir si un ami pouvait m'aider >_<... Semble t'il qu'il fait fausse route, il m'avait dit qu'c'était pas important hmm.

Pourquoi tu veux que télécharge un ISO?

Dernière modification par koshie (14-02-2009 11:54:23)

Hors ligne

#5 14-02-2009 13:41:47

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut,

Je t'ai donné les urls vers des isos, parce que dans le premier post tu commences avec des noyau et module linux en version 2.6.26, et dans le second post tu continues avec noyau et module de la version avant-avant : 2.6.24 : je  te suggère de tout recommencer, mais avec l'iso et les fichiers vmlinuz et initrd les plus récents possibles,  ainsi que le module wifi de la version qui va avec (pour avoir plus de chances que ton wifi fonctionne directement). Je te laisse chercher par toi-même pour la suite, sachant que je t'ai aussi donné l'url de *notre wiki*, pour te dépatouiller avec les docs ad'hoc et plus récentes que celle que tu as utilisée. Bien entendu, si tu as encore besoin d'aide, n'hésites pas !

La méthode pour installer : c'est celle que tu veux employer, puisqu'il n'y a ni lecteur CD ni lecteur disquette sur cette machine. Tu aurais pu installer directement depuis une image iso si tu avais conservé un Windows dessus... smile

Nous avons même un howto dans le wiki, pour faire comme ça aussi.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#6 15-02-2009 15:10:05

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Je tente ça, cependant je suis confronté à un petit soucis dès le départ.

Je lis ce tutorial, j'ai une clé d'un GO, debian-testing-i386-CD-1.iso que j'ai téléchargé en daily aujourd'hui (Squeeze donc?), boot.img.gz, initrd.gz, vmlinuz (tous conforme j'ai vérifié).

Je formate ma clé en FAT32, elle est donc automatiquement démontée, ensuite je place boot.img sur la clé comme ceci :

(avec fdisk -l j'ai vérifié c'est /dev/sda1)

zcat boot.img.gz > /dev/sda1


Ensuite je me dis que je dois mettre initrd.gz et vmlinuz dessus mais dans ce tuto ils disent rien, je passe outre donc... Bref, je tente de copier l'ISO dessus comme ça :

mount /dev/sda1 /mnt && cp debian-testing-i386-CD-1.iso /mnt && umount /dev/sda1


(j'ai retiré le / avant le nom de l'ISO car ça ne marchait pas, faudrait changer ça dans le tuto non?)

Et là :

cp: écriture de `/mnt/debian-testing-i386-CD-1.iso': Aucun espace disponible sur le périphérique


Alors que si on fait le calcul, doit pas y avoir plus de 800mo sur la clé ! Je ne comprend donc pas. Je pourrais prendre une clé de 4Go mais je veux comprendre.

Dernière modification par koshie (15-02-2009 15:13:43)

Hors ligne

#7 15-02-2009 17:06:53

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut koshie

koshie a écrit :

mount /dev/sda1 /mnt && cp debian-testing-i386-CD-1.iso /mnt && umount /dev/sda1


(j'ai retiré le / avant le nom de l'ISO car ça ne marchait pas, faudrait changer ça dans le tuto non?)


Non car quand tu as saisi la commande tu étais déjà dans /chemin/
Tu étais dans le répertoire où se trouvait l'iso donc dans ce cas il faut juste écrire debian-testing-i386-CD-1.iso
Le /chemin/debian-testing-i386-netinst.iso est juste une indication de où se trouve le fichier (dans quel répertoire)

J'espère avoir été clair

Tu dis que tu as une clé de 1Go
Le wiki dit

Une clé USB vide de 256 Mo minimum


Donc quel est la taille de l'image iso "debian-testing-i386-CD-1.iso" que tu as téléchargé ?
Regarde bien c'est l'image iso du CD et non pas la netinstall donc 700Mo.
cf commande du wiki

mount /dev/sde /mnt && cp /chemin/debian-testing-i386-netinst.iso /mnt && umount /dev/sde


Il faut que tu choisisses la netinstall "debian-testing-i386-netinst.iso"

a+

damo

Dernière modification par damien (15-02-2009 17:12:23)


logo_3dminfographie_signature.png

Hors ligne

#8 15-02-2009 17:18:57

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut,

Alors tout ça pose un soucis, je ne vois pas en effet comment je pourrais faire une netinstall puisque la carte réseau ne semble pas être reconnu de base, il faut si j'ai bien compris installer le système de base puis installer manuellement les pilotes... Pour enfin avoir le réseaux ethernet, puis installer Madwifi. Sinon pour tes autres explications elles me semblent clair ^^.

J'ai bien pris un iso de moins de 700mo, donc pour la place je ne comprend pas.

Hors ligne

#9 15-02-2009 17:49:18

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Voici la nouvelle image des dépots de téléchargement de la lenny http://cdimage.debian.org/debian-cd/5.0.0/i386/iso-cd/
Tu télécharges debian-500-i386-netinst.iso (150Mo)
A mon avis, avec cette nouvelle version de debian ta carte réseau devrait être reconnue.

Bon courage !

Dernière modification par damien (15-02-2009 17:50:26)


logo_3dminfographie_signature.png

Hors ligne

#10 19-02-2009 18:57:28

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Avec la netinstall ça me lance une erreur 17 de Grub pour booter sur l'USB, pour le boot sur le net ça ne trouve rien !

Avec un iso normal :

bash-3.2# mount /dev/sdc1 /mnt && cp debian-500-i386-CD-1.iso /mnt/ && umount /dev/sdc1
cp: écriture de `/mnt/debian-500-i386-CD-1.iso': Aucun espace disponible sur le périphérique


Sur une clé de 4go, quand même !

Je comprend pas :-/.

Hors ligne

#11 22-02-2009 10:38:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Salut koshie,

Il y a une install debian sur eeepc701 sur le forum :
http://debian-facile.org/forum/viewtopic.php?id=681
pour t'en inspirer, tu l'as vu ? wink

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 24-02-2009 12:31:35

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Ça ne m'aide pas car TOUT est fait pour un disque dur SSD, moi j'ai un disque dur normale du coup "j'ai pas le droit" à un installer spéciale.

Et j'arrive toujours pas à faire booter la clé ou à mettre un ISO normale, j'en peux plus je craque ! big_smile

Dernière modification par koshie (24-02-2009 12:32:37)

Hors ligne

#13 24-02-2009 12:49:03

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

http://nsa05.casimages.com/img/2009/02/ … 897499.png

Juste après avoir taper :

zcat boot.img.gz > /dev/sdb1


Sur la clé de 4GO ça doit donner pareil vu que ça me laisse pas foutre un iso de 700mo.

Quelqu'un aurait une explication ?

Hors ligne

#14 24-02-2009 21:45:08

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

J'ai trouvé, en faite il faut taper :

mount /dev/sdc1 /mnt && cp debian-500-i386-CD-1.iso /dev/sdc1/ && umount /dev/sdc1


Il faut retirer /mnt au millieu car sinon il remplissait le /mnt de la racine :-/.

Hors ligne

#15 01-03-2009 02:08:01

koshie
Membre
Inscription : 19-06-2008

Re : [RESOLU] Installation debian lenny sur eeePC 900 HD 160GO

Je suis un gros débile quand même, l'img marche avec ma machine, j'ai juste fait une erreur, j'ai fais genre sda1 comme direction alors qu'il fallait mettre sda...

Bon... Debian installé ! Maintenant, j'vais devoir configuré le wifi... L'ethernet marche mais pas le wifi, j'ouvrirais un topic demain matin.

Merci quand même à tous.

Hors ligne

Pied de page des forums