Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 17-08-2015 17:44:41

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

re,

j avais un drivers experimental sur stretch , au passage au noyau 4.0.0.2 mon drivers a planté (ma cg est une 750 ti maxwell).
donc j ai purgé nvidia et je fais les mises a jour , au redemarrage on verra la surprise. lol
ce que je remarque stretch est toujours en sid hmm , jessie j ai eu plus de 50 mise a jour pour un mois et demie , ça fait beaucoup pour une stable tongue
et des soucis sur l upgrade wheezy => jessie (des bugs sur le bureau gnome par exemple)
en gros mon impression apres avoir remit en service quelques machines.

Hors ligne

#52 17-08-2015 18:55:43

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

voila stretch est a jour , avec le noyau 4.1.0-1 , la 750 ti est reconnu , je suis revenu au cuda 6 (et plus l experimental 6.5 ) , tout a l air correct.

le driver non-free nvidia de stretch a l air de gerer les dernieres cartes nvidia (a tester avec les 960 , 970 et 980 smile  )
le nouveau noyau doit y etre pour quelque chose aussi je pense.
pour le driver c est la 340.76-5 et cuda 6.0.37-5
apres avoir purgé nvidia et cuda toujour ma methode bourico tongue


apt-get install xserver-xorg-video-nvidia
 


creation ou verification de la presence de /etc/X11/xorg.conf.d/20-nividia.conf
puis apres reboot


apt-get install nvidia-cuda-toolkit
 



wink

@++

ps: en terme de performance je perd environ 50% par rapport au driver expérimental + cuda expérimental  roll  neutral

Dernière modification par robert2a (17-08-2015 20:15:57)

Hors ligne

#53 18-08-2015 02:55:26

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

suite a ma remarque en #38 sur une gtx770 hs (alimentation se met en defaut) , elle recommence a ce mettre hs (apres remplacement de la carte graphique) , je pense fortement a l alimentation qui a un défaut d usine .

je n en ai pas de disponible  mais je pense a son remplacement , au moins pour confirmer .
cette machine est en stretch , 400 mises a jour et un autre upgrade pour passer au noyau 4.1.0-2 (pas de soucis avec le drivers 340.76-5 la carte est géré a 100% wink  )

Hors ligne

#54 25-08-2015 17:29:40

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour

le driver experimental est a la version 350.30 (je n ai pas trouvé de cuda correspondant )

pour stretch j ai 3 versions. (noyau actuel 4.1.0 )
le driver nouveau (libre et a mon avis amélioré par rapport a jessie (a vérifier ).
le legacy 304.125-2 (non free anciennes cartes)
le legacy 340.76-6 (non-free )
et le 340.76-5 (dernier driver pour stretch et sid actuel , cuda est dispo dans les paquets en version 6 )

si je ne me trompe pas , le legacy 340.76-6 va permettre d utiliser les cartes qui ne vont pas etre prise en compte dans les futurs drivers non-free , comme le 304 prend en compte les cartes tres anciennes.

si quelqu un a plus d infos wink

Dernière modification par robert2a (25-08-2015 17:31:30)

Hors ligne

#55 30-08-2015 20:57:07

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonsoir

apres un test en live , stretch avec le driver non free 343.76-5 ne supporte pas encore les GTX9xx series , par contre en maxwel la 750ti est supporté.
pour ma 960 je n ai pas trop le choix , si je veut cuda il me faut le driver constructeur
pour stretch et le driver "nouveau" malgres quelques messages au démarrage (chargement du noyau ) , le serveur graphique fonctionne avec la GTX960 , j ai mon bureau gnome

ps: voila j ai installé le dernier driver de chez nvidia , avec chaque modification du noyau je serai bon pour le reinstaller hmm

Dernière modification par robert2a (30-08-2015 22:36:56)

Hors ligne

#56 07-09-2015 11:20:48

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour

j'ai un petit soucis avec stretch suite a une grosse mise a jour (plus de 800 fichiers roll ), materiel quad core 6600 (socket 775) 2go de ram , GTX660 nvidia
driver video des dépots debian 340.76-5 + cuda driver 6050
lorsque je lance mon logiciel , l utilisation disque passe a 100% et le curseur a l ecran freeze , je suis obligé soit de faire un reset hard soit de tuer le process en console et de lancer un reboot.
rien de special dans syslog neutral
j ai desinstallé gnome , driver nvidia , cuda et xfce4 et reinstallé propre gnome , driver nvidia et cuda , a priori le probleme est toujours la.
j ai d autres machines avec stretch (a jour) sans soucis de ce genre hmm
je precise l application sur le cpu ne bug pas , mais uniquement sur le gpu ( je pense a un probleme cuda ou driver sad )
j ai un swap de 1.6go (utilisation 0%) et 900mo de memoire vive libre (sur 2go) , peut etre un soucis de memoire disponnible lorsque je lance l application , ce qui explique l utilisation disque hmm

ps: probleme résolu

apres mise a jour et refait l installation de l application tout est rentré dans l ordre.
pas d explication à ce soucis , je pense que c est peut etre le changement de noyau du 3.16.0 au 4.1.0 , et plus de 900 paquets a traiter (entre les mises a jours , paquets retirés   et nouveau programme )

Dernière modification par robert2a (07-09-2015 18:52:18)

Hors ligne

#57 20-09-2015 17:48:04

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour

le driver sur stretch passe a la version 340.93-1 (ancienne 340.76.5 ) , pour le cuda je surveille smile

ps: rien de spécial pour les cartes supportées , (liste identique)

Dernière modification par robert2a (20-09-2015 18:13:12)

Hors ligne

#58 04-10-2015 17:36:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

le noyau est maintenant en version 4.2.0-1   tongue  pour stretch , je n'ai pas regardé les modifications apportées

ps: le driver non-free nvidia des dépots de stretch passe de 340.0.93-1  a 340.0.93-3  (mise a jour mineure wink  )

Dernière modification par robert2a (07-10-2015 11:00:13)

Hors ligne

#59 07-10-2015 11:59:51

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour

j'ai perdu la détection du cuda (ne fonctionne plus) avec le dernier driver 340.0.93-3 (mise a jour )
pour l instant j'ai pas trouvé de solution à ce souci
carte graphique GTX770

Hors ligne

#60 07-10-2015 14:03:23

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

je vais tenter le cuda de sid pour test , la régression au driver 340.76 n ' a pas fonctionné (avec cuda) .
le cuda de sid est en 6.5 (au lieu de 6 pour stretch )
aucun soucis d affichage , le probleme n est que pour driver + cuda (autrement tous les drivers fonctionnent )
ça promet pour la mise a jour du tuto de l installation du driver nvidia non-free  tongue

wink

Hors ligne

#61 07-10-2015 17:10:12

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Nouveau driver nvidia nonfree Stretch

Légèrement, mais très très légèrement têtu ..... tongue

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#62 07-10-2015 17:40:14

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

uiiiiii    tongue  tongue tongue tongue
ps je poste de mon client léger par PXE (reçu ma carte réseau )  wink

Hors ligne

#63 07-10-2015 19:39:21

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

bon tetu mais parfois ça ne fonctionne pas tongue tongue tongue tongue
pas moyen de récupérer le cuda , je laisse comme ça en stretch façon sid  lol (j ai remit mon sources.list en normal )
j ai pas testé "expérimental" mais comme je me connais  ça va se terminer avec une nouvelle installation de debian  cool

Dernière modification par robert2a (07-10-2015 19:40:30)

Hors ligne

#64 08-10-2015 18:09:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Nouveau driver nvidia nonfree Stretch

Faire et défaire ...  big_smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#65 08-10-2015 19:32:57

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

oui j installe jessie (a la place de stretch) pour récupérer cuda , le temps que le souci soit réglé  wink
les autres machines en stretch stop faire les mises a jour pour l'instant tongue

voila ça tourne a nouveau avec cuda , j'ai meme pas mit les backports dans le sources.list  , pour une gtx770 ça suffira une jessie de base tongue

Dernière modification par robert2a (08-10-2015 21:29:07)

Hors ligne

#66 11-10-2015 21:40:07

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

je cherche toujours mon souci de cuda , je suis passé en expérimental c'est pas mieux hmm et la je suis sous sid avec une version 340.93-4 et cuda 6.5 mais j avoue perdre espoir roll

je suis a me demander si mon application n a pas besoin d une mise a jour (qui n existe pas encore sad )
elle ne détecte pas l installation du cuda alors que avec jessie tout est correct a part la version du driver qui ne reconnais pas toutes mes cartes (série maxwell )
c'est la grosse déprime tongue

Dernière modification par robert2a (12-10-2015 12:02:06)

Hors ligne

#67 11-10-2015 23:06:39

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

ps: a ne pas faire  roll tongue lol
de stretch je suis passé a experimental puis reviendu wink a sid et enfin par desespoir j ai installé le driver vidéo de jessie + le kernel 3.16 + cuda (avec une purge des kernel sid et experimental )
et tout fonctionne correctement  tongue tongue tongue
bon la machine est bonne a refaire en entier (c: format comme disent les winpasluxien) 
et je sais toujours pas d ou provient le souci , le kernel , le driver ou le cuda ?
sur ce , debian pour ce soir ça suffit cool

Dernière modification par robert2a (11-10-2015 23:07:27)

Hors ligne

#68 12-10-2015 12:07:06

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

un dernier essaie avec le 340.93-1 de sid  (legacy ) et le cuda 6.5   (pour se mettre en forme pour la journée tongue )
ps: il y a le .run de nvidia , mais déja avec jessie je dois l utiliser , si avec stretch aussi c est pas cool hmm

Hors ligne

#69 12-10-2015 12:39:33

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Nouveau driver nvidia nonfree Stretch


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#70 12-10-2015 13:43:53

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour smile
j'ai pas trop compris ta manipulation , avec le .run de nvidia cuda est dans le driver (pas besoin d installer le cuda a part )
peut etre que blender a besoin de plus ou que tu n a pas voulu mettre le driver proprio en .run
enfin dans mon cas c est l utilisation des paquets debian non free qui fonctionnaient jusqu a la version 340.93.1(driver) et 6.0.3(cuda) et qui fonctionne plus.
merci pour le lien , on testera quand meme  wink

Hors ligne

#71 17-10-2015 20:06:02

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

une petite new , sur sid le driver 340.93-5 n'a plus besoin du xorg.conf , j'ai testé et ça fonctionne wink
voila qui va facilité la vie des débutants  par contre le tuto spécial stretch ce précise  tongue

Hors ligne

#72 17-10-2015 20:21:15

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

voici le Xorg.0.log sur stretch avec le driver nvidia de sid 340.93-5  (sans fichier xorg.conf )


[    31.823]
X.Org X Server 1.17.2
Release Date: 2015-06-16
[    31.823] X Protocol Version 11, Revision 0
[    31.823] Build Operating System: Linux 4.1.0 x86_64 Debian
[    31.823] Current Operating System: Linux debian4 4.2.0-1-amd64 #1 SMP Debian 4.2.1-2 (2015-09-27) x86_64
[    31.823] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.0-1-amd64 root=UUID=b30291dc-401e-48ba-91d1-1f018170d269 ro quiet
[    31.824] Build Date: 11 August 2015  10:51:15AM
[    31.824] xorg-server 2:1.17.2-1.1 (http://www.debian.org/support)
[    31.824] Current version of pixman: 0.33.2
[    31.824]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[    31.824] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    31.824] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 17 20:00:55 2015
[    31.947] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    32.309] (==) No Layout section.  Using the first Screen section.
[    32.309] (==) No screen section available. Using defaults.
[    32.309] (**) |-->Screen "Default Screen Section" (0)
[    32.309] (**) |   |-->Monitor "<default monitor>"
[    32.310] (==) No monitor specified for screen "Default Screen Section".
  Using a default monitor configuration.
[    32.310] (==) Automatically adding devices
[    32.310] (==) Automatically enabling devices
[    32.310] (==) Automatically adding GPU devices
[    32.943] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    32.943]  Entry deleted from font path.
[    32.996] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  built-ins
[    32.996] (==) ModulePath set to "/usr/lib/xorg/modules"
[    32.996] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[    33.015] (II) Loader magic: 0x564cd04c0d40
[    33.015] (II) Module ABI versions:
[    33.015]  X.Org ANSI C Emulation: 0.4
[    33.015]  X.Org Video Driver: 19.0
[    33.015]  X.Org XInput driver : 21.0
[    33.015]  X.Org Server Extension : 9.0
[    33.015] (II) xfree86: Adding drm device (/dev/dri/card0)
[    33.016] (--) PCI:*(0:1:0:0) 10de:1380:1462:3102 rev 162, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    33.052] (II) LoadModule: "glx"
[    33.183] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    36.289] (II) Module glx: vendor="NVIDIA Corporation"
[    36.289]  compiled for 4.0.2, module version = 1.0.0
[    36.289]  Module class: X.Org Server Extension
[    36.318] (II) NVIDIA GLX Module  340.93  Wed Aug 19 16:23:51 PDT 2015
[    36.357] (II) Applying OutputClass "nvidia" to /dev/dri/card0
[    36.357]  loading driver: nvidia
[    36.357] (==) Matched nvidia as autoconfigured driver 0
[    36.357] (==) Matched nouveau as autoconfigured driver 1
[    36.357] (==) Matched nv as autoconfigured driver 2
[    36.357] (==) Matched nouveau as autoconfigured driver 3
[    36.357] (==) Matched nv as autoconfigured driver 4
[    36.357] (==) Matched modesetting as autoconfigured driver 5
[    36.357] (==) Matched fbdev as autoconfigured driver 6
[    36.357] (==) Matched vesa as autoconfigured driver 7
[    36.357] (==) Assigned the driver to the xf86ConfigLayout
[    36.357] (II) LoadModule: "nvidia"
[    36.435] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    37.005] (II) Module nvidia: vendor="NVIDIA Corporation"
[    37.005]  compiled for 4.0.2, module version = 1.0.0
[    37.005]  Module class: X.Org Video Driver
[    37.009] (II) LoadModule: "nouveau"
[    37.009] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    37.060] (II) Module nouveau: vendor="X.Org Foundation"
[    37.060]  compiled for 1.17.1, module version = 1.0.11
[    37.060]  Module class: X.Org Video Driver
[    37.060]  ABI class: X.Org Video Driver, version 19.0
[    37.060] (II) LoadModule: "nv"
[    37.060] (WW) Warning, couldn't open module nv
[    37.060] (II) UnloadModule: "nv"
[    37.060] (II) Unloading nv
[    37.060] (EE) Failed to load module "nv" (module does not exist, 0)
[    37.060] (II) LoadModule: "modesetting"
[    37.060] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    37.075] (II) Module modesetting: vendor="X.Org Foundation"
[    37.075]  compiled for 1.17.2, module version = 1.17.2
[    37.075]  Module class: X.Org Video Driver
[    37.075]  ABI class: X.Org Video Driver, version 19.0
[    37.075] (II) LoadModule: "fbdev"
[    37.075] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    37.176] (II) Module fbdev: vendor="X.Org Foundation"
[    37.176]  compiled for 1.17.1, module version = 0.4.4
[    37.176]  Module class: X.Org Video Driver
[    37.176]  ABI class: X.Org Video Driver, version 19.0
[    37.176] (II) LoadModule: "vesa"
[    37.176] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    37.213] (II) Module vesa: vendor="X.Org Foundation"
[    37.213]  compiled for 1.17.1, module version = 2.3.3
[    37.213]  Module class: X.Org Video Driver
[    37.213]  ABI class: X.Org Video Driver, version 19.0
[    37.213] (II) NVIDIA dlloader X Driver  340.93  Wed Aug 19 16:01:53 PDT 2015
[    37.213] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    37.235] (II) NOUVEAU driver Date:   Thu Aug 28 03:57:48 2014 +0200
[    37.235] (II) NOUVEAU driver for NVIDIA chipset families :
[    37.235]  RIVA TNT        (NV04)
[    37.235]  RIVA TNT2       (NV05)
[    37.235]  GeForce 256     (NV10)
[    37.235]  GeForce 2       (NV11, NV15)
[    37.235]  GeForce 4MX     (NV17, NV18)
[    37.235]  GeForce 3       (NV20)
[    37.235]  GeForce 4Ti     (NV25, NV28)
[    37.235]  GeForce FX      (NV3x)
[    37.235]  GeForce 6       (NV4x)
[    37.235]  GeForce 7       (G7x)
[    37.235]  GeForce 8       (G8x)
[    37.235]  GeForce GTX 200 (NVA0)
[    37.235]  GeForce GTX 400 (NVC0)
[    37.235] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    37.235] (II) FBDEV: driver for framebuffer: fbdev
[    37.235] (II) VESA: driver for VESA chipsets: vesa
[    37.235] (++) using VT number 7

[    37.396] (II) Loading sub module "fb"
[    37.397] (II) LoadModule: "fb"
[    37.398] (II) Loading /usr/lib/xorg/modules/libfb.so
[    37.502] (II) Module fb: vendor="X.Org Foundation"
[    37.502]  compiled for 1.17.2, module version = 1.0.0
[    37.502]  ABI class: X.Org ANSI C Emulation, version 0.4
[    37.502] (WW) Unresolved symbol: fbGetGCPrivateKey
[    37.502] (II) Loading sub module "wfb"
[    37.502] (II) LoadModule: "wfb"
[    37.502] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    37.570] (II) Module wfb: vendor="X.Org Foundation"
[    37.570]  compiled for 1.17.2, module version = 1.0.0
[    37.570]  ABI class: X.Org ANSI C Emulation, version 0.4
[    37.570] (II) Loading sub module "ramdac"
[    37.570] (II) LoadModule: "ramdac"
[    37.570] (II) Module "ramdac" already built-in
[    37.678] (WW) Falling back to old probe method for modesetting
[    37.678] (WW) Falling back to old probe method for fbdev
[    37.678] (II) Loading sub module "fbdevhw"
[    37.678] (II) LoadModule: "fbdevhw"
[    37.678] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    37.746] (II) Module fbdevhw: vendor="X.Org Foundation"
[    37.746]  compiled for 1.17.2, module version = 0.0.2
[    37.746]  ABI class: X.Org Video Driver, version 19.0
[    37.746] (EE) open /dev/fb0: No such file or directory
[    37.746] (WW) Falling back to old probe method for vesa
[    37.746] (II) NVIDIA(0): Creating default Display subsection in Screen section
  "Default Screen Section" for depth/fbbpp 24/32
[    37.746] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    37.746] (==) NVIDIA(0): RGB weight 888
[    37.746] (==) NVIDIA(0): Default visual is TrueColor
[    37.746] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    37.746] (**) NVIDIA(0): Enabling 2D acceleration
[    37.978] (II) NVIDIA(0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    37.978] (II) NVIDIA(0):     stereo.
[    37.979] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[    38.072] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 Ti (GM107-A) at PCI:1:0:0 (GPU-0)
[    38.072] (--) NVIDIA(0): Memory: 2097152 kBytes
[    38.072] (--) NVIDIA(0): VideoBIOS: 82.07.32.00.c0
[    38.072] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    38.080] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 750 Ti at PCI:1:0:0
[    38.080] (--) NVIDIA(0):     Acer B193W (CRT-0) (boot, connected)
[    38.080] (--) NVIDIA(0):     DFP-0
[    38.080] (--) NVIDIA(0):     DFP-1
[    38.080] (--) NVIDIA(GPU-0): Acer B193W (CRT-0): 400.0 MHz maximum pixel clock
[    38.080] (--) NVIDIA(0): DFP-0: Internal TMDS
[    38.080] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    38.080] (--) NVIDIA(0): DFP-1: Internal TMDS
[    38.080] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    38.080] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    38.080] (**) NVIDIA(0):     device Acer B193W (CRT-0) (Using EDID frequencies has been
[    38.080] (**) NVIDIA(0):     enabled on all display devices.)
[    38.142] (==) NVIDIA(0):
[    38.142] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    38.143] (==) NVIDIA(0):     will be used as the requested mode.
[    38.143] (==) NVIDIA(0):
[    38.143] (II) NVIDIA(0): Validated MetaModes:
[    38.143] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select"
[    38.143] (II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
[    38.232] (--) NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config
[    38.232] (--) NVIDIA(0):     option
[    38.232] (II) UnloadModule: "nouveau"
[    38.232] (II) Unloading nouveau
[    38.232] (II) UnloadModule: "modesetting"
[    38.232] (II) Unloading modesetting
[    38.232] (II) UnloadModule: "fbdev"
[    38.232] (II) Unloading fbdev
[    38.232] (II) UnloadSubModule: "fbdevhw"
[    38.232] (II) Unloading fbdevhw
[    38.232] (II) UnloadModule: "vesa"
[    38.232] (II) Unloading vesa
[    38.232] (--) Depth 24 pixmap format is 32 bpp
[    38.233] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    38.233] (II) NVIDIA:     access.
[    38.269] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    38.269] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    38.269] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    38.269] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    38.269] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    38.269] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    38.269] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    38.269] (II) NVIDIA(0):     Config Options in the README.
[    38.278] (II) NVIDIA(0): Setting mode "CRT-0:nvidia-auto-select"
[    38.685] (==) NVIDIA(0): Disabling shared memory pixmaps
[    38.685] (==) NVIDIA(0): Backing store enabled
[    38.685] (==) NVIDIA(0): Silken mouse enabled
[    38.687] (==) NVIDIA(0): DPMS enabled
[    38.687] (II) Loading sub module "dri2"
[    38.687] (II) LoadModule: "dri2"
[    38.687] (II) Module "dri2" already built-in
[    38.687] (II) NVIDIA(0): [DRI2] Setup complete
[    38.687] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    38.687] (--) RandR disabled
[    38.691] (II) SELinux: Disabled on system
[    38.698] (II) Initializing extension GLX
[    38.698] (II) Indirect GLX disabled.(II) config/udev: Adding input device Power Button (/dev/input/event2)
[    39.412] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    39.412] (II) LoadModule: "evdev"
[    39.412] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    39.461] (II) Module evdev: vendor="X.Org Foundation"
[    39.461]  compiled for 1.16.4, module version = 2.9.2
[    39.461]  Module class: X.Org XInput Driver
[    39.461]  ABI class: X.Org XInput driver, version 21.0
[    39.461] (II) Using input driver 'evdev' for 'Power Button'
[    39.461] (**) Power Button: always reports core events
[    39.461] (**) evdev: Power Button: Device: "/dev/input/event2"
[    39.461] (--) evdev: Power Button: Vendor 0 Product 0x1
[    39.461] (--) evdev: Power Button: Found keys
[    39.461] (II) evdev: Power Button: Configuring as keyboard
[    39.461] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event2"
[    39.461] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    39.461] (**) Option "xkb_rules" "evdev"
[    39.461] (**) Option "xkb_model" "pc105"
[    39.461] (**) Option "xkb_layout" "fr"
[    39.461] (**) Option "xkb_variant" "latin9"
[    39.518] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    39.518] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    39.518] (II) Using input driver 'evdev' for 'Power Button'
[    39.518] (**) Power Button: always reports core events
[    39.518] (**) evdev: Power Button: Device: "/dev/input/event1"
[    39.518] (--) evdev: Power Button: Vendor 0 Product 0x1
[    39.518] (--) evdev: Power Button: Found keys
[    39.518] (II) evdev: Power Button: Configuring as keyboard
[    39.518] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input2/event1"
[    39.518] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    39.518] (**) Option "xkb_rules" "evdev"
[    39.518] (**) Option "xkb_model" "pc105"
[    39.518] (**) Option "xkb_layout" "fr"
[    39.518] (**) Option "xkb_variant" "latin9"
[    39.518] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event13)
[    39.518] (II) No input driver specified, ignoring this device.
[    39.518] (II) This device may have been added with another device file.
[    39.519] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event14)
[    39.519] (II) No input driver specified, ignoring this device.
[    39.519] (II) This device may have been added with another device file.
[    39.519] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event15)
[    39.519] (II) No input driver specified, ignoring this device.
[    39.519] (II) This device may have been added with another device file.
[    39.519] (II) config/udev: Adding input device HDA ATI SB Line Out Surround (/dev/input/event8)
[    39.519] (II) No input driver specified, ignoring this device.
[    39.519] (II) This device may have been added with another device file.
[    39.519] (II) config/udev: Adding input device HDA ATI SB Line Out CLFE (/dev/input/event9)
[    39.519] (II) No input driver specified, ignoring this device.
[    39.519] (II) This device may have been added with another device file.
[    39.520] (II) config/udev: Adding input device HDA ATI SB Line Out Side (/dev/input/event10)
[    39.520] (II) No input driver specified, ignoring this device.
[    39.520] (II) This device may have been added with another device file.
[    39.520] (II) config/udev: Adding input device HDA ATI SB Front Headphone (/dev/input/event11)
[    39.520] (II) No input driver specified, ignoring this device.
[    39.520] (II) This device may have been added with another device file.
[    39.520] (II) config/udev: Adding input device HDA ATI SB Front Mic (/dev/input/event4)
[    39.520] (II) No input driver specified, ignoring this device.
[    39.520] (II) This device may have been added with another device file.
[    39.520] (II) config/udev: Adding input device HDA ATI SB Rear Mic (/dev/input/event5)
[    39.520] (II) No input driver specified, ignoring this device.
[    39.520] (II) This device may have been added with another device file.
[    39.520] (II) config/udev: Adding input device HDA ATI SB Line (/dev/input/event6)
[    39.520] (II) No input driver specified, ignoring this device.
[    39.521] (II) This device may have been added with another device file.
[    39.521] (II) config/udev: Adding input device HDA ATI SB Line Out Front (/dev/input/event7)
[    39.521] (II) No input driver specified, ignoring this device.
[    39.521] (II) This device may have been added with another device file.
[    39.521] (II) config/udev: Adding input device Eee PC WMI hotkeys (/dev/input/event12)
[    39.521] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    39.521] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[    39.521] (**) Eee PC WMI hotkeys: always reports core events
[    39.521] (**) evdev: Eee PC WMI hotkeys: Device: "/dev/input/event12"
[    39.521] (--) evdev: Eee PC WMI hotkeys: Vendor 0 Product 0
[    39.521] (--) evdev: Eee PC WMI hotkeys: Found keys
[    39.521] (II) evdev: Eee PC WMI hotkeys: Configuring as keyboard
[    39.521] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input14/event12"
[    39.521] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD, id 8)
[    39.521] (**) Option "xkb_rules" "evdev"
[    39.521] (**) Option "xkb_model" "pc105"
[    39.521] (**) Option "xkb_layout" "fr"
[    39.521] (**) Option "xkb_variant" "latin9"
[    39.522] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    39.522] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    39.522] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    39.522] (**) AT Translated Set 2 keyboard: always reports core events
[    39.522] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    39.522] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    39.522] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    39.522] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    39.522] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    39.522] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    39.522] (**) Option "xkb_rules" "evdev"
[    39.522] (**) Option "xkb_model" "pc105"
[    39.522] (**) Option "xkb_layout" "fr"
[    39.522] (**) Option "xkb_variant" "latin9"
[    39.522] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event16)
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
[    39.522] (II) Using input driver 'evdev' for 'ImExPS/2 Generic Explorer Mouse'
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[    39.522] (**) evdev: ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event16"
[    39.522] (--) evdev: ImExPS/2 Generic Explorer Mouse: Vendor 0x2 Product 0x6
[    39.522] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found 9 mouse buttons
[    39.522] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found scroll wheel(s)
[    39.522] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found relative axes
[    39.522] (--) evdev: ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
[    39.522] (II) evdev: ImExPS/2 Generic Explorer Mouse: Configuring as mouse
[    39.522] (II) evdev: ImExPS/2 Generic Explorer Mouse: Adding scrollwheel support
[    39.522] (**) evdev: ImExPS/2 Generic Explorer Mouse: YAxisMapping: buttons 4 and 5
[    39.522] (**) evdev: ImExPS/2 Generic Explorer Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    39.522] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input4/event16"
[    39.522] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 10)
[    39.522] (II) evdev: ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[    39.522] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[    39.523] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[    39.523] (II) No input driver specified, ignoring this device.
[    39.523] (II) This device may have been added with another device file.
[    39.523] (II) config/udev: Adding input device PC Speaker (/dev/input/event3)
[    39.523] (II) No input driver specified, ignoring this device.
[    39.523] (II) This device may have been added with another device file.
[    60.985] (II) NVIDIA(GPU-0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    60.985] (II) NVIDIA(GPU-0):     stereo.
[    60.997] (II) NVIDIA(GPU-0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    60.997] (II) NVIDIA(GPU-0):     stereo.
[    61.191] (II) NVIDIA(GPU-0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    61.191] (II) NVIDIA(GPU-0):     stereo.
[    61.202] (II) NVIDIA(GPU-0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    61.202] (II) NVIDIA(GPU-0):     stereo.
[    65.254] (II) NVIDIA(GPU-0): Display (Acer B193W (CRT-0)) does not support NVIDIA 3D Vision
[    65.254] (II) NVIDIA(GPU-0):     stereo.

 



toutes mes excuses me suis trompé de xorg j ai pris le Xorg.1.log au lieu du Xorg.0.log
tous fonctionne bien , je pense que ceci sera incorporé dans stretch tres bientot

toujours pas de cuda détecté pour moi , l'espoir fait vivre tongue

Dernière modification par robert2a (17-10-2015 20:29:51)

Hors ligne

#73 07-11-2015 10:43:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonjour

petite mise a jour , cuda fonctionne a nouveau pour moi avec le driver nvidia  des dépots debian .
je teste a l instant la version 340.93-7 de sid (l'ancienne etait 340.93.6 )
gpu pris en charge de la serie 8xxx (8800) a la serie 8xx (8xxM donc les portables) , la serie 9xx pas encore supporté .
je teste avec un pc en stretch + sid et un gpu GTX750TI maxwell  (sur sid je ne prend que la mise a jour driver nvidia et cuda toolkit)
la version de cuda est la 6.5 (pour sid et stretch) , le driver 340.93.6 (stretch ) et 340.93.7 (sid)
ça va doucement mais surement smile

pour la serie 9xx je suis toujours sous jessie + le .run du constructeur (sans aucun soucis non plus )
je n ai plus fait de test avec "experimental" pour l instant
ps: pour le driver libre "nouveau" avec le kernel 4.2  je dirai gpu supportés jusqu'a la serie  gtx780 Ti (je n ai plus testé depuis un moment ).
@++

Hors ligne

#74 18-01-2016 20:25:06

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

Bonsoir

sid contient le driver 343.xx dans les dépots debian , il va etre possible d utiliser celui ci avec les cartes de la serie 9xx  (GTX950 à GTX980)
je teste en sid et une GTX950
ps: je regarde les cartes prise en charge par ce nouveau driver smile
@++

voici les 2 nouvelles cartes prisent en charge :

GeForce GTX 980                       13C0               E
GeForce GTX 970                       13C2               E

je n ai pas trouvé la 950 et 960 mais sur le bureau aucun soucis avec une GTX950
j'ai installé le cuda de sid aussi.
je ferai des tests.


18:55:25:******************************* System ********************************
18:55:25:        CPU: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz
18:55:25:     CPU ID: GenuineIntel Family 6 Model 94 Stepping 3
18:55:25:       CPUs: 4
18:55:25:     Memory: 15.60GiB
18:55:25:Free Memory: 15.23GiB
18:55:25:    Threads: POSIX_THREADS
18:55:25: OS Version: 4.3
18:55:25:Has Battery: false
18:55:25: On Battery: false
18:55:25: UTC Offset: 1
18:55:25:         OS: Linux 4.3.0-1-amd64 x86_64
18:55:25:    OS Arch: AMD64
18:55:25:       GPUs: 1
18:55:25:      GPU 0: NVIDIA:5 GM206 [GeForce GTX 950]
18:55:25:       CUDA: 5.2
18:55:25:CUDA Driver: 6050
 



attention , le premier gpu pris en charge  =>  GeForce GTX 480                       06C0               C
le 340.65 (jessie) et 340.96 (stretch) la prise en charge commence a la serie 8xxx (8800 et autres)  avec ce driver (343) ces vieilles cartes ne risquent de pas fonctionner.

Dernière modification par robert2a (18-01-2016 21:15:11)

Hors ligne

#75 18-01-2016 21:41:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Nouveau driver nvidia nonfree Stretch

vous pouvez voir le suivi ici => https://packages.qa.debian.org/n/nvidia … ivers.html

ça bouge , prévision 346  en sid  (340.3 => 340.4    pour stretch )

ps:j'ai pas trouvé de bug sur la 352.63  d'experimental encore  tongue  wink

Dernière modification par robert2a (18-01-2016 21:43:54)

Hors ligne

Pied de page des forums