Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-05-2015 21:02:56

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

[résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Bonjour,

Mon Dell est en 64 bits et je viens d'installer debian 8 après un formatage de mon disque. Je repars donc de quelque chose de propre ;o)

Malgré une installation sans message de SAMBA et la présence de répertoire et fichier comme /etc/samba/.... je n'arrive pas à lancer SAMBA, il est introuvable !?
Mais que se passe-t-il donc (pour info, précédement sous debian 7.8 en 64 bits, je n'avais pas ce genre de souci !?) ?

Merci par avance et bonne soirée

Dernière modification par debi1 (04-05-2015 06:47:10)

Hors ligne

#2 02-05-2015 21:18:52

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Bonjour, débi

Cela serai possible de voir, si samba est bien installé déjà.

Par exemple avec une commande du style :

apt search samba | grep ^samba



Ou bien

apt-cache show samba




Avant d'aller plus loin, faut déjà valider que tu es bien installé le paquet samba.


Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#3 02-05-2015 21:22:42

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Avant d'aller plus loin, faut déjà valider que tu es bien installé le paquet samba.


> effectivement, tu as tout à fait raison ... et à priori c'est pas OK


apt search samba | grep ^samba

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

samba/stable,now 2:4.1.17+dfsg-2 amd64  [installé]
samba-common/stable,now 2:4.1.17+dfsg-2 all  [installé, automatique]
samba-common-bin/stable,now 2:4.1.17+dfsg-2 amd64  [installé, automatique]
samba-dbg/stable 2:4.1.17+dfsg-2 amd64
samba-dev/stable,now 2:4.1.17+dfsg-2 amd64  [installé]
samba-doc/stable,now 2:4.1.17+dfsg-2 all  [installé]
samba-dsdb-modules/stable,now 2:4.1.17+dfsg-2 amd64  [installé, automatique]
samba-libs/stable,now 2:4.1.17+dfsg-2 amd64  [installé, automatique]
samba-testsuite/stable,now 2:4.1.17+dfsg-2 amd64  [installé]
samba-vfs-modules/stable,now 2:4.1.17+dfsg-2 amd64  [installé, automatique]
 



apt-cache show samba

Package: samba
Version: 2:4.1.17+dfsg-2
Installed-Size: 11173
Maintainer: Debian Samba Maintainers <pkg-samba-maint@lists.alioth.debian.org>
Architecture: amd64
Replaces: libsamdb0 (<< 4.0.0~alpha17~), python-samba (<< 2:4.1.4+dfsg-3), samba-ad-dc, samba-common (<= 2.0.5a-2), samba-doc (<< 2:4.0.5~), samba-libs (<< 2:4.1.4+dfsg-2), samba4
Depends: adduser, heimdal-hdb-api-8, libpam-modules, libpam-runtime (>= 1.0.1-11), lsb-base (>= 4.1+Debian), procps, python (>= 2.7), python-dnspython, python-ntdb, python-samba, samba-common (= 2:4.1.17+dfsg-2), samba-common-bin (= 2:4.1.17+dfsg-2), samba-dsdb-modules, tdb-tools, update-inetd, python (<< 2.8), python2.7:any, libasn1-8-heimdal (>= 1.4.0+git20110226), libbsd0 (>= 0.5.0), libc6 (>= 2.14), libcomerr2 (>= 1.01), libhdb9-heimdal (>= 1.4.0+git20110226), libkdc2-heimdal (>= 1.4.0+git20110226), libkrb5-26-heimdal (>= 1.4.0+git20110226), libldb1 (>= 0.9.21), libpopt0 (>= 1.14), libpython2.7 (>= 2.7), libroken18-heimdal (>= 1.4.0+git20110226), libtalloc2 (>= 2.0.4~git20101213), libtdb1 (>= 1.2.7+git20101214), libtevent0 (>= 0.9.14), samba-libs (= 2:4.1.17+dfsg-2)
Pre-Depends: dpkg (>= 1.15.6~), multiarch-support
Recommends: attr, logrotate, samba-vfs-modules
Suggests: bind9 (>= 1:9.5.1), bind9utils, ctdb, ldb-tools, ntp, smbldap-tools, winbind
Enhances: bind9, ntp
Conflicts: libldb1 (<< 1:1.1.15), samba (<< 2:3.3.0~rc2-5), samba-ad-dc, samba-doc (<< 2:4.0.5~), samba-tools, samba4 (<< 4.0.0~alpha6-2)
Breaks: qtsmbstatus-server (<< 2.2.1-3~)
Description-en: SMB/CIFS file, print, and login server for Unix
 Samba is an implementation of the SMB/CIFS protocol for Unix systems,
 providing support for cross-platform file and printer sharing with
 Microsoft Windows, OS X, and other Unix systems.  Samba can also function
 as an NT4-style domain controller, and can integrate with both NT4 domains
 and Active Directory realms as a member server.
 .
 This package provides the components necessary to use Samba as a stand-alone
 file and print server or as an NT4 or Active Directory domain controller.
 For use in an NT4 domain or Active Directory realm, you will also need the
 winbind package.
 .
 This package is not required for connecting to existing SMB/CIFS servers
 (see smbclient) or for mounting remote filesystems (see cifs-utils).
Description-md5: 3dcec89b7baaa655b2536933cdaeab54
Homepage: http://www.samba.org
Tag: admin::filesystem, implemented-in::c, interface::daemon,
 network::server, network::service, protocol::smb, role::program,
 suite::samba, use::configuring
Section: net
Priority: optional
Filename: pool/main/s/samba/samba_4.1.17+dfsg-2_amd64.deb
Size: 928022
MD5sum: 80f9676696097f3cee357cabbca0b871
SHA1: a24a04d70fd3523001e0b2e7f9af68087cfd77c7
SHA256: 10c8792252207e39ac7eb34570488552bcd9cb6ca584d25226e10ee38c575989
 




qu'en penses-tu ?

Hors ligne

#4 02-05-2015 21:32:52

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Déjà c'est cool tu as au moins le paquet de base du serveur SAMBA => samba/stable,now 2:4.1.17+dfsg-2 amd64  [installé] (le client est déjà présent par défaut sur débian ).

Après faudra voir, si les services sont bien actif, par contre, vu que cela doit faire 1 siècle que j'ai pas utilisé SAMBA ( c'était du temps de samba 3).
Il 'est possible qu'il est changé de nom (mais je ne pense pas).

Il te faut donc contrôler cela avec le commande

systemctl status smbd.service

(si le démon principal  s'appelle toujours smbd ).


Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#5 02-05-2015 22:56:28

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

systemctl status smbd.service

? smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd)
   Active: active (running) since sam. 2015-05-02 20:53:20 CEST; 2h 2min ago
   CGroup: /system.slice/smbd.service
           ??19428 /usr/sbin/smbd -D
           ??19540 /usr/sbin/smbd -D
 

Hors ligne

#6 02-05-2015 23:14:31

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Bien, il est parfaitement actif ton serveur SAMBA depuis 2h 2 minutes.

Du coup, c'est ou que tu bloque ? car sous Débian 8, ont bascule de vieux système traditionnel Unix ( System V) vers systemd du coup les scripts du type

 /etc/init.d/smbd start

par exemple, il faut oublier.

D’ailleurs cela me fera bizarre lorsque les premiers serveurs sur systemd vont débarquer au boulot.


Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#7 02-05-2015 23:59:14

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Oui, il est actif, mais je n'arrive pas à lancer l'interface que j'avais l'habitude d'utiliser pour le paramétrage, l'arrêt et le redémarrage.
Je lance mes applis via "touche windows" + saisie nom programme, et là rien .. donc comment lancer l'interface (GUI n'est-ce pas ?!) de Samba ?

Hors ligne

#8 03-05-2015 00:37:41

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

Je ne suis pas sur que l'interface qui fonctionné sous l’ancienne version de samba, soit compatible avec samba 4.

Il a sûrement été retirer de la distribution, s'il n'est plus compatible.
Je ne sais pas si S.W.A.T l’interface web pour samba et compatible avec SAMBA 4.

J'ai lu quelque part d'un projet de SWAT2 existé pour SAMBA 4 mais, je n'ai pas trouver plus d'information.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#9 03-05-2015 00:38:04

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?



service smbd stop
service smbd start
service smbd restart
service smbd status

 



tu a dans /var/log  des logs de samba

tu a une commande pour reconfigurer samba (je l ai pas en tete )

SWAT ne fait plus partie de debian
il a été supprimé faute de maintient

pour reconfigurer samba


dpkg-reconfigure samba-common samba
 



la version de samba a tres peu évolué entre wheezy et jessie

la commande  pour activer swat (sur wheezy )


update-inetd --enable swat
 



il te faut inetd installé bien sur
l url est http://localhost:901 pour y acceder

Dernière modification par robert2a (03-05-2015 00:52:39)

En ligne

#10 03-05-2015 22:59:26

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

rien à faire après avoir suivi tes instructions robert2a.
Samba ne se lance pas en interface graphique.

Je résume, samba est donc bien installé, mais si je dois me passer de l'interface graphique (dommage car bien pratique) comment puis-je faire pour le paramétrer .. j'avais sauvegardé les parties [global] et [disque1] et [disque2] de mon ancienne instal .. ouf!

Hors ligne

#11 03-05-2015 23:56:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

debi1 a écrit :

rien à faire après avoir suivi tes instructions robert2a.
Samba ne se lance pas en interface graphique.



je n ai pas parlé d interface graphique , je t ai donné quelques info pour vérifier l installation de samba .

et je t ai informé de l arret de la maintenance de swat et le retrait  de celui sur debian jessie. (information officielle de debian mais qui date un peu )

Sinon la moitié de D_F correspond a mon post sur la mise en route de samba lol (je rigole tongue )

donc si tu cherche tu trouvera wiki et posts a ce sujet.

quelques mots clé "samba" ,"wiki samba" , "samba" et rédacteur "robert2a" si tu n'a pas peur d'attraper une migraine.

il me reste une modification a faire , démarrer samba avec inetd (au lieu d un démon ) , je ne l utilise pas beaucoup.

@++

ps: premier lien , courage roll

https://debian-facile.org/viewtopic.php?id=10470

le wiki , a mon avis demande encore un peu de travail , avec je m en suis pas sorti mais je suis un tantiné special wink

https://debian-facile.org/viewtopic.php?id=9685

avec la recherche mot clés "samba" c est un peu plus général mais il ya des posts intéressant

Dernière modification par robert2a (04-05-2015 00:03:43)

En ligne

#12 04-05-2015 06:46:54

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [résolu] SAMBA sur Debian 8 ... ne se lance pas !?

OK merci bcp

Hors ligne

Pied de page des forums