Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-05-2015 17:35:14

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[résolu] owncloud, chiffrement, encfs

Bonjour,


j'arrive d'ici :


http://debian-facile.org/viewtopic.php? … 95#p119395


et j'essaye de chiffrer le répertoire qui sera synchronisé via owncloud-client sur https://webcloud.zaclys.com en m'appuyant sur :


http://doc.ubuntu-fr.org/encfs et


http://doc.ubuntu-fr.org/davfs2#astucen … vie_privee


le montage manuel marche la première fois. Au re-démarrage :


encfs /home/jlg/owncloud/zaclys_f/ /home/jlg/zaclys_o/


Mot de passe :
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
Erreur de fuse. Problèmes courants :
 - module noyau fuse non installé (faites "modprobe fuse")
 - options invalides -- voir le message d'utilisation
 




où doit-on placer l'option "-o nonempty" ?



merci d'avance.
cordialement.
debianux

Dernière modification par debianux (10-05-2015 09:36:43)

Hors ligne

#2 09-05-2015 17:40:35

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

Bonjour debianux !

essaye l'option juste avant l'adresse du premier répertoire :

$ encfs -o nonempty /home/jlg/owncloud/zaclys_f/ /home/jlg/zaclys_o/
Mot de passe :
 



et vérifie avec :

~$ cat /proc/mounts



tu devrais trouver quelque chose comme

encfs /home/jlg/zaclys_o fuse.encfs rw,nosuid,nodev,relatime,user_id=1027,group_id=1001,default_permissions 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
 

Dernière modification par debianux (09-05-2015 18:08:08)

Hors ligne

#3 09-05-2015 17:41:33

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

super debianux, merci !
smile
ou l'art de faire "tricoter" un fil... smile

Hors ligne

#4 09-05-2015 17:43:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] owncloud, chiffrement, encfs

pas cool ça man... smile

Edit :
Je t'ai corrigé le post#1 pour le mettre en conformité avec les balises codes de df.
Je te laisse regarder cela par Modifier sous ce post et corriger les suivants.

Ça ce serait bien cool ! cool

Le tuto qui arrange tout ça :
Voir le tuto : Le code, ça pique moins les yeux en couleur big_smile

Dernière modification par smolski (09-05-2015 17:45:59)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 09-05-2015 17:47:34

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] owncloud, chiffrement, encfs

Bonjour debianux

[voix calme et douce et sourire mielleux]
Ne t'inquiète pas, les messieurs en blanc vont venir te chercher pour t'emmener dans une maison où tu pourras te reposer. Ils t'apprendront à ne plus te parler à toi même ...
[/voix calme et douce et sourire mielleux] lol

Merci pour l'info smile

En plus, si c'est résolu
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 09-05-2015 18:06:21

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

@smolski
ok, je vais modifier !

@bendia
l'histoire n'est pas finie smile
au départ je pensais n'avoir qu'un pb pour automatiser la chose et au moment de rédiger à propos de "pam_mount", qui ne marchait pas, je me suis rendu compte que le "manuel", qui marchait, ne marchait plus smile

donc maintenant je vais aller voir "pam" smile

ps:

[voix calme et douce et sourire mielleux]

on dirait du vécu... et comment ça s'est terminé, pour toi ?
smile

Hors ligne

#7 09-05-2015 18:09:54

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] owncloud, chiffrement, encfs

debianux a écrit :

on dirait du vécu... et comment ça s'est terminé, pour toi


Ben, j'ai arrêté de courir après les moineaux et je ne m'accroche plus aux rideaux à chaque bruit un peu violent qui me réveille durant mes 20 heures de sieste quotidienne big_smile

Edit : Avec la coloration syntaxique, plus besoin des $ ou des # au début des commandes wink


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 09-05-2015 18:16:18

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

après le lancement de la commande encfs, en "manuel", le répertoire "ouvert" comprend 2 titres : on voit et on comprend :


depuis ~/zaclys_o

ls
1710381-entretien-reparation-moteurs-diesel-marins.pdf
auto_reagir-efficacement.odt




fermeture du répertoire :


fusermount -u /home/jlg/zaclys_o




vérification du répertoire "ouvert" : on ne voit plus rien :


depuis ~/zaclys_o

ls
 

zéro réponse.


vérification du répertoire "fermé" : on ne comprend plus rien :
depuis ~/owncloud/zaclys_f

ls
g1,jW1s16lljHkTpylFqqT-vej-UTQGHWoJbUVPe7HPdYPvW1rCMoK0lU1-yFHc9T1RAkaPfGDugqctiINM-NIWY
Sm5IJjPX3EXyBvu2tc5foXeNu3UjZFyAUVAZd1tIdgVts,
 

Dernière modification par debianux (10-05-2015 08:57:14)

Hors ligne

#9 09-05-2015 18:18:49

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] owncloud, chiffrement, encfs

Ah c'est mieux debianux.. encore un effort pour les balises, sépare les commandes des résultats et ne met pas :

:~/owncloud/zaclys_f$


Juste la commande. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#10 09-05-2015 18:47:05

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

[edit] le post initial, qui concerne encfs, est résolu. cette partie sur pam_mount sera reprise ailleurs.



il me semblait, dans ce cas précis, que cela pouvait être utile de préciser à partir de quel répertoire se fait le ls, tout en m'évitant d'avoir à l'écrire à côté smile
sinon, regarde, plus bas, j'ai enlevé le dollar smile

bon, nous voilà au coeur du pb : l'intérieur de "pam" smile

cat /etc/security/pam_mount.conf.xml


<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
  See pam_mount.conf(5) for a description.
-->

<pam_mount>

    <!-- debug should come before everything else,
    since this file is still processed in a single pass
    from top-to-bottom -->

<debug enable="0" />

    <!-- Volume definitions -->

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o/">

    <!-- pam_mount parameters: General tunables -->

<!--
<luserconf name=".pam_mount.conf.xml" />
-->

<!-- Note that commenting out mntoptions will give you the defaults.
    You will need to explicitly initialize it with the empty string
    to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />

<logout wait="0" hup="0" term="0" kill="0" />


    <!-- pam_mount parameters: Volume-related -->


<mkmountpoint enable="1" remove="true" />


</pam_mount>
 



j'ai donc re-démarré car "pam" est censé(e) faire le boulot et ouvrir le couple "zaclys_o et zaclys_f".
à l'ouverture d'un terminal, en root, j'ai droit à des remarques (du frère de "pam" ? smile )

su -


/etc/security/pam_mount.conf.xml:45: parser error : Opening and ending tag mismatch: volume line 17 and pam_mount
</pam_mount>
            ^
/etc/security/pam_mount.conf.xml:46: parser error : Premature end of data in tag pam_mount line 7

^
(rdconf1.c:387): libxml detected a syntax error in /etc/security/pam_mount.conf.xml
/etc/security/pam_mount.conf.xml:45: parser error : Opening and ending tag mismatch: volume line 17 and pam_mount
</pam_mount>
            ^
/etc/security/pam_mount.conf.xml:46: parser error : Premature end of data in tag pam_mount line 7

^
(rdconf1.c:387): libxml detected a syntax error in /etc/security/pam_mount.conf.xml



c'est ma première "pam" modifiée, sans tenir compte de l'option "-o nonempty", dont personne (dans mon installation) n'a l'air de se préoccuper, pour l'instant smile

mais je ne comprends pas grand chose à ces histoires de "tag" pas bons. une idée ?

Dernière modification par debianux (10-05-2015 09:40:12)

Hors ligne

#11 09-05-2015 19:11:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] owncloud, chiffrement, encfs

cossard a écrit :

tout en m'évitant d'avoir à l'écrire à côté


Et alors ?
Les posts du forum ne sont pas destinés à être utilisés par un seul mais par tous les visiteurs et de tous les niveaux.
Il est très important que chacun pense à celui qui n'est pas aussi fortuné en connaissance que lui. C'est le but de df de réaliser cette homogénéïsation de la distribution du savoir partagé équitablement.

Sacré debianux... ça m'évite d'écrire à côté... ah le bras cassé que voilà ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#12 09-05-2015 19:40:57

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

Bien Maître...
et pour pam ?
smile

Edit :
smolski vient d'arranger les balises codes de ton premier post au lieu de travailler sur ses scripts de prod en cours.
En l'occurence c'est donc toi le maître dans cette histoire et ce n'est pas le comportement approprié sur ce forum.

Dernière modification par smolski (09-05-2015 20:04:45)

Hors ligne

#13 10-05-2015 00:10:38

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [résolu] owncloud, chiffrement, encfs

@smolki
je ne comprends pas pourquoi tu es ainsi monté dans les tours pour une simple "blague" : j'ai posé une première question, à laquelle j'ai réussi à répondre : plutôt que la formule "je me réponds à moi-même", j'ai utilisé cette auto-dérision, qui se voulait modestement humoristique.
tu la considère déplacée, c'est ton droit.

dans le même temps je décris ce que j'ai fait afin d'aider, à mon très modeste niveau, la communauté.
lorsque j'ai écrit

~/owncloud/zaclys_f$

, j'ai pensé sincèrement apporter une précision intéressante.

tu considères que ce n'est pas comme ça qu'il fallait faire, c'est ton droit.

lorsque tu écris :

cossard a écrit :

et

ah le bras cassé que voilà !

, là, je trouve que tu dégaines trop vite et trop loin.

mon intention, au départ, était de proposer un article pour le wiki sur ce sujet, si j'arrivais au bout du projet, dans la logique que j'apprécie de

la distribution du savoir partagé

.
là j'en ai beaucoup moins envie.

ne sous-estime pas la sincérité et la spontanéité des débutants tels que moi.
je n'aurai jamais ton niveau de compétence et cela ne me rend pas malheureux.
mais quelques phrases peuvent couper un élan...

smolski vient d'arranger les balises codes de ton premier post au lieu de travailler sur ses scripts de prod en cours.


je t'en remercie et les codes suivants en ont tiré profit, me semble-t-il.

ce n'est pas le comportement approprié sur ce forum.



j'avoue ne pas comprendre quels sont les points de la charte qui, en l'occurence, ont été violés...

Hors ligne

#14 10-05-2015 06:22:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] owncloud, chiffrement, encfs

debianux a écrit :

quels sont les points de la charte qui, en l'occurence, ont été violés...


Ok, regarde :

Ton post#6 :

debianux a écrit :

@smolski
ok, je vais modifier !


Post#8 pas de modification.
post#10 pas de modification. - Dernière modification par smolski (Hier 19:02:40)

Et tu me fais ensuite la morale en m'appelant « maître ».
Je t'ai donc répondu en qualité de modo ce coup-ci, dans ton post#12 et sur le même ton, blaguouneur mais pas trop.

Afin que ce fil soit lu plus facilement par tous (ce n'est pas personnel), je te laisse modifier tes autres posts du fil, ou pas.

debianux a écrit :

...là j'en ai beaucoup moins envie.


Ça n'en sera que mieux réussi, avec l'aide de tous, si tu le veux bien. smile

Edit :

debianux a écrit :

lorsque j'ai écrit
    ~/owncloud/zaclys_f$
j'ai pensé sincèrement apporter une précision intéressante.



Effectivement, mais dans le fil je n'ai pas compris cette intention et je t'en fais mes excuses.
Là, il faut mettre avant la commande le répertoire où tu te situes et non à l'intérieur de la balise.

Ainsi par exemple :

Depuis le répertoire : ~/owncloud/zaclys_ (mais tu peux adopter d'autres façons de le faire...)
et la pure commande en user.

smile

Dernière modification par smolski (10-05-2015 06:56:42)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums