Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-05-2015 17:57:02

Rceez
Membre
Inscription : 27-05-2015

Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Bonjour,
Je suis un nouvel utilisateur de Debian 7 (Wheezy) et je rencontre un problème lors de mon installation de mon serveur FTP, via le package pure-ftpd-mysql.
Je m'aide du tuto http://www.lafermeduweb.net/billet/tuto … l#pureftpd, mais impossible de résoudre le problème que je rencontre.
Alors voila dans ma base de donnée MySQL (accessible via phpmyadmin), j'ai créé une database du nom de GSB qui contient une table "users" qui elle-même contient les logs.
Lorsque j'essaie d'y accéder via ma virtual machine Debian en entrant la commande "ftp localhost", le serveur se connecte bel et bien mais quand j'entre l'identifiant et le mot de passe il en résulte le message suivant:

530 Login authentication failed.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.


Que faire..?

Hors ligne

#2 30-05-2015 18:45:53

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Bonjour,

Es-tu sûr de rentrer les identifiants attendus ? Je pense à un éventuel problème de clavier.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 30-05-2015 20:37:03

Rceez
Membre
Inscription : 27-05-2015

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Oui, il n'y a pas de doute le nom est "PC1" et le mdp est "root". Je l'ai essayer plusieurs fois sans succès.

Hors ligne

#4 19-06-2015 06:17:23

Dessicated
Membre
Distrib. : Debian 7
Inscription : 13-01-2014

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Salut, est-ce que tu est parvenue à résoudre ton problème ?
A vrais dire j'ai exactement le même problème et après avoir passé une bonne dizaine d'heure à lui chercher une solution sur internet, je dois bien admettre être à court d'idée, à moins de trouver quelqu'un qui sait répondre à ce problème ... Pour ma part je pense me diriger vers un autre FTP si je ne trouve pas de solution.

Hors ligne

#5 01-07-2015 08:49:38

Dessicated
Membre
Distrib. : Debian 7
Inscription : 13-01-2014

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Pour ceux que ça intéressent j'ai fini par trouver une solution qui a résolus mon problème, je suis encore relativement novice dans Debian donc il m'arrive très souvent de perdre du temps inutilement au grès des bon et des mauvais conseille qui circulent sur le web, voila pourquoi cette expérience a été très chronophage pour moi et j'espère qu'elle pourras aidé d'autres personnes à l'avenirs.

On commence tout d'abord par vérifier qu'on a bien 50PureDB dans /etc/pure-ftpd/auth/ avec ls -l
On créait ensuite un lien symbolique si ce n'est pas déjà fait avec :

ln -s /etc/pure-ftpd/conf/PureDB /etc/pure-ftpd/auth/75puredb

insérez le cas échéant le résultat de la commande ici



Ensuite si 50PureDB est présent ce qui devrait normalement être le cas, alors on stop le serveur avec /etc/init.d/pure-ftpd-mysql stop puis on vérifie si celui-ci est toujours visible avec ps aux (si celui-ci est encore visible sous la forme SERVER) alors il faut noter son PID et le kill par la suite.

On en arrive au restart, le restart classique ne permettant pas de résoudre le problème de connexion, on relance donc le serveur avec :

/usr/sbin/pure-ftpd-mysql -4 -A -B -c 50 -C 4 -D -E -H -I 15 -j -k 90 -f ftpuser -L 7500:8 -m 4 -s -u 500 -U 033:012 -z -l mysql:/etc/pure-ftpd/db/mysql.conf

insérez le cas échéant le résultat de la commande ici



N'hésitez pas à recommencer l'opération plusieurs fois si le serveur n’apparaît pas avec ps aux, cela n'a pas fonctionné du premier coups pour moi, n'essayé pas de le relancer via la commande ftp.

Vous pouvez aussi supprimer 70pam dans /etc/pure-ftpd/auth/ si le problème de connexion persiste et que vous avez toujours "PAM_RHOST enabled" dans votre sys.logs

Ah oui sinon un dernier conseille : Si vous créez vos tables users pour le ftp via mysql, n'hésitez pas à vider votre cache à chaque déconnexion de phpmyadmin, les bugs graphique sont fréquents et peuvent vous faire perdre un temps fou ou encore vous induire à réaliser des manips contre-productif, en tout cas cela m'est arrivé avec Google Chrome.

Dernière modification par Dessicated (02-07-2015 00:53:18)

Hors ligne

#6 01-07-2015 08:52:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

Super et merci du retour Dessicated. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 01-07-2015 10:33:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

@Dessicated: je m'étonne de la première commande passée en simple user. N'étais-tu pas rootsmile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 02-07-2015 00:52:38

Dessicated
Membre
Distrib. : Debian 7
Inscription : 13-01-2014

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

De rien smile,
effectivement j'ai tout fait en root, j’édite ça tout de suite ^^

Hors ligne

#9 02-07-2015 19:03:29

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème d'authentification sur pure-ftpd-mysql (Erreur 530)

smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums