Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-06-2015 06:58:02

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Outils externes de l'éditeur pluma du bureau mate [Résolu]

Bonjour,

Dans l'éditeur pluma du bureau mate (qui ressemble, à s'y méprendre, à gedit de gnome 2) je n'arrive pas à mettre en service les outils externes:
lorsque je vais dans Edition -- Préférences -- Greffons, je n'arrive pas à cocher la case "Outils externes". Lorsque je clique sur le petit carré correspondant, rien ne se passe. Est-ce parce que cette fonction n'a pas encore été mise en place par les développeurs? C'est bien gênant pour moi
car avec l'ancien gedit, j'en faisais un usage quotidien car j'avais installé les outils externes pour TeX, Latex, Metapost, Asymptote. Existe-t-il un moyen
pour installer quand même ces outils, par exemple en les mettant dans un fichier de configuration approprié? J'ai vainement cherché, car le bouton
"Aide" du menu de pluma ne marche pas: Quand je clique sur Aide -- Sommair dans la barre de menu de pluma, j'ai la réponse: Document non trouvé.

Le passage de whhezy à jessie n'est pas, pour moi, une réussite! Le progrès c'est très bien lorsqu'il ne détruit pas les choses qui auparavant marchaient! Heureusement j'ai gardé wheezy sur mon ordinateur principal.

Cordialement,

C.-M. M.

Dernière modification par cmm (06-06-2015 21:07:07)

Hors ligne

#2 04-06-2015 09:47:18

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Bonjour,

Apparemment, les plugins sont présents dans Jessie : https://packages.debian.org/jessie/all/ … n/filelist

Peut-être peux-tu envisager de réinstaller pluma et pluma-common.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 04-06-2015 12:12:58

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Merci, je vais essayer.

Je viens d'essayer le  live Linux Mint Debian edition, que j'ai mis sur une clef usb bootable faite avec unetbootin.
Sur le pluma de Linux mint Debian edition, l'aide de pluma ne marche pas mieux que sur Jessie, mais le plugin Outils externes marche.
Il n'y a donc aucune raison pour qu'il ne marche pas dans Jessie! à moins que j'aie oublié d'installer un paquet?

Bien cordialement,

C.-M. M.

Hors ligne

#4 04-06-2015 13:21:21

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Re bonjour,

Je pense qu'il y a un bug dans le pluma de Jessie: impossible d'activer le greffon "Outils externes". J'ai désinstallé et réinstallé pluma et pluma-common deux fois, rien à faire. Par contre, je viens d'essayer de faire tourner mon ordinateur avec le live Linux Mint Debian edition et sur le pluma de Mint
j'ai pu activer ce greffon. Cela m'a incité à essayer d'installer Mint Debian edition sur un vieux portable que j'ai en réserve, et j'ai pu installer, dans pluma, tous les outils externes pour TeX, Latex, Metapost et Asymptote. Je ne les ai pas encore tous essayés, mais je pense qu'il y a de grandes chances pour qu'ils fonctionnent.

Après tout, Mate a été développé par Mint, on comprend que l'original marche mieux que la copie! C'est ce qui, jusqu'à présent, m'avait incité à rester fidèle à Debian, mais les temps ont changé!

Cordialement,

C.-M. M.

Hors ligne

#5 04-06-2015 14:28:41

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Je confirme: le pluma de Linux Mint Debian edition marche mieux que celui de Jessie. J'ai installé Jessie avec pluma sur un deuxième vieil ordinateur,
et sur cet ordinateur, comme sur le premier, il est impossible d'activer le greffon "Outils externes" de pluma, alors que c'est possible sur le pluma de Debian mint.

J'ai eu des messages d'erreur en testant les outils pour TeX et Asymptote installés dans pluma, alors qu'ils marchaient très bien avec gedit.
J'ai dû faire des erreurs en les recopiant dans pluma.

Quelqu'un (ou une) ayant pluma sur son ordinateur pourrait-il (ou elle) essayer, dans le menu Edition--Préférences--Outils externes, de cocher le petit carré servant à activer ce greffon? Je n'y suis pas parvenu sur deux ordinateurs différents, mais c'est peut-être moi qui ne sais pas m'y prendre.

C.-M. M.

Dernière modification par cmm (05-06-2015 09:04:57)

Hors ligne

#6 06-06-2015 13:01:39

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Bonjour,

Décidément personne ne s'intéresse au bon fonctionnement de pluma sur Debian 8, à part moi. Je confirme une fois de plus: il y a quelque chose qui ne va pas dans le pluma qui s'installe à partir des dépôts de Debian Jessie: il est impossible d'activer le plugin des outils externes. Je viens d'essayer, une nouvelle fois, de le désinstaller et de le réinstaller, c'est toujours pareil.

Par contre, le pluma qui s'installe avec Linux Mint Debian edition, avec le bureau Mate, marche très bien et il est facile d'y adapter les outils Latex, Metapost et Asymptote de Christophe Grospellier et Denis Le Fur: il suffit, dans les scripts shell de ces outils, de remplacer partout GEDIT par PLUMA.

Le fait que Pluma installé avec Debian Jessie ne marche pas bien et que celui installé avec Linux Mint Debian edition fonctionne correctement est
d'autant plus incompréhensible que les dépôts de packages utilisés par Mint, à par un dépôt spécifique, sont ceux de Debian Jessie!

C.-M. M.

Dernière modification par cmm (06-06-2015 13:05:20)

Hors ligne

#7 06-06-2015 13:22:21

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Hors ligne

#8 06-06-2015 13:51:52

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Merci pour l'information! Je ne savais pas bien comment faire pour signaler une anomalie, je ne suis qu'un utilisateur non informaticien. Je vais peut-être d'abord essayer d'installer le pluma de unstable pour voir s'il comporte le même problème.

Bien cordialement,

C.-M. M.

Hors ligne

#9 06-06-2015 14:06:30

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

En fait, le rapport de bug explique que l'installation permet de résoudre son pb

apt-get install python-gtksourceview2

insérez le cas échéant le résultat de la commande ici



avant de se lancer dans l'installation d'une autre version, lances l'application dans le terminal et essaie d'activer les plugins. Tu nous donneras le contenu du terminal.

Hors ligne

#10 06-06-2015 21:04:42

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Outils externes de l'éditeur pluma du bureau mate [Résolu]

Merci beaucoup, çà résoud en effet le problème. Voici le résultat de la commande:

aptitude install python-gtksourceview2

Les NOUVEAUX paquets suivants vont être installés :    
  python-gtksourceview2
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 147 ko d'archives. Après dépaquetage, 1 147 ko seront utilisés.
Prendre :  1 http://debian.proxad.net/debian/ jessie/main python-gtksourceview2 amd64 2.10.1-2 [147 kB]
 147 ko téléchargés en 0s (3 892 ko/s)        
Sélection du paquet python-gtksourceview2 précédemment désélectionné.
(Lecture de la base de données... 92651 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-gtksourceview2_2.10.1-2_amd64.deb ...
Dépaquetage de python-gtksourceview2 (2.10.1-2) ...
Paramétrage de python-gtksourceview2 (2.10.1-2) ...



Et après cela on n'a plus aucune difficulté pour activer le greffon "Outils externes".

Merci encore, bien cordialement,

C.-M. M.

Hors ligne

Pied de page des forums