Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-06-2015 13:04:42

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Migration Debian 7 vers 8 : Plus de Sites Web

Bonjour à tous,


Je sollicite une nouvelle fois votre aide.


J'ai "tenté" une migration de Debian 7 à 8, tout semble fonctionner (je dit "semble" car je n'ai pas tout vérifié) à part le fait que je n'ai plus de sites web fonctionnels.


En effet, tous les sites développés sur mon serveur ne fonctionnent plus. J'ai pu lire sur le web que les fichiers qui se trouvent dans sites-availables devaient avoir l'extension .conf... Bon.. (pourquoi pas..) je m’exécute et supprime tous les fichiers virtualhost de sites-enabled et renomme les fichiers en .conf dans sites-availables.


Premièrement, le a2dissite ne fonctionne plus et impossible de redémarrer apache comme j'avais l’habitude de le faire avec :


service apache2 reload




La réponse :

Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
 




Suite à ça, je lance comme demandé :


 systemctl status apache2.service
 




Voici ce que j'obtiens :


 apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since dim. 2015-06-07 11:49:04 CEST; 31min ago
  Process: 1474 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

juin 07 11:49:04 macdebian apache2[1474]: Action 'configtest' failed.
juin 07 11:49:04 macdebian apache2[1474]: The Apache error log may have more information.
juin 07 11:49:04 macdebian systemd[1]: apache2.service: control process exited, code=exited status=1
juin 07 11:49:04 macdebian systemd[1]: Failed to start LSB: Apache2 web server.
juin 07 11:49:04 macdebian systemd[1]: Unit apache2.service entered failed state.
juin 07 12:01:38 macdebian systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
juin 07 12:04:33 macdebian systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
juin 07 12:04:38 macdebian systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
juin 07 12:06:07 macdebian systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
juin 07 12:19:28 macdebian systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
 




Donc apparemment, ce sont mes fichiers VirtualHosts qui ne sont plus aux normes !!


Pour test j'ai ensuite copié le fichier 000-default.conf du repertoire sites-availables vers monsite.conf en changant le chemin de mon site qui se trouve dans /home/monsite. Quand je test localhost dans mon navigateur Web mon site s'affiche (enfin..) le seul problème c'est que le PHP n'est plus interprété... un simple <?=echo "toto"?> ne s'affiche pas...


Portant la commande "systemctl status apache2.service" ne retourne plus d'erreur...


Une idée ??


Merci par avance


Orsam


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#2 09-07-2015 06:41:10

aurel-son
Membre
Lieu : Vietnam
Distrib. : Stable/Testing
Noyau : 3.2/3.18
(G)UI : Mate
Inscription : 23-03-2015
Site Web

Re : Migration Debian 7 vers 8 : Plus de Sites Web

Salut
Que nous donnes les details de la commande journalctl -xn ?

Desktop : Debian Jessie Mate/Kali
Serveur/NAS/firewall : Debian stable,Centos,BSD

Hors ligne

#3 09-07-2015 08:54:07

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Migration Debian 7 vers 8 : Plus de Sites Web

Plop smile

Orsam999 a écrit :

J'ai "tenté" une migration de Debian 7 à 8, tout semble fonctionner (je dit "semble" car je n'ai pas tout vérifié) à part le fait que je n'ai plus de sites web fonctionnels.


Il y a eu pas mal de changements entre Apache 2.2 et Apache 2.4. Tu as lu les notes de publications ? https://www.debian.org/releases/stable/ … pd-incomat C'est une bonne habitude à prendre que de les lire AVANT chaque migration smile Il y a quelques liens à ce sujet.


Orsam999 a écrit :

En effet, tous les sites développés sur mon serveur ne fonctionnent plus. J'ai pu lire sur le web que les fichiers qui se trouvent dans sites-availables devaient avoir l'extension .conf... Bon.. (pourquoi pas..) je m’exécute et supprime tous les fichiers virtualhost de sites-enabled et renomme les fichiers en .conf dans sites-availables.


Les fichiers de sites-enabled aussi doivent avoir l'extension .conf.


Orsam999 a écrit :

Premièrement, le a2dissite ne fonctionne plus et impossible de redémarrer apache comme j'avais l’habitude de le faire avec :


a2dissite fonctionne très bien, mais, il s'attend à trouver un fichier avec l'extension .conf dans sites-enabled, et il s'attend peut-être aussi à ce que ce fichier soit un lien symbolique vers le .conf du sites-available.

Orsam999 a écrit :

Donc apparemment, ce sont mes fichiers VirtualHosts qui ne sont plus aux normes !!


C'est sans-doute vrai, mais ça ne devrait pas empêcher Apache2 de se lancer.


Orsam999 a écrit :

Pour test j'ai ensuite copié le fichier 000-default.conf du repertoire sites-availables vers monsite.conf en changant le chemin de mon site qui se trouve dans /home/monsite. Quand je test localhost dans mon navigateur Web mon site s'affiche (enfin..) le seul problème c'est que le PHP n'est plus interprété... un simple <?=echo "toto"?> ne s'affiche pas...


Par défaut, par mesure de sécurité, les short-tags PHP sont désactivés. Essaye plutôt avec le code:

<?php echo "toto"; ?>




Orsam999 a écrit :

Une idée ??


Pour moi, ta démarche de débuggage était déjà assez bonne.

  1. Tu commences par supprimer tous les fichiers dans sites-enabled.

  2. Tu renommes les fichiers en .conf dans le sites-available

  3. Tu actives un de tes vhosts avec a2ensite

  4. Tu regardes petit à petit ce qu'il faut changer pour que ça fonctionne.



Si tu n'utilises pas de module apache2 compilé à la main ou trop exotiques, ça ne devrait pas changer grand chose.

Il te faut simplement penser à remplacer les « order allow,deny, allow from all » par des « Require all granted » et ce sera déjà pas mal.

Pour ton php, pense à virer les short-tags, ou si tu y tiens vraiment, à les activer dans le php.ini (un des problèmes avec les short-tags, c'est que tous les fichiers .xml contiennent des <? et ?>, mais ne sont pas exécutable par php pour autant. C'est donc une bonne habitude que de s'en passer smile )


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums