Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-07-2015 00:28:59

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Panne de mon système de démarrage.

Bonjour,

On n’est jamais à l’abris d’une panne de son chargeur de démarrage !

Mon PC ne démarrait plus, ou pour être plus exact il démarrait puis il s’arrêtait, redémarrait et s’arrêtait à nouveau. Il n’affichait plus que le curseur au moment du redémarrage. Et cela  se poursuivait indéfiniment.
Impossible d'obtenir l'affichage d'un terminal.Pas de texte.

A chaque fois que cela arrive je suis obligé de débrancher, puis de déconnecter 2 disques durs sur 3 en espérant que le PC redémarre sur le dernier disque connecté. S’il ne redémarre pas j’essaie avec un autre disque et ainsi jusqu’à l’obtention d’un redémarrage.
Cette opération est longue, fastidieuse...
Cette fois-ci moultes tentatives se sont soldés par un échec.
Même en connectant le disque dur sur lequel est installé le Grub cela n’a pas marché.
Puis enfin l’ordi a démarré sur le disque réservé à Sid.

J'aimerais bien comprendre ce qui s'est passé. Grub est installé sur le disque consacré à Ubuntu. J'ai éteint l'ordi alors que je venais de faire une mise à jour   sur Sid , après avoir supprimé KDE et ses dépendances. Est-ce - qu'il y a un rapport ? J'ai tenté le redémarrage sur un live cd mais sans réussir. big_smile

Dernière modification par avinash (07-07-2015 00:30:47)

Hors ligne

#2 07-07-2015 10:52:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Panne de mon système de démarrage.

Bonjour,

avinash a écrit :

J'ai tenté le redémarrage sur un live cd mais sans réussir. big_smile

Peux-tu décrire précisément la situation ?  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 07-07-2015 12:14:54

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : Panne de mon système de démarrage.

Bonjour Pascal,
J'ai 3 systèmes sur 3 disques dur et le grub que je mets à jour sur Ubuntu (sudo update-grub). La plupart du temps ça fonctionne: je choisis l'o.s au démarrage sur l'écran de boot.
Mais dimanche soir après une mise à jour sur Sid et la suppression de kde j'ai éteint l'ordi et il n'a pas redémarré. Donc je m'en suis sorti en débranchant alternativement mes disques durs afin de tenter de redémarrer sur un o.s. Ce qui a fini par se produire.
Je me demande si je ne pourrais pas me télécharger sur cdrom un grub rescue en cas de panne ( écran noir, pas d'accès à une console).
Si je ne fais rien l'ordi démarre quelques secondes puis s'arrête puis redémarre, en boucle, indéfiniment: il cherche ce qu'il ne trouve pas pendant quelques secondes. Au démarrage il y a le système d'amorçage, je crois...
En fait je cherche l'explication théorique de ce qui se passe dans ces premières secondes avant que l'ordi s'arrête, sans doute, parce qu'il ne trouve pas le Grub... ?

Dernière modification par avinash (07-07-2015 12:15:51)

Hors ligne

#4 07-07-2015 12:20:40

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Panne de mon système de démarrage.

Si une live ne fonctionne pas, c'est plutôt embêtant.
Tu peux toujours voir ce qu'il se passe avec Super Grub2 Disk

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 07-07-2015 16:44:34

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : Panne de mon système de démarrage.

Merci Pascal, je me documente sur le Super Grub2 Disk.

Mais aussi j'essaie d'identifier le problème:
Au démarrage de l'ordinateur le Bios s'occupe de tester et d'initialiser tous les matériels. C'est la séquence de préboot. Donc avant me que l'OS soit lancé est-ce que du texte s'affiche sur l'écran ?
Car dans mon cas aucun texte ne s'affichait hormis le curseur qui clignotait.

Dernière modification par avinash (07-07-2015 17:11:59)

Hors ligne

#6 07-07-2015 18:40:22

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Panne de mon système de démarrage.

Peut-être ton bios est-il en "mode silencieux" ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 07-07-2015 18:52:58

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : Panne de mon système de démarrage.

En fait devant un bios silencieux on est comme le véto qui doit soigner. Toubib chez les humains ça semble plus facile: au moins on peut interroger la bête ! Mais la vraie bête celle qui ne parle pas elle ne renseigne pas beaucoup de prime abord.
Enfin ma bête informatique a bien voulu parler à nouveau !
Il fut un temps pas si lointain où je n'avais qu'un ordi et en cas de panne plus rien pour interroger un forum...

Dernière modification par avinash (07-07-2015 18:53:31)

Hors ligne

#8 07-07-2015 19:58:45

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Panne de mon système de démarrage.

avinash a écrit :

Il fut un temps pas si lointain où je n'avais qu'un ordi et en cas de panne plus rien pour interroger un forum...

J'ai connu ça.  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums