Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-03-2009 10:14:18

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

module nvidia does not exist in /proc/modules

lors de la mise à jour Etch vers Lenny je reste bloqué à la partie graphique... Le système s'étant préalablement arrêté (bug ?) à initramfs que j'ai pu passé en effaçant l'ensemble initramfs-tools et en relançant...

Pour X J'ai suivi la démarche :

# apt-get install nvidia-kernel-source module-assistant nvidia-settings nvidia-xconfig
# m-a prepare && m-a a-i nvidia
# grep -q ^nvidia /etc/modules || echo nvidia >> /etc/modules
# apt-get install nvidia-glx
la commande suivante m'a affiché le message cité en sujet...
# rmmod nvidia
# modprobe nvidia

j'ai modifié "install nvidia-glx" en "nvidia-glx-legacy" car j'ai une NV - VANTA
j'ai tenté également avec "xserver-xorg-video-nv"

D'autres précisions pour m'aider ?

Merci

Hors ligne

#2 08-03-2009 10:36:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : module nvidia does not exist in /proc/modules

Bonjour et bienvenue sur DF guynux,

Non, que je puisse t'aider, désolé, mais je ne comprends pas ton entame :

... je reste bloqué à la partie graphique ...


Si tu le peux, dis nous :
As-tu un écran graphique mal configuré..? tongue
     Ou rien, que dalle.. nib ? roll

Afin d'en savoir plus sur tes installations, peux-tu nous mettre une copie du sources.list par :

$ cat /etc/apt/sources.list


Et le fichier preferences (du même endroit...) s'il y a lieu...

Et puis le :

$ lspci


de ta carte graphique... des fois que...

Tout ça afin qu'en cas de résolution, hein...
Cela puisse être clair et net pour de nouveaux consultants quoi... une fois... wink

Amitié, Joel

Dernière modification par smolski (08-03-2009 10:45:08)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 08-03-2009 11:45:41

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : module nvidia does not exist in /proc/modules

Salut,

apres installation du pilote Nvidia, il faut dire à Xorg de l'utiliser donc modifier xorg.conf et rajouter
nvidia dans la section device à coté de driver --> Tuto Nvidia

ne tient pas compte de la deuxieme partie du tuto rajouté par Damien, installation du pilote propriétaire via le .run, la premiere via module-assistant installe aussi la version propriétaire, le titre a été modifié pour driver libre, c'est faux, le driver libre est xserver-xorg-video-nv, donc Damien si tu passes par là ou les prochains qui postent ds le wiki, prévenez lorsque vous modifiez une page existante du wiki, au moins un mail au premier auteur, ce n'est pas grave en soi, mais une doc ne doit pas contenir ce genre d'erreur,
déjà le titre "ndidia" à changer pour nvidia, à la limite même si je suis pas pour le .run on peut indiquer "autre méthode d'installation du pilote nvidia", Merci.

Hors ligne

#4 08-03-2009 11:58:34

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

merci d'avoir répondu si vite...

j'ai un écran console... apparemment les commandes passent bien

j'ai remplacé les "Etch" de mon "sources.list" par des "Lenny"
voici mon "sources.list" :

#deb http://ftp.fr.debian.org/debian/ lenny main
#deb-src http://ftp.fr.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
(je viens de constater que sur la ligne précédente j'ai oublié de changer mon etch en lenny (bravo le mec !) mais est-ce la source des problèmes ?)
deb-src http://security.debian.org/ lenny/updates main contrib

deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb http://ftp.fr.debian.org/debian/ lenny non-free

deb http://www.debian-multimedia.org/ lenny main

deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
Peut-être que cette dernière ligne (récupérée sur conseil du Web n'est pas souhaitable !) je la commente !


que veux-tu dire par "fichier preferences (du même endroit...)" ?

le lspci pour la carte graphique est : VCA compatible controller : nvidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

Suite à la découverte de ces 2 lignes bizarres dans mon "sources.list" j'ai fait "aptitude update" et "aptitude upgrade", et j'ai rebooté... mais toujours retour en console et même message en lançant "rmmod nvidia"... Je vais relancer maintenant l'install complète de nvidia (peut-être que la référence US présente dans mon "sources.list" est en cause...

J'ai trouvé aussi ici : https://forum.debian-fr.org/viewtopic.p … w=previous l'existence d'un bug en ... juin 2007 !

Merci à toutes et tous...

Guynux

Hors ligne

#5 08-03-2009 12:05:56

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

Merci Neos
    Je réponds aussitôt sans avoir relancer mon install comme dit dans message précédent car que me conseilles-tu le libre ou le proprio ? (il ne s'agit pas de faire des jeux mais d'être plutot passe partout...)

   Quand au "xorg.conf" j'avais vu les remarque et recopié le "xorg.conf" de ma config "Etch" qui pointe bien vers nvidia...

   Tout ça sans succès

   Encore merci

Hors ligne

#6 08-03-2009 12:13:25

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : module nvidia does not exist in /proc/modules

deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
Peut-être que cette dernière ligne (récupérée sur conseil du Web n'est pas souhaitable !) je la commente !
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free

sont inutiles.

je te conseille ceci pour lenny (actuel stable)

# Dépôts lenny (Stable)
    deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
    # Dépots sécurité
    deb http://security.debian.org/ lenny/updates main contrib non-free
    # Dépôts Multimédia
    deb http://www.debian-multimedia.org/ lenny main


j'ai volontairement enlever les lignes deb-src, qui n'ont aucun interet si tu ne compile pas de paquets via apt-get source par exemple

Hors ligne

#7 08-03-2009 12:29:33

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

Après avoir tenté de reconfigurer avec le libre : "aptitude install xserver-xorg-video-nv" j'ai rebooté, et je reviens encore en console, en faisant "/etc/init.d/kdm" puis ""startx" le message change !!! le voici :
FATAL : error inserting nvidia (/lib/modules/2.6.26-1-686/nvidia/nvidia.ko) : no such device
NVIDIA(0) : Failed ti load the NVIDIA kernel module !
Screen(s) foud , but none have a usable configuration...
...
Sans doute que mes config proprio et libre entre en conflit, non ? comment faire ?

Hors ligne

#8 09-03-2009 16:57:37

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : module nvidia does not exist in /proc/modules

Salut,

Lances la commande:

ls -l /lib/modules/


et donnes-nous le résultat, s'il te plaît.

Rappelles-nous aussi les noms exacts des paquets que tu as installés pour nvidia ? (nv n'est pas un driver pouvant offrir la 3D, il faut un driver nvidia le plus récent possible, choisi en se basant sur ton chipstet).

Si tu ne sais pas ce que tu as installé, tu peux chercher à partir de la fin du fichier /var/log/apt/term.log

Il y a une ligne qui s'intercale avec la date quand tu as fait des opérations utilisant un gestionnaire de paquet, tu dois donc pouvoir trouver les derniers modules nvidia installés.

PS: pour retrouver l'interface graphique, avec le module 'nv', tu dois mettre "nv" sur la ligne "Driver" dans le fichier /etc/X11/xorg.conf à la place de "nvidia".

Tu peux éditer de fichier en root avec nano, depuis ton invite de commande en mode texte.

(Ctrl+O pour écrire, et Ctrl+X pour quitter, je crois : tu regardes en bas dans nano, il y a écrit ^+O ou ^O pour Ctrl+O, chose comme ça et ^X pour Ctrl+X)


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#9 09-03-2009 23:16:38

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

Bonsoir, pour l'instant : à la commande "ls -l /lib/modules/" j'ai bizarrement des affichages de droits... normal ? : voici les 4 lignes :
total 3
drwxr-xr-x 3 root root 1024 fév 16  2008 2.6.18-4-686
drwxr-xr-x 4 root root 1024 fév 16  2008 2.6.18-5-486
drwxr-xr-x 3 root root 1024 mar 8 11:39 2.6.26.-1-686

Hors ligne

#10 10-03-2009 11:39:19

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

mon feuilleton nvidia (suite)
    Il m'est venu l'idée (simpliste) de remplacer "nvidia" dans mon "xorg.conf" (que j'avais copié de la version précédente : Etch) par "vesa" après avoir fait un vulgaire "aptitude install xserver-xorg-video-vesa" et là miracle je retrouve mon home précédent (celui de Etch !)

   Je suppose qu'un pilote adapté à ma carte (j'en ai quand même une quinzaine à configurer) serait plus fluide (mais peut-être très -trop- gourmand ? De toutes façons il n'est pas question de jeux...) J'ai des cartes "VANTA NV6" chipset TNT2
   ... et pilote Debian ou Nvidia (je suppose le "nvidia-glx-legacy-96xx") . (et il me faudra nettoyer les paquets inutiles...

    Un avis ?

   Grand merci d'avance

Hors ligne

#11 10-03-2009 11:56:14

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : module nvidia does not exist in /proc/modules

J'ai peut-être trouvé une réponse en regardant la description du pilote propriétaire : les TNT ne sont plus supportées, comme les premières Geforce, même par la version legacy.

Par contre le pilote libre nv les supporte. As-tu bien essayé de mettre nv dans ton xorg.conf comme Melodie te l'a suggéré (avec xserver-xorg-video-nv d'installé bien sûr) ?

Si ça fonctionne tu pourras retirer les paquets nvidia-* qui ne te serviront à rien...

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#12 10-03-2009 12:50:28

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

J'en viens à la même conclusion...
   J'ai installé nv libre... (avec synaptic) ; je modifie mon "xorg.conf" de "vesa" en "nv" ; je reboote aucun problème...
   J'ai installé "nvidia-glx-legacy-96xx" (avec synaptic qui me propose de charger le noyau correspondant) je dis ok, je modifie mon "xorg.conf" de "nv" en "nvidia" ;  je reboote... et là de nouveau console !
   Il me dit lorsque je lance "startx" à la main : "Failed to load the Nvidia kernel module !" "Error inserting nvidia (/lib/modules/2.6.26-1-686/nvidia.ko) : No such device)
   C'est bien la traduction que le pilote n'est pas bon ??? : "nvidia.ko" ???

     J'ai par ailleurs découvert le projet "Nouveau" sur le site : http://forum.debian-fr.org/viewtopic.php?f=8&t=17595 je vais esayer..

    Je veux "juste" afficher différents "flash" notamment du Web -que j'ai presque réussi sur une autre série d'ordinateurs : des "Compaq Desktop" mais quelle galère pour y arriver!

   Pour la petite histoire après un "glxgears -info" (sous lenny) j'ai 110 fps avec vesa ! 125 avec nv pas top quand même... Peut-être un autre problème ?

Merci à toutes et tous...

A bientôt ?

Hors ligne

#13 10-03-2009 13:03:45

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : module nvidia does not exist in /proc/modules

Le projet nouveau est assez récent je crois, tiens nous au courant si tu réussis à l'installer, peut-être auras-tu du mieux. En tout cas, à terme, il devrait supporter la partie 3D.

Après une TNT2 c'est pas d'aujourd'hui, ne t'attends pas à des performances merveilleuses, surtout si tu as l'ordinosaure qui va avec ! wink

D'après ce que j'ai compris tu comptes utiliser cette machine surtout pour du web et de la bureautique ? Tu utilises quel environnement graphique ? Si tu as Gnome ou KDE, regarde du côté d'Xfce ou de Fluxbox (ou autres) : voir le wiki. Une interface plus légère te fera sans doute gagner de précieux fps... smile

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#14 10-03-2009 13:19:29

guynux
Membre
Distrib. : wheezy
Noyau : 3.2.0-4-686-pae #1 SMP Debian 3.2.53-2 i686 GNU/Li
(G)UI : KDE
Inscription : 08-03-2009

Re : module nvidia does not exist in /proc/modules

Ma situation :
   Je suis prof -en collège où je suis seul à pratiquer Linux, même le gestionnaire réseau ne connais que W...- j'ai récupéré des ordis du lycée voisin (des PIII) qui étaient en réseau bien sûr -que je n'ai pas dans ma salle, que je voudrais placer avec un serveur Debian (quand je toucherai un peu plus). Pour l'instant ils sont donc tous "hors Web". Je récupère des fichiers "pédagogiques" -la plupart en "Flash" -bonjour les surprises !- que j'installe sur ces postes.. J'en configure un, puis ensuite avec la commande super puissante -mais longue- "dd..." je les multiplie comme des petits pains !
    Donc mon exigence est modeste (je crois, sourire), matériel aussi : PIII à 733 Mhz ou 1Ghz, 128 Mo ou 256 Mo, carte TNT 2... duo ou trio boot (W95 et W98). Donc usage : bureautique, lecture de cours plus ou moins animés... mais avec config élève proche de W qu'ils pratiquent... Je peux mettre des liens sur les doc (notamment PSA que je récupère après parfois bien du sport : utilisation de la mémoire cache pour récupérer par petits bouts les différents morceaux des documents...)
   Cela parait clair ?

Hors ligne

#15 10-03-2009 13:44:49

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : module nvidia does not exist in /proc/modules

Oui, avec un PIII, y'a largement de quoi faire ! J'en ai récupéré un il n'y a pas longtemps avec une config assez proche, je l'ai remis en état avec une Debian minimale (pendant l'installation, au moment du choix des logiciles à installer, j'ai tout décoché), puis l'environnement Xfce par la suite. C'était pas mal, pas un foudre de guerre mais largement acceptable. D'ailleurs il termine sa vie dans une école primaire ! smile

Si tu veux voir à quoi ça ressemble, le site du projet : http://www.xfce.org/?lang=fr.

Bon courage !

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

Pied de page des forums