Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-07-2015 19:02:24

piratex
Membre
Distrib. : Debian GNU/Linux
Noyau : Linux 3.16.0-0.bpo.4-amd64
Inscription : 24-11-2014

Installer des paquets instables

Bonjour,

Je suis NEWBIE je tiens à le préciser , je voudrais installer des paquets instables comment faire ?
Je veux installer codeblock (derniere version 12) en effet des que je l'installe une version j'ai toujours une ancienne version stable  comme à chaque fois que j'installe un programme d'ailleurs

Si quelqu'un sait comment faire ça m'aiderait beaucoup.

Merci d'avance smile

Hors ligne

#2 29-07-2015 19:31:52

stephgarg
Membre
Lieu : Périgueux
Distrib. : Debian GNU/Linux Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 01-01-2015

Re : Installer des paquets instables

Bonjour à tous.

Est-il vraiment nécessaire d'avoir la version du paquet 'codeblocks' de chez Unstable (Sid) ?

Notons que c'est la même pour Testing (Stretch) et, aussi, pour le dépôt 'jessie-backports' à la date d'aujourd'hui.

De plus, on ignore quelle version de Debian tu utilises...

Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Et voilà, un second point chocolat Debian Facile pour moi. smile

A bientôt.

Dernière modification par stephgarg (29-07-2015 19:40:49)


Trois PC dont un fixe Sirius, un transportable Canopus et un miniportable Arcturus. smile
Sirius : AMD Athlon 64 X2 à 3 GHz, SDRAM DDR2 800 MHz de 8 Gio, 2 WD VelociRaptor SATA2 de 1000 Go.
Canopus : Intel Core 2 Duo à 2 GHz, SDRAM DDR2 667 MHz de 4 Gio, WD Black Mobile SATA2 de 750 Go.
Arcturus : Intel Atom N270 à 1,6 Ghz, SDRAM DDR2 533 MHz de 2 Gio, Hitachi SATA2 de 160 Go.

Hors ligne

#3 30-07-2015 05:08:46

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Installer des paquets instables

lol stephgarg... Plutôt humble big_smile

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#4 30-07-2015 13:09:34

piratex
Membre
Distrib. : Debian GNU/Linux
Noyau : Linux 3.16.0-0.bpo.4-amd64
Inscription : 24-11-2014

Re : Installer des paquets instables

oui c'est vraiment nécessaire puisque je veux le faire pour savoir comment ça marche .

Hors ligne

#5 31-07-2015 07:32:59

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Installer des paquets instables

Bonjour,

Après avoir ajouté le dépot sid dan le fichier sources.list, il te faudra créer le fichier preferences, puis installer la version désiré (avec aptitude) :


aptitude update && aptitude install -t unstable codeblocks
 


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#6 31-07-2015 10:10:31

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installer des paquets instables

Bonjour,

Il est en général plus rassurant d'utiliser apt ou apt-get qu'aptitude : https://www.debian.org/doc/manuals/debi … de_literal  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 31-07-2015 11:01:38

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Installer des paquets instables

Aptitude n'est pas recommandé uniquement pour passer le système globale d'une release à une autre, même si je n'ai jamais rencontré de problème.

(Et ce même si je migre doucement vers apt.)

Dernière modification par kawer (31-07-2015 11:02:13)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#8 31-07-2015 11:07:59

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installer des paquets instables

Pas d'accord : en dehors d'une mise-à-niveau, j'ai bien souvent rencontré des comportements déroutants.
Je le déconseille donc absolument pour un débutant.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums