Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-03-2009 16:21:40

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

[Résolu] Réglage de l'horloge

Coucou !
Quand je démarre puis que j'ouvre ma session soit je suis connecté au net et l'horloge est à l'heure, soit je suis hors ligne ou derrière un proxy et là l'horloge indique une heure de trop.
Au démarrage j'ai le message suivant:

Setting the system clock.
select() to /dev/rtc to wait for clock tick timed out
Unable to set System Clock to: mardi 10 mars 2009, 15:32:19 (UTC+0000) (warning).


L'heure qui s'affiche sur ce message est la bonne, elle.

Je viens d'installer Lenny et je n'ai jamais constaté ce problème avant que ce soit sour Debian (Sarge il y a longtemps) ou toutes les dernières ubuntu.
Quelqu'un a eu le même souci ?
Une idée ?

Dernière modification par maceo (12-03-2009 16:26:58)


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#2 10-03-2009 17:30:43

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Salut,

J'ai trouvé une piste par là. Apparemment c'est un problème avec le module rtc qu'il faut remplacer par genrtc, tu peux toujours essayer.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 10-03-2009 19:03:35

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

Merci ... mais j'ai toujours le problème.
En fait je n'ai pas le module genrtc et je ne trouve pas comment l'installer.

# modprobe genrtc
FATAL: Module genrtc not found.


J'imagine qu'ne compilant un noyau on doit pouvoir le générer mais bof ... y a pas un paquet avec des modules complémentaires tout prêts ?


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#4 10-03-2009 20:16:40

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Mmmh, une  autre piste par ici...

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#5 10-03-2009 23:09:03

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : [Résolu] Réglage de l'horloge

Salut ,

As tu essayé de te synchroniser via ntp .

Ca prend 5 min à installer et à configurer ..

Ch.

Hors ligne

#6 12-03-2009 10:36:46

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

Les deux pistes de mani conduisent au module genrtc dont je n'ai aucune trace, et bien qu'ayant un problème identique aux sujets indiqués les mêmes manips n'ont aucun effet chez moi sad

Sinon, oui j'ai bien ntp mais justement c'est certainement pour ça que mon problème n'arrive que lorsque je suis hors ligne. En ligne, ntp doit régle le problème.

Donc j'ai toujours le souci parce que je n'ai pas ce module genrtc que tout le monde sauf moi semble avoir ...

Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#7 12-03-2009 10:47:17

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Est-ce que ton Bios est à la bonne heure ?

Et sinon 'modprobe genrtc' me renvoie une erreur aussi. Je n'ai pas testé les manipulations que j'ai trouvé car je suis connecté en permanence, mais si ça se trouve j'ai le même problème !

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#8 12-03-2009 10:54:37

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

mon bios a toujours marché avec les précédentes distribs.
Débranche toi et reboote pour voir ?
Ceci dit j'ai peut être un bios particulier que le module rtc "normal" ne peut pas gérer. Mais comme avant ça marchait j'ai un doute. Ubuntu 7.10 et 8.04 ont toujours marché par défaut sur cette machine.

Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#9 12-03-2009 11:08:03

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Je ne peux pas pour l'instant, mais je le ferai dans la journée, je te tiens au courant.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#10 12-03-2009 11:37:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Réglage de l'horloge

Tsop !

J'ai bien :

# modprobe genrtc
FATAL: Module genrtc not found.


Extinction du pc - débranchement reseau - reboot...
L'heure reste bien calée... roll

Verifie le bios, voir...

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 12-03-2009 12:17:17

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

J'ai rebooté sous ubuntu 8.04 (je l'ai gardée en dual boot):
l'heure est calée avec pendant la séquence de démarrage un joli message

Setting system clock   [OK]


... et pourtant:

# modprobe genrtc
FATAL: Module genrtc not found.
# modprobe rtc
FATAL: Module rtc not found.


Il y a dans un fichier /etc/modprobe.d/isapnp la ligne:

alias pnp:dPNP0b00 rtc


J'ai donc rajouté comme indiqué ici dans mon fichier /etc/modprobe.d/hotplug-pnp la ligne:

alias pnp:dPNP0b00 genrtc


=> Ça marche pô sad

Re essai avec rtc au lieu de genrtc, toujours rien ... mystère !

PS: j'ai fait ça aussi en créant un /etc/modprobe.d/isapnp comme dans ubuntu mais ça n'a rien changé. Il me semble de toute façon que les noms des fichiers dans /etc/morprobe.d sont libres.

Dernière modification par maceo (15-03-2009 01:58:11)


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#12 12-03-2009 15:03:58

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Bon, j'ai essayé hors-ligne je n'ai pas de problème d'horloge non plus... Je passe la main, désolé ! neutral

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#13 12-03-2009 16:15:42

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

Ça y est !!!!!
Le CD d'installation (netinstall) ne voulait pas booter et j'ai lu qu'il fallait lui donner les options noacpi noapic et nolapic, ce que j'ai fait et m'a permis de booter et d'installer.
Mais ces options ont été recopiées dans mon /boot/grub/menu.lst
Je les ai supprimées, et hop !! Depuis tout roule.

Ce qui m'a mis la puce à l'oreille, c'est ça:
http://bugs.debian.org/cgi-bin/bugrepor … 277298#312

Lien trouvé ici: http://wiki.debian.org/rtc
Arrgh ... j'arrive pas à passer le sujet en Résolu, il est où le bouton ??

Et puis ici aussi j'ai un souci: les messages du forum ont une heure de moins que prévu. Mon profil est en +01 CET et mon ordi est à l'heure maintenant. Je suis le seul comme ça ??

Dernière modification par maceo (12-03-2009 16:22:45)


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#14 12-03-2009 16:22:46

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Réglage de l'horloge

Cool ! smile

Pour le [Résolu] tu as simplement à éditer ton premier message !

Edit : pour l'heure du forum, passe en +2 dans ton profil.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#15 12-03-2009 16:27:36

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

mani a écrit :

Cool ! smile

Pour le [Résolu] tu as simplement à éditer ton premier message !

Edit : pour l'heure du forum, passe en +2 dans ton profil.


Merci !


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#16 12-03-2009 20:07:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Réglage de l'horloge

Merci maceo !

Ton tuto est top, les liens parfaits (mais en anglais... roll )... C'est quand tu veux pour un nouveau problème, tu nous fais avancer grave et correct !

Amitié, Joel

Dernière modification par smolski (12-03-2009 20:12:31)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#17 15-03-2009 02:01:01

maceo
Membre
Lieu : Toulon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 10-03-2009
Site Web

Re : [Résolu] Réglage de l'horloge

smolski a écrit :

Merci maceo !

Ton tuto est top, les liens parfaits (mais en anglais... roll )...


Desoled, excusing ... roll


Quel programmeur C n'a jamais nommé une variable u juste pour le plaisir de faire malloc(u) ?

Hors ligne

#18 19-03-2009 08:50:02

saintshakajin
Modérateur
Distrib. : Unstable
Noyau : uname -r
(G)UI : KDE4
Inscription : 01-06-2007

Re : [Résolu] Réglage de l'horloge

stopher a écrit :

Salut ,

As tu essayé de te synchroniser via ntp .

Ca prend 5 min à installer et à configurer ..

Ch.


Même moins si on prend la config basique:
apt-get install ntp
et ça marche... puis un peu hs mais on fera avec ^^

Hors ligne

Pied de page des forums