Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-08-2015 18:57:32

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

[Résolu] Sid - Wesnoth

Salut !

Depuis peu sous Sid, au bout de deux semaines, ça y est, je fais un post.


Voilà, hier, mise à jour wesnoth que j'ai acceptée, listbugs ne m'a rien signalé et patatra.
Mon jouet est cassé.
Après un remove :

apt install wesnoth
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 wesnoth : Dépend: wesnoth-1.12 (>= 1:1.12.4-1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Dernière modification par Papadakis (04-08-2015 06:16:28)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#2 01-08-2015 19:25:50

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Sid - Wesnoth

Que te renvoie la commande suivante sur ta Sid ?

apt-cache policy wesnoth wesnoth-1.12


Jouer sous Debian ? Facile !

Hors ligne

#3 01-08-2015 19:31:03

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Sid - Wesnoth

apt-cache policy wesnoth wesnoth-1.12



wesnoth:
  Installé : (aucun)
  Candidat : 1:1.12.4-1
 Table de version :
     1:1.12.4-1 0
        500 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
wesnoth-1.12:
  Installé : (aucun)
  Candidat : 1:1.12.4-1
 Table de version :
     1:1.12.4-1 0
        500 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#4 01-08-2015 20:51:26

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Sid - Wesnoth

Le problème se situe donc plus loin.
Que te donne la commande suivante ?

apt-get install -s wesnoth-1.12


(à répéter à chaque nouveau paquet qui t’est signalé par « Dépend: … mais ne sera pas installé » jusqu’à trouver le paquet bloquant)


Jouer sous Debian ? Facile !

Hors ligne

#5 01-08-2015 23:00:13

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Sid - Wesnoth

apt-get install -s wesnoth-1.12


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 wesnoth-1.12 : Dépend: wesnoth-1.12-core (>= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-core (< 1:1.12.4-1.~) mais ne sera pas installé
                Dépend: wesnoth-1.12-httt (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-tsg (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-trow (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-ttb (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-ei (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-utbs (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-did (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-nr (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-sof (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-sotbe (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-l (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-aoi (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-thot (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-low (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-dm (= 1:1.12.4-1) mais ne sera pas installé
                Dépend: wesnoth-1.12-dw (= 1:1.12.4-1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Y'en a pas qu'un smile


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#6 02-08-2015 21:06:43

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Sid - Wesnoth

Regarde juste pour 'wesnoth-1.12-core', je pense que c’est lui qui bloque tous les autres.

apt-cache policy wesnoth-1.12-core
apt-get install -s wesnoth-1.12-core

Dernière modification par vv222 (02-08-2015 21:07:53)


Jouer sous Debian ? Facile !

Hors ligne

#7 03-08-2015 20:56:29

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Sid - Wesnoth

C'est là que ça se complexifie (j'avais laisser tomber)

apt-cache policy wesnoth-1.12-core


wesnoth-1.12-core:
  Installé : (aucun)
  Candidat : 1:1.12.4-1
 Table de version :
     1:1.12.4-1 0
        500 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status



apt-get install -s wesnoth-1.12-core


NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 apache2 : Dépend: apache2-bin (= 2.4.16-1) mais ne sera pas installé
 libqt5core5a : Dépend: libicu52 (>= 52~m1-1~) mais ne sera pas installé
 libstdc++6 : Casse: wesnoth-1.12-core (<= 1:1.12.4-1) mais 1:1.12.4-1 devra être installé
 libxml2 : Dépend: libicu52 (>= 52~m1-1~) mais ne sera pas installé
 php5 : Dépend: libapache2-mod-php5 (>= 5.6.11+dfsg-1~) mais ne sera pas installé ou
                 libapache2-mod-php5filter (>= 5.6.11+dfsg-1~) mais ne sera pas installé ou
                 php5-cgi (>= 5.6.11+dfsg-1~) mais ne sera pas installé ou
                 php5-fpm (>= 5.6.11+dfsg-1~) mais ne sera pas installé
 wesnoth-1.12-core : Dépend: libboost-filesystem1.55.0 mais ne sera pas installé
                     Dépend: libboost-iostreams1.55.0 mais ne sera pas installé
                     Dépend: libboost-locale1.55.0 mais ne sera pas installé
                     Dépend: libboost-program-options1.55.0 mais ne sera pas installé
                     Dépend: libboost-regex1.55.0 mais ne sera pas installé
                     Dépend: libboost-system1.55.0 mais ne sera pas installé
                     Dépend: libsdl-image1.2 (>= 1.2.10) mais ne sera pas installé
                     Dépend: libsdl-mixer1.2 mais ne sera pas installé
                     Dépend: libsdl-net1.2 mais ne sera pas installé
                     Dépend: libsdl-ttf2.0-0 mais ne sera pas installé
                     Dépend: libsdl1.2debian (>= 1.2.11) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
 


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#8 03-08-2015 22:07:47

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Sid - Wesnoth

Salut,

Souvent aptitude s'en sort mieux avec la résolution des dépendances, du moins, il cherche des solutions, quitte à downgrader des paquets . ( de unstable vers testing/stable ou autre ... )
As tu essayé avec aptitude ? , tu peux répondre non n pour qu'il propose d'autres solutions .

aptitude install wesnoth-1.12 -s



smile

Dernière modification par nono47 (03-08-2015 22:13:45)

Hors ligne

#9 03-08-2015 22:54:50

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Sid - Wesnoth

@papadakis: Sid est en pleine transition gcc5 et libstdc++. Il va falloir être un peu patient avant que les choses ne se dé-cassent smile Il y a plus d'un millier de paquets qui semblent affectés par cette transition…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 03-08-2015 23:56:32

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Sid - Wesnoth

Tu as apparemment un conflit entre libstdc++6 et wesnoth-1.12-core comme captnfab le fait remarquer.
Ici j’ai bloqué ce paquet à sa version 5.1.1-14 et je n’ai aucun problème à installer wesnoth 1.12.

Jouer sous Debian ? Facile !

Hors ligne

#11 04-08-2015 06:16:10

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Sid - Wesnoth

Je me doutais qu'à un moment ou à un autre je serai affecté par la transition gcc5.

Merci pour vos réponses.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#12 04-08-2015 11:30:02

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Sid - Wesnoth

Si tu tiens à retrouver Wesnoth (ce que je comprendrais facilement) tu peux revenir à une version compatible de libstdc++6 via la commande suivante et un peu de gymnastique :

aptitude install libstdc++6=5.1.1-14


Jouer sous Debian ? Facile !

Hors ligne

#13 07-08-2015 22:34:46

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Sid - Wesnoth

vv222 a écrit :

Si tu tiens à retrouver Wesnoth (ce que je comprendrais facilement) tu peux revenir à une version compatible de libstdc++6 via la commande suivante et un peu de gymnastique :

aptitude install libstdc++6=5.1.1-14



Finalement, aptitude est très efficace. smile


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#14 10-08-2015 18:31:44

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Sid - Wesnoth

Salut,

sid ( vilain garçon ! ) m'a désinstallé wesnoth pour se mettre à jour, la libstdc++ casse wesnoth ! . J'attends une mise à jour de wesnoth ? ? ?
Pas envie de downgrader libstdc++, c'est un peu chaud les mises à jour sous sid en ce moment, beaucoup de paquets en attente !

?


smile

Dernière modification par nono47 (10-08-2015 18:39:16)

Hors ligne

#15 11-08-2015 08:17:04

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Sid - Wesnoth

@nono47: Attention à la bernacle !

nono47 a écrit :

sid ( vilain garçon ! ) m'a désinstallé wesnoth pour se mettre à jour, la libstdc++ casse wesnoth ! . J'attends une mise à jour de wesnoth ? ? ?


Je reformule : « Sid t'as proposé de désinstaller wesnoth pour se mettre à jour, et tu lui as dit "oui" » tongue

Oui, je te conseille d'attendre.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 11-08-2015 23:42:55

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [Résolu] Sid - Wesnoth

Bonjour,
Devrais-je préférer faire  les m.a.j  avec un " aptitude update" puis un "aptitude upgrade" ?
Actuellement je teste en utilisant alternativement " apt update && apt upgrade " et aptitude...
Hum ?

Hors ligne

#17 13-08-2015 18:00:22

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : [Résolu] Sid - Wesnoth

Salut,


apt-get install wesnoth-1.10
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Les paquets supplémentaires suivants seront installés :
  libboost-program-options1.55.0 libboost-regex1.55.0 libsdl-net1.2 wesnoth-1.10-aoi wesnoth-1.10-core wesnoth-1.10-data
  wesnoth-1.10-did wesnoth-1.10-dm wesnoth-1.10-dw wesnoth-1.10-ei wesnoth-1.10-httt wesnoth-1.10-l wesnoth-1.10-low
  wesnoth-1.10-music wesnoth-1.10-nr wesnoth-1.10-sof wesnoth-1.10-sotbe wesnoth-1.10-thot wesnoth-1.10-trow wesnoth-1.10-tsg
  wesnoth-1.10-ttb wesnoth-1.10-utbs
Paquets suggérés :
  wesnoth
Les NOUVEAUX paquets suivants seront installés :
  libboost-program-options1.55.0 libboost-regex1.55.0 libsdl-net1.2 wesnoth-1.10 wesnoth-1.10-aoi wesnoth-1.10-core
  wesnoth-1.10-data wesnoth-1.10-did wesnoth-1.10-dm wesnoth-1.10-dw wesnoth-1.10-ei wesnoth-1.10-httt wesnoth-1.10-l
  wesnoth-1.10-low wesnoth-1.10-music wesnoth-1.10-nr wesnoth-1.10-sof wesnoth-1.10-sotbe wesnoth-1.10-thot wesnoth-1.10-trow
  wesnoth-1.10-tsg wesnoth-1.10-ttb wesnoth-1.10-utbs
0 mis à jour, 23 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 322 Mo dans les archives.
Après cette opération, 448 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]




avinash a écrit :

Actuellement je teste en utilisant alternativement " apt update && apt upgrade " et aptitude...
Hum ?


? c'est ce qu'il faut faire.


Tu es sous Jessie je vois, le titre du sujet est Sid - Wesnoth


Pour aptitude, je ne vois pas ce que ça change.

Hors ligne

#18 13-08-2015 23:08:30

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [Résolu] Sid - Wesnoth

J'ai un disque réservé à Jessie et un disque réservé à Sid. J'ai  lu beaucoup de choses concernant l'utilisation de apt update... ou aptitude update...En fait plus je lis à ce sujet moins  c'est clair du point de vue des maj de Sid.

Hors ligne

#19 14-08-2015 13:56:55

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : [Résolu] Sid - Wesnoth

Salut,

avinash a écrit :

J'ai un disque réservé à Jessie et un disque réservé à Sid. J'ai  lu beaucoup de choses concernant l'utilisation de apt update... ou aptitude update...En fait plus je lis à ce sujet moins  c'est clair du point de vue des maj de Sid.


Pour Aptitude il y a par exemple https://wiki.debian.org/fr/Aptitude, ça peu être plus clair pour toi, je te donne mon petit mémo perso rapide, que tu vas vite ingérer de tête à mon avis wink

Aptitude
**********

    « / » pour la recherche
    « n » pour poursuivre la recherche (next)
    « + » pour sélectionner pour installation
    « = » pour maintenir le paquet dans sa version actuelle
    « g » (première fois) confirmer les changements (go)
    « g » (deuxième fois) pour appliquer les changements (go)


    « – » pour une suppression simple (apt-get remove)
    « _ » pour une suppression du paquet et de ses fichiers de configuration (apt-get remove –purge)
    « = » pour maintenir le paquet dans sa version actuelle
    « g » (première fois) confirmer les changements
    « g » (deuxième fois) pour appliquer les changements


    « u » mise à jour de la liste des paquets (apt-get update)
    « U » mise à jour des paquets (apt-get upgrade)
    « g » (première fois) confirmer les changements
    « g » (deuxième fois) pour appliquer les changements

*



Après, c'est vrai que c'est pas simple, il y a la communauté smile

D'après ce que j'ai compris, si tu as une Sid propre et stable, c'est encore plus de stabilité que la Stable en elle même, exemple : (Jessie) ! Je n'es pas assez d'expériences pour t'en dire plus.
J'imagine qu'il va y avoir du retour, mais comme tu dis ont cherche à en savoir plus et pour ça ont va nous dire de créer un nouveau post, car ont s'éloigne du sujet smile

De plus, le sujet est Résolu !

Dernière modification par Atys (14-08-2015 22:31:04)

Hors ligne

Pied de page des forums