Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-08-2015 20:00:53

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Problème avec VLC en grand écran

Bonsoir,

J'ai téléchargé VLC pour Linux mais lorsque j'essaye de visualiser une vidéo en grand écran, l'écran se fige ; l'image reste bloquée. Seul le son continue normalement Comment remédier à ce problème ?

Dernière modification par durn1818 (06-08-2015 20:01:37)

Hors ligne

#2 06-08-2015 20:52:45

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Problème avec VLC en grand écran

Salut,


Quand tu dis que tu l'as téléchargé, tu l'as installé avec apt ?


Sinon pour trouver la solution, tu peux le lancer à partir d'un terminal, pour avoir les messages d'erreur ( et les poster ) :

vlc

Dernière modification par nono47 (06-08-2015 20:56:17)

Hors ligne

#3 06-08-2015 21:00:04

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Re : Problème avec VLC en grand écran

Bonsoir,

Oui, je l'ai téléchargé simplement avec "apt-get install vlc". Voici ce que j'obtiens lorsque je lance vlc depuis une console :

VLC media player 2.2.0-rc2 Weatherwax (revision 2.2.0-rc1-118-g22fda39)
[0000000001bc8118] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Gtk-Message: Failed to load module "canberra-gtk-module"
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[00007f2084001268] xcb_xv vout display error: no available XVideo adaptor
[00007f209c002108] http access error: error: HTTP/1.1 403 Forbidden
[00007f2080000eb8] http access error: error: HTTP/1.1 403 Forbidden
[00007f209c002108] http access error: error: HTTP/1.1 403 Forbidden
[00007f2080000eb8] http access error: error: HTTP/1.1 403 Forbidden
[00007f209c002108] access_mms access error: unrecognized chunk FATAL (0x3f3c)
[00007f209c002108] access_mms access error: header size == 0
[00007f209c001b58] core art finder error: no suitable access module for `http://services.tvrage.com/feeds/search.php?show=got'
[00007f2080000eb8] access_mms access error: unrecognized chunk FATAL (0x3f3c)
[00007f2080000eb8] access_mms access error: header size == 0
[00007f2080000958] core art finder error: no suitable access module for `http://services.tvrage.com/feeds/search.php?show=got'
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f20a0d9a988] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
 



Merci !

Hors ligne

#4 06-08-2015 21:16:48

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Problème avec VLC en grand écran

apt install libcanberra-gtk-module


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#5 06-08-2015 21:17:38

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : Problème avec VLC en grand écran

Salut,

Essaye ça:

apt-get install libcanberra-gtk-module



Edit: oups Ir0nsh007er a été plus rapide que moi, j'ai posté en même temps que lui. roll

Dernière modification par Slyfox (06-08-2015 21:19:46)

Hors ligne

#6 06-08-2015 21:19:32

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Problème avec VLC en grand écran

Tu utilise gnome, xfce, kde ??? MATE CINAMON ???

Est-ce si difficile bien remplir son profil ??
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#7 06-08-2015 21:21:36

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Problème avec VLC en grand écran

De toute façon si tu a gnome pour fixé le driver NVIDIA Si tu a NVIDIA

ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#8 06-08-2015 21:24:43

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Problème avec VLC en grand écran

Peut-etre serait-il bon de voir ton driver est bien installer.
Renvoi le resultat de cette commande.

apt-cache policy nvidia-vdpau-driver


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#9 07-08-2015 12:04:22

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Re : Problème avec VLC en grand écran

Bonjour,

J'ai suivi vos instructions. En réponse à "apt-cache policy nvidia-vdpau-driver" , j'ai obtenu

nvidia-vdpau-driver:
  Installé : (aucun)
  Candidat : 340.65-2
 Table de version :
     340.65-2 0
        500 http://ftp2.fr.debian.org/debian/ jessie/non-free amd64 Packages
 

Dernière modification par durn1818 (07-08-2015 12:05:13)

Hors ligne

#10 07-08-2015 12:07:27

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Problème avec VLC en grand écran

Dans VLC, sortie Vidéo tu es sur quoi ?

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#11 07-08-2015 12:10:22

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Re : Problème avec VLC en grand écran

Désolé, je ne comprends pas bien votre question. Je suis débutant. Je ne sais pas ce que représente la "sortie vidéos"... Lorsque je lance vlc dans une console, j'obtiens maintenant cici :

VLC media player 2.2.0-rc2 Weatherwax (revision 2.2.0-rc1-118-g22fda39)
[000000000152c118] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.

Dernière modification par durn1818 (07-08-2015 12:14:25)

Hors ligne

#12 07-08-2015 12:13:50

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Problème avec VLC en grand écran

Je vais installer VLC pour voir quelque chose wink  ....

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#13 07-08-2015 12:34:13

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Problème avec VLC en grand écran

Tu as quoi comme carte graphique ?


Ouvres un terminal et tapes la commande:


lspci | grep "VGA compatible controller"
 



Lances VLV et dans :

Outils --- Préférences -- Bouton VIDEO , tu verras " sortie" qui est sur automatique, tu sélectionnes pour voir  "sortie Video OpenGL (experimental) pour voir.

Dernière modification par golgot200 (07-08-2015 12:37:24)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#14 07-08-2015 13:06:28

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Re : Problème avec VLC en grand écran

Voici ce que j'obtiens en réponse à

lspci | grep "VGA compatible controller


00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]
 



J'ai sélectionné "sortie Video OpenGL (experimental)" comme suggéré et relancé vlc. Malheureusement, dans ce cas, il n'y a même plus de grand écran. Lorsque j'essaye de mettre en gand écran, j'obtiens un écran noir et en bas à gauche la vidéo qui défile comme si elle n'était pas en grand écran.

Par ailleurs, après avoir supprimé la fenêtre vidéo de vlc, j'ai obtenu ce message sur mon terminal.

Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
libEGL warning: DRI2: failed to authenticate
[00007fb524001668] http access error: error: HTTP/1.1 403 Forbidden
[00007fb524001668] http access error: error: HTTP/1.1 403 Forbidden
[00007fb524001668] access_mms access error: unrecognized chunk FATAL (0x3f3c)
[00007fb524001668] access_mms access error: header size == 0
[00007fb524000958] core art finder error: no suitable access module for `http://services.tvrage.com/feeds/search.php?show=got'

[00007fb528c04f28] http access error: error: HTTP/1.1 500 Internal Server Error
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[00007fb528c04f28] http access error: error: HTTP/1.1 403 Forbidden
[00007fb528c04f28] access_mms access error: unrecognized chunk FATAL (0x3f3c)
[00007fb528c04f28] access_mms access error: header size == 0
[00007fb528c0e718] core art finder error: no suitable access module for `http://services.tvrage.com/feeds/search.php?show=got'

 

Dernière modification par durn1818 (07-08-2015 13:08:22)

Hors ligne

#15 07-08-2015 14:51:53

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Problème avec VLC en grand écran

Tu as une carte ATI et là, je connais pas. Je ne peux que te renvoyer à la documentation.

http://debian-facile.org/doc:materiel:c … ue:ati:ati

EDIT : Regarde aussi là au cas où :

1438956819.png

Dernière modification par golgot200 (07-08-2015 16:14:47)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#16 07-08-2015 17:13:38

durn1818
Membre
Distrib. : Debian Jessy
Noyau : Linux 3.16.0-4-amd64
Inscription : 27-07-2015

Re : Problème avec VLC en grand écran

Oui, je suis en Automatique également...

Hors ligne

#17 07-08-2015 19:01:17

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Problème avec VLC en grand écran

Oui mais essaies les différentes options du décodage matériel et les options de mon post 13 wink

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#18 10-04-2016 09:18:42

IceF0x
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : OpenBox
Inscription : 05-02-2012

Re : Problème avec VLC en grand écran

Désolé pour le déterrage, mais pour le message suivant: Failed to open VDPAU backend libvdpau_nouveau.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type , mais j'ai résolu simplement le souci en installant ce paquet: mesa-vdpau-drivers

sudo apt-get install mesa-vdpau-drivers


J'ai constaté ce souci depuis que j'ai remarqué que certaines vidéos ne fonctionnaient pas (celle de mon smartphone), donc si ça peut aider.
Je n'ai pas de driver propriétaires installé et mon matériel est:
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK110 [GeForce GTX 780] (rev a1)


1475862269.gif

En ligne

Pied de page des forums