Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-03-2009 04:48:59

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Comment forcer une mise à jour

Bonjour!

J'ai fait les commandes suivantes, parce que je veux installer php5-cli

patrick:/home/patrick# apt-get -V install php5-common
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
php5-common est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

patrick:/home/patrick# apt-get -V install php5-cli
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  php5-cli: Dépend: php5-common (= 5.2.6.dfsg.1-1+lenny2) mais 5.2.6.dfsg.1-3 devra être installé
E: Paquets défectueux

Comment se fait-il donc qu'on me demande une version plus récente alors qu'apt-get  me dit que j'ai déjà la plus récente?
J'ai essayé avec synaptic et c'est le même problème.

Merci encore de votre aide.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 12-03-2009 09:46:02

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Comment forcer une mise à jour

Bonjour Patriboom,

Alors là... Justement, me semble que le wiki en gestation sur le fichier preferences, là :
http://debian-facile.org/forum/viewtopic.php?id=1193
Devrait t'apporter une réponse...
Les priorités des mises à jour, tout ça... cool

Pis, si tu utilises synaptic/apt-get, ne mêle pas avec aptitude... Les librairies de mise à jour sont différentes... voit là :
http://www.commentcamarche.net/forum/af … c-aptitude.

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 14-04-2009 04:37:29

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Comment forcer une mise à jour

Bonsoir,

   j'ai lu le wiki cité et exécuté toutes les étapes. 
   Ce que je cherche, c'est maintenant à défaire les "mise à jour" erronnées ou faites à partir de version expérimentales.  Vous vous rappelez certainement mon fameux sources.list abracadabrant.

J'ai tout épuré ça, mais je veux maintenant épuré mes paquets installés.
C'est rendu infernal, il y a plein de messages d'erreurs, une foule de fonctions d'admin retournent des erreurs ou n'acceptent pas les bons mots de passe.  Il semble que mon gestionnaire de trousseaux soit tout mêlé (et de toutes façon n'est plus éditable en mode graphique).  J'ai fait des gaffes et je n'arrive plus à revenir en arrière.

Y a-t-il une autre solution que le formattage?

merci

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 15-04-2009 02:33:23

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Comment forcer une mise à jour

Salut

Pour forcer l'installation de paquets se trouvant dans une branche tu donnes une priorité de 1001 à celle-ci dans le fichier preferences. Cela forcera l'installation des paquets de cette branche. Pour enlever toute trace de paquets d'une branche donnée, tu donnes un priorité négative (-100 par exemple). Cela empêche un paquet se trouvant dans cette branche d'être installé.

Après tu fais un aptitude update et un aptitude full-upgrade. Il se peut que tu doives répéter les commandes jusqu'à ce que tu n'es plus de paquets cassés ou autre problèmes de dépendances. Avant lancer les commandes pour vrai, tu peux commencer par utiliser l'option -s pour voir le résultat.

Une fois que aptitude ne râle plus tout est ok, tu remets un bon sources.list et un bon preferences. Il ne faut pas redémarrer tant que aptitude indique des problèmes.

Bonne chance
Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 17-04-2009 15:21:46

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Comment forcer une mise à jour

Salut!

  Voilà que je m'attèle à la marche arrière.
Vous vous rappelez peut-être de mon sources.list qui fit écarquiller tous les yeux, le voici de nouveau:

#
# deb cdrom:[Debian GNU/Linux 4.0 r5 _Lenny_ - Official i386 NETINST Binary-1 20081024-15:53]/ lenny contrib main
# deb cdrom:[Debian GNU/Linux 4.0 r5 _Lenny_ - Official i386 NETINST Binary-1 20081024-15:53]/ lenny contrib main

#Méthode universelle pour charger la version stable actuelle
deb http://ftp.fr.debian.org/debian/ stable main
deb-src http://ftp.fr.debian.org/debian/ stable main

#Dépôt principal de Lenny (version fixe, version déclarée stable en fév. 2009), répertoire des paquets non-gratuits
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

#Dépôt principal de Lenny (version fixe, version déclarée stable en fév. 2009), répertoire des mises à jour non-gratuites
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

# Dépôts multimédia  (ceci a été ajouté pour charger des fichiers qui devraient faire fonctionner le son de mes vidéos)
deb http://www.debian-multimedia.org/ lenny main
deb-src http://www.debian-multimedia.org/ lenny main

#Dépôt principal de Lenny (version fixe, version déclarée stable en fév. 2009), répertoire principal
deb http://gulus.usherbrooke.ca/debian/ lenny main
deb-src http://gulus.usherbrooke.ca/debian/ lenny main

#Dépôt principal de Lenny (version fixe, version déclarée stable en fév. 2009), répertoire des mises à jour
deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

#Dépôt mirroir de Lenny référencé parce en cas de troubles de serveur ailleurs (version fixe, version déclarée stable en fév. 2009)
deb http://mirrors.kernel.org/debian lenny main
deb-src http://mirrors.kernel.org/debian lenny main

#Dépôt des paquets de la version stable ayant précédée celle qui est actuellement la version de référence
deb http://ftp.fr.debian.org/debian/ oldstable main
deb-src http://ftp.fr.debian.org/debian/ oldstable main

#Dépôt des paquets de la prochaine version, cest paquets ne sont pas encore entièrement fiables, mais leur développement est en cours
deb http://ftp.fr.debian.org/debian/ testing main
deb-src http://ftp.fr.debian.org/debian/ testing main


Et voici mon /etc/apt/preferences

Package: *
Pin: release o=Debian,a=stable
Pin-priority: 990

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-priority: -100

Package: *
Pin: release o=Unofficial Multimedia Packages,a=unstable
Pin-priority: -100

Package: *
Pin: release o=Debian,a=experimental
Pin-priority: -100

Package: *
Pin: release o=Unofficial Multimedia Packages,a=experimental
Pin-priority: -100


Je compte avec ça revenir en arrière, suite à des installations malheureuses.
Je me bute encore à des messages d'erreur récursifs, même à après trois apt-get updapte, toujours le même résultat
Que faire?

Les messages d'erreurs sont les suivants:

Atteint http://ftp.fr.debian.org oldstable/main Sources                        
11,7ko réceptionnés en 8s (1347o/s)                                            
Lecture des listes de paquets... Fait
W: GPG error: http://www.debian-multimedia.org lenny Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 07DC563D1F41B907
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.


Chaque fois que je veux travailler en root sur ces fichiers avec gedit, j'ai ceci qui m'apparaît:
Une erreur est survenue lors du chargement ou de l'enregistrement des informations de configuration de Éditeur de texte.  Certains de vos paramètres de configuration  ne fonctionnent peut-être pas correctement.

En détails j'ai:
Le contact du serveur de configuration a échoué ; causes possibles : vous n'avez pas activé le réseau TCP/IP pour ORBit ou des verrous NFS non valides existent suite à un blocage du système. Voir http://www.gnome.org/projects/gconf/ pour plus d'informations. (Détails -  1: La connexion à la session a échoué : Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)



Si ce n'était que ça!

Je n'ai plus de Nautilus fonctionnel en root (je sais que vous me direz que c'est dangereux, mais c'est parfois utile pour faire des changement de permission ou petites bricoles du genre).   Voici le message d'erreur que je rencontre:  assez semblable à celui ci-haut, mais bilingue.  On fait référence à Gconf: Erreur GConf: le contact du serveur de configuration a échoué; causes possibles: vous n'avez pas activé le réseau TCP/IP pour ORBit ou des verrous NFS non valides existent suite à un blocage du système.

C'est tout lié, ça, à mon avis.
Mon gestionnaire de clefs  ( Keyring Manager 2.20.0 )   ne fonctionne plus non plus.

Une idée?

Merci encore

Dernière modification par Patriboom (17-04-2009 15:29:20)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 17-04-2009 16:14:08

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Comment forcer une mise à jour

Yop !

Puisque tu utilises apt-get, as-tu fais des :

# apt-get clean


et

# autoclean


Consulter le :

$ man apt-get


Perso, il me semble que tu devrais commenter les doublons de ton sources.list, c'est à dire ne garder d'abord que le lenny :


sans fichier preferences...
faire des update, upgrade et autoclean, jusqu'à la stabilité du système.
Modifier en ajoutant le non-free
update...etc...
puis rajouter le testing avec le fichier preference
update...etc...
puis le multimedia
update
Et la clé qu'il faut également updater !

puis chacun de tes dépôts suivants, un à un... cool

Pour ma part, mêler le lenny main et le non-free me paraît superfétatoire, pour le moins... Quel est ton but en fin de compte, avoir un serveur, un pc multimedia ? tongue

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 17-04-2009 16:23:06

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Comment forcer une mise à jour

Je ne garderai de tout cela que ceci:

#
# deb cdrom:[Debian GNU/Linux 4.0 r5 _Lenny_ - Official i386 NETINST Binary-1 20081024-15:53]/ lenny contrib main
# deb cdrom:[Debian GNU/Linux 4.0 r5 _Lenny_ - Official i386 NETINST Binary-1 20081024-15:53]/ lenny contrib main

##Méthode universelle pour charger la version stable actuelle
deb http://ftp.fr.debian.org/debian/ stable main
deb-src http://ftp.fr.debian.org/debian/ stable main

## Dépôts multimédia  (ceci a été ajouté pour charger des fichiers qui devraient faire fonctionner le son de mes vidéos)
deb http://www.debian-multimedia.org/ lenny main
deb-src http://www.debian-multimedia.org/ lenny main


C'était simplement pour donner les indications des paquets que je voulais ôter, d'où le préférences avec des valeurs négatives.

merci.


J'ai fait une série de apt-get clean et apt-get autoclean  J'ai vu des pourcentages monter et c'est tout.  Pas de résultat affiché, pas de commentaire, pas d'explication.

Je pars un nouveau sujet pour mon problème de Gconf.  Je crois qu'est là tout mon probléme.

Dernière modification par Patriboom (17-04-2009 16:27:01)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 17-04-2009 16:36:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Comment forcer une mise à jour

OK !
Pour le multimedia
as-tu mis la cle et update celle-ci également ?

Qu'appelles-tu le Gconf ?

Tsop... smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 17-04-2009 16:46:28

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Comment forcer une mise à jour

smolski a écrit :

OK !
Pour le multimedia
as-tu mis la cle et update celle-ci également ?


Euh!  Qu'est-ce que tu veux dire?

smolski a écrit :

Qu'appelles-tu le Gconf ?


J'ai toujours un message d'erreur au logiciel GConf (erreur citée plus haut).
Il se trouve que je comprends que Gconf est le logiciel qui gère les clefs d'accès (mots de passe usagers et root).  Il s'agit de Keyring Manager 2.20.0  Lui aussi est bloqué par Gconf?  Est-ce le même logiciel ou non, je ne sais pas.

Je n'en sais pas plus sur Gconf sinon que j'ai aussi un logiciel qui s'appelle gconf-editor 2.22.0 dans mon menu "Outils système"


Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 17-04-2009 17:14:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Comment forcer une mise à jour

Aaaaaah ça s'eclairci là !

Voilà le lien wiki pour installer et updater un dépôt multimedia :
http://debian-facile.org/wiki/doku.php? … multimedia

En fait, tu mets le dépôt debian-multimedia dans ton sources.list, PUIS tu le update...
Tu as le message indiquant le manquement d'une cle, c'est ok, tu installes cette clé :

# apt-get install debian-multimedia-keyring


et tu updates le nouveau sources.list complet.
C'est fait.

Si tu rajoutes testing ou unstable dans le sources.list, tu dois faire un fichier preferences, reportes-toi au wiki DF ci-dessus lié.

A noter que tu n'as pas besoin de fichier preferences à ce niveau, les dépôts multimedia ne sont pas en double avec ceux de debian officiel...

YEs ?

Amitié, Joel

Dernière modification par smolski (17-04-2009 17:15:23)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 19-04-2009 23:22:01

alex
Membre
Lieu : Trevoux
Distrib. : etch
Noyau : 2.6.25
(G)UI : kde
Inscription : 07-06-2007
Site Web

Re : Comment forcer une mise à jour

dans ton fichier sources.list, (la derniere version que tu as posté) il te manque le depot fournissant les mises à jour de sécurité pour la stable.

#Dépôt principal de Lenny
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

Hors ligne

#12 20-04-2009 04:40:55

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Comment forcer une mise à jour

Merci beaucoup.  j'ai fait l'ajout.

Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums