Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-08-2015 01:53:44

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

FluxBox {RESOLU}

Salut tout le monde ! smile

Je viens vers pour car je souhaiterai installé le gestionnaire de fenêtres FluxBox.

En revanche, j'ai tenté de l'installer via le gestionnaire de fenêtres "aptitude".

Une fois le paquet correctement installé, j'ai essayé, avec l'aide de tutos sur internet de le configurer.

Malheureusement, impossible ! Apparemment, le soucis viendrait d'une incompatibilité avec Xfce4.

Quelqu'un a-t-il déjà connu des problèmes similaires ? Ou peut être que quelqu'un de bien plus expérimenté que moi par rapport à ce genre de processus aurait une idée de la genèse de l'incident procédural ?   

Merci d'avance smile

Dernière modification par Pearce (21-08-2015 17:59:33)

Hors ligne

#2 13-08-2015 02:20:10

Beta-Pictoris
Membre
Distrib. : Centos 7
Inscription : 12-08-2015

Re : FluxBox {RESOLU}

Tu essayes de configurer quoi, exactement, et dans quel but ?

Hors ligne

#3 13-08-2015 03:07:39

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Je souhaiterai installer FluxBox pour plusieurs raisons:
- aller au coeur même des choses, en d'autres termes, apprendre comment fonctionne les différents outils, de ceux natifs à ceux que je souhaite ajouter dans le plus details, c'est à dire les utiliser en ligne de commande pour parfaitement comprendre le rouage de chacun d'entre eux
- j'ai choisis FluxBox car, d'après ce que j'ai pu lire à plusieurs endroit, c'est un bon outils pour mon objectif

Quelqu'un aurait des tuyaux à me donner ?

Hors ligne

#4 13-08-2015 03:11:17

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

J'aimerai, d'un point de vu global, apprendre à tout configurer et gérer à partir du terminal, donc en ligne de commande. smile

Hors ligne

#5 13-08-2015 07:24:52

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : FluxBox {RESOLU}

Salut,

Tu arrives à lancer fluxbox ?
Tu as un gestionnaire de connexion ?

Pour lancer fluxbox -> https://wiki.debian.org/fr/FluxBox#La_Session_Fluxbox
Pour configurer fluxbox -> https://debian-facile.org/doc:environne … 11:fluxbox

Dis en plus, si tu veux de l'aide . ( édition : notamment cette histoire d'incompatibilité avec xfce )
smile

Dernière modification par nono47 (13-08-2015 07:35:17)

Hors ligne

#6 13-08-2015 13:25:27

Beta-Pictoris
Membre
Distrib. : Centos 7
Inscription : 12-08-2015

Re : FluxBox {RESOLU}

Pearce, arrives tu, déjà, à lancer fluxbox ?

Hors ligne

#7 13-08-2015 19:36:12

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : FluxBox {RESOLU}

J'ai pour ma part longtemps utilisé Fluxbox + XFCE 4. Il n'y a aucune incompatibilité.
Sous Debian, XFCE 4 est géré au démarrage par Lightdm, et à partir de Lightdm, on peut choisir de démarrer soit XFCE, soit Fluxbox.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#8 14-08-2015 18:48:05

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Alors, en effet, je n'arrive pas à lancer Fluxbox.

j'ai tenté en procédant comme nono47 l'a dit, par KDM ou GDM mais cela ne fonctionne pas.

Hors ligne

#9 14-08-2015 19:12:30

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : FluxBox {RESOLU}

Alors, installe Lightdm en lieu et place de GDM/KDM et tu verras, ça marchera. De ce que je me rappelle, quand on arrive sur Lightdm, en haut à droite: session: XFCE ou Fluxbox.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#10 14-08-2015 20:04:34

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Grâce à la commande à la commande "apt-cache search", j'ai pu identifier le paquet dans les sources Debian. Puis, avec la commande "aptitude show" j'ai vérifié son installation. Il s'avère que c'est un paquet déjà installé.
En revanche, je n'arrive pas à y accéder. Pourtant, dans les processus qui se lance lors du démarrage, j'ai vérifié qu'il se lance correctement; c'est le cas.

Hors ligne

#11 14-08-2015 20:35:15

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : FluxBox {RESOLU}

D"après la documentation -> https://wiki.debian.org/fr/LightDM peut être un

dpkg-reconfigure lightdm


pour le configurer ?

Hors ligne

#12 15-08-2015 17:40:12

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Pour le coup, je me demande si c'est moi qui suis nul mais je n'arrive pas à me servir de LightDM.

J'ai tenté la commande "dpkg-reconfigure lightdm" mais rien ne se passe de particulier. De ce fait, j'ai désinstallé puis réinstallé mais toujours rien.

Hors ligne

#13 16-08-2015 10:52:00

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : FluxBox {RESOLU}

Salut,

Avec Xfce j'ai remarqué que je n'arrivais plus à utiliser Openbox comme avant, non plus. Je pense (sans être totalement certaine) que les nouvelles versions de Xfce ne permettent plus de changer de gestionnaire de fenêtres. Et sur le site de Openbox : http://openbox.org il n'y a plus le tutoriel pour présenter comment le faire (c'est un indice de plus). Alors il est possible que ça doit pareil pour fluxbox ?

Essaie pour voir, de trouver le fichier "fluxbox.desktop" et de le copier vers /usr/share/applications; ça doit être sous /usr/share/xsessions, ou quelque chose comme ça. C'est juste une piste, lue sur un forum ubuntu. À voir si ça change quelque chose ? Quand à lightdm il est possible de modifier directement /etc/lightdm/lightdm.conf. (mettre "user-session=fluxbox" : sans les guillemets).


PS: je crois que ce fil devrait être déplacé vers une autre section: soit dans Xfce, soit dans "Autres WM".

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#14 16-08-2015 11:08:36

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : FluxBox {RESOLU}

Done  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#15 17-08-2015 15:46:16

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Bon, je viens de consulter le fichier "lightdm.conf" et, à chaque début de ligne, il y a le signe "#", ce qui veut dire que les instructions sont inactives.
Et, plus précisément, à la ligne "user-session" il n'y a rien d'écrit à part les instructions à mettre, comme si le fichier n'avait jamais était configuré.

Quelqu'un pourrait il m'orienter car je n'y arrive vraiment pas. hmm

Hors ligne

#16 17-08-2015 18:26:24

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : FluxBox {RESOLU}

Bonjour,


Pour être sûr :

basename $(cat /etc/X11/default-display-manager)




Mes fichiers de conf n'ont pas été modifiés par la migration de Wheezy à Jessie.

/etc/lightdm/lightdm.conf :

#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# xsessions-directory = Directory to find X sessions
# xgreeters-directory = Directory to find X greeters
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#log-directory=/var/log/lightdm
#run-directory=/var/run/lightdm
#cache-directory=/var/cache/lightdm
#xsessions-directory=/usr/share/xsessions
#xgreeters-directory=/usr/share/xgreeters

#
# Seat defaults
#
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xserver-layout = Layout to pass to X server
# xserver-config = Config file to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# user-session = Session to load for users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# exit-on-failure = True if the daemon should exit if this seat fails
#
[SeatDefaults]
#xserver-command=X
#xserver-layout=
#xserver-config=
xserver-allow-tcp=false
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
greeter-session=lightdm-gtk-greeter
greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#user-session=default
#allow-guest=true
#guest-session=UNIMPLEMENTED
session-wrapper=/etc/X11/Xsession
#display-setup-script=
greeter-setup-script=/usr/bin/numlockx on
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-session=UNIMPLEMENTED
#exit-on-failure=false

#
# Seat configuration
#
# Each seat must start with "Seat:".
# Uses settings from [SeatDefaults], any of these can be overriden by setting them in this section.
#
#[Seat:0]

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#key=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# port = TCP/IP port to listen for connections on
#
[VNCServer]
#enabled=false
#port=5900
#width=1024
#height=768
#depth=8




/etc/lightdm/users.conf:

#
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserAccounts]
minimum-uid=500
hidden-users=xxxxx  xxxxxxx  xxxxxxx
hidden-shells=/bin/false /usr/sbin/nologin




/etc/lightdm/lightdm-gtk-greeter.conf :

#
# background = Background file to use, either an image path or a color (e.g. #772953)
# show-language-selector (true or false)
# theme-name = GTK+ theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
#
[greeter]
background=/usr/share/images/desktop-base/106830.png
#show-language-selector=false
theme-name=Adwaita
#font-name=
xft-antialias=true
#xft-dpi=
xft-hintstyle=hintfull
xft-rgba=rgb


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#17 18-08-2015 18:14:18

Beta-Pictoris
Membre
Distrib. : Centos 7
Inscription : 12-08-2015

Re : FluxBox {RESOLU}

Pearce a écrit :

Bon, je viens de consulter le fichier "lightdm.conf" et, à chaque début de ligne, il y a le signe "#", ce qui veut dire que les instructions sont inactives.
Et, plus précisément, à la ligne "user-session" il n'y a rien d'écrit à part les instructions à mettre, comme si le fichier n'avait jamais était configuré.

Quelqu'un pourrait il m'orienter car je n'y arrive vraiment pas. hmm



Normalement, il n'y a rien à faire. Je viens d'installer xfce puis fluxbox. Pour passer de l'un à l'autre, il suffit de fermer sa session, on revient, alors, sur l'écran d'accueil lightdm. Il y a un petit icône en haut à droite de cet écran et qui permet de choisir entre "Default Xsession", "Fluxbox" et "Session Xfce". Il suffit de cocher "Fluxbox" puis mettre ses identifiants et cliquer sur "Se connecter".

Hors ligne

#18 18-08-2015 19:54:37

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Et, comment faire pour pouvoir démarrer, dès l'entrer du login et password, avec fluxbox ?

Hors ligne

#19 18-08-2015 19:57:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : FluxBox {RESOLU}

Hé bien, tu dois avoir un menu, en haut à droite, qui te donne le choix de l'environnement de bureau.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 20-08-2015 09:30:45

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

En effet, j'ai pu identifier le menu en haut à droite.
En revanche, pour affiner la chose, je souhaiterai pouvoir démarrer sur debian, après avoir rentrer mon login et mot de passe, directement sur fluxbox.

Pour se faire, quelqu'un pourrait il m'aider à:
- identifier mon gestionnaire d'écran de connexion
- lequel, de très léger me conseillez vous ?
- comment configurer fluxbox ?

Hors ligne

#21 20-08-2015 09:57:59

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : FluxBox {RESOLU}

Pearce a écrit :

- identifier mon gestionnaire d'écran de connexion

Ce sera le résultat de la commande de mon #16  smile
Si elle te retourne lightdm, pas de souci, c'est du léger.  big_smile

Pour Fluxbox, je regarde ça dans la journée.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#22 20-08-2015 11:51:26

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : FluxBox {RESOLU}

J'ai en tête deux voies à explorer :


La première, via le fichier ~/.dmrc, à éditer en dehors de la session graphique de ton user :

[Desktop]
Session=fluxbox
Language=fr_FR.utf8




La seconde, mais je n'y crois guère, par les commandes :

update-alternatives --config x-session-manager


update-alternatives --config x-window-manager




J'espère que lightdm n'est pas à la ramasse sur ce coup ...


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#23 21-08-2015 15:14:33

Pearce
Membre
Distrib. : Debian Jessie
Noyau : Gnu/Linux 4.0.0-2-amd64
(G)UI : Xfce4
Inscription : 11-08-2015

Re : FluxBox {RESOLU}

Bon, à présent je reviens vers vous pour une autre raison: j'ai réinstaller debian sur ma machine et j'ai mis en gestionnaire de fenêtre FluxBox.

Sauf qu'il s'avère que je vagabonde de doc en doc mais j'ai du mal à en trouver une en français qui soit vraiment complète.

Mon premier problème étant que je n'arrive pas à configurer le wifi. Je souhaiterai avoir la petite icone du wifi dans la barre d'outils fluxbox mais je n'arrive pas à trouver comment faire.

Please, HELP !!!

Hors ligne

#24 21-08-2015 16:48:09

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : FluxBox {RESOLU}

Salut Pearce,

Ouvre un autre post pour ce nouveau problème et si celui-ci est résolu, marque-le dans le titre :

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Et wouais mon gaw, un problème par post et les résolus seront bien gardés !big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums