Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-08-2015 15:45:22

spontuk
Membre
Inscription : 21-08-2015

Configuration de debian

Bonjour,

Alors voilà, j'ai installé une machine virtuelle qui tourne sur Windows Server 2012 R2, cette machine est mon controller de domaine. Elle dispose de l'active directory.
J'ai ensuite installé une autre machine virtuelle qui tourne du Debian 7. Cetet machine est en NAT pour communiquer avec mon controller de domaine.
Sur la vm Debian je dois installer un partage de ressources Windows via samba serveur, un serveur NFS, un service FTP.
J'ai installé samba sur cette VM, j'ai configuré le smb.conf (je ne sais pas si je l'ai bien fait).
Lors de la création des utilisateurs dans le groupe, je n'arrive à rien,

je tape: ~#

usermod -G nas, utilisateur3


usermod : le groupe << >> n'existe pas




Qu'est ce qu'il faut que je fasse?

Je vous remercie d'avance.

Hors ligne

#2 22-08-2015 15:53:46

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Configuration de debian

spontuk a écrit :

je tape: ~# usermod -G nas, utilisateur3
usermod : le groupe << >> n'existe pas


Que cherches-tu à faire exactement via cette commande ?
Si tu veux ajouter l'utilisateur utilisateur3 au groupe nas, tu dois employer :

usermod -aG nas utilisateur3


Si tu veux créer ces deux groupes :

addgroup nas
addgroup utilisateur3


Est-ce que le groupe nas existe actuellement sur ton système ?


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 22-08-2015 15:57:14

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Configuration de debian

Bonjour spontuk,

Je ne pourrai pas t'aider loin mais je pense qu'il faut que tu nous indiques ta config samba pour qu'on y voit plus clair.
Indique cette config en utilisant Autre code pour l'encadrer sur le forum des bonnes balises.
Par ailleurs, je t'ai tatouillé ton post 1 pour y mettre les bonnes balises qui faut, tu peux le voir en cliquant sur Modifier sous ton post.

Pour l'ensemble des œuvres des balises-facile voir le tuto gagnant le point choco df là :

Voir le tuto : Le code, ça pique moins les yeux en couleur big_smile

Dernière modification par smolski (22-08-2015 15:57:48)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 22-08-2015 15:57:48

spontuk
Membre
Inscription : 21-08-2015

Re : Configuration de debian

Oui ce groupe existe, je cherche à ajouter deux utilisateurs au groupe.

Avec ta commande sa fonctionne je te remercie, je vais tester pour voir si tout fonctionne.

Hors ligne

#5 22-08-2015 15:59:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Configuration de debian

bon.. ben jojo se garde le point choco quand même ! tongue

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 22-08-2015 16:00:11

spontuk
Membre
Inscription : 21-08-2015

Re : Configuration de debian

Quand je tape la commande pour l'utilisateur3, sa fonctionne.
Mais quand je tape cette même commande et que je remplace utilisateur3 par utilisateur4, sa fonctionne pas, il me disent "l'utilisateur utilisateur4 n'existe pas".

J'ai fais quelque chose qu'il ne fallait pas ? lol

Hors ligne

#7 22-08-2015 16:00:29

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Configuration de debian

smolski a écrit :

bon.. ben jojo se garde le point choco quand même ! tongue


Nan, nan, nan, partage là ! Anarcho mais pas pour le choco hein !!!! tongue


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#8 22-08-2015 16:01:36

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Configuration de debian

spontuk a écrit :

Quand je tape la commande pour l'utilisateur3, sa fonctionne.
Mais quand je tape cette même commande et que je remplace utilisateur3 par utilisateur4, sa fonctionne pas, il me disent "l'utilisateur utilisateur4 n'existe pas".


Tu as créé l'utilisateur 4 sur le système ?
Lectures conseillées:

man adduser
man usermod


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#9 22-08-2015 16:11:15

spontuk
Membre
Inscription : 21-08-2015

Re : Configuration de debian

Ma config samba est:

[global]

netbios name = ITDS 1    #Le nom du serveur Windows2012
server string = Serveur de fichier

win server = 192.168.1.1
password server = 192.168.1.1
client use spnego = yes
client ntlmv2 auth = yes

workgroup = infotech.ad
realm = infotech.ad

encrypt passwords = yes

idmap uid = 10000-20000
idmap gid = 10000-20000

winbind enum users = yes
winbind enum groups = yes
winbind use default domain = yes

template shell = /bin/bash
template homedir = /home/infotech.ad/%U

obey pam restrictions = yes


[Homes]
comment = User Homes Directories
create mask = 0700
directory mask = 0700
browseable = yes

 

Hors ligne

#10 22-08-2015 16:36:40

spontuk
Membre
Inscription : 21-08-2015

Re : Configuration de debian

J'ai réussie à créer les deux utilisateurs pour le groupe nas,
j'ai ensuite taper la commande :

smbpasswd -a utilisateur3


smbpasswd -a utilisateur4


C'est ok.
Ensuite sur ma VM windows server 2012, je n'arrive pas à entrer sur le partage, je tape dans la barre de recherche "\\ITDS1\samba , on me demande de m'inditifier ce que je fais puis on me rejette.

Help me please yikeslol

Hors ligne

#11 22-08-2015 16:42:42

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Configuration de debian

spontuk a écrit :

Ensuite sur ma VM windows server 2012


Arf, là je passe la main, je suis vraiment un con pétant sur fenêtre...


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#12 22-08-2015 19:17:44

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Configuration de debian

sogal a écrit :

smolski a écrit :

bon.. ben jojo se garde le point choco quand même ! tongue


Nan, nan, nan, partage là ! Anarcho mais pas pour le choco hein !!!! tongue

L'anarcho-capitaliste a encore frappé !  lol


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#13 23-08-2015 18:37:31

spontuk
Membre
Inscription : 21-08-2015

Re : Configuration de debian

Concernant mon problème de configuration de samba, je l'ai résolu en partie mais, un code d'erreur revient souvent:

Ignoring unknown parameter "winbind enum groups"



Et lorsque je veux monter un partage samba avec la commande :

smbclient //192.168.1.1/samba -U administrateur


Il affiche plusieurs messages d'erreurs

WARNING: The "idmap uid" option deprecated


WARNING: The "idmap gid" option deprecated


Il me demande mon mot de passe, je le rentre ensuite il affiche ce message

Domain= [infotech] OS=[Windows Server 2012 R2 Datacenter 9600] Server=[Windows Server 2012 R2 Datacenter 6.3
tree connect failed: NT_STATUS_BAD_NETWORK_NAME



Donc je ne sais pas quoi faire ?? roll

Hors ligne

Pied de page des forums