Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-03-2009 10:45:56

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

[Résolu] Udevadm settle timeout

J'ai eu un message surprenant ce matin, au démarrage, alors que je n'ai rien fait de spécial hier. Après Loading, please wait :

After the udevadm settle timeout, the events queue contains :
759 : /devices/pci0000:00/0000:00:0d.0/ide0/0.0
760 : /devices/pci0000:00/0000:00:0d.0/ide0/0.1
796 : /block/hda


Et après Waiting for /dev to be fully populated :

After the udevadm settle timeout, the events queue contains :
875 : /block/hda


J'ai fait plusieurs redémarrages, toujours pareil, et cherché une solution sur Internet, mais sans trop de succès. J'ai fini par trouver comment réduire le timeout de udevadm :

Dans le fichier /etc/initd/udev, on rajoute --timeout=3 (cherchez la chaîne "settle") :

# wait for the udevd childs to finish
log_action_begin_msg "Waiting for /dev to be fully populated"
if udevadm settle --timeout=3 ; then
    log_action_end_msg 0
else
    log_action_end_msg 0 'timeout'
fi
;;


Ca a réglé le problème, à moins qu'il ne soit parti de lui même, comme il était venu... Bizarre tout ça. neutral


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

Pied de page des forums