Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-09-2015 18:14:11

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Root en mode graphique ?

Pour des raisons pratiques j'ai changé de coté mes écrans et du coup ils s 'ouvrent à l'envers c'est à dire que pour passer de l'écran de gauche à celui de droite, je dois sortir par le coté gauche de l'écran de droite.
Ce n'est pas un problème l'application Nvidia X server settings en mode graphique le fait très bien, mais cette config n'est pas conservée et je dois la refaire à chaque réouverture.
Je peux enregistrer cette modif pour la session en cours, mais elle n'est pas conservée.

Il existe bien un bouton Save to X Configuration file, mais il répond
You do not have adequate permission to open the existing X configuration file '/etc/X11/xorg.conf' for writing. You must be 'root' to modify the file.

Oui je comprends bien ! mais es-ce que je peux passer en root en mode graphique le temps d'enregistrer cette modif ?
vous allez sans doute me répondre que ce n'est pas une bonne idée, mais j'aimerais autant ne pas récrire le fichier à la main dans une console en root, ça ne me semble pas su non plus à cause des erreurs de frappe ou d'inattention.

Guppy
Es e qu"'un change mod en mode console serait une solution?
Je préfère demander avant de faire.

Dernière modification par Guppy88 (20-09-2015 18:15:53)

Hors ligne

#2 20-09-2015 18:28:45

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Root en mode graphique ?

bonsoir

peut être qu'en lisant ton fichier xorg.conf tu trouvera comment est configuré la position des écrans et qu'il te seras possible de changer manuellement cette configuration en mode console

commandes utils

/etc/X11/xorg.conf



/etc/X11/xorg.conf


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

En ligne

#3 24-09-2015 00:31:02

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : Root en mode graphique ?

Bien j'ai essayé, j'ai copié le xorg nvidia provisoire avec les écrans dans le bon sens, et j'ai modifié  le xorg nvidia d'origine, mais je n'ai réussi qu'à obtenir un écran noir.
J'ai alors essayé de remettre le xorg qui fonctionnait à l'envers mais je ne fais qu'empirer les choses, avec seulement une jessie qui fonctionnait en mode console.
Alors j'ai du tout désinstaller et remettre en état, pour me retrouver au point de départ. Je n'ai donc pas avancé d'un pouce.
J'ai donc à nouveau besoin de vos conseils avisés.
Merci d'avance.

Je suis en mode graphique et l'utilitaire NVIDIA qui veut bien enregistrer les modifs, me répond !

You do not have adequate permission to open the existing X configuration file '/etc/X11/xorg.conf' for writing. You must be 'root' to modify the file.




Guppy

Dernière modification par Guppy88 (24-09-2015 00:42:33)

Hors ligne

#4 24-09-2015 06:56:58

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Root en mode graphique ?

bhê (comme je ne suis pas un forcené de la commande, et que lancer des applications en root ne me gène pas...)
tu peux lancer ton utilitaire NVIDIA en mode root pour sauver une bonne fois pour toute ta config.

(attention, ce n'est pas toute la session qu'il faut lancer en root, juste l'utilitaire)

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

En ligne

#5 24-09-2015 10:24:39

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Root en mode graphique ?

commence par poster le fichier

cat /etc/X11/xorg.conf



ensuite tu modifies ton paramétrage depuis l'utilitaire Nvidia et tu nous le donnes également.
On t'expliquera comment on fait après.

Lancer une application root en mode graphique est une mauvaise chose et il faut éviter pour des raisons de sécurité et dans ce cas ce n'est pas nécessaire (il va simplement copier un fichier de config dans un coin).

Hors ligne

#6 24-09-2015 10:45:24

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : Root en mode graphique ?

à Severian Ben oui c'est ça que je voulais : Simplement  lancer l'utilitaire NVIDIA en mode root pour sauver une bonne fois pour toute ma config.
L'ouverture d'un terminal en root où j'ai recopié, la config de l'utilitaire Nvidia ne m'a pas réussi. Pourtant il n'y avait que des lignes en plus pour les moniteurs

cat /etc/X11/xorg.conf



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 346.96  (buildmeister@swio-display-x64-rhel04-17)  Sun Aug 23 23:07:23 PDT 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 



Et Xorg modifié par l'utilitaire pour obtenir les écrans dans le bon sens

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 346.96  (buildmeister@swio-display-x64-rhel04-17)  Sun Aug 23 23:06:14 PDT 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0                      Ligne modifiée avec l'ajout de  0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"                      Ligne supplémentaire
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Targa LCDTV16"              Ligne modifiée avec le nom  de l'écran
    HorizSync       32.0 - 80.0                         Ligne modifiée    28.0 - 33.0
    VertRefresh     56.0 - 75.0                         Ligne modifiée    43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980"            Ligne ajoutée avec le nom de la carte
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"                                                                                                                       Options ajoutées
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DVI-I-0: nvidia-auto-select +1920+0, HDMI-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Dernière modification par Guppy88 (24-09-2015 11:04:16)

Hors ligne

#7 24-09-2015 13:09:59

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Root en mode graphique ?

maintenant on va sauvegarder ton ancien fichier de config.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak



ensuite tu copies le tout dans un fichier /tmp/xorg.conf
et tu le remplaces dans /etc/X11/xorg.conf

mv  /tmp/xorg.conf /etc/X11/xorg.conf

Hors ligne

Pied de page des forums