Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-09-2015 15:23:49

enebre
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4
Inscription : 18-10-2010

ati rage 128

Bonjour,

Je viens d'installer Jessie sur mon vieux pc équipé d'une carte ati rage 128, je constate un mauvais affichage avec des trainées aux déplacement des fenêtres.
Est-il possible d'améliorer les performances de cette carte ?
voici quelques infos issues des commandes....

lspci -nn | grep VGA


$


01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Rage 128 PRO Ultra AGP 4x [1002:5446]
linux@debian:~$
 


cat /var/log/Xorg.0.log



[    26.258] (II) R128(0): Modeline "320x240"x60.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz zd)
[    26.258] (**) R128(0): Display dimensions: (460, 290) mm
[    26.258] (**) R128(0): DPI set to (92, 91)
[    26.258] (II) Loading sub module "fb"
[    26.258] (II) LoadModule: "fb"
[    26.258] (II) Loading /usr/lib/xorg/modules/libfb.so
[    26.299] (II) Module fb: vendor="X.Org Foundation"
[    26.299]  compiled for 1.16.4, module version = 1.0.0
[    26.299]  ABI class: X.Org ANSI C Emulation, version 0.4
[    26.299] (II) Loading sub module "ramdac"
[    26.299] (II) LoadModule: "ramdac"
[    26.299] (II) Module "ramdac" already built-in
[    26.299] (II) Loading sub module "shadowfb"
[    26.299] (II) LoadModule: "shadowfb"
[    26.300] (II) Loading /usr/lib/xorg/modules/libshadowfb.so
[    26.310] (II) Module shadowfb: vendor="X.Org Foundation"
[    26.310]  compiled for 1.16.4, module version = 1.0.0
[    26.310]  ABI class: X.Org ANSI C Emulation, version 0.4
[    26.310] (II) R128(0): Page flipping disabled
[    26.310] (!!) R128(0): For information on using the multimedia capabilities
  of this adapter, please see http://gatos.sf.net.
[    26.310] (II) UnloadModule: "modesetting"
[    26.310] (II) Unloading modesetting
[    26.310] (II) UnloadModule: "fbdev"
[    26.310] (II) Unloading fbdev
[    26.310] (II) UnloadSubModule: "fbdevhw"
[    26.310] (II) Unloading fbdevhw
[    26.310] (II) UnloadModule: "vesa"
[    26.310] (II) Unloading vesa
[    26.310] (--) Depth 24 pixmap format is 32 bpp
[    26.310] (II) R128(0): Acceleration of RENDER operations will be enabled upon successful loading of DRI and EXA
[    26.473] drmOpenDevice: node name is /dev/dri/card0
[    26.478] drmOpenDevice: node name is /dev/dri/card0
[    26.594] drmOpenByBusid: Searching for BusID pci:0000:01:00.0
[    26.594] drmOpenDevice: node name is /dev/dri/card0
[    26.594] drmOpenDevice: open result is 10, (OK)
[    26.595] drmOpenByBusid: drmOpenMinor returns 10
[    26.595] drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[    26.595] (II) [drm] loaded kernel module for "r128" driver.
[    26.595] (II) [drm] DRM interface version 1.4
[    26.595] (II) [drm] DRM open master succeeded.
[    26.595] (II) R128(0): [drm] Using the DRM lock SAREA also for drawables.
[    26.595] (II) R128(0): [drm] framebuffer handle = 0xec000000
[    26.595] (II) R128(0): [drm] added 1 reserved context for kernel
[    26.595] (II) R128(0): X context handle = 0x1
[    26.595] (II) R128(0): [drm] installed DRM signal handler
[    26.595] (II) R128(0): [agp] Mode 0x1f000211 [AGP 0x8086/0x2570; Card 0x1002/0x5446]
[    26.606] (II) R128(0): [agp] 8192 kB allocated with handle 0x00000001
[    26.607] (II) R128(0): [agp] ring handle = 0xf0000000
[    26.607] (II) R128(0): [agp] Ring mapped at 0xb69e4000
[    26.608] (II) R128(0): [agp] ring read ptr handle = 0xf0101000
[    26.608] (II) R128(0): [agp] Ring read ptr mapped at 0xb6df1000
[    26.608] (II) R128(0): [agp] vertex/indirect buffers handle = 0xf0102000
[    26.608] (II) R128(0): [agp] Vertex/indirect buffers mapped at 0xb4742000
[    26.608] (II) R128(0): [agp] AGP texture map handle = 0xf0302000
[    26.608] (II) R128(0): [agp] AGP Texture map mapped at 0xb4262000
[    26.608] (II) R128(0): [drm] register handle = 0xe8100000
[    26.608] (II) R128(0): [dri] Visual configs initialized
[    26.698] (II) R128(0): CCE in BM mode
[    26.698] (II) R128(0): Using 8 MB AGP aperture
[    26.698] (II) R128(0): Using 1 MB for the ring buffer
[    26.698] (II) R128(0): Using 2 MB for vertex/indirect buffers
[    26.698] (II) R128(0): Using 5 MB for AGP textures
[    26.698] (II) R128(0): Filling in EXA memory info
[    26.698] (II) R128(0): Loading EXA module...
[    26.698] (II) Loading sub module "exa"
[    26.698] (II) LoadModule: "exa"
[    26.699] (II) Loading /usr/lib/xorg/modules/libexa.so
[    26.762] (II) Module exa: vendor="X.Org Foundation"
[    26.762]  compiled for 1.16.4, module version = 2.6.0
[    26.762]  ABI class: X.Org Video Driver, version 18.0
[    26.762] (II) R128(0): Allocating EXA driver...
[    26.762] (II) R128(0): Acceleration enabled
[    26.762] (II) R128(0): Filled in offs
[    26.762] (II) R128(0): Going to init EXA...
[    26.762] (II) R128(0): Setting up EXA callbacks
[    26.762] (II) R128(0): Initalizing 2D acceleration engine...
[    26.762] (II) R128(0): Initializing EXA driver...
[    26.762] (II) EXA(0): Offscreen pixmap area of 21255552 bytes
[    26.762] (II) EXA(0): Driver registered support for the following operations:
[    26.762] (II)         Solid
[    26.762] (II)         Copy
[    26.762] (II)         Composite (RENDER acceleration)
[    26.762] (II) R128(0): EXA Acceleration enabled
[    26.762] (II) R128(0): Actually trying an EXA allocation...
[    26.762] (II) R128(0): Went swimmingly...
[    26.762] (II) R128(0): Reserved back buffer from (192,3163) to (192,4213) offset: 14457c0
[    26.762] (II) R128(0): Reserved depth buffer from (192,2112) to (192,3163) offset: d89300
[    26.762] (II) R128(0): Reserved depth span from (192,3162) offset 0x1443d80
[    26.762] (II) R128(0): Reserved 5120 kb for textures at offset 0x1afff40
[    26.762] (==) R128(0): Backing store enabled
[    26.762] (==) R128(0): Silken mouse enabled
[    26.799] (II) R128(0): Using hardware cursor (scanline 8447)
[    26.828] (==) R128(0): DPMS enabled
[    26.828] (II) R128(0): [DRI] installation complete
[    26.895] (II) R128(0): [drm] Added 128 16384 byte vertex/indirect buffers
[    26.895] (II) R128(0): [drm] Mapped 128 vertex/indirect buffers
[    26.895] (II) R128(0): [drm] dma control initialized, using IRQ 16
[    26.895] (II) R128(0): Direct rendering enabled
[    26.895] (==) RandR enabled
[    26.944] (II) SELinux: Disabled on system
[    26.946] (II) AIGLX: Screen 0 is not DRI2 capable
[    26.946] (EE) AIGLX: reverting to software rendering
[    27.516] (II) AIGLX: Loaded and initialized swrast
[    27.516] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[    27.998] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    27.998] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    27.998] (II) LoadModule: "evdev"
[    27.998] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    28.045] (II) Module evdev: vendor="X.Org Foundation"
[    28.045]  compiled for 1.16.0, module version = 2.9.0
[    28.045]  Module class: X.Org XInput Driver
[    28.045]  ABI class: X.Org XInput driver, version 21.0
[    28.045] (II) Using input driver 'evdev' for 'Power Button'
[    28.045] (**) Power Button: always reports core events
[    28.045] (**) evdev: Power Button: Device: "/dev/input/event3"
[    28.045] (--) evdev: Power Button: Vendor 0 Product 0x1
[    28.045] (--) evdev: Power Button: Found keys
[    28.045] (II) evdev: Power Button: Configuring as keyboard
[    28.045] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event3"
[    28.045] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    28.045] (**) Option "xkb_rules" "evdev"
[    28.045] (**) Option "xkb_model" "pc105"
[    28.045] (**) Option "xkb_layout" "be"
[    28.114] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    28.114] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    28.114] (II) Using input driver 'evdev' for 'Power Button'
[    28.114] (**) Power Button: always reports core events
[    28.114] (**) evdev: Power Button: Device: "/dev/input/event2"
[    28.114] (--) evdev: Power Button: Vendor 0 Product 0x1
[    28.114] (--) evdev: Power Button: Found keys
[    28.114] (II) evdev: Power Button: Configuring as keyboard
[    28.114] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input4/event2"
[    28.114] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    28.114] (**) Option "xkb_rules" "evdev"
[    28.114] (**) Option "xkb_model" "pc105"
[    28.114] (**) Option "xkb_layout" "be"
[    28.115] (II) config/udev: Adding drm device (/dev/dri/card0)
[    28.115] (II) xfree86: Adding drm device (/dev/dri/card0)
[    28.115] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[    28.116] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event0)
[    28.116] (**) HID 046a:0023: Applying InputClass "evdev keyboard catchall"
[    28.116] (II) Using input driver 'evdev' for 'HID 046a:0023'
[    28.116] (**) HID 046a:0023: always reports core events
[    28.116] (**) evdev: HID 046a:0023: Device: "/dev/input/event0"
[    28.116] (--) evdev: HID 046a:0023: Vendor 0x46a Product 0x23
[    28.116] (--) evdev: HID 046a:0023: Found keys
[    28.116] (II) evdev: HID 046a:0023: Configuring as keyboard
[    28.116] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0/0003:046A:0023.0001/input/input2/event0"
[    28.116] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 8)
[    28.116] (**) Option "xkb_rules" "evdev"
[    28.116] (**) Option "xkb_model" "pc105"
[    28.116] (**) Option "xkb_layout" "be"
[    28.117] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event1)
[    28.117] (**) HID 046a:0023: Applying InputClass "evdev keyboard catchall"
[    28.117] (II) Using input driver 'evdev' for 'HID 046a:0023'
[    28.117] (**) HID 046a:0023: always reports core events
[    28.117] (**) evdev: HID 046a:0023: Device: "/dev/input/event1"
[    28.117] (--) evdev: HID 046a:0023: Vendor 0x46a Product 0x23
[    28.117] (--) evdev: HID 046a:0023: Found 1 mouse buttons
[    28.117] (--) evdev: HID 046a:0023: Found scroll wheel(s)
[    28.117] (--) evdev: HID 046a:0023: Found relative axes
[    28.117] (II) evdev: HID 046a:0023: Forcing relative x/y axes to exist.
[    28.117] (--) evdev: HID 046a:0023: Found absolute axes
[    28.117] (II) evdev: HID 046a:0023: Forcing absolute x/y axes to exist.
[    28.117] (--) evdev: HID 046a:0023: Found keys
[    28.117] (II) evdev: HID 046a:0023: Configuring as mouse
[    28.117] (II) evdev: HID 046a:0023: Configuring as keyboard
[    28.117] (II) evdev: HID 046a:0023: Adding scrollwheel support
[    28.117] (**) evdev: HID 046a:0023: YAxisMapping: buttons 4 and 5
[    28.117] (**) evdev: HID 046a:0023: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    28.118] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.1/0003:046A:0023.0002/input/input3/event1"
[    28.118] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 9)
[    28.118] (**) Option "xkb_rules" "evdev"
[    28.118] (**) Option "xkb_model" "pc105"
[    28.118] (**) Option "xkb_layout" "be"
[    28.118] (II) evdev: HID 046a:0023: initialized for relative axes.
[    28.118] (WW) evdev: HID 046a:0023: ignoring absolute axes.
[    28.118] (**) HID 046a:0023: (accel) keeping acceleration scheme 1
[    28.118] (**) HID 046a:0023: (accel) acceleration profile 0
[    28.118] (**) HID 046a:0023: (accel) acceleration factor: 2.000
[    28.118] (**) HID 046a:0023: (accel) acceleration threshold: 4
[    28.119] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event5)
[    28.119] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
[    28.119] (II) Using input driver 'evdev' for 'ImPS/2 Generic Wheel Mouse'
[    28.119] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[    28.119] (**) evdev: ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event5"
[    28.119] (--) evdev: ImPS/2 Generic Wheel Mouse: Vendor 0x2 Product 0x5
[    28.119] (--) evdev: ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[    28.119] (--) evdev: ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[    28.119] (--) evdev: ImPS/2 Generic Wheel Mouse: Found relative axes
[    28.119] (--) evdev: ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[    28.119] (II) evdev: ImPS/2 Generic Wheel Mouse: Configuring as mouse
[    28.119] (II) evdev: ImPS/2 Generic Wheel Mouse: Adding scrollwheel support
[    28.119] (**) evdev: ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[    28.119] (**) evdev: ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    28.119] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event5"
[    28.119] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE, id 10)
[    28.119] (II) evdev: ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[    28.120] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping acceleration scheme 1
[    28.120] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
[    28.120] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration factor: 2.000
[    28.120] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration threshold: 4
[    28.120] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse0)
[    28.120] (II) No input driver specified, ignoring this device.
[    28.120] (II) This device may have been added with another device file.
[    28.121] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[    28.121] (II) No input driver specified, ignoring this device.
[    28.121] (II) This device may have been added with another device file.
[    28.127] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card0 /dev/dri/card0
[    28.127] (II) config/udev: Adding drm device (/dev/dri/card0)
[    28.127] (II) xfree86: Adding drm device (/dev/dri/card0)
[    28.127] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied


linux@debian:~$

$

dmesg | grep -E 'drm|radeon'



[   26.548553] [drm] Initialized drm 1.1.0 20060810
[   26.594555] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   26.594562] [drm] No driver support for vblank timestamp query.
[   26.594566] [drm] Initialized r128 2.5.0 20030725 for 0000:01:00.0 on minor 0


linux@debian:~$

les microcode ne sont pas chargés
$

dmesg | grep -E 'drm|radeon' | grep -iE 'firmware|microcode'


linux@debian:~$

install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati  xserver-xorg-video-r128



[sudo] password for linux:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
firmware-linux-nonfree est déjà la plus récente version disponible.
libgl1-mesa-dri est déjà la plus récente version disponible.
xserver-xorg-video-ati est déjà la plus récente version disponible.
xserver-xorg-video-r128 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


linux@debian:~$


Merci


debian jessie X8 Voyager, hp dv6

Hors ligne

#2 22-09-2015 16:27:50

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : ati rage 128

Bonjour

cette carte est faite pour un affichage serveur , je doute que tu est un bon rendu sur un ordinateur de bureau avec gnome par exemple.
il faut que tu complète ton profil
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

des détails sur la machine (processeur mémoire etc ) et quelle debian tu a installé.
le firmware-linux-nonfree et le xserver-xorg-video-ati est inutile pour cette carte.

ps: je n ai pas trouvé de wiki pour carte ati (juste radeon ).
pour donner une idée l ATI rage 128 a été ma premiere carte 3D apres la woodoo2 et 3 , dans les année 2001 . wink (jeux unreal , quake2 , etc tongue )
la Rage 128 PRO Ultra AGP 4x est un peu plus performante , meme pas en 8X , donc ton premier souci est les ressources de ta machine, insuffisantes surement . (on attend ta description de cet ordinateur )

Dernière modification par robert2a (22-09-2015 16:44:54)

Hors ligne

#3 22-09-2015 16:57:40

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

enebre a écrit :

je constate un mauvais affichage avec des trainées aux déplacement des fenêtres.


Quel type de traînées, qui durent le temps du déplacement ou qui restent après ?

robert2a a écrit :

cette carte est faite pour un affichage serveur


La famille Rage 128 était la génération de GPU avec accélération 3D d'ATi précédent la famille Radeon, à la fin des années 1990. Sa concurrente était la famille Riva TnT de Nvidia. Les deux étaient dédiées au jeu en 3D.

robert2a a écrit :

le firmware-linux-nonfree et le xserver-xorg-video-ati est inutile pour cette carte.


Le paquet xserver-xorg-video-r128 contient le pilote X.org pour Rage 128 suggère l'installation du paquet firmware-linux qui dépend de firmware-linux-nonfree qui contient le microcode pour Rage 128 r128/r128_cce.bin dont dépend le module d'accélération graphique pour Rage 128 r128. smile

Le paquet xserver-xorg-video-ati n'est pas strictement nécessaire mais il fournit l'auto-détection pour tous les GPU ATI/AMD supportés et est nécessaire pour la configuration automatique sans fichier /etc/X11/xorg.conf. Sans ce paquet, il faut impérativement créer un fichier de configuration pour spécifier le pilote ATI à utiliser.

Dernière modification par smolski (22-09-2015 17:05:04)

Hors ligne

#4 23-09-2015 13:02:56

enebre
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4
Inscription : 18-10-2010

Re : ati rage 128

Bonjour,
merci pour vos réponses.
Le pc est un vieux flatop P4 3.0Gh Fujitsu  DT4-D1534
Je vois aussi que le microcode est correctement installé

$ dmesg | grep -E 'drm|r128' | grep -iE 'firmware|microcode'
[   30.929663] platform r128_cce.0: firmware: direct-loading firmware r128/r128_cce.bin
 


Le déplacement des fenêtres est fastidieux, ne suivent pas la souris, efface le fond d'écran qui réapparaît après qq instants.

Si je dois créer un fichier xorg.conf, là je vais avoir qq difficultés, je n'ai pas trop l'habitude de cette gymnastique.

S'il n'y a pas de solution le mieux serait que je trouve une autre carte graphique, car le pc est assez bon dans l'ensemble.

Dernière modification par enebre (23-09-2015 13:55:06)


debian jessie X8 Voyager, hp dv6

Hors ligne

#5 23-09-2015 16:16:49

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

Si je comprends bien, l'affichage du déplacement d'une fenêtre est juste très lent, au point qu'il y a du "lag" et qu'on a le temps de voir les opérations intermédiaires qui redessinent l'image. Cela pourrait venir des lignes suivantes dans le log d'X.org :

[    26.946] (II) AIGLX: Screen 0 is not DRI2 capable
[    26.946] (EE) AIGLX: reverting to software rendering
[    27.516] (II) AIGLX: Loaded and initialized swrast
[    27.516] (II) GLX: Initialized DRISWRAST GL provider for screen 0


En clair, le pilote r128 n'est pas compatible DRI2 (je crois qu'il n'a pas été porté de DRI à DRI2) et cela force l'utilisation du rendu logiciel pour la 3D.

Quel est l'environnement de bureau ou le gestionnaire de fenêtres ? Un environnement plus léger n'utilisant pas massivement le rendu 3D serait peut-être plus fluide.

Dernière modification par raleur (23-09-2015 16:17:09)

Hors ligne

#6 23-09-2015 16:34:57

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : ati rage 128

tu a xfce4 comme bureau qui est assez léger et n utilise pas la 3D
une carte AGP 8x si ton AGP de la carte mere le supporte et plus récente (on est en 2015 )
attention aux normes il y a plusieurs tension pour l AGP (3volt et 1.5 , de tete ) et pas de détrompeur . (voir la doc de ta carte mere et celle de ta carte graphique)
je pense que ton P4  est en 478 (ne supporte pas le 64) et pas de HT
une alternative c est d utiliser wheezy (ou plus ancien) a la place de jessie.

ps: j'ai un P4 (socket 775 ) avec un PCIE version1 ça commence à ramer un peu avec stretch amd64 (et une GTX750 TI ) . l AGP est en fin de vie , pas assez de débit
dans les année 2000 beaucoup de serveur avait ce chipset intégré a la carte mere.
ci tu remplace ta carte vidéo évite ATI  smile

Dernière modification par robert2a (23-09-2015 16:35:47)

Hors ligne

#7 23-09-2015 19:22:21

enebre
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4
Inscription : 18-10-2010

Re : ati rage 128

Merci de vous être penché sur mon antiquité, j'ai bien compris et je vais essayer de trouver une autre carte pour cette machine.

debian jessie X8 Voyager, hp dv6

Hors ligne

#8 23-09-2015 22:17:16

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : ati rage 128

Salut,


Oui étrange !


Tu peux essayer en réinstallant xserver

apt-get update


apt-get --yes --force-yes --reinstall install firmware-linux firmware-linux-free firmware-linux-nonfree libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core xserver-xorg-video-ati xserver-xorg-video-r128




Dans AtiHowTo il parle de xorg.conf

La configuration optionelle suivante peut être utilisée pour augmenter les performance 3D

Dernière modification par Atys (23-09-2015 22:17:32)

Hors ligne

#9 24-09-2015 11:01:23

enebre
Membre
Lieu : Belgique
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4
Inscription : 18-10-2010

Re : ati rage 128

Merci Atys pour cette précision , je vais essayer de réinstaller le pilote avec ta commande et pour le fichier xorg, dois-je apporter des modification aux trois premières lignes, ou plus  ?
Je ne suis pas certain que le xorg proposé soit compatible pour r128, il ne figure pas dans la liste...

Section "Device"
 Driver "radeon"
 Identifier "My GPU"

Dernière modification par enebre (24-09-2015 11:13:09)


debian jessie X8 Voyager, hp dv6

Hors ligne

#10 24-09-2015 11:19:10

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

Le pilote "radeon" ne fonctionnera pas avec un GPU Rage 128.

Hors ligne

#11 24-09-2015 12:36:38

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : ati rage 128

Il me semble qu'il y a un driver libre r128 et au contraire ne pas spécifier radeon dans xorg.conf

Je me trompe, possible, mais je vois pas pourquoi une ancienne carte comme la sienne ne soit pas reconnue !

Je ne vois pas sinon, désolé.

Hors ligne

#12 24-09-2015 12:46:23

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

Elle est reconnue par le pilote r128. Le problème n'est pas là.

Hors ligne

#13 24-09-2015 15:57:31

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : ati rage 128

raleur a écrit :

Elle est reconnue par le pilote r128. Le problème n'est pas là.




Peu être mettre de côté le xorg.conf pour le moment

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.b



Installer mesa-utils

apt-get install mesa-utils



cat /etc/initramfs-tools/modules



nano /etc/modprobe.d/r128.conf


#blacklist <nom du module>



depmod -ae



update-initramfs -u



cd /etc/modprobe.d/


ls -altr



cat fichier.conf fichier.conf fichier.conf ...



Je veux bien de l'aide, ou me dire si je m'égare !
J'ai cherché, j'attends les résultats de la réinstallation de xserver !

Dernière modification par Atys (24-09-2015 16:09:15)

Hors ligne

#14 24-09-2015 17:57:08

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

Tu pourrais expliquer quel est l'objectif de toutes ces opérations ?

Je pense que tu t'égares, et que la cause de cette lenteur est simplement que le Rage 128 fait partie des GPU qui ne sont plus supportés par la version actuelle de Mesa pour l'accélération 3D. Cf. www.mesa3d.org/relnotes/8.0.html

Removed all DRI drivers that did not support DRI2. Specifically, i810, mach64, mga, r128, savage, sis, tdfx, and unichrome were removed.


La dernière version de Debian avant que ce support soit retiré est Squeeze.

Dernière modification par raleur (24-09-2015 17:59:39)

Hors ligne

#15 26-09-2015 12:36:11

raleur
Membre
Inscription : 03-10-2014

Re : ati rage 128

A enebre :

Disposant par chance d'une carte graphique apparemment similaire (mêmes identifiants PCI), je l'ai testée avec Jessie LXDE sur un Pentium 4 3,2 GHz et 512 Mio de RAM.

Première constatation : sans le firmware /lib/firmware/r128/r128_cce.bin du paquet firmware-linux-nonfree, le démarrage de l'interface graphique se fige et /var/log/Xorg.0.log est rempli de messages d'erreur mentionnant CCE.

Seconde constatation : avec le firmware, les logs du noyau et de X.org sont similaires aux tiens et l'interface graphique se lance bien. Le bureau LXDE est plutôt fluide, je ne constate aucune traînée ni délai lors du déplacement d'une fenêtre.

Tu n'as toujours pas dit quel environnement de bureau ou gestionnaire de fenêtres tu as installé. C'est peut-être lui qui est trop lourd pour la configuration.

PS : Je n'ai pas créé de fichier de configuration /etc/X11/xorg.conf ni /etc/X11/xorg.conf.d/*.conf.

Dernière modification par raleur (26-09-2015 12:39:51)

Hors ligne

Pied de page des forums