Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-03-2009 05:47:36

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Ouvrir un port https

Bonjour,

   mon FAI me donne accès au Cpanel et, par là, je pourrais installer des disques virtuels avec mon serveur.  Ce que je comprends de la chose, c'est que les répertoires de mon serveur pourraient m'être accessibles aussi facilement que les répertoires de mon propre disque dur.

J'ai examiné http://www.linuxquestions.org/questions … fs-632056/
et je crois qu'en faisant comme lui, je pourrais y arriver.
Je crains pour la sécurité.  Je me demande aussi si je dois installer le paquet davfs ou non.

Voici ce que me donne le cPanel et qui me lance dans cette nouvelle aventure:


Notez Bien : Pour pourvoir utiliser le disque Web il faut activer les ports 2078 (SSL) ou 2077 (non-SSL) sur le firewall de votre ordinateur.


Le début de l'expérience est cette tentative d'utiliser   https://cartefoi.net:2078 comme affiché dans le cPanel.
Bien entendu, j'ai configuré le répertoire et le mot de passe et je les utilise correctement.


Merci de vos commentaires


J'oubliais ... voici ce que mes recherches internent m'ont amené à faire:

patrick:/home/patrick# netstat -antp
Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name
tcp        0      0 127.0.0.1:647           0.0.0.0:*               LISTEN      3439/famd       
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      2660/mysqld     
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      2119/portmap   
tcp        0      0 0.0.0.0:113             0.0.0.0:*               LISTEN      3206/inetd     
tcp        0      0 0.0.0.0:55605           0.0.0.0:*               LISTEN      2130/rpc.statd 
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      2749/cupsd     
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3125/exim4     
tcp        0      0 192.168.0.215:44756     192.168.0.200:445       ESTABLISHED -               
tcp6       0      0 :::139                  :::*                    LISTEN      3306/smbd       
tcp6       0      0 :::80                   :::*                    LISTEN      3749/apache2   
tcp6       0      0 :::445                  :::*                    LISTEN      3306/smbd


et

patrick:/home/patrick# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination


Je ne comprends pas trop, mais il me semble bien que d'après ces résultats je n'ai pas de port 2078 actif.
Comment l'activer?


Tant qu'à y être ....

voici aussi ce que j'ai essayé

smbmount //209.172.41.155/~cartefoi:2078 /home/patrick/cartefoi davfs uid=user,gid=group 0 0


Cette commande a fait en sorte qu'on me demande un mot de passe, mais pas de nom d'usager!
C'est resté figé longtemps sans bouger ni changer. Je me suis lassé et j'ai fait Ctrl-C (j'étais en consol usager)


Merci à l'avance.

Dernière modification par Patriboom (22-03-2009 06:27:19)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 22-03-2009 11:22:41

alex
Membre
Lieu : Trevoux
Distrib. : etch
Noyau : 2.6.25
(G)UI : kde
Inscription : 07-06-2007
Site Web

Re : Ouvrir un port https

concernant le port, actuellement tu n'as aucune regle iptables de définis, donc tout peut passer. Et pour activer le port en question, cela se fera des qu'un daemon ecoutera sur ce port.

Hors ligne

#3 22-03-2009 13:52:29

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Euh...

   Je comprends qu'il n'y a pas de barrière dans ma configuration.  Est-ce bien ou pas?
   Je comprends aussi qu'il faudrait un daemon pour que ça marche.  Comment l'activer?

Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 02-04-2009 23:23:14

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

J'ai vérifié auprès de mon FAI et je dois configurer correctement mon ordi.  Il m'assure avoir testé la chose et avoir réussi à faire fonctionner le tout chez lui.  Que dois-je donc faire?
J'ai deux possibilités qui me soient offertes par mon FAI:  https  (SSL)  ou http (non-SSL)
Ni l'une ni l'autre n'a encore fonctionné, avec la configuration que vous pouvez voir ci-haut.

Vous avez une piste?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 02-04-2009 23:49:28

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Ouvrir un port https

tu as juste a configurer l archive listen.conf pour le mettre en 443 et redemarrer le service apache.

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#6 03-04-2009 02:46:11

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Je n'ai pas de fichier listen.conf

Est-ce que je mets la ligne "listen 443" dans le fichier ports.conf ?

Pourquoi  le chiffre 443 ?

Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#7 12-04-2009 12:42:12

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : Ouvrir un port https

quelle version d'apache ?

Hors ligne

#8 12-04-2009 19:16:54

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Voici tout ce que me donne PHPINFO() à propos de Apache:

apache2handler
Apache Version     Apache/2.2.11 (Debian) PHP/5.2.6-3 with Suhosin-Patch
Apache API Version     20051115
Server Administrator     webmaster@localhost
Hostname:Port     127.0.0.1:80
User/Group     www-data(33)/33
Max Requests     Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts     Connection: 300 - Keep-Alive: 15
Virtual Server     Yes
Server Root     /etc/apache2
Loaded Modules     core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_mime mod_negotiation mod_php5 mod_setenvif mod_status


Directive    Local Value    Master Value
engine    1    1
last_modified    0    0
xbithack    0    0



Apache EnvironmentVariable    Value
HTTP_USER_AGENT     Opera/9.64 (X11; Linux i686; U; fr-CA) Presto/2.1.1
HTTP_HOST     localhost
HTTP_ACCEPT     text/html, application/xml;q=0.9, application/xhtml+xml, image/png, image/jpeg, image/gif, image/x-xbitmap, */*;q=0.1
HTTP_ACCEPT_LANGUAGE     fr-CA,fr;q=0.9,en;q=0.8
HTTP_ACCEPT_CHARSET     iso-8859-1, utf-8, utf-16, *;q=0.1
HTTP_ACCEPT_ENCODING     deflate, gzip, x-gzip, identity, *;q=0
HTTP_CONNECTION     Keep-Alive, TE
HTTP_TE     deflate, gzip, chunked, identity, trailers
PATH     /usr/local/bin:/usr/bin:/bin
SERVER_SIGNATURE     <address>Apache/2.2.11 (Debian) PHP/5.2.6-3 with Suhosin-Patch Server at localhost Port 80</address>
SERVER_SOFTWARE     Apache/2.2.11 (Debian) PHP/5.2.6-3 with Suhosin-Patch
SERVER_NAME     localhost
SERVER_ADDR     127.0.0.1
SERVER_PORT     80
REMOTE_ADDR     127.0.0.1
DOCUMENT_ROOT     /var/www
SERVER_ADMIN     webmaster@localhost
SCRIPT_FILENAME     /var/www/index.php
REMOTE_PORT     39203
GATEWAY_INTERFACE     CGI/1.1
SERVER_PROTOCOL     HTTP/1.1
REQUEST_METHOD     GET
QUERY_STRING     no value
REQUEST_URI     /index.php
SCRIPT_NAME     /index.php

Portez la paix
Patrick Allaire, ptre

Hors ligne

#9 13-04-2009 12:05:28

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : Ouvrir un port https

oui c'est dans le ports.conf, il faut activer le mode ssl : a2enmod ssl si mes souvenirs sont bons

Hors ligne

#10 14-04-2009 04:32:36

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Voici la réponse que j'obtiens:
NameVirtualHost *:443 has no VirtualHosts

Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 14-04-2009 13:41:28

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Ouvrir un port https

dans le virtualhost default change le *:80 par *:443 si tu as d autre vhost pareil, oublie pas de relancer apache apres la modification

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#12 14-04-2009 15:04:09

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Toujours en problème, je vous soumets le ports.conf et le résultat:

Ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

#NameVirtualHost *:80
#Listen 80

NameVirtualHost *:443
Listen 443

#NameVirtualHost *:2078
#Listen 2078


<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>



Résultat:
# /etc/init.d/apache2 restart
Restarting web server: apache2[Tue Apr 14 09:01:23 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
... waiting [Tue Apr 14 09:01:24 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:443
.


Merci encore

Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 15-04-2009 04:07:13

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Ouvrir un port https

ben la c est pas un probleme c est une erreur courante ton serveur ecoute bien sur le port 443, simplement qu il faudrai commenté ta ligne
NameVirtualHost *:443 dasn le fichier de port.conf et la mettre dans les virtualhost qui se situe dans /etc/apache2/site-availables/nomvhost

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#14 24-06-2009 05:14:19

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Encore en problème.  Voilà que je reçois info d'un port 443 déjà en usage.

voici ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

#NameVirtualHost *:443
Listen 443

#NameVirtualHost *:2078
#Listen 2078


<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>


voici nomvhost
NameVirtualHost *:80
NameVirtualHost *:443



Restarting web server: apache2 ... waiting (98)Address already in use: make_sock: could not bind to address [::]:443
.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#15 25-06-2009 00:33:52

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Ouvrir un port https

Dans le virtualhost tu as du mettre le port 443 donc ca te ferai 2 ports 443.

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#16 01-07-2009 17:07:23

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Ouvrir un port https

Bonjour,

Patriboom, je suppose qu'en plus de l'ordinateur tu disposes d'un modem/routeur. As-tu vérifié que sur ce dernier les ports demandés (2007 2078) sont autorisés?

@+

Hors ligne

#17 17-09-2009 06:58:43

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

MaTTuX_ a écrit :

dans le virtualhost default change le *:80 par *:443 si tu as d autre vhost pareil, oublie pas de relancer apache apres la modification


Bonsoir,

   après longue attente et oisivité, je reviens à la charge.

   Où est virtualhost?
   Je veux garder mon serveur PHP actif sur ma machine, je crains qu'en changeant 80 par 443 je perde ce service.

   Objectif final:
          1) accéder à un disque distant (voir ci-haut)
          2) conserver mon serveur PHP local actif
          3) donner accès à un répertoire Linux à Windows XP installé en VirtualBox et auquel je devrais (selon VirtualBox) pouvoir accéder à l'adresse suivante \\vboxsrv\nom_de_partage_du_repertoire

Voici mon fichier ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

#NameVirtualHost *:80
Listen 80

#NameVirtualHost *:443
#Listen 443

#NameVirtualHost *:2078
#Listen 2078


<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>


Et voici aussi le fichier /etc/apache2/sites-enabled/000-default auquel on réfère

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
        Options FollowSymLinks
        AllowOverride all
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Est-ce donc ce 000-default qui est mon virtualhost?
Devrais-je donc faire une configuration 443 semblable à ce que j'ai pour 80 ?

   Merci encore

Dernière modification par Patriboom (17-09-2009 07:07:37)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#18 17-09-2009 09:15:05

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Ouvrir un port https

Salut

Oui c'est bien ton Virtualhost, je te propose un tuto qui regroupe ce qui est dit un peu plus haut par Ksmoino et MaTTuX_ --> http://www.ac-creteil.fr/reseaux/system … e-ssl.html

En gros, installation d'openssl, activation de ssl dans apache et configuration du VH.

Tux12 t'as aussi suggéré de vérifier que ta box ne te bloque pas ces ports wink

Bon courage

Hors ligne

#19 17-09-2009 17:23:01

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Merci palmito,

   je bloque déjà.

  suivant les étapes du tuto proposé, j'arrive à l'étape 5
[q][q]5 Génération du certificat auto-signé
Génération du certificat
cd /etc/apache2/ssl
apache2-ssl-certificate
et on répond aux questions :

[/q][/q]
Je n'ai pas de répertoire ssl dans /etc/apache2, mais j'en ai un dans /etc
dans /etc/ssl, donc, j'ai essayé la commande apache2-ss-certificate et j'obtiens "command not found"
je l'ai essayé aussi dans /etc/ssl/certs
Dans ce dernier répertoire (/etc/ssl/certs), je trouve un tas de choses, mais qui m'aide pour le moment.
J'ai ouvert le fichier openssl.cnf  qui semble très intéressant, mais je ne sais pas pour que programme sont préparées toutes ces valeurs par défaut.

En tapant "openssl" en terminal, j'obtiens une invite de commande.  J'y ai mis "certificate" et j'ai obtenu une liste des fonctions possibles.  Très bien, mais est-ce que ça me servira?

Merci encore palmito, je n'avais ps saisi l'utilité de SSL dans le processus.

Quant à la question de tux12, je ne peux répondre, car c'est mon FAI qui a tout.  Là, je viens de changer de FAI et c'est toujours la même chose.  Je n'ai pas de routeur.  Je n'ai que le modem fourni par la compagnie.  Comment puis-je savoir si le port est bloqué par cette petite boite noire là?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#20 20-09-2009 13:07:39

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Ouvrir un port https

Salut

On dirait effectivement que le script n'éxiste plus....un petit tuto pour le générer manuellement wink --> http://www.slywalker.com/2009/09/instal … php-5-ssl/

@+

Hors ligne

#21 22-09-2009 19:06:17

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Ouvrir un port https

Bon, voilà du nouveau.

J'ai reformatté mon HDD-Linux et tout va mieux.  Aïlle pour le temps passé là-dessus!

Voici la nouvelle donne.
  J'ai accés à mon site via Nautilus en faisant "Se connecter à un serveur".
  J'y ai accédé une fois, mais j'ai mis un signet.
  J'y vais à ma guise maintenant (bien que je n'aie pas encore re-booté).

  J'ai fait "démonter le volume"

  Tout va bien jusque là.

   Je cherche maintenant à avoir le volume "monté" et dans mon arborescence lorsque j'y accède simplement en passant par le signet.  Est-ce possible?

   Question technique.  Passant par Nautilus, les changements de répertoire et les transferts de fichiers me semblent plus lent qu'avec mon logiciel gftp habituel.  Est-ce normal?

   Dernière:   est-ce que je peux faire un montage automatique (à l'ouverture de gnome) sans avoir à installer samba? Si oui, comment?  Pour le montage automatique via samba, je m'étais fait un petit fichier .sg que j'appellais à l'ouverture avec des lignes comme smbmount //192.168.0.2/NomRepDist /home/patrick/NomRepLocal -o username=NomUsager,password=MotdePasse,rw.  Qu'y mettre si je ne  neprends pas samba?

Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums